OpenWrt Forum Archive

Topic: WNDR3700 exploration

The content of this topic has been archived between 1 Oct 2014 and 7 May 2018. Unfortunately there are posts – most likely complete pages – missing.

Passive wrote:

Is anyone else having problems with the tracker site timing out?

Thanks

Could someone announce the torrent to another tracker, maybe like openbittorrent?

Thanks a lot!

carletto wrote:

For kamzata, i have followed this step for reflashing my wndr3700 router after a brick and now it work perfect:

-   power down the router
-   set your IP to 192.168.1.2 (the same class of the router)
-   press and hold the RESET button for about 2 min
-   until you see the power LED become orange and start blinking
-   release connect you PC to a LAN port of the router
-   from the command prompt type "tftp -i 192.168.1.1 PUT <filename>"

LED become green and blinking. Should it become orange and blinking? I recieve always the same message error...

"Error occurred during the file transfer (error code = 0):
Error in recfrom() call. Please check in the TFTP server is available."

(Last edited by kamzata on 21 Feb 2010, 13:16)

People who are looking for better performance on 5 GHz might want to check out Erich Boehm's recent suggested change to antenna group selection. I haven't tried this myself but the OP writes that it works better for him:

https://dev.openwrt.org/ticket/6533

Well this is fun :-)

Compiled from trunk and flashed my WNDR3700 yesterday, and for the most part, it all works. Thanks! Only issue is lan<->wan performance. With the NETGEAR firmware, it did around 500Mbps, with NAT. On OpenWRT it initially only managed to do 180Mbps. After disabling l7 modules, string matching, mtu fix, its now doing about 270-280Mbps.

When pushing a lot of data sys% hits 99-100% in notime.

I wonder what netgear is doing differently? Any hints on what else to change? I'll try subnetting my network instead of passing the traffic through a bridge, but I doubt that will make much difference.

Also, I'd like to profile the kernel. For doing this, I'd like to set custom kernel parameters, can that be done relatively easily?

I will probably not push more than 50Mbps from wan to lan (for now..), but as its also going to be a OpenVPN client I'd like to get as many spare cpu cycles as possible.

Is radius currently supported in the tracker build of OpenWRT?

For example, going from Radius to WPA2-PSK wifi starts working just fine.
Any way to make this work?

ifconfig: SIOCGIFFLAGS: No such device
ifconfig: SIOCGIFFLAGS: No such device
Configuration file: /var/run/hostapd-phy0.conf
Line 46: unknown configuration item 'auth_server_addr'
Line 47: unknown configuration item 'auth_server_port'
Line 48: unknown configuration item 'auth_server_shared_secret'
Line 51: unknown configuration item 'radius_acct_interim_interval'
Line 65: unknown configuration item 'auth_server_addr'
Line 66: unknown configuration item 'auth_server_port'
Line 67: unknown configuration item 'auth_server_shared_secret'
Line 70: unknown configuration item 'radius_acct_interim_interval'
Invalid IEEE 802.1X configuration (no EAP authenticator configured).
9 errors found in configuration file '/var/run/hostapd-phy0.conf'
Failed to start hostapd for phy0
ifconfig: SIOCGIFFLAGS: No such device
ifconfig: SIOCGIFFLAGS: No such device
Configuration file: /var/run/hostapd-phy1.conf
Line 46: unknown configuration item 'auth_server_addr'
Line 47: unknown configuration item 'auth_server_port'
Line 48: unknown configuration item 'auth_server_shared_secret'
Line 51: unknown configuration item 'radius_acct_interim_interval'
Line 65: unknown configuration item 'auth_server_addr'
Line 66: unknown configuration item 'auth_server_port'
Line 67: unknown configuration item 'auth_server_shared_secret'
Line 70: unknown configuration item 'radius_acct_interim_interval'
Invalid IEEE 802.1X configuration (no EAP authenticator configured).
9 errors found in configuration file '/var/run/hostapd-phy1.conf'
Failed to start hostapd for phy1

My /etc/config/wireless is as follows:

config 'wifi-device' 'radio0'
    option 'type' 'mac80211'
    option 'channel' '5'
    option 'macaddr' '00:26:f2:a1:5c:08'
    option 'country' 'US'
    option 'hwmode' '11ng'
    option 'htmode' 'HT20'
    list 'ht_capab' 'SHORT-GI-40'
    list 'ht_capab' 'DSSS_CCK-40'

config 'wifi-iface'
    option 'device' 'radio0'
    option 'network' 'lan'
    option 'mode' 'ap'
    option 'ssid' 'Hardware'
    option 'key' 'xxxxxxxx'
    option 'encryption' 'wpa2'
    option 'server' '10.0.0.1'
    option 'port' '1812'
    option 'hidden' '0'

config 'wifi-iface'
    option 'device' 'radio0'
    option 'network' 'lan'
    option 'mode' 'ap'
    option 'ssid' 'Hardware-G'
    option 'key' 'xxxxxxxx'
    option 'encryption' 'wpa2'
    option 'server' '10.0.0.1'
    option 'port' '1812'
    option 'hidden' '1'

config 'wifi-iface'
    option 'device' 'radio0'
    option 'network' 'wan'
    option 'mode' 'ap'
    option 'ssid' 'Hardware-Guest'
    option 'encryption' 'none'
    option 'hidden' '0'

config 'wifi-device' 'radio1'
    option 'type' 'mac80211'
    option 'channel' '36'
    option 'macaddr' '00:26:f2:a1:5c:0a'
    option 'country' 'US'
    option 'hwmode' '11na'
    option 'htmode' 'HT20'
    list 'ht_capab' 'SHORT-GI-40'
    list 'ht_capab' 'DSSS_CCK-40'

config 'wifi-iface'
    option 'device' 'radio1'
    option 'network' 'lan'
    option 'mode' 'ap'
    option 'ssid' 'Hardware'
    option 'key' 'xxxxxxxx'
    option 'encryption' 'wpa2'
    option 'server' '10.0.0.1'
    option 'port' '1812'
    option 'hidden' '0'
   
config 'wifi-iface'
    option 'device' 'radio1'
    option 'network' 'lan'
    option 'mode' 'ap'
    option 'ssid' 'Hardware-A'
    option 'key' 'xxxxxxxx'
    option 'encryption' 'wpa2'
    option 'server' '10.0.0.1'
    option 'port' '1812'
    option 'hidden' '1'

config 'wifi-iface'
    option 'device' 'radio1'
    option 'network' 'wan'
    option 'mode' 'ap'
    option 'ssid' 'Hardware-Guest'
    option 'encryption' 'none'
    option 'hidden' '0'

trippeh wrote:

Compiled from trunk and flashed my WNDR3700 yesterday, and for the most part, it all works. Thanks! Only issue is lan<->wan performance. With the NETGEAR firmware, it did around 500Mbps, with NAT. On OpenWRT it initially only managed to do 180Mbps. After disabling l7 modules, string matching, mtu fix, its now doing about 270-280Mbps.

As expected, going from bridge on the lan side to normal routing didn't make much difference. However killing off most netfilter/iptables modules seems to be the key to performance, nuking the raw table and its module boosted performance to 340Mbps. So, getting there, one small step at a time smile

tysonedwards,

The recent torrent build was compiled with wpad-mini, which (as far as I recall) supports only PSK. I've not worked with Radius support before, but if you want full WPA support, at the very least you'll need a full version of hostapd.

It's possible that you may need to recompile the build yourself to get this.

You might also be able to get away with just using the torrent build, and then using opkg to install hostapd and wpa-supplicant. The hostapd and WPA supplicant package names seem to have gotten shuffled around a bit in the latest trunk builds, so those may not be quite correct...but it's something along those lines. Opkg may also ask you to install some other dependencies.

If you don't have any luck, try looking around on the general OpenWRT forums/wiki about RADIUS since this should not be a WNDR3700-specific issue.

gulikoza wrote:

Works great wink I still have to get 300mbps working though...

I wonder why I'm having problems with luci network settings on my own firmware. Here it works perfectly, but with mine, the pages never load...

I have the same problem on my self-compiled firmware: working Status, System and Services LuCI menus, but anything below Network gives me a blank page and no error message anywhere I can find. Any idea how I can figure out what's going on?

rockpilp wrote:
gulikoza wrote:

Works great wink I still have to get 300mbps working though...

I wonder why I'm having problems with luci network settings on my own firmware. Here it works perfectly, but with mine, the pages never load...

I have the same problem on my self-compiled firmware: working Status, System and Services LuCI menus, but anything below Network gives me a blank page and no error message anywhere I can find. Any idea how I can figure out what's going on?

Turns out I was just missing some packages; installing luci-ntp fixed it.

Is there a downloadable 3rd party for this router? I am pulling my hair out dealing with the crippled stock firmware. I continue to have my wireless drop.

johnny55 wrote:

Is there a downloadable 3rd party for this router? I am pulling my hair out dealing with the crippled stock firmware. I continue to have my wireless drop.

Yes, see the previous page on this very thread.

Using essdz's tracker image right now and everything appears to be working. I do however have one question; I cannot get anything above 130mb/s even with the access point next to the computer. When I put it in the bedroom, where I usually got 200+mb/s using factory firmware, it sits right around 65mb/s. How can I enable full 300mb/s bandwidth on the 5ghz channel. I have switched it to channel 153, the default from netgear which they changed recently to obtain better performance and range I believe, and I have excellent signal strength but still only 65mb/s. I read some others have said they achieved 300mb/s with default settings while another said it took some tweaking. What settings can I tweak to get the speeds up to par? It is useable shorterm i.e. I have internet access working but I would like to take full advantage of the connection.

(Last edited by skarlson on 2 Mar 2010, 23:46)

I flashed my firmware today with the firmware in the torrent file. I am very happy with this as I was able to get everything working. Wireless worked out of the box. Thank you everyone that has worked hard on this firmware. I am a longtime dd-wrt user and this is my first experience with openwrt and I am very pleased with it. Now I am on to find some packages to install. smile

I got OpenWRT up and running on my WNDR3700.

I tried the prebuilt downloads but they don't work because they don't honour WiFi country codes. They only allow channels 1-11 on 2.4GHz and _none_ on 5GHz. To get the wndr running as an AP it really needs the "Force Atheros drivers to respect the user's regdomain settings = YES" option.

The wiki instructions on building your own image worked great. http://wiki.openwrt.org/inbox/netgear/wndr3700
Thanks to essdz and other writers!

The changes I made:
1)- switched the 'option led 6' and 'option led 9' around in /etc/config/network. This makes the switch LEDS for Gbit & 100/10Mbit work like it is printed on the router instead of the other way around.
2)- added these options to the 2 wifi-device sections of /etc/config/wireless:

list ht_capab    HT40+
list ht_capab    HT40-

These were needed to get 40MHz bands working. This changed my 11n speed from 65Mbps to 135Mpbs. I only got 1 TX antenna on my EEE901 but 2 RX so download speed is actually 270Mbps, 12-15MBps in real world performance. Very nice.

The 40MHz bands are checked by the atheros drivers before they're used. If there more than a few APs in 2.4GHz, they're not used and you're back to 20MHz (max 65Mbps for me). The 5GHz area has a lot more room and is used by my AppleTV nicely.

Thanks to all that made this possible, I really like the OpenWRT+WNDR3700 combo. big_smile

(Last edited by grard on 3 Mar 2010, 00:40)

I do agree that it would have seemed more logical to make the LED defaults be the same as original firmware, for consistency. And with other hardware too, my d-link switch is also green for gigabit, orange for 100/10

(Last edited by Dragon on 3 Mar 2010, 01:03)

I have a theory that my problem is simply that in the wireless config file htmode is set to ht20 which is preventing channel bonding. I did a cat wireless tonight to see the settings; I will vi the mode to ht40+ and then restart wifi to see if that fixes my issues. If the Lord is willing this should give me a fully functioning (I haven't tested usb but I will worry about that some other time) openwrt build. *tentative yay!*

(Last edited by skarlson on 3 Mar 2010, 02:33)

rockpilp wrote:
rockpilp wrote:
gulikoza wrote:

Works great wink I still have to get 300mbps working though...

I wonder why I'm having problems with luci network settings on my own firmware. Here it works perfectly, but with mine, the pages never load...

I have the same problem on my self-compiled firmware: working Status, System and Services LuCI menus, but anything below Network gives me a blank page and no error message anywhere I can find. Any idea how I can figure out what's going on?

Turns out I was just missing some packages; installing luci-ntp fixed it.

I have this exact problem and installing luci-ntp didn't fix it. Any other ideas?

No go on my hopefulness. I am going back to the factory firmware until this gets ironed out. Using wireless-n at 54mb/s is not acceptable and messing with /etc/config/wireless settings doesn't help one bit. If hwmode is set to anything but HT20 the wireless network will come up but I cannot connect to it and conversely if it is set to HT20 I can connect to it but I can't get anything higher than 54mb/s. Factory will give me full speed although the firmware options suck and the usb is slow; functionality beats toys however.

Have been playing with OpenWrt on the wndr3700 for a couple of days now and i'm running into a (for me) huge problem. I'm trying to setup multiple VLAN's on the switch. But as soon as i configure port 5 as 802.1q trunk, ip connectivity is lost. Did anyone ever succeed in adding a new "routed" VLAN?

Thank you.

Adze wrote:

Have been playing with OpenWrt on the wndr3700 for a couple of days now and i'm running into a (for me) huge problem. I'm trying to setup multiple VLAN's on the switch. But as soon as i configure port 5 as 802.1q trunk, ip connectivity is lost. Did anyone ever succeed in adding a new "routed" VLAN?

Same here. The WAN port doesn't seem to be programmable. I added that info to the wiki page.

rockpilp wrote:

Same here. The WAN port doesn't seem to be programmable. I added that info to the wiki page.

I'm not talking about the WAN port here, but the LAN side only. As soon as i add another VLAN i loose connectivity to the router. sad

@rockpilp: The WAN port is also a 10/100/1000mbps port (WIKI info is incorrect)...

(Last edited by Adze on 3 Mar 2010, 17:42)

I've created VLANs on eth0 no problem (eth0.0-eth0.2). Perhaps the issue you're seeing is with 802.1q (I'm not familiar with that).

:-) I should have read wikipedia before responding, 802.1q IS VLAN...

(Last edited by rockpilp on 3 Mar 2010, 17:49)

skarlson wrote:

No go on my hopefulness. I am going back to the factory firmware until this gets ironed out. Using wireless-n at 54mb/s is not acceptable and messing with /etc/config/wireless settings doesn't help one bit. If hwmode is set to anything but HT20 the wireless network will come up but I cannot connect to it and conversely if it is set to HT20 I can connect to it but I can't get anything higher than 54mb/s. Factory will give me full speed although the firmware options suck and the usb is slow; functionality beats toys however.

I didn't edit the hwmode (well, I did but that made wifi not work at all wink ). I added ht_capab to make 40MHz / higher speeds work.

Part of my current /etc/config/wireless :

config wifi-device  radio0
        option type     mac80211
        option country  NL
        option channel  9
        option macaddr  <snip>
        option hwmode   11ng
        option htmode   HT20
        list ht_capab   HT40-
        list ht_capab   HT40+
        list ht_capab   SHORT-GI-40
        list ht_capab   DSSS_CCK-40

As I understand it, for higher channels HT40- would be used and for lower channels HT40+.

http://en.wikipedia.org/wiki/802.11n#40MHz_in_2.4GHz shows what channels will be used.

Ok, I tried again, using just HT20 and the ht_capab HT40+/- and then it did not work. I went into the driver software in windows, again, to check different settings and found one that lists the different frequencies. Some listed just the frequency while others listed a frequency with a (U) or (L); it was set to channel 11 for that setting with no auto setting and changing channels normally works fine without changing it in the driver. So, I do not think that setting really does anything for my purposes in the driver but it did give me the thought that perhaps the netgear adapter only works with certain channels for HT40+/- modes so I switched the router to a channel the driver lists with a (U/L) and viola it works. I am now functional as far as wireless-n is concerned.