OpenWrt Forum Archive

Topic: Flashing the WRT160NL with CA-42 USB Cable

The content of this topic has been archived on 5 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hello i don't know if this is the right forum to ask in, but looking at the hardware hacking category
it feelt like it was more meant to modding the router. If i have posted my question in the wrong forum my misstake.
And i am sorry for making another thread regarding this router but i feelt it were needed
since that thread really did not cover that much how to do it with a CA-42 Cable.

Well lets get on to the first question regarding the flashing.
Today i got both my WRT160NL router and a Nokia CA-42 USB Cable. Once removing the Nokia Pop-Port but cutting it off we get 5 cables.
Yellow, red, blue, white and black as shown on the picture here http://img41.imageshack.us/img41/5904/ca42cables.png
I would really like to know which cables to use since i haven't found any consistent information during wich color does what.
This is the CA-42 cable i ordered http://www.mytrendyphone.se/shop/nokia- … 3871p.html

Second question is will this method work?
i am planning to use the CA-42 cables and put them on old hdd-led power-led connectors that do fit on serial pins on the router,
for a better explanation have a look here http://img41.imageshack.us/img41/4817/ideaj.png
I found this image on someones blog showing what each pin connector on the router does
http://nanl.de/blog/wp-content/wrt160nl.jpg Can anyone confirm if this information is correct?
if so then we just need to find out what wich cables are the correct ones from the CA-42 cable to put on those pins

Third question.
I am sorry for repeating CA-42 everytime,
but should i consider shortening the cable? ive heard people having issues if the cable is too long,
at this moment the cable is 108cm or 3.54 feet calculated with http://www.convertunits.com/from/cm/to/feet

Forth question.
From what i understand does the serial connectors on the router works at 3.3V and the USB works at 5V
Yet again i have heard sucessfull flashing through USB, but should i be worried?

And the final question
once the cables are connected to the serial and the USB port is plugged into the computer,
how do i reach the router? i found this guide http://www.cdaniel.de/?p=46
which is saying it's done via tftp, I've always thought the flashing were made different.
But to be able to access the tftp i beleive i have to be connected to the router's LAN port wink
I know it's a silly question probably obvious but i had to ask.

Sorry for my limited english, i hope that i could express myself in a clear way.

1. It's somewhat tricky, there's no common "color scheme". The most "secure" way to open phone side connector, see what color goes to what pin and then see http://pinouts.ru/CellularPhonesCables/ … nout.shtml to find out what do what.

3. Mine works as it is, so probably cable should be cut as last resort.

4. Cable chip do all that stuff.

5. You send commands thru serial cable and transfer firmware thru lan, so yes, you need to be connected to router via ethernet too.

Cables: You only need 3 connections from the CA42 to the router, GND (0V), TX and RX.

Black should be GND.

White and Blue were TX and RX on my cable, but this method should help you verify:

-Strip the insulation off each wire and tin the tips with solder.
-Identify the 3.3V supply wire with a multimeter if you can (assume black is 0V/GND to start with)
-Download Bray's Terminal from http://sites.google.com/site/braypp/terminal (handy little terminal application)
-Connect to the COM port associated with the CA-42 (You can find out which it is from Device Manager in windows)
-Click on the bottom box in Bray's terminal (the one just below the 'Send' button). Join the two wires that you suspect to be the TX and RX and hold down a key so that it is continuously sending this character (eg 'aaaaaaaaaaaaaaaaaaaaaaa'). If one of the wires is TX and the other RX, you should see the characters echoed in the 'Receive' window near the top.

Method: Those connectors should work fine. The pins in the blog image are correct.

Cable length: I use a cable of 100cm length (just removed the Nokia connector at the end) without problems. Just keep it in mind if you're trying to solve problems later on.

Voltage question: The voltage is converted to 3.3V by the CA-42.

Connection question: Not a silly question. The serial interface is best used as a backup / for debugging, not as the main means of communicating with the router. I flashed my WRT160NL using the web interface (see 'OEM easy installation' at http://wiki.openwrt.org/toh/linksys/wrt160nl )

To reach the shell console using the serial cable, you just run PuTTy, select 'Serial' and connect to COMX (whatever com port number your CA-42 is) and baud rate 115200. You may have to hit Enter to bring up the Kamikaze banner.

Hope that helps.

damn, the CA42-Cable does not show up in the device manager anymore.
I think that some of the cables gotten accidentally togheter, I will look more into this.
But is it possible that the CA42 can just die of something like that?

EDIT
Tried the OEM easy installation, go to the web interface and just upload http://downloads.openwrt.org/snapshots/ … uashfs.bin
*There's seems to not come with any web interface by default, so ill get right on compiling the trunk*

Thanks for your help guys

EDIT 2
As i heard there's a posibillity that you can overwrite Uboot while flashing making it not possible to reach the Uboot from the serial interface. So i am ordering a new CA42 cable and making sure this time that it's done with care

(Last edited by Insecure on 20 Nov 2009, 01:00)

I got another CA42 cable - just in case if the other one became bricked or not. The thing about this is that i can't measure any voltage on the multimeter it only gives 0 on all cables, and the CA42 cable won't appear in the device manager unless it's connected to a cellphone / a connection is made.

[EDIT]
I solved the issue with the system not picking up the cable by putting two aa batteries togheter and connecting red cable on + and black cable on - http://img684.imageshack.us/img684/8250/solutiont.jpg
* Ive been told on IRC to use three aa batteries instead making it 4.5v*

Seems like white and blue are TX and RX on my cable aswell, tried what you said above by using the Terminal application.

(Last edited by Insecure on 20 Nov 2009, 15:52)

I'm planning to use a CA-42 cable to add serial connection to my WRT160NL. I have some questions about it.

staylo wrote:

White and Blue were TX and RX on my cable

Is white TX and Blue RX?
Does the TX be connected to the RX or TX of the WRT160NL board?

Insecure wrote:

I solved the issue with the system not picking up the cable by putting two aa batteries togheter and connecting red cable on + and black cable on -

Are the batteries also needed when connected to the WRT or is it only needed when attaching only the cable to your PC.
I confirmed my cable by putting one AA battery to the red/black wires and shortening blue and white. Then i got my inputs echoed in PuTTY

Last question: Is there any need to remove the serial cable from the device when using the device with no serial console access needed?

(Last edited by aritmeester on 11 Jan 2010, 10:37)

bump

Does anyone have answers to my questions?

Hi aritmeester,
   Although I am late to answer your questions, you shoudnt need any batteries but just rx tx and gnd at minimum to do the communication.

The discussion might have continued from here.