OpenWrt Forum Archive

Topic: TP Link WR1043ND 11n gigabit router

The content of this topic has been archived between 20 Jul 2013 and 7 May 2018. Unfortunately there are posts – most likely complete pages – missing.

I also tried yours, andrewt12, but also with a problem. I installed tha one is in the trunk, in which there are two versions (i don't know exactly the diferences). I was unable to bridge wlan with lan. I configured the wireless correctly, but when I tried to connect, my computer doesn't get ip (the dhcp server is another computer with linux).

I have to say that my knowledge of vlans and bridge (also english) is not so good, so maybe is my fault.

Thank you very much for your work

manolito1998 wrote:
shibby wrote:

you dont have to use sda-to-root if you dont want.

You dont need serial cable. Simply flash router via gui or mtd.
Flashdrive was used only for test script. I use HDD drive in usb case smile
Why do i use swap? run transmission and you will see smile i have 64mb ram mod and 64mb swap. all works fine.
If you dont want use swap, answer (n) in the question.

btw i missed in changelog

- button QSS run/halt transmission (if installed and configured). Led QSS on = transmission run, led off = transmission = halt)

Hello,

I tried your build but I had a problem with it.  If I made some changes in the configuration or install some new packages, the next time I reboot the router, I loose all the conf and I'm unable to access to the router. Then I need to connect to failsafe mode and run firstboot to reset the conf.

Thank you very much for your work.

which one did you install? i tested all two version and install package to / and save configuration works fine. I`m using now my openwrt without webif.

I was unable to bridge wlan with lan. I configured the wireless correctly, but when I tried to connect, my computer doesn't get ip

try change /etc/config/network from

config interface lan
        option ifname   eth0.1

to

config interface lan
        option ifname   'eth0.1 wlan0'

Can anyone teach me how to unbrick my router.

I have tried to use shibby's and andrewt12's firmware image, they worked very well too.

But, last night, I test the mtd command and try to write a file to the rom (the rootfs).
ie. mtd writejffs /etc/config/network rootfs   (Now i know that, It is wrong!!)

After that, I reboot the router and I cannot access to it anymore. I know that the ROM is corrupted.

Here, I want to ask.

Is it possible to reflash my router manually?

Do I need to use console cable to unbrick my router?

If I a console cable is needed. Where can I find details to build a console cable?

Hope that someone can help me. Thank you very much.

I downloaded openWrt with GUI from shibby. It seems like the wireless network speed is limited to 54Mbps. My question is how it can be set to get the maximum possible speed? It is my first 11n network so i'd like to do some tests even it is unstable:)

@dx950
show me your /etc/config/wireless (remember hash your wireless key)

how did you enable wireless? with gui or menually (file or uci)

@drchoi you can use nokia cable CA-42, is cheap and works very well.
http://www.infernallegion.extra.hu/downloads/wrrs_my_ca-42_cable_ok.jpg

(Last edited by shibby on 10 Jan 2010, 12:09)

my /etc/config/wireless:

config 'wifi-device' 'radio0'
    option 'type' 'mac80211'
    option 'macaddr' '00:19:e0:66:66:68'
    list 'ht_capab' 'HT40-'
    list 'ht_capab' 'SHORT-GI-40'
    list 'ht_capab' 'DSSS_CCK-40'
    option 'country' ''
    option 'hwmode' ''
    option 'maxassoc' ''
    option 'distance' ''
    option 'diversity' ''
    option 'txantenna' ''
    option 'rxantenna' ''
    option 'disabled' '0'
    option 'antenna' ''
    option 'channel' '04'

config 'wifi-iface'
    option 'device' 'radio0'
    option 'network' 'lan'
    option 'mode' 'ap'
    option 'ssid' 'homespot'
    option 'bssid' ''
    option 'encryption' 'psk-mixed/tkip+aes'
    option 'server' ''
    option 'port' ''
    option 'hidden' '0'
    option 'isolate' '0'
    option 'txpower' ''
    option 'bgscan' '0'
    option 'frag' ''
    option 'rts' ''
    option 'wds' '0'
    option 'key' '***********'
    option 'key1' ''
    option 'key2' ''
    option 'key3' ''
    option 'key4' ''
    option '80211h' ''
    option 'compression' ''
    option 'bursting' ''
    option 'ff' ''
    option 'wmm' ''
    option 'xr' ''
    option 'ar' ''
    option 'turbo' ''
    option 'macpolicy' 'none'
    option 'maclist' ''
    option '80211h' ''

Add

option 'hwmode' '11ng'

to wifi-device section

Why you changed default configuration?

i suppose its effect using webif wireless configuration.

remove all and past this

config wifi-device  radio0
option type     mac80211
option channel  5
option macaddr<>00:19:e0:66:66:68
option hwmode<->11ng
option disabled 0
list ht_capab<->HT40-
list ht_capab<->SHORT-GI-40
list ht_capab<->DSSS_CCK-40

config wifi-iface
option device   radio0
option network  lan
option mode     ap
option ssid     OpenWrt
option encryption psk2
option key your_key

I added hwmode 11ng and it connects now at 300Mbps;-) (i even measured once 5MB transfer but most of the time it is about 4MB). I havent changed the configuration but as shibby suspect it may be a result of the webif i used to config.
thanks

Accidently I´ve entered the PPPOE settings for the LAN port and can´t connect to my router anymore. Any reset procedure?

Thanks, that worked well. Is there a way to slow down the webif redirections? It would be nice to see which files are edited by webif for a openwrt novice - currently it's often too fast.
Is there a way to allow the "auto" channel setting? Currently hostapd is only working with a specified channel.
I'd also like to use the dnsomatic service as I did with dd-wrt and my Netgear WGR614L. http://dnsomatic.com/wiki/dd-wrt
I wonder why the G connection of this 3 antennae monster seems to be weaker than with my old Netgear.

(Last edited by Schugy on 12 Jan 2010, 02:37)

Hi,

I have revision 19067 and the router always reboots after 1-2 hours. Just before that happens system load suddenly increases and then the router boots up. Right before the crash top showed
Mem: 17984K used, 11644K free, 0K shrd, 1444K buff, 5176K cached
CPU:   0% usr   0% sys   0% nic   0% idle   0% io  94% irq   5% sirq
Load average: 4.39 3.31 1.59 3/31 965
  PID  PPID USER     STAT   VSZ %MEM %CPU COMMAND
  441     2 root     RW<      0   0%  43% [phy0]
    3     2 root     RW<      0   0%  42% [ksoftirqd/0]
  965   256 root     R     1360   5%  13% top

Do you have any ideas how to investigate that deeper? Serial console is attached, still struggling with JTAG.

TIA

Thomas

r19052 seems to work quite good already, some issues like stunnel configuration through webif or not working useradd through webif (endless list and 100% CPU-usage).
The wireless survey doesn´t work for me either, seems like hostapd binds the radio to the specified channel. Next project is making my samba share usable. Currently I can´t make it accept the password and other users. The "auto" channel should be greyed out becaus hostapd refuses to start without the specified channel.

Is it possible that someone commit vlan patches to trunk in the near future?

I`m testing now my 19111 (new wireless driver) and all works fine. The wireless survey doesn`t work in webif. I`m compiling now r19124. Tommorow i will test it.

@baroo you can patch yourself using andreewt12 patch, but you have to manually apply rejected changes.

This hwmode "11ng" doesn't work for me. My g hardware shows WEP encryption and can't connect. If I change hwmode to "" it works at low speed (sub g, but n devices reach only 800kb/sec too). Is there a working (b/)g/n  option?

11ng works fine, I think. I've tested it with poor quality 3com 802.11n adapters based on Ralink chipset and the result measured without encryption with iperf was 51 Mbps (synchronization speed was 250-300Mbps). I know that is not very good result, but it is because of Ralink chipset I suppose.

@shibby, with vlan patch inside the trunk it would be much easier. Who is resposible for commiting patches?

I have tried my Marvell SD8686 and my Belkin F5D7050 (Ralink rt73 chipset) wireless g adapters.
While n only mode might work I'm looking for n/g mixed mode to use these older devices too (at the cost of slower (but still faster than wireless g) wireless n devices.

@baroo, andrewt12 have not yet uploaded patch to svn.

@schugu if you have G adapter when try hwmode "11g". I have about 3MB/s in G mode.

(Last edited by shibby on 14 Jan 2010, 11:37)

baroo wrote:

Is it possible that someone commit vlan patches to trunk in the near future?

Hi baroo, it may be a while for the switch driver / vlans to get into trunk. In its current form it wont get accepted, I wouldnt even try.

It needs to be made to work with the kernel switchconfig so the vlans can be set from user space rather than statically from in the kernel as it is now.

I would love to finish it off and get it in trunk but not being an expert programmer its very time consuming for me. I am slowly learning how best to implement it properly.

My unit has been running well. It only has basic duties as a nat router / firewall, but does a few small extras.
root@router:~# uptime
19:24:20 up 5 days,  7:45, load average: 0.04, 0.01, 0.00

I will update my patch to work with svn in a few days, there have been a few decent changes in trunk since. Also the wireless MAC address is right now also.

@trichter
Your CPU usage is very high in irq, cat /proc/interupts may show somthing.

Andrew

(Last edited by andrewt12 on 14 Jan 2010, 10:32)

@shibby: 11g works for me but 11ng not. I assume 11 ng should be g/n mixed mode but g devices don't work.
In the original TP-Link firmware I could choose b/g/n, g/n, n (as far as I remember and I wonder whether g/n really supported n speeds or only g). I think the syntax should be easier than 11g, 11g pureg=1, 11ng and 11g.
Or at least we need a matrix of all modes defined in ath9k.

Seems like there was something wrong with my config. Now I have 11ng. I just have to test with N client. Only addition: option country DE for Germany.

(Last edited by Schugy on 15 Jan 2010, 15:36)