OpenWrt Forum Archive

Topic: mpd doesn't play mms streams (wma)

The content of this topic has been archived on 7 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hi guys,

I compiled mpd with ffmeg support. FFmpeg includes a codec for wma files.

Nevertheless I can't play any mms Stream which sends a wma stream.

Can anyone help me?

br Razer

I have the same problem. Has anyone got it to work? Shoutcast streams work fine, but not windows media.

# mpd --version
mpd (MPD: Music Player Daemon) 0.15.8

Copyright (C) 2003-2007 Warren Dukes <warren.dukes@gmail.com>
Copyright (C) 2008 Max Kellermann <max@duempel.org>
This is free software; see the source for copying conditions.  There is NO
warranty; not even MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

Supported decoders:

[mad] mp3 mp2
[vorbis] ogg oga
[flac] flac
[ffmpeg] 16sv 3g2 3gp 4xm 8svx aa3 aac ac3 afc aif aifc aiff al alaw amr anim apc ape asf atrac au aud avi avm2 avs bap bfi c93 cak cin cmv cpk daud dct divx dts dv dvd dxa eac3 film flac flc fli fll flx flv g726 gsm gxf iss m1v m2v m2t m2ts m4a m4v mad mj2 mjpeg mjpg mka mkv mlp mm mmf mov mp+ mp1 mp2 mp3 mp4 mpc mpeg mpg mpga mpp mpu mve mvi mxf nc nsv nut nuv oga ogm ogv ogx oma ogg omg psp pva qcp qt r3d ra ram rl2 rm rmvb roq rpl rvc shn smk snd sol son spx str swf tgi tgq tgv thp ts tsp tta xa xvid uv uv2 vb vid vob voc vp6 vmd wav wma wmv wsaud wsvga wv wve

Supported outputs:

shout null fifo alsa oss httpd

Supported protocols:

file:// http:// lastfm:// mms:// mmsh:// mmst:// mmsu://

However when I try to play a stream, this happens

# mpc add mms://wm-live.sr.se/SR-P3-High
# mpc play
mms://wm-live.sr.se/SR-P3-High
[playing] #1/1   0:00/0:00 (100%)
volume: n/a   repeat: off   random: off   single: off   consume: off

No sound, checking status after a while:

# mpc
mms://wm-live.sr.se/SR-P3-High
[playing] #1/1   0:00/0:00 (100%)
volume: n/a   repeat: off   random: off   single: off   consume: off

# mpc stop
error: connection timeout

# mpc stop
volume: n/a   repeat: off   random: off   single: off   consume: off

Need help! Bought my WL-500GU just for using as a webradio alarm clock.

(Last edited by e85 on 9 Apr 2010, 00:45)

I tried to compile xmms2 for my wrt160nl, it begins to play mms audio stream, but CPU power is not enough, and the sound stutters. To reduce the  processor load may be need to recompile the audio decoding libraries and xmms2 using different optimization options.

--
  p.s. "waf" build script of xmms2 is awful 8-(

I have tried the same with mpd

I have also compiled 0.15.10 with ffmpeg support but not solve the problem.

I have also tried to run mpd in console:

mpd --no-deamon --stdout -v

When i tried to play a wma or a mms stream i receive the error:

ffmpeg: Open failed

But ffmpeg is correctly installed

(Last edited by ramponis on 12 Jul 2010, 18:12)

Hi there,

Please may I ask if anyone found any solutions to this problem?  Or even any clues as to what's going wrong?

Many thanks,
Jack

(Last edited by jack_kelly on 28 Feb 2011, 00:49)

The discussion might have continued from here.