OpenWrt Forum Archive

Topic: Netgear WNR100 v2

The content of this topic has been archived between 19 Apr 2018 and 22 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

nchall wrote:

I don't see how something as complicated as the PS3 can be hacked to run custom firmware, but this POS router from Comcast is somehow bulletproof? Wish I was more l33t!

It's not nearly as difficult, but there is much more attention focused on the PS3. I've had that router sitting on my desk since I made my last post, and I've cleared enough of my project backlog that I'm going to be working on it again. If you really want to get OpenWrt on this, you should learn the necessary skills and help out. Believe it or not, the biggest challenge I faced when I last worked on this was not the programming or working with the router, but reverse engineering the OpenWrt project structure and toolchain. The documentation on the wiki seems to be somewhat lacking.

I've made a post to the developer forums where you are all more than welcome to join me in my efforts to make this happen. Here's the link to the post.

OK I just stumbled upon this what do I need to learn to help with this and also I want to help with this I have this router also and I want to have the original firmware

Will appreciate the binary image even if it can't find the rootfs.. thanks

I had a WNR1000v2 gifted to me. It the retail unit and not the Comcast unit. I was able to enable Telnet on the unit and access it with Putty.

As mentioned earlier, it runs a modified version of OpenWRT Kamikaze 7.09. Several things have been removed from the looks of it. Even the vi editor is gone. None of the configuration files are in the right place, if they exist at all. The uci is there but is basically non-functional from what I could tell. I did discover the you can use "config show" to see the current configuration and use "config set" to change the configuration with "config commit" to make the configuration stick.

Many config items are listed that are not in the gui included WDS, But the listing is so convoluted that I have not made heads or tails of it yet.

I got the info for enabling telnet from a post in this thread. It appears that you have to do this each time the router reboots.

I hope this info helps someone out there.

(Last edited by zecableguy on 19 Nov 2013, 18:58)

Is there a way to to look at how Kamikaze is configured on the WNR1000v2 and use that to help build a newer OpenWRT?

I have telnet access to my WNR100v2-VC and it seems to have a stripped down version of Kamikaze OpenWRT already installed by Comcast.

Is there a way to read any useful data from that, or request from Netgear or Comcast the source code of their custom OpenWRT build?

I have a UK Model Netgear WNR1000V2h2. Not sure what the h2 part means. It was a retail boxed model purchased to fill a gap as a temporary router.
I have telnetted into it and retreived the following info. Not sure if it will help. I was going to look into building a firmware for it but it may be beyond me.

BusyBox v1.4.2 (2012-05-07 12:19:11 EDT) Built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 KAMIKAZE (7.09) -----------------------------------
  * 10 oz Vodka       Shake well with ice and strain
  * 10 oz Triple sec  mixture into 10 shot glasses.
  * 10 oz lime juice  Salute!
 ---------------------------------------------------


root@WNR1000v2:/# cat /proc/cpuinfo
system type             : Atheros AR7240 (Python)
processor               : 0
cpu model               : MIPS 24K V7.4
BogoMIPS                : 225.28
wait instruction        : yes
microsecond timers      : yes
tlb_entries             : 16
extra interrupt vector  : yes
hardware watchpoint     : yes
ASEs implemented        : mips16
VCED exceptions         : not available
VCEI exceptions         : not available



root@WNR1000v2:/# cat /proc/meminfo
MemTotal:        30232 kB
MemFree:         11872 kB
Buffers:          1716 kB
Cached:           5872 kB
SwapCached:          0 kB
Active:           4656 kB
Inactive:         4852 kB
HighTotal:           0 kB
HighFree:            0 kB
LowTotal:        30232 kB
LowFree:         11872 kB
SwapTotal:           0 kB
SwapFree:            0 kB
Dirty:               0 kB
Writeback:           0 kB
Mapped:           3308 kB
Slab:             6696 kB
CommitLimit:     15116 kB
Committed_AS:     5940 kB
PageTables:        468 kB
VmallocTotal:  1048560 kB
VmallocUsed:      1364 kB
VmallocChunk:  1047108 kB



root@WNR1000v2:/# ps
  PID  Uid     VmSize Stat Command
    1 root        352 S   init
    2 root            SWN [ksoftirqd/0]
    3 root            SW< [events/0]
    4 root            SW< [khelper]
    5 root            SW< [kthread]
    8 root            SW< [kblockd/0]
   36 root            SW  [pdflush]
   37 root            SW  [pdflush]
   39 root            SW< [aio/0]
   38 root            SW  [kswapd0]
   50 root            SW  [mtdblockd]
  140 root        268 S   klogd
  144 root        228 S   datalib
  241 root        112 S   /usr/sbin/potval
  336 root        348 S   udhcpd /tmp/udhcpd.conf
  340 root        204 S   /usr/sbin/net-scan
  387 nobody      356 S   /usr/sbin/dnsmasq -r /tmp/resolv.conf --wan-interface
  418 root         84 S   udhcpc -b -i eth0 -h WNR1000v2 -r 0.0.0.0 -N 0.0.0.0
  426 root        224 S   /usr/sbin/ntpclient
  447 root        320 S   /usr/sbin/miniupnpd
  462 root        820 S   uhttpd -e /usr/sbin/detwan
  465 root        136 S   inetd
 1667 root        652 S   hostapd /var/run/topology.conf
 1678 root        124 S   /usr/bin/wlanlog
 1699 root        356 S   syslogd -m 0 -T GMT-0 -c 511
 1714 root        348 S   crond -c /tmp/etc/crontabs -T GMT-0
 1735 root        236 S   /usr/bin/detcable 2
 1738 root        428 S   /bin/sh /sbin/button_detecte
 1754 root        272 S   lld2d br0
 1779 root        292 S   /sbin/traffic_meter
 1798 root        208 S   init
 1858 root        260 S   /usr/sbin/utelnetd -d -i br0
 1949 root        456 S   /bin/ash --login
 2584 root        220 R   /bin/sh /sbin/button_detecte
 2585 root        376 R   ps



root@WNR1000v2:/# lsmod
Module                  Size  Used by    Tainted: P
wlan_scan_ap            9344  1
ath_pktlog             14336  0
wlan_me                 9152  0
wlan_acl                5152  0
wlan_wep                5536  0
wlan_tkip              12608  0
wlan_ccmp               7936  0
wlan_xauth              1024  0
ath_pci                59104  0
ath_dev               123696  2 ath_pktlog,ath_pci
ath_rate_atheros       46928  2 ath_pktlog,ath_dev
wlan                  248768  11 wlan_scan_ap,ath_pktlog,wlan_me,wlan_acl,wlan_wep,wlan_tkip,wlan_ccmp,wlan_xauth,ath_pci,ath_dev
wlan_ext                3328  1 wlan
ath_hal               277088  4 ath_pktlog,ath_pci,ath_dev
ar7240gpiointr          4000  0
ar7240gpio              2720  0
ag7240_mod             39616  1 ar7240gpio
ip_nat_dnisip           6688  0
ip_conntrack_dnisip    15712  1 ip_nat_dnisip
ipt_TRIGGER             3232  1
ipt_spiadvDoS          13760  1
ipt_NETGEAR_REJECT     12672  0
ipt_urlBlock            5200  0
ipt_dnshijack           1408  0
ipt_spiDoS             18192  2
ip_nat_pptp             4880  0
ip_conntrack_pptp       7312  1 ip_nat_pptp
ip_nat_proto_esp        1280  0
ip_conntrack_proto_esp     6736  0
ip_nat_dnirtsp          6416  0
ip_conntrack_dnirtsp     8416  1 ip_nat_dnirtsp
ip_nat_dnih323          6016  0
ip_conntrack_dnih323    37440  1 ip_nat_dnih323
ip_nat_STARCRAFT        1504  0
ip6t_CONE               2304  0
ipt_CONENAT             1856  2
ip_nat_ftp              2464  0
ip_conntrack_ftp        5520  1 ip_nat_ftp

Is the hardware similar to another model. I need to do more digging. Maybe someone more experienced could look over the mem/cpu details.

I have since got myself a new UART - USB cable and connected to the serial port inside the WNR1000v2 and heres the output from the bootup. If someone could direct me to a guide where i can try producing a rom for this router i would be very gratefull. I do understand quite technical things but this would be my first venture into a custom rom for something.

I should also add that nothing is connected to the router apart from power and the serial cable, no lan cables etc.

Heres the UBoot log from the serial port.

U-Boot 1.1.4 (Sep  3 2009 - 20:04:48)

WNR1000v2 (ar7240) U-boot dni7 V0.8
DRAM:
sri
#### TAP VALUE 1 = e, 2 = e
32 MB
Top of RAM usable for U-Boot at: 82000000
Reserving 269k for U-Boot at: 81fbc000
Reserving 192k for malloc() at: 81f8c000
Reserving 44 Bytes for Board Info at: 81f8bfd4
Reserving 36 Bytes for Global Data at: 81f8bfb0
Reserving 128k for boot params() at: 81f6bfb0
Stack Pointer at: 81f6bf98
Now running in RAM - U-Boot at: 81fbc000
id read 0x100000ff
flash size 4194304, sector count = 64
Flash:  4 MB
In:    serial
Out:   serial
Err:   serial
Net:   ag7240_enet_initialize...
No valid address in Flash. Using fixed address
No valid address in Flash. Using fixed address
: cfg1 0xf cfg2 0x7014
eth0: 00:03:7f:09:0b:ad
eth0 up
: cfg1 0xf cfg2 0x7214
eth1: 00:03:7f:09:0b:ad
ATHRS26: resetting s26
ATHRS26: s26 reset done
eth1 up
eth0, eth1
Trying eth1
eth1 link down
FAIL
Trying eth0
eth0 link down
FAIL

 Client starts...[Listening] for ADVERTISE...TTT
Retry count exceeded; boot the image as usual

 nmrp server is stopped or failed !
Hit any key to stop autoboot:  0
   Verifying Checksum ... OK
### SQUASHFS loading 'image/uImage' to 0x80800000
### SQUASHFS load complete: 708303 bytes loaded to 0x80800000
## Booting image at 80800000 ...
   Image Name:   Linux Kernel Image
   Created:      2012-05-07  16:23:21 UTC
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    708239 Bytes = 691.6 kB
   Load Address: 80002000
   Entry Point:  8020d000
   Verifying Checksum ... OK
   Uncompressing Kernel Image ... OK
No initrd
## Transferring control to Linux (at address 8020d000) ...
## Giving linux memsize in bytes, 33554432

Starting kernel ...

Booting AR7240(Python)...
Linux version 2.6.15 (chao.zhang@dni-l-sw01) (gcc version 3.4.4 (OpenWrt-2.0)) #199 Mon May 7 12:22:02 EDT 2012
flash_size passed from bootloader = 4
CPU revision is: 00019374
Determined physical RAM map:
 memory: 02000000 @ 00000000 (usable)
Built 1 zonelists
Kernel command line: console=ttyS0,115200 root=31:08 rootfstype=squashfs init=/etc/preinit mtdparts=ar7240-nor0:256k(u-boot),64k(u-boot-env),3392k(rootfs),64k(config),128k(language_table),64k(pot),64k(traffic_meter),64k(ART),3473344@327744(mount_fs)
Primary instruction cache 64kB, physically tagged, 4-way, linesize 32 bytes.
Primary data cache 32kB, 4-way, linesize 32 bytes.
Synthesized TLB refill handler (20 instructions).
Synthesized TLB load handler fastpath (32 instructions).
Synthesized TLB store handler fastpath (32 instructions).
Synthesized TLB modify handler fastpath (31 instructions).
Cache parity protection disabled
PID hash table entries: 256 (order: 8, 4096 bytes)
Using 170.000 MHz high precision timer.
Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
Memory: 30108k/32768k available (1739k kernel code, 2644k reserved, 348k data, 108k init, 0k highmem)
Mount-cache hash table entries: 512
Checking for 'wait' instruction...  available.
NET: Registered protocol family 16
Returning IRQ 48
AR7240 GPIOC major 0
squashfs: version 3.0 (2006/03/15) Phillip Lougher
Initializing Cryptographic API
io scheduler noop registered
io scheduler deadline registered
Serial: 8250/16550 driver $Revision: #1 $ 1 ports, IRQ sharing disabled
serial8250.0: ttyS0 at MMIO 0x0 (irq = 19) is a 16550A
9 cmdlinepart partitions found on MTD device ar7240-nor0
Creating 9 MTD partitions on "ar7240-nor0":
0x00000000-0x00040000 : "u-boot"
0x00040000-0x00050000 : "u-boot-env"
0x00050000-0x003a0000 : "rootfs"
0x003a0000-0x003b0000 : "config"
0x003b0000-0x003d0000 : "language_table"
0x003d0000-0x003e0000 : "pot"
0x003e0000-0x003f0000 : "traffic_meter"
0x003f0000-0x00400000 : "ART"
0x00050040-0x003a0000 : "mount_fs"
mtd: partition "mount_fs" doesn't start on an erase block boundary -- force read-only
u32 classifier
    Perfomance counters on
nf_conntrack version 0.4.1 (256 buckets, 2048 max)
NET: Registered protocol family 2
IP route cache hash table entries: 512 (order: -1, 2048 bytes)
TCP established hash table entries: 2048 (order: 1, 8192 bytes)
TCP bind hash table entries: 2048 (order: 1, 8192 bytes)
TCP: Hash tables configured (established 2048 bind 2048)
TCP reno registered
ip_conntrack version 2.4 (256 buckets, 2048 max) - 260 bytes per conntrack
ip_tables: (C) 2000-2002 Netfilter core team
IPP2P v0.8.2 loading
DNIFILTER loading
TCP bic registered
NET: Registered protocol family 1
NET: Registered protocol family 10
IPv6 over IPv4 tunneling driver
ip6_tables: (C) 2000-2002 Netfilter core team
NET: Registered protocol family 17
Ebtables v2.0 registered
VFS: Mounted root (squashfs filesystem) readonly.
Freeing unused kernel memory: 108k freed
Warning: unable to open an initial console.
Algorithmics/MIPS FPU Emulator v1.5
init started:  BusyBox v1.4.2 (2012-05-07 12:19:11 EDT) multi-call binary
Loading data from /dev/mtd/3 ...
The data configuration is Valid
The data center is Running ...
/etc/net6conf/6proc: /etc/net6conf/6proc: 31: cannot create /proc/sys/net/ipv6/conf/eth0/accept_dad: Directory nonexistent
/etc/net6conf/6proc: /etc/net6conf/6proc: 31: cannot create /proc/sys/net/ipv6/neigh/eth0/not_send_neighbor_solicitation: Directory nonexistent
ipt_CONENAT: module license 'unspecified' taints kernel.
ip_conntrack_rtsp v0.6.21 loading
ip_nat_rtsp v0.6.21 loading
ip_conntrack_proto_esp loaded
ip_nat_proto_esp loaded
ip_conntrack_pptp version 3.1 loaded
ip_nat_pptp version 3.0 loaded
Generating Rules...
Done!
rmmod: ip_nat_dnisip.ko: Success
rmmod: ip_conntrack_dnisip.ko: Success
POT is Running...
POT is Finished!!!
The POT-(Get/Set) Demo is Running ...
SN: 2N3114590021E
WAN MAC: a0:21:B7:aD:E0:C9
AG7240: Length per segment 1536
AG7240: Max segments per packet 1
AG7240: Max tx descriptor count    40
AG7240: Max rx descriptor count    252
AG7240: fifo cfg 3 01f00140
AG7240CHH: Mac address for unit 0
AG7240CHH: a0:21:b7:ad:e0:c9
AG7240CHH: Mac address for unit 1
AG7240CHH: a0:21:b7:ad:e0:c8
INIT-SWITCH: Default WAN MAC is : a0:21:b7:ad:e0:c9
ag7240_ring_alloc Allocated 640 at 0x81c4ac00
ag7240_ring_alloc Allocated 4032 at 0x81368000
Setting PHY...
ADDRCONF(NETDEV_UP): eth0: link is not ready
/etc/rc.common: eval: 13: cannot create /proc/sys/net/ipv6/conf/eth0/accept_dad: Directory nonexistent
/etc/rc.common: eval: 13: cannot create /proc/sys/net/ipv6/neigh/eth0/not_send_neighbor_solicitation: Directory nonexistent
device eth1 entered promiscuous mode
ag7240_ring_alloc Allocated 640 at 0x81c4a800
ag7240_ring_alloc Allocated 4032 at 0x81cf1000
ATHRS26: resetting s26
ATHRS26: s26 reset done
Setting PHY...
ADDRCONF(NETDEV_UP): eth1: link is not ready
/etc/rc.common: eval: 13: cannot create /proc/sys/net/ipv6/neigh/eth1/not_send_neighbor_solicitation: Directory nonexistent
/etc/rc.common: eval: 13: cannot create /proc/sys/net/ipv6/neigh/eth1/not_send_neighbor_solicitation: Directory nonexistent
udhcp server (v0.9.8) started
The attached devices demo is Running ...
killall: utelnetd: no process killed
killall: telnetenable: no process killed
The telnetenable is running ...
Deleting static route ... Done!
Adding static route ... Done!
/etc/rc.common: eval: 13: /usr/sbin/hnapd: not found
Terminated
User defined signal 1
ag7240_ring_free Freeing at 0x81c4ac00
ag7240_ring_free Freeing at 0x81368000
ag7240_ring_alloc Allocated 640 at 0x81c4ac00
ag7240_ring_alloc Allocated 4032 at 0x81368000
Setting PHY...
ADDRCONF(NETDEV_UP): eth0: link is not ready
udhcp client (v0.9.8) started
killall: pppd: no process killed
Sending discover...
Sending discover...
Sending discover...
No lease, forking to background.
killall: ntpclient: no process killed
time zone index is : 0
Run NTP Client with setting: pri:time-g.netgear.com sec:time-h.netgear.com
killall: miniupnpd: no process killed
Jan  1 00:00:50 miniupnpd[444]: listening on 192.168.1.1:5555
cp: cannot stat '/usr/www/*': No such file or directory
The region number is: 0xFFFF
REGION is NULL
The abbreviation of English is Eng!
Didn't find the language table we need!
gui_region = English
region = English, download_region =
 Update string table successfully, memory usage: 312KB.
The httpd server is running ...
/etc/rc.common: eval: 13: detplc: not found
grep: /proc/pci: No such file or directory
/etc/rc.d/rc.wlan: /etc/rc.d/rc.wlan: 56: uname: not found
Args: 1
ath_hal: 0.9.17.1 (AR5416, REGOPS_FUNC, WRITE_EEPROM, 11D)
wlan: 0.8.4.2 (Atheros/multi-bss)
ath_rate_atheros: Copyright (c) 2001-2005 Atheros Communications, Inc, All Rights Reserved
ath_dev: Copyright (c) 2001-2007 Atheros Communications, Inc, All Rights Reserved
ath_pci: 0.9.4.5 (Atheros/multi-bss)
wifi0: Atheros 9285: mem=0x10000000, irq=48 hw_base=0xb0000000
wlan: mac acl policy registered
wlan_me: Version 0.1
Copyright (c) 2008 Atheros Communications, Inc. All Rights Reserved
wifi1     no private ioctls.

Creating ap for NETGEAR on
Added ath0 mode master
Interface doesn't accept private ioctl...
HALDbg (8BE0): Operation not permitted
Invalid command : ampdumin
Created ath0 mode ap for NETGEAR
/etc/ath/activateVAP: /etc/ath/activateVAP: 62: uname: not found
lo        no wireless extensions.

sit0      no wireless extensions.

br0       no wireless extensions.

eth0      no wireless extensions.

eth1      no wireless extensions.

wifi0     no wireless extensions.

device ath0 entered promiscuous mode
br0: port 2(ath0) entering learning state
br0: topology change detected, propagating
br0: port 2(ath0) entering forwarding state
/etc/ath/activateVAP: /etc/ath/activateVAP: 1: arping: not found
>>>>> WPS MODE, 1
>>>>> WPS ENABLED, PSK
cat: /etc/wpa2/WSC_ath0.conf: No such file or directory
>>>>> WPS Translate, Index:0
Making Topology File . . .
Reading topology file /var/run/topology.conf ...
Reading bss configuration file /etc/wpa2/WSC_ath0.conf ...

Too much delay 230865244 -3116016
br0: port 2(ath0) entering disabled state
Could not connect to kernel driver.
Using interface ath0 with hwaddr a0:21:b7:ad:e0:c8 and ssid 'NETGEAR'
Country ie is DE
br0: port 2(ath0) entering learning state
br0: topology change detected, propagating
br0: port 2(ath0) entering forwarding state
upnp_wps_device_init called
l2_packet_receive - recvfrom: Network is down
Starting Firewall...
Done!
/etc/rc.common: eval: 13: /bin: Permission denied
dnsmasq: failed to create listening socket: Address already in use
Start utelnetd by telnetenable
killall: lld2d: no process killed
traffic_meter start : .
killall: igmpproxy: no process killed
System startup completed!
/etc/init.d/rcS: /etc/init.d/rcS: 21: cannot create /proc/sys/net/ipv4/ip_conntBoot up procedure is Finished!!!

Please press Enter to activate this console.


BusyBox v1.4.2 (2012-05-07 12:19:11 EDT) Built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 KAMIKAZE (7.09) -----------------------------------
  * 10 oz Vodka       Shake well with ice and strain
  * 10 oz Triple sec  mixture into 10 shot glasses.
  * 10 oz lime juice  Salute!
 ---------------------------------------------------
root@WNR1000v2:/#

Bit more info from the Uboot after i interupted it.

ar7240> imls
Image at 9F050000:
   Image Name:   WNR1000v2-V1.1.2.54
   Created:      2012-05-07  16:23:25 UTC
   Image Type:   MIPS Linux Unknown Image (uncompressed)
   Data Size:    3444740 Bytes =  3.3 MB
   Load Address: 9f050000
   Entry Point:  9f050000
   Verifying Checksum ... OK
ar7240> printenv
bootdelay=4
baudrate=115200
ethaddr=0x00:0xaa:0xbb:0xcc:0xdd:0xee
serverip=192.168.1.101
ipaddr=192.168.1.1
bootcmd=fsload 80800000 image/uImage;bootm 80800000
bootargs=console=ttyS0,115200 root=31:08 rootfstype=squashfs init=/etc/preinit mtdparts=ar7240-nor0:256k(u-boot),64k(u-boot-env),3392k(rootfs),64k(config),128k(language_table),64k(pot),64k(traffic_meter),64k(ART),3473344@327744(mount_fs)
stdin=serial
stdout=serial
stderr=serial
ethact=eth1

Environment size: 451/65532 bytes
ar7240> bdinfo
boot_params = 0x81F6BFB0
memstart    = 0x80000000
memsize     = 0x02000000
flashstart  = 0x9F000000
flashsize   = 0x00400000
flashoffset = 0x00039A28
ethaddr     = 00:AA:BB:CC:DD:EE
ip_addr     = 192.168.1.1
baudrate    = 115200 bps
ar7240>

(Last edited by Ballz on 8 Jul 2014, 18:54)

I have been examining hardware and looking at this TP-Link TL-WR841ND the hardware list of the v5 is pretty much the same.

4MB Flash
32MB Memory
AR7240 CPU
and the wifi is Atheros 9280, this Netgear has an Atheros 9285 looking at the uboot log above. Any chance this firmware could work? How can I flash and test the v5 firmware?

Also how do i backup the current firmware before I start playing?

Thanks in advance. smile

Hi, guys!
Any progress here?
Thanks.

Just in case some of you are still watching this thread, OpenWRT just added support for this router in a recent patch.

https://dev.openwrt.org/changeset/44221
https://downloads.openwrt.org/chaos_cal … actory.img

I was able to use the firmware image from the second link to get OpenWRT running on mine. I never did get around to figuring out why my firmware wasn't working but the fact that the patch adding support for it modified the WNR1000v3 setup code means I was on the right track haha. If only we could have gotten there sooner we could have been running OpenWRT on these routers for 2-3 years. Anyways, the problem is solved now, so enjoy.

to CTRLC-ROOT

I have a WNR1000V2 and tried to upgrade from Web-Interface using openwrt-ar71xx-generic-wnr100v2-squashfs builts from "latest" and "trunk" and "chaos-calmer" .........all images were rejected !
Went thru all Netgears versions.....1.0.1.1 and 1.1.2.28 and 1.1.2.50 and 1.1.2.54 and tried again, ..all .img files were rejected.

Can you tell, what Netgear firmware you had installed, and did you used Web-Interface to load or something else ?
Thanks

(Last edited by jenom on 14 Oct 2015, 17:57)

jenom: First, do you have a WNR1000v2 or the comcast version WNR1000v2-VC? They use different images so make sure you're using the right one. I have the VC model and you can see the image I linked to above has "-vc-" in the filename. Second, if it fails through the web interface and you have a TTL-to-USB serial adapter then I would recommend opening up the case and connecting to the broken out serial port. On mine the serial port header was actually already present and I didn't even have to do any soldering. Then you can use the uboot prompt and tftp to transfer the image to the router and try booting from it. If that works you can then use the web interface in OpenWRT to upload a proper image to install. See http://wiki.openwrt.org/doc/howto/generic.flashing.tftp for more information on this approach. This is how I actually installed the image because I didn't have the original netgear firmware on the router from when I had been playing around with it earlier trying to get OpenWRT working on it.

The discussion might have continued from here.