OpenWrt Forum Archive

Topic: Multi-WAN Load Balancing

The content of this topic has been archived between 29 Mar 2018 and 3 May 2018. Unfortunately there are posts – most likely complete pages – missing.

potsmaster wrote:

VPN Routes

I am trying to use multiwan just for failover and I need to set up several routes via VPN devices (e.g. tap0) that should bypass the multiwan rules.   I could not get this to work with 1.0.16-0--the multiwan script only picks up "scope link" routes from the main routing table and ignores others, and it does not seem like the multiwan traffic rules support this.

The patch below causes routes which do not have link scope but do have a "via" attribute to be picked up as well.  Can you consider adding this to the next release, or letting me know if there's a better way to do this?  I also posted a ticket (https://dev.openwrt.org/ticket/7613).

Thanks.

Chris

--- multiwan.orig
+++ multiwan
@@ -661,7 +661,7 @@
 
         for TABLE in 170
         do
-                ip route | grep link | grep -Ev ^default | while read ROUTE
+                ip route | egrep 'link| via ' | grep -Ev ^default | while read ROUTE
                 do
                 ip route add table $TABLE to $ROUTE
                 done
@@ -748,7 +748,7 @@
 
         for TABLE in $(expr $i + 170)
         do
-                ip route | grep link | grep -Ev ^default | while read ROUTE
+                ip route | egrep 'link| via ' | grep -Ev ^default | while read ROUTE
                 do
                 ip route add table $TABLE to $ROUTE
                 done

1.0.17 should take care of this, let me know if it does not.

Thanks,
-Craig

SouthPawn wrote:
blubbi321 wrote:

ok, ive changed my configuration to have three nets now. lan on the router, wan - pointing to my internet connection, wlan - pointing to another internet connection.

since it is still not working - i can see traffic getting split using tcpdump, but clients dont get to see said traffic - i wanted to ask if you got any kind of documentation that i could use to debug what is going wrong?

Sorry, still working on creating better documentation, however in the meantime one thing I'd suggest is that atleast for firewall settings they are similar on both wan interfaces, including masquerading, icmp, etc..

ok, working now. thanks for your reply!

hope to see some documentation soon smile

luci-app-multiwan_1.0.16.ipk what exactly adds to LuCi interface? Because after the installation of this module I've not seen anything related to "multiwan" in LuCi web interface.

Thanks!

thanks for your multiwan.

I have trouble to use this with three wan.
I use PPPOE adsl, in my place it is possible to dial use the same username/password with the same physical line.
use this it is very easy to add up the bandwidth.
the adsl modem was connected to the router's wan port, I use macvlan to make virtual wan link to router's wan.
I named these to wan2,wan3 etc.
when there are two wan (wan ,wan2) everything is ok with multiwan,but when there are  three wan(wan ,wan2 wan3), only few chance to add up wan3's bandwidth. because the three wan dial up at the same time and sometimes they get the same gatway.
I also try three wan with dhcp ,it sees the same.
you chan see this


root@OpenWrt:~# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     *               255.255.255.0   U     0      0        0 br-lan
10.98.131.0     *               255.255.255.0   U     0      0        0 eth1.1
10.98.131.0     *               255.255.255.0   U     0      0        0 eth2
10.98.131.0     *               255.255.255.0   U     0      0        0 eth3
default         10.98.131.254   0.0.0.0         UG    0      0        0 eth1.1
now I use 1.0.17 ,the route table is like this with 1.0.16
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     *               255.255.255.0   U     0      0        0 br-lan
10.98.131.0     *               255.255.255.0   U     0      0        0 eth1.1
10.98.131.0     *               255.255.255.0   U     0      0        0 eth2
10.98.131.0     *               255.255.255.0   U     0      0        0 eth3
default         10.98.131.254   0.0.0.0         UG    0      0        0 eth1.1
default         10.98.131.254   0.0.0.0         UG    0      0        0 eth2
default         10.98.131.254   0.0.0.0         UG    0      0        0 eth3
root@OpenWrt:~# ip route
192.168.1.0/24 dev br-lan  src 192.168.1.1
10.98.131.0/24 dev eth1.1  src 10.98.131.42
10.98.131.0/24 dev eth2  src 10.98.131.87
10.98.131.0/24 dev eth3  src 10.98.131.91
default via 10.98.131.254 dev eth1.1

this is /etc/config/network

root@OpenWrt:/etc/config# vi network
        option 'nat' '1'
        option 'gateway' '192.168.1.1'
        option 'defaultroute' '0'
        option 'peerdns' '0'
        option 'dns' '202.106.196.115 202.96.64.38'

config 'interface' 'wan'
        option 'ifname' 'eth1.1'
        option 'defaultroute' '0'
        option 'peerdns' '0'
        option 'proto' 'dhcp'

config 'interface' 'wan2'
        option 'ifname' 'eth2'
        option 'defaultroute' '0'
        option 'peerdns' '0'
        option 'proto' 'dhcp'

config 'interface' 'wan3'
        option 'ifname' 'eth3'
        option 'defaultroute' '0'
        option 'peerdns' '0'
        option 'proto' 'dhcp'
- network 48/50 96%

config 'switch' 'eth1'
        option 'reset' '1'
        option 'enable_vlan' '1'

config 'switch_vlan'
        option 'device' 'eth1'
        option 'vlan' '0'
        option 'ports' '0 1 2 5*'

config 'switch_vlan'
        option 'device' 'eth1'
        option 'vlan' '1'
        option 'ports' '3 5*'

config 'interface' 'loopback'
        option 'ifname' 'lo'
        option 'proto' 'static'
        option 'ipaddr' '127.0.0.1'
        option 'netmask' '255.0.0.0'

config 'interface' 'lan'
        option 'type' 'bridge'
        option 'ifname' 'eth1.0'
        option 'proto' 'static'
        option 'ipaddr' '192.168.1.1'
        option 'netmask' '255.255.255.0'
        option 'nat' '1'
        option 'gateway' '192.168.1.1'
        option 'defaultroute' '0'
        option 'peerdns' '0'
        option 'dns' '202.106.196.115 202.96.64.38'

config 'interface' 'wan'
        option 'ifname' 'eth1.1'
        option 'defaultroute' '0'
        option 'peerdns' '0'
        option 'proto' 'dhcp'

config 'interface' 'wan2'
        option 'ifname' 'eth2'
        option 'defaultroute' '0'
        option 'peerdns' '0'
        option 'proto' 'dhcp'

config 'interface' 'wan3'
        option 'ifname' 'eth3'
        option 'defaultroute' '0'
        option 'peerdns' '0'
        option 'proto' 'dhcp'

this is /etc/config/multiwan

root@OpenWrt:/etc/config# vi multiwan

config 'multiwan' 'config'
        option 'default_route' 'balancer'

config 'interface' 'wan'
        option 'weight' '3'
        option 'health_interval' '10'
        option 'icmp_hosts' 'dns'
        option 'timeout' '3'
        option 'health_fail_retries' '3'
        option 'health_recovery_retries' '5'
        option 'dns' 'auto'
        option 'failover_to' 'balancer'

config 'interface' 'wan2'
        option 'weight' '3'
        option 'health_interval' '10'
        option 'icmp_hosts' 'dns'
        option 'timeout' '3'
        option 'health_fail_retries' '3'
        option 'health_recovery_retries' '5'
        option 'failover_to' 'balancer'
        option 'dns' 'auto'

config 'interface' 'wan3'
        option 'weight' '4'
        option 'health_interval' '10'
        option 'icmp_hosts' 'dns'
        option 'timeout' '3'
        option 'health_fail_retries' '3'
        option 'health_recovery_retries' '5'
        option 'failover_to' 'balancer'
        option 'dns' 'auto'

config 'mwanfw'
        option 'wanrule' 'balancer'

some guy at local forum told me that restart multiwan(/etc/init.d/multiwan restart) can solve this problem , I tryed it seem like what he said.

huglester wrote:
 tcpdump -ni eth0.3
00:31:49.680112 IP 192.168.0.101 > 8.8.4.4: ICMP echo request, id 8015, seq 0, length 64
00:31:49.708319 IP 8.8.4.4 > 192.168.0.101: ICMP echo reply, id 8015, seq 0, length 64
00:31:50.816975 IP 192.168.0.101.40315 > 8.8.4.4.53: 3459+ A? gg.google.com. (31)
00:31:50.882518 IP 8.8.4.4.53 > 192.168.0.101.40315: 3459 7/0/0 CNAME[|domain]

Thnaks for spending your time on me...

SouthPawn wrote:

Sorry for the delayed reply, and you may have already answered this, but when you reverse the wans in the config file, does the failure stay with the primary or is it always wan that fails?

If so, I'd be sure to check the firewall settings and make sure they are identical for both devices.

Helo again!
I'm also sorry for the delay, was away.. And want to continue the discution.

After your recommendations about looking into firewall, I looked inside the
/etc/config/firewall, and decided to add these lines:

config 'forwarding'
        option 'src' 'lan'
        option 'dest' 'wan2'

config 'rule'
        option 'src' 'wan2'
        option 'proto' 'udp'
        option 'dest_port' '68'
        option 'target' 'ACCEPT'

config 'rule'
        option 'src' 'wan2'
        option 'proto' 'icmp'
        option 'icmp_type' 'echo-request'
        option 'target' 'ACCEPT'

config 'zone'
        option 'name' 'wan2'
        option 'output' 'ACCEPT'
        option 'masq' '1'
        option 'mtu_fix' '1'
        option 'input' 'DROP'
        option 'forward' 'DROP'

before:

config 'include'
        option 'path' '/etc/firewall.user'

Now I don't see DNS request delays.. I'm only two hours under this settins, but with earlier settings even after 2-5minutes internet started timing out, and WANs were 'failing'

I'll post back the results, later, when I test this settings under 200MBit internet load smile

Thanks SouthPawn for this cute package smile!

cheers,
Jaroslav

Hello,

well I must say smth strange is still happening here...:(

logread |grep WAN
shows smth like this:

# logread  | grep WAN
Aug  5 20:27:13 tplink user.notice root: [Multi-WAN Notice]: Succesfully Initialized on Thu, 05 Aug 2010 20:27:13 +0300.
Aug  5 20:48:23 tplink user.notice root: [Multi-WAN Notice]: wan2 has failed and is currently offline.
Aug  5 20:49:28 tplink user.notice root: [Multi-WAN Notice]: wan2 has recovered and is back online!
Aug  5 20:50:06 tplink user.notice root: [Multi-WAN Notice]: wan2 has failed and is currently offline.
Aug  5 23:18:54 tplink user.notice root: [Multi-WAN Notice]: wan has failed and is currently offline.
Aug  5 23:21:17 tplink user.notice root: [Multi-WAN Notice]: wan has recovered and is back online!
Aug  5 23:25:25 tplink user.notice root: [Multi-WAN Notice]: wan has failed and is currently offline.
Aug  5 23:26:55 tplink user.notice root: [Multi-WAN Notice]: wan has recovered and is back online!
Aug  5 23:30:43 tplink user.notice root: [Multi-WAN Notice]: wan has failed and is currently offline.
Aug  5 23:33:58 tplink user.notice root: [Multi-WAN Notice]: wan has recovered and is back online!
Aug  5 23:47:01 tplink user.notice root: [Multi-WAN Notice]: wan has failed and is currently offline.
Aug  5 23:47:52 tplink user.notice root: [Multi-WAN Notice]: wan has recovered and is back online!
Aug  5 23:51:20 tplink user.notice root: [Multi-WAN Notice]: wan has failed and is currently offline.
Aug  5 23:53:43 tplink user.notice root: [Multi-WAN Notice]: wan has recovered and is back online!
Edit, these lines appeared not long ago:
Aug  6 00:16:31 tplink user.notice root: [Multi-WAN Notice]: wan has failed and is currently offline.
Aug  6 00:17:35 tplink user.notice root: [Multi-WAN Notice]: wan has recovered and is back online!
Aug  6 00:28:52 tplink user.notice root: [Multi-WAN Notice]: wan2 has recovered and is back online!

For example now, I'm pinging for ~30 minutes: ping -c 1 -W 3 -I eth0.3 8.8.8.8
(eth0.3 is wan2) - and I am not getting ANY reply...

If I reboot the router, the wan2 interface will work for some time...

Thanks for your ideas guys

(Last edited by huglester on 6 Aug 2010, 00:38)

@huglester - have you tried extending ping timeout to more than 3 secs? (Health Monitor ICMP Timeout) looks like a lossy connection to me.

andyballon wrote:

@huglester - have you tried extending ping timeout to more than 3 secs? (Health Monitor ICMP Timeout) looks like a lossy connection to me.

Hello. I have not tried, but the problem is that even when I tried pinging the gateway of WAN/WAN2 - they are timing out ....

oh. try setting it to a higher value. sometimes multiwan thinks the interface is down and tries to fix it and things go wrong. that's why you can't ping the gateways.
it's also " option 'timeout' '3' " in the config file. try 5secs.

Hello Andy,

sorry for the delay and thanks for suggestions. Well I tried them, situation is in some way better, I'll explain:

Setting these settings to higher values, does not bring the interfaces  down so often, but I see that sometime I ust have no internet connection.
After digging for more informations, I found out, that when I have no internet connection (to some hosts) I see that WAN or WAN2 is timing out ...

After some more investigation, I found out, that for example, traffic via WAN interface is dropping about 10-15% of pings, but when I have removed WAN2 - and logs showed that WAN2 has failed,
traffic via WAN interface gave me 0% of ping loss, I tried reviewing the code, since I know iptables a little. But here I see that I can't solve this problem by myself...

Thank You!

huglester

hmmm.... that is odd. are you pinging a host name or an ip address? try pinging 8.8.8.8 and see if you get lost packets. if you can ping that without lost packets then maybe it's your dns that's causing the problem.

Hey Craig,

You have a wonderful script for multiple wan configuration. I've been hacking something like your balancer and mwanfw for ~2 years. But nothing like this real thing! Therefore, I'm jumping your wagon and making a few contributions... see https://dev.openwrt.org/ticket/7792

Beside those minor improvements, I wonder the memory footprint of the script can be reduced? When the script manages triple wan's on my little thin WHR-HP-G54 with only 16 MB memory,  4 multiwan agents, plus an instance of wpa_supplicant and openvpn server, make it impossible to download a page with ssl curl. It actually runs out of memory and crashes/restarts the little wimp. smile

It will be nice if only one agent is needed to manage multiple wan's.

andyballon wrote:

hmmm.... that is odd. are you pinging a host name or an ip address? try pinging 8.8.8.8 and see if you get lost packets. if you can ping that without lost packets then maybe it's your dns that's causing the problem.

Hello Andy and others smile
It's me again... Thanks for taking so much of your time to look into my problem!

Well I was playing with this multiwan thingie for serveral hours and came to sollution, that this can be my VLAN issue.
Maybe I have configured them wrong....

Because: when I restarted router, I managed to get IP in the range of WAN, I could even ping a GATEWAN of WAN, (ttl was 64), and it should be 63, because I was behind the router...
So maybe I could paste ne network config, so you experts could take a look at it?

/etc/config/network

config 'interface' 'loopback'
       option 'ifname'   'lo'
       option 'proto'    'static'
       option 'ipaddr'   '127.0.0.1'
       option 'netmask'  '255.0.0.0'

config 'interface' 'lan'
        option 'ifname'   'eth0.1'
        option 'type'     'bridge'
        option 'proto'    'static'
        option 'ipaddr'   '192.168.1.1'
        option 'netmask'  '255.255.255.0'

config 'interface' 'wan'
        option 'ifname' 'eth0.2'
        option 'proto' 'dhcp'
        option 'dns' '8.8.8.8'
        option 'defaultroute' '0'
        option 'peerdns' '0'

config 'interface' 'wan2'
        option 'ifname' 'eth0.3'
        option 'dns' '8.8.4.4'
        option 'proto' 'dhcp'
        option 'defaultroute' '0'
        option 'peerdns' '0'

config 'switch'
    option 'name' 'rtl8366rb'
        option 'reset' '1'
        option 'enable_vlan' '1'

config 'switch_vlan'
        option 'device' 'rtl8366rb'
        option 'vlan' '1'
        option 'ports' '2 3 4 5t'

config 'switch_vlan'
        option 'device' 'rtl8366rb'
        option 'vlan' '2'
        option 'ports' '0 5t'

config 'switch_vlan'
        option 'device' 'rtl8366rb'
        option 'vlan' '3'
        option 'ports' '1 5t'

WAN is connected to WAN port
and WAN2 is connected to Port #1

What do you guys think of this config? is there anything I could change or maybe there are some obvious 'errors'?

Thank you!

Thanks for your multiwan.
It works well in my rg100a-aa residential gateway with 2 internet connection.

However, I get trouble while trying to compile the sources into the final image.

I'd like to compile the two packages into the openwrt-RG100A_DB120-jffs2-128k-cfe.bin file. The source of multiwan_1.0.12.ipk can be found at https://dev.openwrt.org/browser/packages/net/multiwan, and luci-app-multiwan_1.0.12d.ipk found at http://luci.subsignal.org/trac/browser/ … i-multiwan.

Here is my approach.

   0. cd ~/
   1. svn checkout svn://svn.openwrt.org/openwrt/branches/backfire
   2. cd backfire
   3. ./scripts/feeds update -a
   4. ./scripts/feeds install -a
   5. make menuconfig, bcm63xx, add libpthread and libpcap
   6. make
   7. copy ./bin/bcm63xx/openwrt-RG100A_DB120-jffs2-128k-cfe.bin to another directory, it works quite well in my rg100a-aa router
   8. cp feed.conf.default feed.conf
   9. vi feed.conf , replace "src-svn luci http://svn.luci.subsignal.org/luci/tags/0.9.0/contrib/package" by "src-svn luci http://svn.luci.subsignal.org/luci/trunk/contrib/package" which has luci-multiwan source codes.
   10. rm -rf feeds/luci*
   11. ./scripts/feeds update luci
   12. make menuconfig, add luci-multiwan
   13. make
   14. get new  ./bin/bcm63xx/openwrt-RG100A_DB120-jffs2-128k-cfe.bin, but it doesn't work in my rg100a-aa router. Evenmore, I coudn't get icmp reply by ping 192.168.1.1 command.

The strangest thing occured when I upload the early compiled firmware into rg100a-a router and opkg ./bin/bcm63xx/packages/luci-app-multiwan_0.9+svn6240-1_brcm63xx.ipk as long as ./bin/bcm63xx/packages/multiwan_1.0.17-0_brcm63xx.ipk. Those two packages work quite well now!

I'm puzzled why those two packages works well while installing them by opkg, but bad while packing them into image file?

Counld anyone help?

(Last edited by mzguanglin on 20 Aug 2010, 17:30)

buildster wrote:

Hey Craig,

You have a wonderful script for multiple wan configuration. I've been hacking something like your balancer and mwanfw for ~2 years. But nothing like this real thing! Therefore, I'm jumping your wagon and making a few contributions... see https://dev.openwrt.org/ticket/7792

Beside those minor improvements, I wonder the memory footprint of the script can be reduced? When the script manages triple wan's on my little thin WHR-HP-G54 with only 16 MB memory,  4 multiwan agents, plus an instance of wpa_supplicant and openvpn server, make it impossible to download a page with ssl curl. It actually runs out of memory and crashes/restarts the little wimp. smile

It will be nice if only one agent is needed to manage multiple wan's.

Hey buildster, I'm looking over some of the changes you submitted in that ticket. (was away on vaca.)
Anyhow, yeah I've been looking towards possibly making a stand-alone health-monitor as a means of reducing the overhead required for monitoring the active wan links.

(Last edited by SouthPawn on 23 Aug 2010, 09:34)

SouthPawn wrote:

Hey buildster, I'm looking over some of the changes you submitted in that ticket. (was away on vaca.)
Anyhow, yeah I've been looking towards possibly making a stand-alone health-monitor as a means of reducing the overhead required for monitoring the active wan links.

Hope you had a wonderful vacation. It's cool that you're looking for a means of reducing the overhead! I just started, over the weekend, experimenting changes toward this objective based on your job queue design.

Would you help me understand the script better? There are 5 types of tasks: fail, pass, acquire, refresh, and monitor (a wan's health). In term of task scheduling, should any priority be given to a certain type of task over another, or will first-in-first-out be fine? Are any duplicates for a particular group possible (and disallowed) in the job queue?

buildster wrote:
SouthPawn wrote:

Hey buildster, I'm looking over some of the changes you submitted in that ticket. (was away on vaca.)
Anyhow, yeah I've been looking towards possibly making a stand-alone health-monitor as a means of reducing the overhead required for monitoring the active wan links.

Hope you had a wonderful vacation. It's cool that you're looking for a means of reducing the overhead! I just started, over the weekend, experimenting changes toward this objective based on your job queue design.

Would you help me understand the script better? There are 5 types of tasks: fail, pass, acquire, refresh, and monitor (a wan's health). In term of task scheduling, should any priority be given to a certain type of task over another, or will first-in-first-out be fine? Are any duplicates for a particular group possible (and disallowed) in the job queue?

Well, the way it's structured is there is a background task launched for each wan, it's only job is to ping the hosts it's told to ping and check to make sure no ips have changed on it, this then writes a jobqueue file in /tmp/.mwan as to whether it passed or failed.

A third background task is launched that reads the file and calls adds to the failover count, recovery count or reacquisition of information from the wan link, and periodically checks to make sure the iptables rules are still in place.

Thanks for the great multi-wan package. I am using it for failover only (no load balancing) with 2 WAN connections. It would be really useful if it could send myself a notification email whenever the primary WAN goes down. Would this be hard to implement?

IIRC, link failure detection notifications already exist within one of the two Statistics apps for OpenWrt.
All that one needs to do is set up your OK, INFO, WARN, CRIT states and then assign which conditions need mailings.

Thank you so much! This is what I've been waiting for!

I run the script (1.0.17) on a Dlink DIR-825 with backfire 10.03, with a wireless-DSL link as default route and a (very slow, 384k) ADSL link as failover with quite a few traffic rules. It works just fine! Asterisk and Openvpn server that are run on the same router have their routes automatically adjusted after a short delay (depending on settings not relying on this script). It's just fantastic!

However I might have discovered a minor bug. The health monitor intervall setting seems to be broken. No matter what value is set, it sends a ping evey second. Not that this is interfering with normal operation, but it is a waste of resources and renders the setting quite pointless.

Greetings,
renoir.

renoir wrote:

However I might have discovered a minor bug. The health monitor intervall setting seems to be broken. No matter what value is set, it sends a ping evey second. Not that this is interfering with normal operation, but it is a waste of resources and renders the setting quite pointless.

Greetings,
renoir.

I can see a ping per second if health_interval is missing or "intervall" is misspelled. Also every second the script will check whether the iptables rules are still in place.

By the way, speaking about resources, I'm experimenting changes that reduce the load/overhead of monitoring multiple wan's.

buildster wrote:

I can see a ping per second if health_interval is missing or "intervall" is misspelled.

I checked my config file, no spelling mistakes. Still sends a ping every second...

Resources again, I noticed that the script runs n+1 agents for n WANs...

For performance, on a WRT54GS v1.1 running at 216 MHz, 2.4 kernel, wan speed maxed out at 9mbit while the script was running, with 2 active wans (pppoe), no load balancing. With the script not running, it reached 12 mbit which equals to the maximum speed I get from my ISP.

The DIR-825 doesn't show this bottleneck (not even noticeable load), but it runs at 680 MHz...

What is your approach to reduce load, if I may ask?

Greetings,
renoir.

(Last edited by renoir on 9 Sep 2010, 01:17)

renoir wrote:
buildster wrote:

I can see a ping per second if health_interval is missing or "intervall" is misspelled.

I checked my config file, no spelling mistakes. Still sends a ping every second...

Resources again, I noticed that the script runs n+1 agents for n WANs...

For performance, on a WRT54GS v1.1 running at 216 MHz, 2.4 kernel, wan speed maxed out at 9mbit while the script was running, with 2 active wans (pppoe), no load balancing. With the script not running, it reached 12 mbit which equals to the maximum speed I get from my ISP.

The DIR-825 doesn't show this bottleneck (not even noticeable load), but it runs at 680 MHz...

What is your approach to reduce load, if I may ask?

Greetings,
renoir.

I take my previous statement back. If health_interval is missing, it means ping is disabled--you won't see n+1 agents, but just 1 agent. I don't know how a ping every second comes about. Only another background process (the 1, not the n) wakes up every second, checking on iptables.

As for load reduction, I'm testing changes to the script on a WHR-HP-G54 (200 MHz CPU, 16 MB memory).... the load average is around 0.10 most of the time for 3 wan's, with a 2~4 minutes delay in updating health status. They're useful for thin routers if anyone is interested in making corresponding changes in luci-app-multiwan...

Hi,

Does any one have this multiwan running on D-Link DIR-825? I cannot get it working and cant find any howtos how to exactly do it with this device. I have one 200Mbit cable connection with DHCP and other 50/30Mbit VDSL2 with static ip-address. I would like to setup the cable connection so that it is on the LAN4 port on the switch and it would be only used by one port (torrents, heh).

Then the VDSL2 connection would be the primary connection and ALL the other traffic except the torrent-port would be routed via it.

question to southpawn: is it possible to (easily) modify the script in a way so that one can use multiple gateways (on the same network) without having to use multiple network interfaces?