OpenWrt Forum Archive

Topic: WZR-HP-G300NH Support

The content of this topic has been archived between 6 Feb 2018 and 3 May 2018. Unfortunately there are posts – most likely complete pages – missing.

Yup,

as far as I know, it's still a known problem. It has been improving over the last
year though. It's not openWrt specific.

This seems to be a long-term problem related to either a binary driver blob (Atheros) and/or hardware bug that's difficult to code around without greatly reducing WiFi throughput.  Sad, as this router has so much else going for it (Gigabit ports, large flash and memory, N WiFi).

As a B/G only AP it's fine.  It's stable if N WiFi is disabled.

Maybe it's time to purchase a different unit.

Any suggestions for a model with at least as much memory (flash and RAM), gigabit ports, runs OpenWrt/gargoyle and in the same price range?

Does anyone know whether Backfire 10.03.1 final works on an WZR-HP-G300NH A2 A0 other than the wireless problems reported? I do not use the wireless capabilities of the router - it is solely used as a wired router. When I installed OpenWRT on it I used the r27340 build for the WZR-HP-G301NH to work around the rtl8366s/rtl8366b issue, and the

* Merged WZR-HP-G300NH and -G301NH images

bullet in the -rc6 description gives me hope, but I'd like to know whether anyone's actually tested this combination before I possibly end up with no internet connection!

Thanks!

EDIT - Never mind - further digging found the answer sad

(Last edited by tww1fa on 4 May 2012, 05:27)

tww1fa, what did you find?  I never really found anything I considered to be concrete on the matter, but I definitely had no luck with 10.03.1 on the A2 A0 hardware revision.  I believe it was that same line in the rc6 release notes that prompted me to try it, but it wouldn't boot.

baar, it was actually your post on the previous page that I found.

I did some more research and found:

https://dev.openwrt.org/changeset/30724

which is a checkin from a couple of months ago on the backfire branch. This explains why people have been successful with Gargoyle 1.5.4 which is based on r30752. So the good news is that the fix is now in the backfire branch and should be in the next backfire beta/RC. The bad news is that it definitely is not in 10.03.1. Oh, well - I'll just have to wait some more or find an r30724+ backfire image somewhere...

EDIT: Looks like

https://dev.openwrt.org/changeset/30739

is also needed.

(Last edited by tww1fa on 4 May 2012, 08:06)

tww1fa wrote:

I did some more research and found:

https://dev.openwrt.org/changeset/30724

which is a checkin from a couple of months ago on the backfire branch. This explains why people have been successful with Gargoyle 1.5.4 which is based on r30752. So the good news is that the fix is now in the backfire branch and should be in the next backfire beta/RC. The bad news is that it definitely is not in 10.03.1. Oh, well - I'll just have to wait some more or find an r30724+ backfire image somewhere...

EDIT: Looks like

https://dev.openwrt.org/changeset/30739

is also needed.

Hmm, yeah I noticed OpenWRT snapshots broke on my A2 A0 device somewhere in early 2012.  Gargoyle's been working well; I've been running 1.5.3 and 1.5.4 for a few months now.

Regarding those patches you mentioned... if they're in Backfire SVN, I wonder if they're in the recent snapshots? http://downloads.openwrt.org/snapshots/trunk/ar71xx/

If I'm bored I'll try to flash one tonight.

aorth wrote:

Hmm, yeah I noticed OpenWRT snapshots broke on my A2 A0 device somewhere in early 2012.  Gargoyle's been working well; I've been running 1.5.3 and 1.5.4 for a few months now.

Regarding those patches you mentioned... if they're in Backfire SVN, I wonder if they're in the recent snapshots? http://downloads.openwrt.org/snapshots/trunk/ar71xx/

If I'm bored I'll try to flash one tonight.

Any luck?  Every snapshot I've tried from http://downloads.openwrt.org/snapshots/trunk/ar71xx/ has worked on my A2 02 G300NH.

This router does not support 3G dongles with the native firmware.
Will flashing it with openWRT allow me to use one?

@sim-value
Of course!

Thank you very much, will try this!

@aorth

Snapshots still seem to be working for me...

Hi,

So I am another newbiw looking to get Open-wrt running on my buffalo router, I'm just about ready to throw it at the wall. My current set up is:

Buffalo WZR-HP-G300NH(B) B0 C0
Kernel Version 3.3.8
OpenWrt Attitude Adjustment r32130 / LuCI Trunk (trunk+svn8702)

I installed the firmware and successfully set up the pppoe connection and can connect to the internet. I then installed LuCI and can access the router configuration through a web browser.

Ive set up wireless and can connect to the router via wireless.

The problems I am having are to do with browsing the internet and connecting to my work SSL VPN. Some sites will work most of the time, such as google.com, and then some sites won't load at all, and I cannot get my work SSL VPN page to load. The best connections seem to be immediately after the router has been rebooted and the connections slowly deteriorate after that. For example, I can connect to facebook and facebook chat will load, after a few minutes facebook chat will disconnect. As well, i can connect to https://mail.google.com and browse my email, but google chat will not connect. Throughout all this, Skype will stay connected fine (its the first thing to connect).

I am assuming there might be something that i need to configure with IPTables, but I havent been able to find what that might be, and as I'm experiencing intermittent problems (not a consistent blocking of ssl for example) I am not sure what configuration might need to be changed.

I have searched the forums a little bit, and there are certainly some versions of firmware that are recommended by some people, but others still have trouble, so im not sure if changing my firmware is the answer or not. I'm hoping that there are a few simple configuration steps that I have overlooked!

An example from my iptables log when trying to connect to the SSL VPN:

Jun 21 18:36:23 OpenWrt kern.warn kernel: [  585.130000] MSSFIX(wan):IN=br-lan OUT=pppoe-wan MAC=XX:XX:XX:3f:f9:d1:08:11:96:3e:c8:2c:XX:XX SRC=192.168.1.176 DST=x.x.x.x LEN=48 TOS=0x00 PREC=0x00 TTL=127 ID=19534 DF PROTO=TCP SPT=49868 DPT=443 WINDOW=8192 RES=0x00

And randomly in the logs i see the below, which from searches I have done was fixed in patches, but I'm still seeing it in the logs and not sure what that means.

OpenWrt kern.err kernel: [  199.840000] ath: phy0: Failed to stop TX DMA, queues=0x004!

Any hints on how to get this router stable will be much appreciated!!

I _believe_ but am no expert--
On your MSSFIX it appears that your computer (IN=br-lan)  is trying to send a packet larger than the MTU of the router out (OUT=pppoe-wan) to the WAN/internet.
http://www.firebrick.co.uk/fb6000/tcpmssfix.php

Not sure if this is hurting your transmission, as the page above says "The tcp-mss-fix option spots the TCP connection packets (SYN), finds the TCP MSS option, checked the value, and if too big it adjusts it. This way the negotiated MSS for the TCP link is lower and the end points send smaller packets to each other, so avoiding any errors or fragments."  -- which woudl imply it automatically limits itself.

Perhaps as a troubleshooting step you could turn down the MTU on your computer?  (i don't _know_ thats the right thing to do but it _seems_ to me like it would be)

just an idea to start with..

On the second point, cc yourself on
https://dev.openwrt.org/ticket/9654

Appears that there is investigation ongoing.  I have a friend having some wireless issues and is seeing this as well.

kernel: [90750.250000] ath: phy0: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x42000020 DMADBG_7=0x000082c0
kernel: [90750.260000] ath: phy0: Could not stop RX, we could be confusing the DMA engine when we start RX up

Thankyou! I did drop the MTU on the router, but I'll try and do that on the computer as well as see if that helps! And ill subscribe to that other thread and see where it goes smile

Actually, i think turning down the MTU on the router would have the opposite of the desired effect, if i'm reading the error correctly.  But then again, i'm no expert..

I'd set the router MTU back to default, and set the computer to that (or if it already is, to lower than that)..

Just a thought

Yup that's the plan, the router is now on default (drops to 1492) and ill change the computer instead!

I just bought a Buffalo WZR-HP-G300NH2. I wasn't able to do a tftp install, probably because of the locked U-boot mentioned in this forum and elsewhere, but I was able to do an mtd system upgrade from within an ssh session on the DD-WRT profesional firmware the router came with. (which I could tftp install just fine). As an important note, after the mtd flash and when the router came up, the red diag light never went off, but I was able to telnet in anyway. Once Luci was up I was able to turn off the red diag light, so it might be that the trunk version I installed just had the light on by default. (I installed OpenWrt Attitude Adjustment r32793)

Here are a couple of strange aspects that seem to differentiate the version I have.

root@host:/etc/config# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 01000000 00010000 "spi0.0"
mtd1: 01000000 00010000 "spi0.1"
mtd2: 00040000 00010000 "u-boot"
mtd3: 00010000 00010000 "u-boot-env"
mtd4: 00010000 00010000 "art"
mtd5: 00100000 00010000 "kernel"
mtd6: 01e90000 00010000 "rootfs"
mtd7: 01d10000 00010000 "rootfs_data"
mtd8: 00010000 00010000 "user_property"
mtd9: 01f90000 00010000 "firmware"

I got fw_printenv working, but only after fiddling with the numbers used to recreate the configuration file.
root@host:/etc/config# cat /etc/fw_env.config
#MTD device name    Device offset    Env. size    Flash sector size
/dev/mtd3        0x20500000        0x10000        0x10000

I'm still getting it all set up, so I haven't turned on wifi yet. It is replacing an existing WRT54GL that had openwrt on it, but I need to plan for a time to convert so I can handle the inevitable problems.

kowallis wrote:

I just bought a Buffalo WZR-HP-G300NH2. I was able to do an mtd system upgrade from within an ssh session on the DD-WRT profesional firmware the router came with.

I got a new WZR-HP-G300NH2 as well. I tried hard to love dd-wrt (I have it running on a "bridged" router) but I gave up. Things that are trivial in openwrt are just not working there (maybe, I couldn't figure out, mayby). Anyway, I ran mtd upgrade the diag light was steady red, and the device was not reachable.

Buffalo support offered RMA, so I am now waiting for replacement. I am nervous to brick another router; however, the limitations of DD-WRT will make network management much more difficult... Any advice?

For me, flashing using the web-interface has been more stable (100% success) as flashing over
ssh. So maybe that's an option for you as well ?

Luckily tftp works for me, so even when the flashing goes wrong, I can easily recover.

Question (and I am clearly grasping at straws here): do you change network segment before flashing? I changed  default 192.168.11.0 to 192.168.1.0. Obviously, the new image (openwrt) has 192.168.1 as well - so it shouldn't matter... But who knows!

Hello all how set wireles client mode in openwrt with virtual wifi internce?

I have a Buffalo WZR-450HP (WZR-HP-450) bought here in Japan, and following the guide;

* used the admin CGI URL to enable telnetd shown on the WZR-HP-G300NH page.
* used telnet to change uboot env for accept_open_rt_fmt=1
* set IP and static ARP entry as per WZR-HP-G450H page
* used DD tftp tool to successfully install openwrt.
* used telnet to set initial password
* used ssh to configure LAN to talk to internet (via other router)
* used ssh to run opkg commands to install LuCi and IPv6
* Configured WAN for my ISP, and enabled IPv6 to test HikariTV (IPv6 multicast IPTV)

No complaints, confirming this model was upgradable without much issues.

Can not get HikariTV to work as of yet, unsure if PPPoe should get an IPv6 address, or, its supposed to be "IPv6 passthrough".

(Last edited by lundman on 18 Aug 2012, 08:06)