OpenWrt Forum Archive

Topic: Bricked TP-LINK TL-WR741ND with compiled openwrt

The content of this topic has been archived on 27 Aug 2014. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hello all,

I'm afraid I bricked my router TL-WR741ND v1.8. After successful installing … actory.bin , I tried to make my own image using the image builder to save some space. So I listed all packages currently installed on this firmware version and removed all *luci* packages, because I wanted only access it via SSH.

I also included my config files by adding the FILES= parameter on make.

I used the procedure and tried to upload via netcat:

On the router run:
root@OpenWrt:/# nc -l -p 1234 | mtd write - firmware

On your system run:
user@yourpc:~% nc -q0 1234 < openwrt.bin

wherenever it finished uploading I typed reboot on the router and now it doesn't answer anything. Sometimes it is possible to ping it when it is booting (it answers only three times) and then the SYS LED stops blinking and is kept ON.

I have tried telnet'ing to it on ports 22, 23 and 9000 when it answer but all I get is connection refused.

I'm thinking of creating a cable to connect to it via console on its SJ1 port, but I don't know what to do next. Tried to contact TP-LINK support, but nothing yet.

Does anyone knows a way to unbrick it? Any procedure to reflash it via console through SJ1?

Thanks in advance,


Hey Tom,

Thank you very much for the reply. I'm going to try to make the cable and I'll post it when finished.

BTW, I'm running now a TL-WR1043ND with a USB Hub I have extended its memory by using a pen drive. Also, it is now a 3G router smile



mferreira, where can I find a tutorial about how to make tp-link serial cable? (i have a tl-wr741nd)

The discussion might have continued from here.