OpenWrt Forum Archive

Topic: Kamikaze 8.09 installed on Netgear DG834 - Cant route from LAN to WAN

The content of this topic has been archived on 1 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Running Kamikaze 8.09.2, r18801 (svn co at revision 21732), on a Netgear DG834 V2, using it to connect to my New Zealand ISP with PPPoA. Have documented my complete installation process up until now: http://compulsive-evasion.blogspot.com/ … er-v2.html

I can get the modem connected to my ISP just fine - I get a public IP on my WAN interface that changes each time I connect (I do not have a static IP, so this is correct). Have used the SSH client on the router to SSH out to my servers on the internet, so I can confirm the uplink is stable.

*UPDATE*
Works fine now!! Here is my setup:  http://compulsive-evasion.blogspot.com/ … er-v2.html if anyone needs this documentation in the future.

Now the problem is that i can't get any traffic from my LAN (laptop plugged into the modem, gets ip via DHCP) to route out to the WAN. Have read FAQ and tried to search for this, not entirely sure what part of the setup is wrong. So very close to having this running!
My OpenWRT setup is:

/etc/config/network:

config 'interface' 'loopback'
    option 'ifname' 'lo'
    option 'proto' 'static'
    option 'ipaddr' '127.0.0.1'
    option 'netmask' '255.0.0.0'

config 'interface' 'lan'
    option 'type' 'bridge'
    option 'ifname' 'eth0'
    option 'proto' 'static'
    option 'netmask' '255.255.255.0'
    option 'nat' '1'
    option 'dns' ''
    option 'gateway' '192.168.0.1'
    option 'ipaddr' '192.168.0.1'

config    'interface' 'wan'
    option 'ifname' 'nas0'
    option 'unit' '0'
    option 'proto' 'pppoa'
    option 'encaps' 'vc'
    option 'vpi' '0'
    option 'vci' '100'
    option 'username' 'XXX@adsl.XXXXX'
    option 'password' 'XXXXXXXXXX'
    option 'keepalive' '5,5'

So close to being able to use my OpenWRT as a ADSL router.. .

(Last edited by redrs on 10 Aug 2010, 13:34)

I can't say this will fix your problem for sure since I don't use PPPoA, but looking at the default /etc/config/network config, I believe you should replace nas0 with atm0.

config interface wan
##  PPPoA:
    option ifname   atm0
    option proto    pppoa
    option encaps   vc
    option vpi      0
    option vci      100
    option username "my_username"
    option password "my_password"

Since you're in NZ, you should verify that you're using Annex A (buildroot by default chooses Annex A).
I see that you have ATM stats, which I'm guessing means you're synced, but just to be sure look for the word SHOWTIME in /proc/avalanche/avsar_modem_training

If you have a serial console you can add an mtd5 spanning across both mtd0 and mtd1. That way you don't have to split images in the future.
Serial access is also very helpful for accessing the bootloader, since that 1 second FTP window can be a real pain sometimes.....as you're already aware.

Also, for the first boot section of your tutorial, you might want to check dmesg to make sure that your jffs2 partition has successfully completed before issuing 'passwd' and 'reboot'.
It can take a minute or two to finish.

Sorry for mentioning ATM at all, I should have read your second and third paragraphs.
I just noticed the inconsistency from the default config and went with it.

I don't know where you problem could be since DNS works as you've stated.

I did notice however that you're using an older build config on an 8.09 checkout.
The config from r10681 was meant for the 2.6.24 kernel whereas the latest 8.09 source is using 2.6.26.8.

If no one else has an ideas, I would build again, this time selecting the packages you want manually in buildroot.
This is my fairly minimal .config from yesterday, but I don't include any PPP packages.

Destination Port Unreachable

Firewall issue. Try restarting the firewall after the PPPoA connection is established.

KillaB, using nas0 and atm0 seem to have the same effect. Although I stuck with nas0 because it seems to come up a little faster.

Cheers for the config file. I'll use it as reference and try making my own, then I'll build and hopefully flashing it again with ADAM2 will be easy like it was the first time.

To the modem connected I have just:
* ssh to the modem
* ifup wan
* ifconfig -a -(I get my public IP)
* /etc/init.d/firewall restart
* the modem is connected, does dns and connects to internet servers fine.

Still can't get traffic on my LAN out to the Internet. I can SSH and HTTP to the modem fine, and can connect to its DNS server to get resolution. Seems to be a routing or firewall issue? I am trying to get this going all in IPv4.

Have not altered any of the firewall settings in /etc/config. I thought that my setup was kinda vanilla - minus using using PPPoA instead of PPPoE because of NZ ISP's.

Why don't you simply modify the stock /etc/config/network file instead of applying a new one?
I see a few lines that are just not necessary.

I'd remove the following, reboot, and see if that makes a difference.

    option 'dns' ''
    option 'gateway' '192.168.1.1'

    ## enable all network ports on router
    config 'switch' 'eth0'
    option 'reset' '1'

Again, not sure if this is required, but the wan ifname "should" be atm0 according to the example provided in the default /etc/config/network file.

option 'ifname' 'atm0'

I'm out of ideas beyond this.

Hi there.

I believe that all along it was this option that messed up my routing.

    option 'gateway' '192.168.1.1'

Using OpenWRT on my modem to post this right now!! Thanks for all the help.

I have documented the complete install on the DG834 v2 - and it works fine now. How would I get write access to the wiki to put it up? There was no complete documentation all on one page to do this before.

The discussion might have continued from here.