OpenWrt Forum Archive

Topic: FPU emulator disabled on brcm63xx

The content of this topic has been archived on 1 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

I compile some program for openwrt on AGPF ( brcm63xx ) but I have some problem with :

"FPU emulator disabled, make sure your toolchainwas compiled with software floating point support (soft-float"

I tested with

make kernel_menuconfig
    [*] Enable FPU emulation

but FPU emulation doesn't start .....

how can I do ?

(Last edited by magicko on 4 Aug 2010, 17:10)

The point was that this message does not indicate an error. Enabling the option above will get rid of the message but not change anything except making the kernel bigger.

jow wrote:

The point was that this message does not indicate an error. Enabling the option above will get rid of the message but not change anything except making the kernel bigger.

it's wrong

Enabling the option all applications start , before they stopped after message !!!

Then you compiled with an inappropraiate toolchain or used binaries not intended for this release.

The discussion might have continued from here.