OpenWrt Forum Archive

Topic: Bricked tp-link tl-wr1043nd?

The content of this topic has been archived on 17 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hi guys,

i have little problem with my TP-Link tl-wr1043nd.
I have installed backfire as described on this wiki page:
http://wiki.openwrt.org/toh/tp-link/tl- … s=wr1043nd

Everything went OK, until i accidentally disabled SSH server on router.
I have uninstalled few packages from openwrt like webserver because i did not wanted them.

Now i can't log into my router because there is no way how to do it.
Router was configured to have this IP address: 10.10.10.100

I setup-ed my local computer to have IP address 192.168.1.2 and if i plug off power cord from router and again put power cord on I can ping router for probably two seconds. I'm pinging router to address 192.168.1.1 - default as from manufacturer.

I guess there must be some way how load stock openwrt using TFTP but i can't figure how.

I tried use atftp like this:
atftp --trace --option "timeout 2" --option "mode octet" --put --local-file openwrt-ar71xx-tl-wr1043nd-v1-squashfs-factory.bin 192.168.1.1
But this do not work for me. Router continue as to boot - no flash.

I also tried "failsafe mode" as described here:
http://wiki.openwrt.org/toh/tp-link/tl- … lsafe.mode
Also did not worked for me.

Any suggestions what I should try?

Thanks in advance.

J.

I'v tried new approach. smile
According to this forum:
http://forum.fw5.net/viewtopic.php?f=7&t=6

I'v used these steps:
Alternative (the FiReSTaRT way, not sure if I picked it up on their # or on the forum)
-Unplug and replug the router
-Press the reset button for 2 seconds as soon as the 2nd(?) light goes on
-Let go and one of the lights will start blinking rapidly
-Test failsafe by pinging

Now I'm in failsafe mode. Wiki way did not worked for me - i think i messed something.

Good that it works now. Failsafe method on the wiki should work iinm. Spam the QSS button while it starts and one of the lights should be blinking periodically. When it blinks periodly, stop spamming. The same light will start blinking rapidly. Now you're in failsafe mode.


Well, since you're in failsafe mode, just telnet 192.168.1.1, type firstboot, and then reset the router. Your router should be back to default.

I had the same problem just a few seconds ago, but with VLAN, not SSH...
the firstboot/failsafe solution worked great.

Instead of using firstboot to reset the router you should use:

mtd -r erase rootfs_data

The mtd method wipes all changes you have made after flashing and is the recommended way for doing this.

(Last edited by written_direcon on 7 Nov 2010, 17:41)

The discussion might have continued from here.