OpenWrt Forum Archive

Topic: Differences in config between the fresh source and downloaded image?

The content of this topic has been archived on 22 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hi all,

Sorry for asking so many beginner questions in this group and thanks for the great help this far.

I notice that the size of the image built with the fresh source (i.e. built from the SVN check-out without any modification in the configurations) and the size of the pre-built image downloaded from the website are very different (7MB vs. 4MB, based on the same target). 

In fact, the image built from the fresh source doesn’t seem to be correct (Luci won’t load, although failsafe mode still works). 

So what are the major differences in the config files between the fresh source and the pre-built image?  If I want to build a working image from the fresh source, what configuration do I need to change (other than changing the target machine)?

Thanks very much in advance.

Regards,

Robert

when building from source only the base-system is selected by default, no other packages are selected. So, you have to select additional packages you need, and you can choose between building them into the image or compiling them as seperate packages (modules) to install them later. Integrating into the image has the advantage, that you save (flash-)space, because the compressionrate is higher.

eleon216 wrote:

when building from source only the base-system is selected by default, no other packages are selected. So, you have to select additional packages you need, and you can choose between building them into the image or compiling them as seperate packages (modules) to install them later. Integrating into the image has the advantage, that you save (flash-)space, because the compressionrate is higher.

Hi eleon,

Thanks for the explanation. 

My major problem is that I do want to start from the base-system (I only changed the target to TP-Link tl-wr741nd v1 which is my router).  The build and the flashing all went smooth, but Luci doesn't load (and therefore I cannot connect to 192.168.1.1) after flashing. 

So what else do I need to enable luci?  I went through all the config options (through make menuconfig and make kernel_menconfig), there isn't anything to specify luci though.  Any pointer will be greatly appreciated.

Thanks very much in advance.

Regards,

Robert

Hi Eleon and CuriousFig,

Thanks very much for the help.

I followed the instructions on the links and the build completed successfully.  However, when I look into the /bin/ar71xx/ directory, I cannot find the target image.  That is, I specified TP-Link TL-WR741ND as my target in both menuconfig and kernel_menuconfig, but I only got the following:

-rw-r--r-- 1 patrick patrick  4027432 2010-09-16 10:28 openwrt-ar71xx-rootfs.tar.gz
-rw-r--r-- 1 patrick patrick  5373952 2010-09-16 10:28 openwrt-ar71xx-root.jffs2-128k
-rw-r--r-- 1 patrick patrick  5373952 2010-09-16 10:28 openwrt-ar71xx-root.jffs2-64k
-rw-r--r-- 1 patrick patrick  3276800 2010-09-16 10:28 openwrt-ar71xx-root.squashfs
-rw-r--r-- 1 patrick patrick  3219460 2010-09-16 10:28 openwrt-ar71xx-root.squashfs-4k
-rw-r--r-- 1 patrick patrick  1193594 2010-09-16 10:28 openwrt-ar71xx-uImage-gzip.bin
-rw-r--r-- 1 patrick patrick   860028 2010-09-16 10:28 openwrt-ar71xx-uImage-lzma.bin
-rwxr-xr-x 1 patrick patrick  2640456 2010-09-16 10:28 openwrt-ar71xx-vmlinux.bin
-rwxr-xr-x 1 patrick patrick  2706848 2010-09-16 10:28 openwrt-ar71xx-vmlinux.elf
-rw-r--r-- 1 patrick patrick  1245184 2010-09-16 10:28 openwrt-ar71xx-vmlinux.gz
-rw-r--r-- 1 patrick patrick   917504 2010-09-16 10:28 openwrt-ar71xx-vmlinux.lzma
-rw-r--r-- 1 patrick patrick 26112826 2010-09-16 10:31 OpenWrt-ImageBuilder-ar71xx-for-Linux-i686.tar.bz2
-rw-r--r-- 1 patrick patrick 26962227 2010-09-16 10:30 OpenWrt-SDK-ar71xx-for-Linux-i686-gcc-4.3.3+cs_uClibc-0.9.30.1.tar.bz2
-rw-r--r-- 1 patrick patrick 13525554 2010-09-16 10:32 OpenWrt-Toolchain-ar71xx-for-mips_r2-gcc-4.3.3+cs_uClibc-0.9.30.1.tar.bz2

That is, the target image  "openwrt-ar71xx-tl-wr1043nd-v1-squashfs-factory.bin" is missing.  I did get that in my previous build (without Luci) though. 

I don't think the addition of Luci is the cause.  But what else could I be missing (I am using the latest source from SVN)?

Thanks again in advance.

Regards,

Robert

run make -V99 and look for errors.

But the compilation seems fine, just combining the kernel-image and rootfs-image to  trx- and bin-files fails.
I think your rootfs is just to big, I'm not sure whats the real limit, but I experienced something around 6MByte. (the flash has only 8MByte, some space is use for the bootloader, etc. and you need some space for your configuration-changes) so this limit makes probably sense.

You can try only building the squashfs-rootfs because thats what you will likely flash. If it doesn't work deselect packages which you don't need. If you need all of them consider using "mount-extroot", and move the rootfs to a big usbstick, oder usb-harddrive.

If you think the limit is nonsense... figure out where you can change it, or how to build a trx yourself smile

ps: I just checked: your device tl-wr741ND has just 4MB flash so, your image is way too big!

(Last edited by eleon216 on 16 Sep 2010, 20:21)

Hi Eleon,

Thanks so much again for your detailed instructions.  I really appreciate it.

Yeah, I think you are right.  I have trimmed many packages and rebuild again, now I got the target image, and it is now flashed perfectly onto my TL-WR741ND.

By the way, as I just posted as a new topic, I now have problem in configuring mesh networking in Luci.  Maybe you can help me again as well.

Basically, after flashing the image to the router, I just cannot find any mesh (or 802.11s) related menu in Luci.  So do I need to configure mesh in Luci at all? 

If so, where in Luci can I find the 802.11s configuration menu?

Thanks very much in advance.

Regards,

Rober

OK.  .  I finally figured out that it is hidden inside the “Mode” field underneath the Network->Wifi->Radio menu.

Now mesh is enabled.  I will try it out soon.

Regards,

Robert.

The discussion might have continued from here.