OpenWrt Forum Archive

Topic: WDS problem

The content of this topic has been archived between 31 Mar 2018 and 7 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

I still have problems setting up WDS.
The problem in detail is described here.
I can also put it here again, if necessary.
In the meantime i switched the routers, but this also did not help. At the moment, the LinkSys router acts as the "master" AP and the Buffalo is the "client" STA. However, the effect is still the same, exactly as described.
Do i have to configure anything else? Firewall? I read half the Internet, but did not find anything.
All clients (notebooks) connect only to the "master", no way, getting "hand-over" to work. And the "client" STA is not accessible from the clients (notebooks), except ping. LuCi doesn't load, ssh doesn't work. So what's wrong?
As ping works fine, i think, the general setup should be ok.
Any ideas?

Thanks in advance.

From the wireless wiki, lazy-wds is valid only for madwifi. If you want wds, set the operation mode to wds and specify bssid with the mac address of the other end.

lazy-wds?
there are so many (and the most outdated) descriptions out there, that i lost overview.
so, can you be more detailed?

So am i right and the config should look like this?

/etc/config/wireless:

config 'wifi-device' 'radio0'
    option 'type' 'mac80211'
    option 'macaddr' '00:1d:73:b1:91:d1'
    list 'ht_capab' 'SHORT-GI-40'
    list 'ht_capab' 'DSSS_CCK-40'
    option 'disabled' '0'
    option 'country' 'DE'
    option 'distance' '20'
    option 'channel' '8'
    option 'hwmode' '11g'

config 'wifi-iface'
    option 'device' 'radio0'
    option 'network' 'lan'
    option 'mode' 'wds'
    option 'isolate' '0'
    option 'bgscan' '0'
    option 'macfilter' 'none'
    option 'ssid' 'ssid'
    option 'bssid' '68:7f:74:06:b8:3a'
    option 'encryption' 'psk2'
    option 'key' 'secret'
/etc/config/wireless:

config 'wifi-device' 'radio0'
    option 'type' 'mac80211'
    option 'macaddr' '68:7f:74:06:b8:3a'
    list 'ht_capab' 'SHORT-GI-40'
    list 'ht_capab' 'DSSS_CCK-40'
    option 'hwmode' '11g'
    option 'channel' '8'
    option 'disabled' '0'

config 'wifi-iface'
    option 'device' 'radio0'
    option 'network' 'lan'
    option 'ssid' 'ssid'
    option 'bssid' '00:1d:73:b1:91:d1'
    option 'mode' 'wds'
    option 'encryption' 'psk2'
    option 'key' 'secret'

Nope, thats wrong.
Corrected configs below.

config 'wifi-device' 'radio0'
    option 'type' 'mac80211'
    option 'macaddr' '00:1d:73:b1:91:d1'
    list 'ht_capab' 'SHORT-GI-40'
    list 'ht_capab' 'DSSS_CCK-40'
    option 'disabled' '0'
    option 'country' 'DE'
    option 'distance' '20'
    option 'channel' '8'
    option 'hwmode' '11g'

config 'wifi-iface'
    option 'device' 'radio0'
    option 'network' 'lan'
    option 'mode' 'ap'
    option 'wds' '1'
    option 'isolate' '0'
    option 'bgscan' '0'
    option 'macfilter' 'none'
    option 'ssid' 'ssid'
    option 'encryption' 'psk2'
    option 'key' 'secret'
config 'wifi-device' 'radio0'
    option 'type' 'mac80211'
    option 'macaddr' '68:7f:74:06:b8:3a'
    list 'ht_capab' 'SHORT-GI-40'
    list 'ht_capab' 'DSSS_CCK-40'
    option 'hwmode' '11g'
    option 'channel' '8'
    option 'disabled' '0'

config 'wifi-iface'
    option 'device' 'radio0'
    option 'network' 'lan'
    option 'ssid' 'ssid'
    option 'mode' 'sta'
    option 'wds' '1'
    option 'encryption' 'psk2'
    option 'key' 'secret'

That's exactly how it was before, which doesn't work. See the link in the first post.
I'm getting more and more confused hmm

Oh I see. If you let the both APs ping each other, does it let you access both from the client?

jow wrote:

Oh I see. If you let the both APs ping each other, does it let you access both from the client?

No, i can't connect to the STA while they both are pinging each other. I only can reach the AP.

I did not change anything other except the changes in /etc/config/wireless.
Do i have to change anything else? Firewall settings or similar?
The link between the routers is established, so these setting in /etc/config/wireless should be ok.
Additionally i added the option bssid to both configs and put the mac-address of the other router in it without success.

One thing i just recognized:
I do have a static lease in my DHCP options on the AP. But sometimes i get another address out of the range on the STA. So i seem to be connected to the STA.
Internet works then, but much slower. I even can access the AP as before. But even if i got my IP-address from the STA i can't access LuCi or ssh into the STA.
This drives me crazy sad

anyone?

Just another idea. Do i need to enable STP as mentioned here? May this be the problem?

groovy wrote:

Just another idea. Do i need to enable STP as mentioned here? May this be the problem?

It's because he has several paths to the same destination. I think you can try it because "Broadcom WDS (Kernel 2.4) - OpenWrt Wiki" also mentioned stp.

Gargoyle set "ap+wds" on my Fonera+ running Gargoyle v1.2.5 (Kamikaze 8.09.2) like the following.

/etc/config/wireless

config 'wifi-device' 'wifi0'
    option 'type' 'atheros'
    option 'txpower' '10'
    option 'channel' '11'

config 'wifi-iface' 'cfg2'
    option 'device' 'wifi0'
    option 'mode' 'ap'
    option 'network' 'lan'
    option 'bssid' '00:11:22:33:44:55 00:11:22:33:44:66'
    option 'wds' '1'
    option 'ssid' 'ap_plus_wds'
    option 'encryption' 'psk2'
    option 'key' 'xxxxxxxx'

the most notable difference here is:


option 'type' 'atheros'

instead of

option 'type' 'mac80211'

I'll give it a try.

Read the uci wireless doc.

Used values are broadcom on brcm-2.4, atheros for madwifi or mac80211 for b43, ath5k and ath9k

fyi wrote:

Read the uci wireless doc.

Used values are broadcom on brcm-2.4, atheros for madwifi or mac80211 for b43, ath5k and ath9k

Thanks and sorry, i missed this one.

So my wireless config seems to be ok for WDS.
And as already mentioned, the routers _are_ connected because i can ping them both from the other routers console.
The problem must be anything else, but i have not the faintest idea what the problem could be sad

Try the 10.03.1-rc4 build.
Set option wds 1.
Set option bssid to peers mac address. It could be redundant but at least harmless.
Add ath0 to the ifname of lan interface. Again, redundant but harmless.
Try different encryptions.

(Last edited by fyi on 26 Nov 2010, 20:21)

Thanks for your time.
I will try rc4, didn't even know it's in the wild smile

For this:

fyi wrote:

Add ath0 to the ifname of lan interface. Again, redundant but harmless.

Do you really mean 'add' or should i 'rename' the interface? Can you provide a sample, how it's meant?

Thanks again for your support.

Run ifconfig to find out the name of the wifi interface and add it to br-lan.

    option 'ifname' 'eth0 wlan0 wlan0.sta1'

Suggested by projectgus. Don't you remember?

projectgus wrote:

Note the explicit adding of ath0 and ath0.sta0 to the bridge. Should not be necessary, but I found it was.

Edit:
I searched for "ath0.sta0" and found several interesting posts.

OpenWrt / troubles getting a LAN bridge setup
OpenWrt / mac80211 with security in WDS mode
OpenWrt / Working *but SLOW* WDS (wpa2) between two "foneras"

(Last edited by fyi on 27 Nov 2010, 11:49)

fyi wrote:

Run ifconfig to find out the name of the wifi interface and add it to br-lan.

    option 'ifname' 'eth0 wlan0 wlan0.sta1'

I upgraded both routers to backfire 10.03.1-rc4 (btw.: the WRT160NL got bricked with the sysupgrade-image, had to tftp the factory-image. Sysupgrade for the Buffalo went fine). So these are almost fresh installations without any additional packages installed.
After adding wlan0 and wlan0.sta to 'ifname' on the AP and switching the firewall completely off on the STA, i was able to successfully connect to the STA from the notebook (with ~10 second delay for each request). Well. For about 5 minutes. After that, the connection stalled again. On the STA there was no interface called wlan0.sta. Only eth0 and wlan0. So i only added wlan0 to 'ifname' on the STA.

Actually i have a printserver connected to the STA. It gets an ip-address from the AP (DHCP is disabled on the STA). I can ping this printserver from the notebook (sometimes) but very slow with more than 50% loss of packets.
I can successfully ping the printserver from the AP, but as soon as i try to access the configuration-website for the printserver (which never opens. surprise, surprise), the ping from the AP starts to lose packets and the respond time from the printserver increases.

So, i'm out of ideas. I hope you're not.

Don't count on me. I don't even have a decent draft N router.

The "wlan.sta0" or "wlan0.sta1" will come up when wds link is created.

You can see that I also run out of ideas so I started to search for useful information. Try "OpenWrt / Working *but SLOW* WDS (wpa2) between two "foneras" which created a redundant ap besides the wds ap.

groovy wrote:

I still have problems setting up WDS.
...
In the meantime i switched the routers, but this also did not help. At the moment, the LinkSys router acts as the "master" AP and the Buffalo is the "client" STA. However, the effect is still the same, exactly as described.

If you want WDS working, get two similar devices first.
This means - either two Linksys routers, or two Buffalo.  They should also have same chipset. And even better- to be the same model.

I have tested WDS between two TP-Link routers - WR1043ND and WR841ND (OpenWrt), and router and Wi-Fi Access Point WA801ND.
It works just fine. All of those have Atheros chipset.

Wireless mode for OpenWrt mode should be "AP+WDS"

vplessky wrote:

If you want WDS working, get two similar devices first.
This means - either two Linksys routers, or two Buffalo.  They should also have same chipset. And even better- to be the same model.

This doesn't really help me here. Both are Atheros based and i don't want to spend another € 80 just to find out, that it doesn't work either.

groovy wrote:
vplessky wrote:

If you want WDS working, get two similar devices first.
This means - either two Linksys routers, or two Buffalo.  They should also have same chipset. And even better- to be the same model.

This doesn't really help me here. Both are Atheros based and i don't want to spend another € 80 just to find out, that it doesn't work either.

That's why I asked question on forum What Atheros-based router(s) would you recommend some time ago.

Than I took list with suggestions, and bought WR841ND ($40) and WR1043ND (~$80).  Two routers for the price of one Linksys WRT160NL.
And added WA801ND, as it was also just $40.

Checked WDS between those units - it works.
Next step was to flash OpenWrt (to WR841ND) - and WDS again works.

P.S. You may try to contact Tech.Support for Buffalo and Linksys.
  But I doubt they would support you with creating WDS link with equipment from another vendor.

(Last edited by vplessky on 29 Nov 2010, 20:09)