OpenWrt Forum Archive

Topic: Simple Way to debrick WRT 160 NL

The content of this topic has been archived on 22 Mar 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hi friends, I just bricked my wrt 160 NL by using OEM  easy installation. I found this solution from the internet . Here are the steps ( under Linux Ubuntu).
0. Download binary form of WRT 160 NL
1. plug in the ethernet cable into ethernet no : 4 (on wrt 160 NL)
2. set ip addres of Linux and WRT 160 NL into 192.168.X subnet 255.255.255.0
3 Get into the console and type : 192.168.1.1 69 (do not press enter )
4. Turn on your WRT 160 NL
5  Within 2 Seconds you must press enter
6 Type :
   binary
    put firmware-wrt160nl.bin
    exit
Note (you must on the same directory where bin form of wrt 160 nl when you run steps no 6)

The process of debricking only last for 10 seconds.

I hope that it would be any help for friends.

Four years later, this post is still valid, but way miss spelled or incomplete, rendering it useless! But don't faint, there is still faith, you may be able to recover it without serial port!

Here is what I did:
I have had this router a long time, but I haven't flashed it with a custom firmware until some days ago. I tried to flash OpenWRT last version available for this hardware, openwrt-ar71xx-generic-wrt160nl-squashfs-factory.bin, and I bricked it!

Based on the previous post, I tried this on my Ubuntu 14.04 LTS 64 bits:
1) Install tftp client:
sudo apt-get install tftp
2) I downloaded DD-WRT's firmware for this hardware from http://www.dd-wrt.com/site/support/router-database, search for WRT160NL and you can download "WRT160NL v1 Firmware - Webflash image for first installation" (linksys-to-ddwrt-firmware.bin). I guess OpenWRT version or the original one (get it from http://support.linksys.com/en-us/suppor … /WRT160NL) should also work - not tested
2) I disabled my wifi interface, and manually configured eth0 to IP 192.168.1.2 and mask 255.255.255.0, no gateway or DNS needed, so forget it.
3) Connect eth0 to router's 4th LAN port
4) Open a terminal and go the folder where you downloaded the firmware. In my case,
cd ~/Downloads
5) Write the following command, but DON'T press enter:
6) tftp 192.168.1.1 69
7) Power on the router, and after some seconds (when ubuntu detects network link) press enter to run the command.
8) set it to binary mode writing:
binary
9) send the downloaded firmware, in my case DD-WRT's linksys-to-ddwrt-firmware.bin:
put linksys-to-ddwrt-firmware.bin
10) When it is done, exit tftp client:
quit
11) After some seconds, ping default ip address, and you should have brought it to live!!
ping 192.168.1.1
Now you can set your IP address to DHCP, configure the router, or whatever.

Credits to fishball: I wouldn't have been able to do this without your help!

I just brought back from the deads my modem following the second posts guidelines.
Thank you sooooo much smile

(Last edited by lepidas on 5 May 2016, 08:22)

Thanks, this worked perfectly after I disabled IPv6 as in Adapater Properties.

The discussion might have continued from here.