OpenWrt Forum Archive

Topic: Build for WNDR3700/WNDR3800

The content of this topic has been archived between 9 Jul 2013 and 6 May 2018. Unfortunately there are posts – most likely complete pages – missing.

Summary:  WDS client disconnect is causing WDS master to drop transition power to 3.  How to debug?

Details:  I was running Arokh's trunk.  I built my own using your recipe above (BTW, huge thanks!).  Everything works excellent, except the transition power of the master on the WDS drops to 3 dbm when one of the WDS clients disconnects.  The big power decrease happens every time a WDS client disconnects and no other time I have seen.  I can reboot a client or hit save on the wifi page and the host will drop the power.  I only need to click save-apply on the wifi page of the master to restore it to full power.  I have not tried your build, but I am sure it is the same as I do your build exactly.  I have 3 wndr3800s.  One is the master connected to the main wired internet connection.  The other two act as access points.  I use the A channel for the WDS (the two access points connect to the master on this channel) and the B/G channels on all three for wifi access if that make sense.

/etc/config/wireless on master

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11ng'
        option path 'pci0000:00/0000:00:11.0'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option channel '1'
        option htmode 'HT40+'
        option noscan '1'
        option txpower '26'
        option country '00'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'REDACTED-B-G-N'
        option encryption 'psk2+ccmp'
        option key 'REDACTED'
        option wps_pushbutton '0'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11na'
        option path 'pci0000:00/0000:00:12.0'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option channel '157'
        option htmode 'HT40+'
        option noscan '1'
        option distance '50'
        option country 'US'
        option txpower '24'

config wifi-iface
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'REDACTED-A-N'
        option wds '1'
        option encryption 'psk2+ccmp'
        option key 'REDACTED'
        option wps_pushbutton '0'

/etc/config/wireless on client(s)

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11ng'
        option path 'pci0000:00/0000:00:11.0'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option noscan '1'
        option country 'US'
        option txpower '26'
        option htmode 'HT40-'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'REDACTED-B-G-N'
        option encryption 'psk2+ccmp'
        option key 'REDACTED'
        option wps_pushbutton '0'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11na'
        option path 'pci0000:00/0000:00:12.0'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option channel 'auto'
        option htmode 'HT40+'
        option noscan '1'
        option distance '50'
        option country 'US'
        option txpower '24'

config wifi-iface
        option device 'radio1'
        option network 'lan'
        option encryption 'psk2'
        option key 'REDACTED'
        option wps_pushbutton '0'
        option ssid 'REDACTED-A-N'
        option mode 'sta'
        option wds '1'
        option bssid 'REDACTED'

Juhosg enabled kernel 3.7 support for ar71xx today, so I made a test build. Seems to work ok.
The build is available for adventurous people here: http://koti.welho.com/hnyman1/Openwrt/

(Officially the kernel version for ar71xx is still 3.6.11.)

------
@johnthomas00: I haven't tested WDS extensively, as there are no special modifications regarding that in my build. The radio driver should be just the standard one.

@Tacoos: I have been able to connect my USB sticks or HDDs just normally. Mostly FAT32 formatted.

(Last edited by hnyman on 1 Jan 2013, 21:10)

Ipconfig windows XP gives this:

Passerelle par défaut . . . . . . : 192.168.1.1
                                            fe80::3046:xxxx:xxxx:xxxx%4
        Serveur DHCP. . . . . . . . . . . : 192.168.1.1
        Serveurs DNS . . . . . . . . . .  : 192.168.1.1
                                            fec0:0:0:ffff::1%1
                                            fec0:0:0:ffff::2%1
                                            fec0:0:0:ffff::3%1

IPv6 gateway is false, it should be something with: 2a01:e34

Overall this is not a problem except for Windows Live messenger wich shows gateway error.

Manani wrote:

Ipconfig windows XP gives this:

Passerelle par défaut . . . . . . : 192.168.1.1
                                            fe80::3046:xxxx:xxxx:xxxx%4
...

IPv6 gateway is false, it should be something with: 2a01:e34

Overall this is not a problem except for Windows Live messenger wich shows gateway error.

My windows 7 gives the similar link-local fe80 address as the gateway, but it works just fine. That is probably not your error. For DNS I get the full routable address of the server.

(what are those %4 and %1? they look a bit strange.)

I just checked in windows 7, I have a full DNS too. It must be a particularity for Windows XP.

(Last edited by Manani on 30 Dec 2012, 20:25)

hnyman wrote:

what are those %4 and %1? they look a bit strange.

It is possible that this is a DOS format.

I have this as default firewall settings, is that makes sense?

config rule
    option name 'Allow-DHCPv6'
    option src 'wan'
    option proto 'udp'
    option src_port '547'
    option dest_port '546'
    option family 'ipv6'
    option target 'ACCEPT'
    option src_ip 'fe80::/10'
    option dest_ip 'fe80::/10'

This should not be the prefix of ISP?

Manani wrote:
hnyman wrote:

what are those %4 and %1? they look a bit strange.

It is possible that this is a DOS format.

Those are the scope id (interface index).

hnyman wrote:

EDIT: alternatively, if you only want that module and you already have a build environment ready, you could try just taking my .config.init, copy it to .config, run make menuconfig to blow it out and add that one kmod you want to the config. Then a normal make should create a firmware (that you do not need) and the packages directory with the kmod you could then install. There should be no strange kernel config options and the build scripts do nothing strange for the actual make process.

Hi Hnyman, and happy new year smile

I was able to spend some time on this just yesterday (had to deal with a massive RAID5 failure on my home server for several weeks, ending up losing the array... My rsnapshot-based backup saved my life smile). Here's what I did:

I checked out the trunk r34940 from the SVN (to match your build from the 31st)

I took you WNDR370.[...].config and used it to replace the .config of the trunk.

I then make menuconfig, and select the kmod-ipt-nathelper-rtsp as a package. I exit & save, and make.

It starts to build, builds properly a bunch of packages (but not the one I'm looking for) but the build exits without any clear reason. Even the verbose is unclear, it just exits after skipping some PCMCIA related packages.

Am I missing something?

Thanks !

(Last edited by Etique on 2 Jan 2013, 09:51)

Etique wrote:

Even the verbose is unclear, it just exits after skipping some PCMCIA related packages.
Am I missing something?

Hard to say. But based on that vagueness of the error message, you might try "make dirclean" to clean out all intermediate steps and the toolchain. There has been some changes like the kernel bump to 3.6.11 that require you to rebuild most of the toolchain.

I didn't also quite understand for your message if you had already a full buildroot environment ready, maening that you have updated & installed packages feeds etc. (look at the "updateNmake.sh" script about the steps related to updating all the svn sources, "installing" packages etc.

You should do at least:

svn up
./scripts/feeds update -a
./scripts/feeds install -a
make defconfig
make

If you want to fully mirror my "production environment", follow the advice here to re-create my build environment:
https://forum.openwrt.org/viewtopic.php … 11#p127011

(Last edited by hnyman on 2 Jan 2013, 10:06)

hnyman wrote:

Juhosg enabled kernel 3.7 support for ar71xx today, so I made a test build. Seems to work ok.
The build is available for adventurous people here: http://koti.welho.com/hnyman1/Openwrt/

(Officially the kernel version for ar71xx is still 3.6.11.)

------
@johnthomas00: I haven't tested WDS extensively, as there are no special modifications regarding that in my build. The radio driver should be just the standard one.

@Tacoos: I have been able to connect my USB sticks or HDDs just normally. Mostly FAT32 formatted.

Yesterday i tried the latest attitude adj build r34938 and immediatly the router went into failure again.
Unplugging the usb drive and rebooting the router solves the issue.

So i reverted to a trunk built r34940 and then no hang ups.

Now struggeling to get access to samba. Opened up firewall and created a mount point. The drive and directory are visible as share but access is refused. Am i suffering from the issue you mentioned above and is it solved in later builts??

Tacoos wrote:

Now struggeling to get access to samba. Opened up firewall and created a mount point. The drive and directory are visible as share but access is refused. Am i suffering from the issue you mentioned above and is it solved in later builts??

That issue was only in the trunk test build with kernel 3.71 and has been fixed by my own patch, which got pushed to svn by juhosg as r34955 and 34956.

I am not quite sure what you are trying to do. My build does NOT have samba server support. Instead, it has support for the cifs/smb (samba) filesystem and the router can act as a cifs/samba client. I can mount from the server console my NAS (which is the samba server). See https://dev.openwrt.org/ticket/12711#comment:9 for an example. I tested using the mounted NAS as the directory for Transmission torrenting and it worked just fine for me.

For the client functinality, there is no need for any firewall settings, so I guess that you are trying to do something else.

I'm trying to make the drive connected to the WNDR available for clients in the network. Eventually, it will be used for backing up data from a freenas server elsewhere in the network.
I installed samba server on the wndr and luci samba components, created a mount point and a share on the drive with guest access. As far as i know, it should now be accessible for anyone in the network.
I can see the share from clients in the network, but access is stil refused.
But maybe this is off-topic here?

Tacoos wrote:

I installed samba server on the wndr and luci samba components, created a mount point and a share on the drive with guest access. As far as i know, it should now be accessible for anyone in the network.
I can see the share from clients in the network, but access is stil refused.
But maybe this is off-topic here?

Yep, from my perspective it is off-topic, as there is no samba server in my firmware and there are (hopefully) no build-specific issues reagrding that extra module.
(Arokh's thread transformed itself into a generic wndr3700 & other help thread and I hope that it does not happen here...)

I have not published a new trunk version for a few days, as I have been struggling with high CPU load in the recent builds.

I have now identified one possible reason: apparently the changes made by r35025 to busybox options cause a conflict between two 'mkswap' versions, one provided by block-mount and the other by busybox. Info at bug 12765: https://dev.openwrt.org/ticket/12765

Currently compiling a new build with that culprit busybox setting disabled, so hopefully things get fixed.

EDIT:
build 35070 seems to work ok. UUID support has been added to the busybox mkswap. No idea why that helps. And not sure if that is a final cure or just a coincidence.

(Last edited by hnyman on 10 Jan 2013, 16:45)

I don't see any use of mkswap in r35003 - is that new? And is swap really needed, for this configuration? Hate to think that the BB build is becoming "heavyweight".

BusyBox v1.19.4 (2013-01-03 21:10:11 EET) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 BARRIER BREAKER (Bleeding Edge, r35003)
 -----------------------------------------------------
  * 1/2 oz Galliano         Pour all ingredients into
  * 4 oz cold Coffee        an irish coffee mug filled
  * 1 1/2 oz Dark Rum       with crushed ice. Stir.
  * 2 tsp. Creme de Cacao
 -----------------------------------------------------
root@Upstairs:~# cat /proc/swaps
Filename                                Type            Size    Used    Priority
root@Upstairs:~# grep mkswap /etc/init.d/*
root@Upstairs:~# 

(Last edited by tt on 10 Jan 2013, 14:47)

tt wrote:

I don't see any use of mkswap in r35003 - is that new? And is swap really needed, for this configuration? Hate to think that the BB build is becoming "heavyweight".

You are right, there is no use of mkswap with 35003. The functionality has been introduced by 35025 to trunk. And my build does not even activate that functionality.

And I am still not sure, if my diagnosis of the problem is right.

(Last edited by hnyman on 10 Jan 2013, 16:22)

Ok, sounds like it's time to sit tight for a bit and see what's coming in. Thanks for the heads-up!

A new build r35262 is up with the new defaults, kernel 3.7.3 and changed ipv6 config.
I had to modify my own ipv6 config slightly, and there was some strange trouble with the leftover settings, but the basic config worked after cleaning the router settings.

Info at: https://forum.openwrt.org/viewtopic.php … 40#p189540

EDIT:
This /etc/config/network seems to work for me. For tunnel usage, the default 6relayd config works ok, but please note that the defaults changes in the past few days, so make sure that you have the current version of /etc/config/6relayd

config 'interface' 'lan'
        option 'ifname' 'eth0.1'
        option 'type' 'bridge'
        option 'proto' 'static'
        option 'ipaddr' '192.168.1.1'
        option 'netmask' '255.255.255.0'
        option accept_ra '1'
        option ip6assign '64'

config 'interface' 'wan'
        option 'ifname' 'eth1'
        option 'proto' 'dhcp'

config 'interface' 'sixxs'
        option 'proto' '6in4'
        option 'mtu' '1424'
        option 'ttl' '64'
        option 'peeraddr' '62.78.96.38'
        option 'ip6addr' '2001:2222:100:444::2/64'
        option ip6prefix '2001:2222:333::/48'

(Last edited by hnyman on 22 Jan 2013, 11:36)

Hi hnyman,

I wanted to ask you if you got openvpn to work with ipv6-support.

If yes, could you explain me how to build openvpn-devel to support ipv6? (I am on a different router)

Sorry, I have never used openvpn.

(Last edited by hnyman on 21 Jan 2013, 14:47)

Ok, thank you.