OpenWrt Forum Archive

Topic: OpenWRT on a Davolink DV-201AMR

The content of this topic has been archived on 2 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hello.

We are trying to run OpenWRT on a Davolink DV-201AMR: http://wiki.openwrt.org/oldwiki/Hardwar … k/DV201AMR

But after this:

root@OpenWrt:/tmp# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00010000 00002000 "CFE"
mtd1: 000eff00 00010000 "kernel"
mtd2: 002f0000 00010000 "rootfs"
mtd3: 00180000 00010000 "rootfs_data"
mtd4: 00010000 00010000 "nvram"
mtd5: 003e0000 00010000 "linux"
root@OpenWrt:/tmp# mtd unlock CFE
Unlocking CFE ...
root@OpenWrt:/tmp# mtd write -f /tmp/patched-cfe-for-davolink.bin CFE
Unlocking CFE ...

Writing from /tmp/patched-cfe-for-davolink.bin to CFE ...     
root@OpenWrt:/tmp# reboot

The router is bricked

I guess next step is to connect with jtag according to this: http://gathering.tweakers.net/forum/lis … 4#27451094

And try to program the original or patched CFE via jtag.

Your help would be much appreciated!

Thank you.

(Last edited by NetworkPro on 21 Feb 2011, 02:38)

NetworkPro,

I unbricked my DV-2020 a few times.

You should be able to use the debrick utility from CShore:
http://wiki.openwrt.org/doc/hardware/jtag.cable
using a jtag cable. I used an unbuffered cable.

To compile just use make, and before executing rmmod lp.

Command to use:
./debrick -flash:custom /start:1fc00000 /window:1fc00000 /length:10000 /nobreak /noreset /bigendian

Before flashing a CFE verify it is in the correct format (bigendian versus litleendian)
Verify the first 4 bytes with the following command: od -x <file name>
The file should start with 0010 7802

It took me a lot of effort to get the CFE flashed back again.
I also tried the CFE form LinuxInside, but it doesn't give the full 8MB (some more effort is needed according LinuxInside).

Edit: a link to some additonal info on tweakers.net (Dutch) http://gathering.tweakers.net/forum/lis … 4#27451094

Edit2: direct link: https://docs.google.com/leaf?id=0B07LcV … amp;num=50

(Last edited by RomMon on 12 Feb 2011, 00:47)

I renamed patched-cfe-for-davolink.bin to CUSTOM.BIN and used your exact instructions.


[root@localhost HairyDairyMaid_WRT54G_Debrick_Utility_v48~cshore]# od -x CUSTOM.BIN |less
0000000 0010 7802 0000 0000 0000 0000 0000 0000

Very important step:

cat patched-cfe-for-davolink.bin | ./switchend > CUSTOM.BIN

./debrick -flash:custom /start:1fc00000 /window:1fc00000 /length:10000 /nobreak /noreset /bigendian

====================================
WRT54G/GS EJTAG Debrick Utility v4.8
====================================

Probing bus ... Done

Instruction Length set to 5

CPU Chip ID: 00000110001101001000000101111111 (0634817F)
*** Found a Broadcom BCM6348 Rev 1 CPU chip ***

    - EJTAG IMPCODE ....... : 00000000100000000000100100000100 (00800904)
    - EJTAG Version ....... : 1 or 2.0
    - EJTAG DMA Support ... : Yes

Issuing Processor / Peripheral Reset ... Skipped
Enabling Memory Writes ... Done
Halting Processor ... Skipped
Clearing Watchdog ... Done

Probing Flash at (Flash Window: 0x1fc00000) ... Done

Flash Vendor ID: 00000000000000000000000011000010 (000000C2)
Flash Device ID: 00000000000000000010001001111110 (0000227E)
*** Found a MX29LV640MB 4Mx16 BotB    (8MB) Flash Chip ***

    - Flash Chip Window Start .... : 1c000000
    - Flash Chip Window Length ... : 00800000
    - Selected Area Start ........ : 1c000000
    - Selected Area Length ....... : 00040000

...
[ 99% Flashed]   1fc0fff0: ffffffff ffffffff ffffffff ffffffff
Done  (CUSTOM.BIN loaded into Flash Memory OK)

=========================
Flashing Routine Complete
=========================
elapsed time: 192 seconds


*** REQUESTED OPERATION IS COMPLETE ***

[root@localhost HairyDairyMaid_WRT54G_Debrick_Utility_v48~cshore]#

I did this and WE HAVE A CFE !!!

(Last edited by NetworkPro on 13 Feb 2011, 05:07)

I flashed through the CFE Web interface: downloads.openwrt.org/backfire/10.03.1-rc4/brcm63xx/openwrt-DV201AMR-squashfs-cfe.bin

But it seems it is not working, there is nothing coming out of the router.


I then flashed openwrt-96348GW-10-gen-squashfs-cfe.bin via CFE web page 192.168.1.1 and now the OpenWRT is running

BUT

after restart EVERYTHING IS BACK TO DEFAULT

(Last edited by NetworkPro on 21 Feb 2011, 02:34)

NetworkPro,

Good the hear you have your CFE flashed again.

Regarding OpenWRT. Unfortunately I never managed to get it installed.
Jou should read the posts from LinuxInside (In https://forum.openwrt.org/viewtopic.php?id=17370) to understand why. It is probably needed to get his patch working again with the latest trunk.
Ciaby got it to work see this porst: https://forum.openwrt.org/viewtopic.php … 07#p121607
I never managed to get it to work: https://forum.openwrt.org/viewtopic.php … 18#p123118
Every time I do the make it will fail with:

src/imagetag.c: In function 'tagfile':
src/imagetag.c:340: error: 'struct bcm_tag' has no member named 'flashImageStart'
src/imagetag.c:343: error: 'struct bcm_tag' has no member named 'flashImageStart'
make[3]: *** [~/dv201/openwrt/trunk-24522/build_dir/host/firmware-utils/.built] Error 1
make[3]: Leaving directory `~/dv201/openwrt/trunk-24522/tools/firmware-utils'
make[2]: *** [tools/firmware-utils/compile] Error 2
make[2]: Leaving directory `~/dv201/openwrt/trunk-24522'
make[1]: *** [~/dv201/openwrt/trunk-24522/staging_dir/target-mips_uClibc-0.9.31/stamp/.tools_install_nnynn] Error 2
make[1]: Leaving directory `~/dv201/openwrt/trunk-24522'
make: *** [world] Error 2


Edit: The steps I used to compile OpenWRT without the patch from Ciaby:


svn co svn://svn.openwrt.org/openwrt/trunk
mv trunk trunk-24824
cd trunk-24524
make package/symlinks   
make menuconfig
make V=99
This takes about 1 hour and creates all images as expected.

After this the following is possible:
make kernel_menuconfig
find . -name board_bcm963xx.c                               



But if I use the patch from Ciaby:
svn co svn://svn.openwrt.org/openwrt/trunk
mv trunk trunk-24824
cd trunk-24824
wget http://www.brokenbydesign.org/Davolink2.patch
patch -p0 < Davolink2.patch
make package/symlinks   
make menuconfig
make V=99

Than make fails after about 15minutes with the above mentioned error :--(

(Last edited by RomMon on 13 Feb 2011, 23:04)

GOOD NEWS !!!

My friend danielskii gave me this file:
http://www.megaupload.com/?d=IALV1N7M = downloads.openwrt.org/backfire/10.03.1-rc4/brcm63xx/openwrt-96348GW-generic-squashfs-cfe.bin

With it, and with the LinuxInside patched CFE - the router remembers its settings after reboot !!!

Now I have to make the Wireless work.


root@OpenWrt:/# dmesg
Linux version 2.6.32.25 (openwrt@ampere) (gcc version 4.3.3 (GCC) ) #1 Fri Nov 19 21:51:29 PST 2010
Detected Broadcom 0x6348 CPU revision a2
CPU frequency is 256 MHz
16MB of RAM installed
registering 37 GPIOs
board_bcm963xx: CFE version: 1.0.37-0.6
bootconsole [early0] enabled
CPU revision is: 00029107 (Broadcom BCM6348)
board_bcm963xx: board name: DV201AMR
Determined physical RAM map:
 memory: 01000000 @ 00000000 (usable)
Initrd not found or empty - disabling initrd
Zone PFN ranges:
  Normal   0x00000000 -> 0x00001000
Movable zone start PFN for each node
early_node_map[1] active PFN ranges
    0: 0x00000000 -> 0x00001000
On node 0 totalpages: 4096
free_area_init_node: node 0, pgdat 802981f0, node_mem_map 802df000
  Normal zone: 32 pages used for memmap
  Normal zone: 0 pages reserved
  Normal zone: 4064 pages, LIFO batch:0
Built 1 zonelists in Zone order, mobility grouping off.  Total pages: 4064
Kernel command line: root=/dev/mtdblock2 rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200
PID hash table entries: 64 (order: -4, 256 bytes)
Dentry cache hash table entries: 2048 (order: 1, 8192 bytes)
Inode-cache hash table entries: 1024 (order: 0, 4096 bytes)
Primary instruction cache 16kB, VIPT, 2-way, linesize 16 bytes.
Primary data cache 8kB, 2-way, VIPT, no aliases, linesize 16 bytes
Memory: 13284k/16384k available (2140k kernel code, 3100k reserved, 453k data, 140k init, 0k highmem)
Hierarchical RCU implementation.
NR_IRQS:128
Calibrating delay loop... 254.97 BogoMIPS (lpj=509952)
Mount-cache hash table entries: 512
NET: Registered protocol family 16
registering PCI controller with io_map_base unset
registering PCI controller with io_map_base unset
bio: create slab <bio-0> at 0
pci 0000:01:1e.0: CardBus bridge, secondary bus 0000:02
pci 0000:01:1e.0:   IO window: 0x8008000-0x80080ff
pci 0000:01:1e.0:   IO window: 0x8008400-0x80084ff
pci 0000:01:1e.0:   MEM window: 0x38000000-0x3fffffff
PCI: Enabling device 0000:01:1e.0 (0000 -> 0003)
PCI: Setting latency timer of device 0000:01:1e.0 to 64
Switching to clocksource MIPS
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 512 (order: 0, 4096 bytes)
TCP bind hash table entries: 512 (order: -1, 2048 bytes)
TCP: Hash tables configured (established 512 bind 512)
TCP reno registered
NET: Registered protocol family 1
audit: initializing netlink socket (disabled)
type=2000 audit(0.233:1): initialized
squashfs: version 4.0 (2009/01/31) Phillip Lougher
Registering mini_fo version $Id$
JFFS2 version 2.2. (NAND) (SUMMARY)  ?© 2001-2006 Red Hat, Inc.
msgmni has been set to 25
io scheduler noop registered
io scheduler deadline registered (default)
gpiodev: gpio device registered with major 254
gpiodev: gpio platform device registered with access mask FFFFFFFF
bcm63xx_uart.0: ttyS0 at MMIO 0xfffe0300 (irq = 10) is a bcm63xx_uart
console [ttyS0] enabled, bootconsole disabled
bcm963xx_flash: 0x00400000 at 0x1fc00000
bcm963xx: Found 1 x16 devices at 0x0 in 16-bit bank
NOR chip too large to fit in mapping. Attempting to cope...
 CFI mfr 0x000000c2
 CFI id  0x0000227e
 Amd/Fujitsu Extended Query Table at 0x0040
  Amd/Fujitsu Extended Query version 1.3.
number of CFI chips: 1
cfi_cmdset_0002: Disabling erase-suspend-program due to code brokenness.
Reducing visibility of 8192KiB chip to 4096KiB
bcm963xx_flash: Read Signature value of CFE1CFE1
bcm963xx_flash: CFE bootloader detected
bcm963xx_flash: CFE boot tag found with version 6 and board type 96348GW
bcm963xx_flash: Partition 0 is CFE offset 0 and length 10000
bcm963xx_flash: Partition 1 is kernel offset 10100 and length dff00
bcm963xx_flash: Partition 2 is rootfs offset f0000 and length 300000
bcm963xx_flash: Partition 3 is nvram offset 3f0000 and length 10000
bcm963xx_flash: Partition 4 is linux offset 10000 and length 3e0000
bcm963xx_flash: Spare partition is 2a0000 offset and length 150000
Creating 5 MTD partitions on "bcm963xx":
0x000000000000-0x000000010000 : "CFE"
0x000000010100-0x0000000f0000 : "kernel"
mtd: partition "kernel" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
0x0000000f0000-0x0000003f0000 : "rootfs"
mtd: partition "rootfs" set to be root filesystem
mtd: partition "rootfs_data" created automatically, ofs=2A0000, len=150000 
0x0000002a0000-0x0000003f0000 : "rootfs_data"
0x0000003f0000-0x000000400000 : "nvram"
0x000000010000-0x0000003f0000 : "linux"
bcm63xx_enet MII bus: probed
bcm63xx_wdt started, timer margin: 30 sec
TCP westwood registered
NET: Registered protocol family 17
802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
All bugs added by David S. Miller <davem@redhat.com>
VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
Freeing unused kernel memory: 140k freed
Please be patient, while OpenWrt loads ...
mini_fo: using base directory: /
mini_fo: using storage directory: /overlay
bcm63xx_enet bcm63xx_enet.0: attached PHY at address 1 [Broadcom BCM63XX (1)]
eth1: link forced UP - 100/full - flow control off/off
device eth1 entered promiscuous mode
br-lan: port 1(eth1) entering forwarding state
Compat-wireless backport release: compat-wireless-2010-10-14-7-gab01eca
Backport based on wireless-testing.git master-2010-10-19
cfg80211: Calling CRDA to update world regulatory domain
roboswitch: Probing device eth0: Failed to enable switch
roboswitch: Probing device eth1: found a 5325! It's a 5350.
cfg80211: World regulatory domain updated:
    (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Broadcom 43xx driver loaded [ Features: PL, GPIO LED Mask: 0x000f, Firmware-ID: FW13 ]
PPP generic driver version 2.4.2
ip_tables: (C) 2000-2006 Netfilter Core Team
NET: Registered protocol family 24
nf_conntrack version 0.5.0 (209 buckets, 836 max)
CONFIG_NF_CT_ACCT is deprecated and will be removed soon. Please use
nf_conntrack.acct=1 kernel parameter, acct=1 nf_conntrack module option or
sysctl net.netfilter.nf_conntrack_acct=1 to enable it.
root@OpenWrt:/#

(Last edited by NetworkPro on 21 Feb 2011, 02:29)

More good news smile

I followed this https://dev.openwrt.org/ticket/7102

So this looks right, and after setting macaddr in /etc/config/wireless to the value of /sys/class/ieee80211/phy0/macaddress , the wireless was up again.

And the Bradcom b43 radio is working !! smile


More good news:

I did this:

I changed the original Broadcom miniPCI card with a TP-Link Atheros 802.11g miniPCI card and...

root@OpenWrt:/# opkg list kmod* | grep wirel
kmod-ath5k - 2.6.32.25+2010-10-19-1 - This module adds support for wireless adapters based on
kmod-ath9k - 2.6.32.25+2010-10-19-1 - This module adds support for wireless adapters based on
kmod-b43 - 2.6.32.25+2010-10-19-1 - Kernel module for Broadcom 43xx wireless support (mac80211 stack) new
kmod-b43legacy - 2.6.32.25+2010-10-19-1 - Kernel module for Broadcom 43xx-legacy wireless support (mac80211 stack) new
kmod-cfg80211 - 2.6.32.25+2010-10-19-1 - cfg80211 is the Linux wireless LAN (802.11) configuration API.
kmod-hostap - 2.6.32.25-brcm63xx-1 - Host AP is a driver for 802.11b wireless cards based on Intersil
kmod-hostap-cs - 2.6.32.25-brcm63xx-1 - Host AP is a driver for 802.11b wireless cards based on Intersil
kmod-hostap-pci - 2.6.32.25-brcm63xx-1 - Host AP is a driver for 802.11b wireless cards based on Intersil
kmod-hostap-plx - 2.6.32.25-brcm63xx-1 - Host AP is a driver for 802.11b wireless cards based on Intersil
kmod-usb-serial-sierrawireless - 2.6.32.25-1 - Kernel support for Sierra Wireless devices
kmod-wprobe - 2.6.32.25+1-1 - A module that exports measurement data from wireless driver to user space
root@OpenWrt:/# opkg install kmod-ath5k

and after reboot I had:

root@OpenWrt:/# wifi detect
root@OpenWrt:/# vi /etc/config/wireless

config wifi-device  radio0
        option type     mac80211
        option channel  11
        # option macaddr  00:14:78:xx:xx:xx
        option hwmode   11g

        # REMOVE THIS LINE TO ENABLE WIFI:
        option disabled 1

config wifi-iface
        option device   radio0
        option network  lan
        option mode     ap
        option ssid     OpenWrt
        option encryption none

root@OpenWrt:/# wifi up
Configuration file: /var/run/hostapd-phy0.conf
Using interface wlan0 with hwaddr 00:14:78:xx:xx:xx and ssid 'OpenWrt'
root@OpenWrt:/#

And wireless is up !!!

(Last edited by NetworkPro on 21 Feb 2011, 02:26)

NetworkPro,

Finally first time I see OpenWRT running on (one of) my router, a DV201.


BusyBox v1.15.3 (2010-11-11 23:54:31 PST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
|       |.-----.-----.-----.|  |  |  |.----.|  |_
|   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
|_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
Backfire (10.03.1-rc4, r24045) --------------------
  * 1/3 shot Kahlua    In a shot glass, layer Kahlua
  * 1/3 shot Bailey's  on the bottom, then Bailey's,
  * 1/3 shot Vodka     then Vodka.
---------------------------------------------------
root@OpenWrt:/#


But after a reboot:
Checking running image.....
Illegal image ! Image crc failed.(0xbfc10000)
Running image bad.
Checking backup image....
Backup image good. Copying backup to running(2686980).....
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
Image copied to running.(2686980)

So somehow the running image is altered, and causing the backup to be used.

You used the CFE from LinuxInside (http://wiki.openwrt.org/_media/oldwiki/ … volink.bin), which doesn’t have a backup mechanism.
Not sure if LinuxInside also disabled the crc verification…..




On my DV-2020 it didn’t work…
Auto run second count down: 0
Checking running image.....
Running image good. Comparing running image to backup.....
Backup image is different from running image. Copying running to backup(2686980).....
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
Image copied to running.(2686980)
Code Address: 0x80010000, Entry Address: 0x80010000
Decompression OK!
Entry at 0x80010000
Closing network.
Starting program at 0x80010000
Linux version 2.6.32.25 (openwrt@ampere) (gcc version 4.3.3 (GCC) ) #1 Fri Nov 19 21:51:29 PST 2010
Detected Broadcom 0x6348 CPU revision b0
CPU frequency is 256 MHz
16MB of RAM installed
registering 37 GPIOs
board_bcm963xx: CFE version: 1.0.37-4.3
board_bcm963xx: unknown bcm963xx board: DV2020
bootconsole [early0] enabled
CPU revision is: 00029107 (Broadcom BCM6348)
Kernel panic - not syncing: unable to detect bcm963xx board

But that is expected as the board id is not known.


I will try to flash the CFE from LinuxInside to my DV2020 and see the behavior. This CFE will also cause the board-id to become DV201AMR.
So I should get passed the above failure.


Edit:

Btw, what is switchend doing the the important step?

"Very important step:
cat patched-cfe-for-davolink.bin | ./switchend > CUSTOM.BIN"

(Last edited by RomMon on 14 Feb 2011, 22:31)

Good idea:
- if you have a JTAG to the board
- if you have a CFE backup to debrick later if needed

It's all about collaboration these projects, I couldn't have done it without you and without danielskii and LinuxInside as well.

We need this guy LinuxInside to show us how to mod the CFE.

I need to mod the CFE on A LOT of Broadcom machines to be able to run OpenWRT and use them as Wi-Fi APs/Clients as well as VLAN managed switches/wired routers.

Could you please share a compiled firmware for a Davolink router or a backup CFE from DV-201AMR ?

Thank you.

P.S. in the very important step, switchend is converting the endianness smile

(Last edited by NetworkPro on 14 Feb 2011, 22:36)

RomMon, The switchend program is included with HairyDairyMaid_WRT54G_Debrick_Utility_v48~cshore2.zip that you have shared with me smile

Too bad that there isn't an universal CFE that would work on DV201AMR and on RTA1025W for example.


It seems the Klojo CFE has endianness that could not be converted with switchend. I thought the process could be reversed (tested with another CFE). Maybe the Klojo CFE is not good.

I need to compare it to the other one to see what was patched. For the same purpose I need an original CFE.

We urgently need CFE modding examples, how-tos.




And about the CRC error: I found this mtd fixtrx command that is supposed to help with this: http://dev.openwrt.org/search?q=fixtrx http://www.google.com/search?q=mtd+fixtrx http://www.myopenrouter.com/download/10 … r-WGR614L/

(Last edited by NetworkPro on 26 Oct 2011, 08:46)

NetworkPro,

Thanks for pointing me to the switchend program. Never saw that it was included.
Saves me to reboot to windows and back.....


From what I have seen so far the CFE is (almost) not exchangeble with other boards.
I suspect that even the CFE from the DV-201AMR is not completely compatible with the CFE from the DV-2020.
One difference is the board-id, but there is probably more.....

I will have a look at CFE from Klojo. Maybe it got corrupted somehow.


Conversion of endianness from BE to LE is the same as from BE to LE.

a b c d e f g h
d c b a h g f e
a b c d e f g h


Regarding CFE modding. I didn't found much info, and after reading http://lostscrews.com/viewtopic.php?f=16&t=61 (also a nice project) I understood that it is not possible to decrypt the CFE. But LinuxInside action would suggest it is possible to decrypt the CFE.


Edit (15-2): Had a look at the uploaded CUSTOM-NO-MACADRES-ready-to-flash.bin file, but I don't see something wrong.
From my notes the files should start with 00-10-78-02 (hex). If you succeed to load the file then you can change the MAC via serial.
Can you check again from the file you succesfuly flashed using Cshore flasher did it start with 00-10-78-02 (hex)?
I think last time I used the one without DMA support...maybe it requires an CFE that is diffectly bite-swapped.
Too long ago to remember.

Edit2 (16-2): NetworkPro, I send you a pm with CFE info.

Edit3 (17-2): Just had a look at trunk-25565 and this seems to have the patches submitted by Cshore with mtd fixtrx for bcm63xx. I compiled this trunk release succesfully. I will try this image tomorrow or this weekend.

Edit4 (18-2): NetworkPro, great...the patch you found is working!!!!

Steps performed:
After first startup(only needed once):
root@OpenWrt:/# mtd fixtrx linux
Trying to fix trx header in linux at 0x0...
Verifying we actually have an imagetag.
Checking current fixed status.
Setting root length to 0.
Recalculating CRCs.
Erasing imagetag block
New image crc32: 0x9b1ddef0, rewriting block
New header crc32: 0x9f797d3c, rewriting block
Done.
root@OpenWrt:/# reboot
:
:
Auto run second count down: 0
Checking running image.....
Running image good. Comparing running image to backup.....                           <====Running image is now good!!
Backup image is different from running image. Copying running to backup(917504).....     <==== due to the new CRC value the backup is different.
>>>>>>>>>>>>>>>>>>>>>
Image copied to running.(917504)
:
:
And on each following reboot:
Checking running image.....
Running image good. Comparing running image to backup.....
Two Images are same.

(Last edited by RomMon on 19 Feb 2011, 01:24)

WOW AMAZING !!!! smile))

We have solved it !!! smile No more CFE patching required to run OpenWRT!

- How do we get rid of the firmware backup that CFE keeps, so we could use the space for installed software and stuff?

smile

(Last edited by NetworkPro on 21 Feb 2011, 02:18)

Building with V=99 reveals some error:

...
# Comtrend 536, 5621
# Generate the tagged image
/home/compileuser/trunk/staging_dir/host/bin/imagetag -i /home/compileuser/trunk/build_dir/linux-brcm63xx/vmlinux.lzma.cfe -f /home/compileuser/trunk/build_dir/linux-brcm63xx/root.squashfs --output /home/compileuser/trunk/bin/brcm63xx/openwrt-CT536_CT5621-squashfs-cfe.bin --boardid 96348GW-11 --chipid 6348 --entry 0x80010000                       --load-addr 0x80010000          --rsa-signature "" --info1 "+CT536_CT5621" --info2 squashfs   
Broadcom 63xx image tagger - v2.0.0
Copyright (C) 2008 Axel Gembe
Copyright (C) 2009-2010 Daniel Dickinson
Licensed under the terms of the Gnu General Public License
Data alignment to 64k with 'deadc0de' appended
# Davolink DV201AMR
/home/compileuser/trunk/scripts/brcmImage.pl -t -p -b DV201AMR -c 6348 -k /home/compileuser/trunk/build_dir/linux-brcm63xx/vmlinux.lzma.cfe -r /home/compileuser/trunk/build_dir/linux-brcm63xx/root.squashfs -o /home/compileuser/trunk/bin/brcm63xx/openwrt-DV201AMR-squashfs-cfe.bin
Can't locate Compress/Zlib.pm in @INC (@INC contains: /usr/local/lib/perl5 /usr/local/share/perl5 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl5 /usr/share/perl5 /usr/local/lib/perl5/site_perl/5.10.0/i386-linux-thread-multi /usr/local/lib/perl5/site_perl/5.10.0 /usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl /usr/lib/perl5/site_perl .) at /home/compileuser/trunk/scripts/brcmImage.pl line 31.
BEGIN failed--compilation aborted at /home/compileuser/trunk/scripts/brcmImage.pl line 31.
make[5]: *** [install] Error 2
make[5]: Leaving directory `/home/compileuser/trunk/target/linux/brcm63xx/image'
make[4]: *** [install] Error 2
make[4]: Leaving directory `/home/compileuser/trunk/target/linux/brcm63xx'
make[3]: *** [install] Error 2
make[3]: Leaving directory `/home/compileuser/trunk/target/linux'
make[2]: *** [target/linux/install] Error 2
make[2]: Leaving directory `/home/compileuser/trunk'
make[1]: *** [/home/compileuser/trunk/staging_dir/target-mips_uClibc-0.9.32/stamp/.target_install] Error 2
make[1]: Leaving directory `/home/compileuser/trunk'
make: *** [world] Error 2
[compileuser@fedora14 trunk]$

By the way now we can get images from here http://downloads.openwrt.org/snapshots/trunk/brcm63xx/

But if we need own customized images what do we need for the build to work?

(Last edited by NetworkPro on 21 Feb 2011, 05:29)

NeworkPro, routednbooted,

Here a link to my compiled image:
http://rapidshare.com/files/449177939/o … fs-cfe.bin

I compiled this on Slackware64-13.1 with the following commands, and it took about 1 hour or so.
It takes about 4GB of diskspace....on my VirtualBox VM.

svn co svn://svn.openwrt.org/openwrt/trunk
mv trunk trunk-25565
cd trunk-25565
make package/symlinks              # this gave an error
make V=99 package/symlinks     # this was errorfree
make menuconfig
make V=99
cd ~/openwrt/trunk-24824-2/bin/brcm63xx


If you use the CFE from LinuxInside it will skip the backup. According LinuxInside it is still needed to modfy the kernel to register the botom 4MB of the flash before you can use it. No idea how to do that...

I suspect LinuxInside did something similar as ali1234 to modify the CFE.

(Last edited by RomMon on 27 Feb 2011, 00:23)

NetworkPro

Can you help verify the Davolink Wiki page that I created?
Especially the JTAC section, as you have used it resently, where I'm really intrested if the CFE file to flash should start with 1000 0278.

I red it, I like it. The community should be thankful for your and our work put into this. I should find the time to check more closely soon.

NetworkPro, I think the community should be thankful for Orca and his work and time he put into this. I see his signature on each and every page I look at. Really amazing.

Orca,
I still have to look at the Flash Layout of the router. I read your pages about flash layout and file system. This made a lot more clear.
Hopefully this helps to create the table for the DV-201AMR.

The discussion might have continued from here.