Hi lordex,
i have installed openwrt bleeding edge r25661 on tplink mr3220(not sure if v1 or v1.2) few months ago and it works like a charm.
I use it as the AP and MJPEG streaming server(1280*800@5fps) with Logitech B905 usb webcam connected.
Here is the list of installed packeges:
root@OpenWrt:~# opkg list
base-files - 66-r25661
busybox - 1.17.3-2
crda - 1.1.1-1
dnsmasq - 2.57-1
dropbear - 0.52-5
firewall - 2-21
hotplug2 - 1.0-beta-4
iptables - 1.4.10-1
iptables-mod-conntrack - 1.4.10-1
iptables-mod-nat - 1.4.10-1
iw - 0.9.22-1
kernel - 2.6.32.29-1
kmod-ath - 2.6.32.29+2011-02-07-1
kmod-ath9k - 2.6.32.29+2011-02-07-1
kmod-button-hotplug - 2.6.32.29-3
kmod-cfg80211 - 2.6.32.29+2011-02-07-1
kmod-crc-ccitt - 2.6.32.29-1
kmod-crypto-aes - 2.6.32.29-1
kmod-crypto-arc4 - 2.6.32.29-1
kmod-crypto-core - 2.6.32.29-1
kmod-i2c-core - 2.6.32.29-1
kmod-input-core - 2.6.32.29-1
kmod-input-gpio-buttons - 2.6.32.29-1
kmod-input-polldev - 2.6.32.29-1
kmod-ipt-conntrack - 2.6.32.29-1
kmod-ipt-core - 2.6.32.29-1
kmod-ipt-nat - 2.6.32.29-1
kmod-ipt-nathelper - 2.6.32.29-1
kmod-leds-gpio - 2.6.32.29-1
kmod-ledtrig-usbdev - 2.6.32.29-1
kmod-mac80211 - 2.6.32.29+2011-02-07-1
kmod-nls-base - 2.6.32.29-1
kmod-ppp - 2.6.32.29-1
kmod-pppoe - 2.6.32.29-1
kmod-usb-core - 2.6.32.29-1
kmod-usb-ohci - 2.6.32.29-1
kmod-usb2 - 2.6.32.29-1
kmod-video-core - 2.6.32.29-1
kmod-video-uvc - 2.6.32.29-1
libc - 0.9.32-66
libgcc - 4.3.3+cs-66
libiptc - 1.4.10-1
libjpeg - 6b-1
libnl-tiny - 0.1-2
libpthread - 0.9.32-66
libuci - 2011-01-19.1-1
libxtables - 1.4.10-1
mjpg-streamer - r136-1
mtd - 15
opkg - 576-1
ppp - 2.4.4-16
ppp-mod-pppoe - 2.4.4-16
swconfig - 7
uci - 2011-01-19.1-1
udevtrigger - 106-1
wireless-tools - 29-4
wpad-mini - 20110117-1
---------------------------------------
And some configuration (maybe someone find it usefull):
/etc/config/mjpg-streamer
config mjpg-streamer core
option device "/dev/video0"
option resolution "1280x800"
option fps "5"
option port "8090"
option enabled "true"
/etc/hotplug.d/usb/20-mjpg-streamer
case "$ACTION" in
add)
# start process
/etc/init.d/mjpg-streamer start
;;
remove)
# stop process
/etc/init.d/mjpg-streamer stop
;;
esac
Wifi:
/etc/config/wireless
config wifi-device wlan0
option type mac80211
option channel 11
option macaddr 74:ea:3a:cd:5a:00
option hwmode 11ng
option htmode HT20
list ht_capab SHORT-GI-40
list ht_capab TX-STBC
list ht_capab RX-STBC1
list ht_capab DSSS_CCK-40
# REMOVE THIS LINE TO ENABLE WIFI:
option disabled 0
config wifi-iface
option device wlan0
option network lan
option mode ap
option ssid Skola2
option encryption psk2
option key some_strong_pass
LAN:
/etc/config/network
config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
config interface lan
option ifname eth0
option type bridge
option proto static
option ipaddr 192.168.1.16
option netmask 255.255.255.0
option gateway 192.168.1.1
option dns 192.168.1.1
#config interface wan
# option ifname eth1
# option proto dhcp
config switch eth0
option enable_vlan 1
config switch_vlan
option device eth0
option vlan 1
option ports "0 1 2 3 4"
mount:
root@OpenWrt:~# mount
rootfs on / type rootfs (rw)
/dev/root on /rom type squashfs (ro,relatime)
proc on /proc type proc (rw,noatime)
sysfs on /sys type sysfs (rw,noatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
tmpfs on /dev type tmpfs (rw,noatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,noatime,mode=600)
/dev/mtdblock3 on /overlay type jffs2 (rw,noatime)
mini_fo:/overlay on / type mini_fo (rw,noatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
none on /proc/bus/usb type usbfs (rw,relatime)
root@OpenWrt:~# df -h
Filesystem Size Used Available Use% Mounted on
/dev/root 1.5M 1.5M 0 100% /rom
tmpfs 14.4M 40.0K 14.4M 0% /tmp
tmpfs 512.0K 0 512.0K 0% /dev
/dev/mtdblock3 1.1M 380.0K 756.0K 33% /overlay
mini_fo:/overlay 1.5M 1.5M 0 100% /
root@OpenWrt:~# uptime
04:57:42 up 17 days, 4:57, load average: 0.00, 0.00, 0.00
root@OpenWrt:~# free
total used free shared buffers
Mem: 29528 19224 10304 0 1332
Swap: 0 0 0
Total: 29528 19224 10304
list of loaded kernel modules:
root@OpenWrt:~# lsmod
Module Size Used by Not tainted
uvcvideo 52448 1
v4l2_common 11760 0
videodev 29344 3 uvcvideo,v4l2_common
v4l1_compat 12128 2 uvcvideo,videodev
i2c_dev 4064 0
ohci_hcd 16896 0
ledtrig_usbdev 2112 0
nf_nat_tftp 432 0
nf_conntrack_tftp 2400 1 nf_nat_tftp
nf_nat_irc 816 0
nf_conntrack_irc 2512 1 nf_nat_irc
nf_nat_ftp 1328 0
nf_conntrack_ftp 4640 1 nf_nat_ftp
ipt_MASQUERADE 992 1
iptable_nat 2768 1
nf_nat 10912 5 nf_nat_tftp,nf_nat_irc,nf_nat_ftp,ipt_MASQUERADE,iptable_nat
xt_NOTRACK 544 0
iptable_raw 656 1
xt_state 768 3
nf_conntrack_ipv4 7920 6 iptable_nat,nf_nat
nf_defrag_ipv4 656 1 nf_conntrack_ipv4
nf_conntrack 38848 12 nf_nat_tftp,nf_conntrack_tftp,nf_nat_irc,nf_conntrack_irc,nf_nat_ftp,nf_conntrack_ftp,ipt_MASQUERADE,iptable_nat,nf_nat,xt_NOTRACK,xt_state,nf_conntrack_ipv4
ehci_hcd 32384 0
pppoe 8304 0
pppox 1216 1 pppoe
ipt_REJECT 1712 2
xt_TCPMSS 2560 1
ipt_LOG 4272 0
xt_comment 464 0
xt_multiport 1792 0
xt_mac 576 0
xt_limit 1008 1
iptable_mangle 992 0
iptable_filter 768 1
ip_tables 8544 4 iptable_nat,iptable_raw,iptable_mangle,iptable_filter
xt_tcpudp 1760 4
x_tables 9296 13 ipt_MASQUERADE,iptable_nat,xt_NOTRACK,xt_state,ipt_REJECT,xt_TCPMSS,ipt_LOG,xt_comment,xt_multiport,xt_mac,xt_limit,ip_tables,xt_tcpudp
ppp_async 6400 0
ppp_generic 18848 3 pppoe,pppox,ppp_async
slhc 4160 1 ppp_generic
ath9k 73536 0
ath9k_common 1200 1 ath9k
ath9k_hw 257136 2 ath9k,ath9k_common
ath 13424 2 ath9k,ath9k_hw
mac80211 203312 1 ath9k
usbcore 98368 5 uvcvideo,ohci_hcd,ledtrig_usbdev,ehci_hcd
nls_base 4800 1 usbcore
crc_ccitt 976 1 ppp_async
cfg80211 118736 3 ath9k,ath,mac80211
compat_firmware_class 4688 0
compat 7632 3 ath9k,mac80211,cfg80211
arc4 816 2
aes_generic 30256 2
ecb 1328 2
leds_gpio 1456 0
button_hotplug 2720 0
gpio_buttons 2128 0
input_polldev 1360 1 gpio_buttons
input_core 17056 6 uvcvideo,button_hotplug,gpio_buttons,input_polldev
root@OpenWrt:~# cat /proc/version
Linux version 2.6.32.29 (buildslave@dd.das-iro.de) (gcc version 4.3.3 (GCC) ) #1 Wed Feb 23 05:58:57 CET 2011
I have installed it without any complication, it tooks me cca 15 minutes.
Best regards.
Peter
(Last edited by PVi1 on 14 Jul 2011, 15:50)