OpenWrt Forum Archive

Topic: WPS Button dosen't work on wndr3700v2

The content of this topic has been archived on 19 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hello everyone,
I tried to configure my wndr3700v2 (with backfire 10.03.1-rc5) to use the wps button following the steps here... http://wiki.openwrt.org/toh/netgear/wnd … wps.button

However when I try to run the command:

hostapd_cli -p /var/run/hostapd-phy0 wps_pbc

from the command line I get the following message: wps_pbc unknown command.
Any ideas?

Did you set wps_pushbutton 1 under wifi-iface in /etc/config/wireless?

yes ... I put the tag on both interfaces (2.4 and 5 GHz). (config 'wifi-iface')

Having the same problem with Buffalo WZR-HP-G300NH. I have replaced wpad-mini with wpad and installed hostapd-utils. In /etc/config/wireless I have

config 'wifi-iface'
    option 'device' 'radio0'
    option 'network' 'lan'
    option 'mode' 'ap'
    option 'ssid' 'Andromeda'
    option 'encryption' 'psk2'
    option 'key' '********'
    option 'wps_pushbutton' '1'
snk wrote:

Having the same problem with Buffalo WZR-HP-G300NH. I have replaced wpad-mini with wpad and installed hostapd-utils.

And have you implemented a WPS button hotplug?
See the hotplug script that I wrote for WNDR3700:
http://wiki.openwrt.org/toh/netgear/wnd … wps.button

Yes, it is implemented, but the problem appears already when running

hostapd_cli -p /var/run/hostapd-phy0 wps_pbc

from the command line.

I'm starting to think that maybe the problem is in the hostapd_cli binary, since WPS support is correctly advertised to clients. I wonder if there is a compile option in hostap-utils which determines the supported commands?

Seems to work OK in my build:

root@OpenWrt /root# hostapd_cli -p /var/run/hostapd-phy0 wps_pbc
Selected interface 'wlan0'
OK

No special compile options, wpad/hostapd-utils version 20110527-2. I don't have a WPS capable client to test though.

Have you seen this? https://dev.openwrt.org/ticket/9597

(Last edited by arokh on 25 Aug 2011, 12:43)

My Buffalo WZR-HP-G300NH also doesn't understand what 'wps_pbc' is.  Running wpad & hostpad-utils, configured the option wps_pushbutton, installed the hotplug, and still I get:

#  hostapd_cli -p /var/run/hostapd-phy0 wps_pbc
Selected interface 'wlan0'
Unknown command 'wps_pbc'

Any thoughts?

arokh wrote:

Have you seen this? https://dev.openwrt.org/ticket/9597

Indeed, it seems that the commands recognized by hostapd_cli depend on whether it was built together with wpad-mini or wpad (full). I rebuilt hostapd-utils together with wpad, and lo and behold, wps_pbc is recognized and wps works.

I uploaded the binary here, in case someone wants to try it.

(Last edited by snk on 26 Aug 2011, 11:07)

snk wrote:

Having the same problem with Buffalo WZR-HP-G300NH. I have replaced wpad-mini with wpad and installed hostapd-utils.

Did you remove both wpad-mini and hostapd-mini?

fyi wrote:
snk wrote:

Having the same problem with Buffalo WZR-HP-G300NH. I have replaced wpad-mini with wpad and installed hostapd-utils.

Did you remove both wpad-mini and hostapd-mini?

I don't think I ever had hostapd-mini, only wpad-mini.

snk wrote:

Having the same problem with Buffalo WZR-HP-G300NH. I have replaced wpad-mini with wpad and installed hostapd-utils.

Same problem here for a BRCM63xx based router (exact image here) for Backfire 10.03.1 and same cure as snk.

Has anyone field a bug report?

snk wrote:

Indeed, it seems that the commands recognized by hostapd_cli depend on whether it was built together with wpad-mini or wpad (full).

Fixed with https://dev.openwrt.org/changeset/33393

jow wrote:
snk wrote:

Indeed, it seems that the commands recognized by hostapd_cli depend on whether it was built together with wpad-mini or wpad (full).

Fixed with https://dev.openwrt.org/changeset/33393

Please do remember that to use WPS, you still need to install the full version of wpad!
Not realizing this sent me into a spin for quite some time today, `$ wifi` giving me lots of errors about unrecognized options, until I finally replaced wpad-mini with wpad.

(isn't that why they call this OpenWRT version "Attitude Adjustment"? How ironic :-) )

(Last edited by ack on 7 Dec 2012, 21:26)

The discussion might have continued from here.