OpenWrt Forum Archive

Topic: WRT54GL Password Issues (WhiteRussian 0.9)

The content of this topic has been archived on 28 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

I just purchased a new WRT54GL and tried to install WhiteRussian on it. The firmware flashed successfully, but I have been completely unable to change the password. I have tried both on the web-based interface and via Putty and have tried multiple different passwords with varying levels of strength, but haven't gotten it to work. When I attempt to set the password, it prompts me to re-enter the new password, which I do, but then nothing happens.

What can I do to solve this very troublesome issue? I have been really excited to get into OpenWRT and I was told White Russian is arguably the best interface, but it looks now as though I will be unable to do anything for a while. Help would be very much appreciated.

I looked through the wiki on firstlogin ( ) and it has no help addressing why I can't seem to set a password. This is really frustrating. Someone please help.

When I telnet the router it'll ask to set the password, but then freezes up and ceases to work; same deal when in the web UI. wtf am I doing wrong here? Did I brick it?

It is normal that "nothing happens" after you entered the passcode two times while invoking the "passwd" command.

If that's the case, why am I unable to access the router's settings via SSH or the web UI?

The discussion might have continued from here.