OpenWrt Forum Archive

Topic: RTSP not working

The content of this topic has been archived on 17 Jan 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

I cannot open RTSP streams from my ISP in VLC. I use Backfire 10.03.1-RC at a WNDR3700v2 router.
I tested without router (pc directly @ modem) and the RTSP stream was working!

What i tried:

installing package hxxp://downloads.openwrt.org/backfire/10.03.1-rc5/ar71xx/packages/kmod-ipt-nathelper-extra_2.6.32.27-1_ar71xx.ipk
installing package hxxp://downloads.openwrt.org/backfire/10.03.1-rc5/ar71xx/packages/kmod-ipt-conntrack-extra_2.6.32.27-1_ar71xx.ipk
installing package hxxp://downloads.openwrt.org/backfire/10.03.1-rc5/ar71xx/packages/kmod-ipt-nat-extra_2.6.32.27-1_ar71xx.ipk
installing package hxxp://downloads.openwrt.org/backfire/10.03.1-rc5/ar71xx/packages/kmod-ipt-extra_2.6.32.27-1_ar71xx.ipk


Put all Firewall policies (INPUT, OUTPUT, FORWARD) on ACCEPT. I did this with 'Default', 'WAN->LAN' and 'LAN>WAN'. So basically everything on accept.... But still not working! Is there a bug in the RTSP part of OpenWRT or is it me doing things completely wrong?

(Last edited by Alex24 on 13 Aug 2011, 04:58)

bump

please help

You may need portfowarding?

The RTSP conntrack helper is frequently broken, you might try an alternative ipt_recent based solution using the rules suggested here:
http://forums.gentoo.org/viewtopic-t-86 … art-0.html

Insert those with iptables -I FORWARD  to bypass other rules.

Thanks jow

I see there are a few patches available:
https://dev.openwrt.org/ticket/5168

But they are not yet intergrated in Backfire 10.03.1-RC5?
Will they be integrated in the final 10.03.1?

(Last edited by Alex24 on 14 Aug 2011, 00:49)

Hi Alex24,

I have the same problem, have you find a solution to open RTSP streams?
I am a little lost with how to apply a patch for this package.

If you or someone else could help me, it would be very kind! I am new with openWRT.

Regards

The discussion might have continued from here.