OpenWrt Forum Archive

Topic: minidlna Missing From Menuconfig

The content of this topic has been archived on 19 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

I've recently started using minidlna on my RouterStation Pro running OpenWrt trunk and really like it. minidlna has disappeared from the menuconfig Multimedia listing. Is this intentional or do I have a problem with my setup? Was it dropped intentionally? If so what media server should I use to replace it with?

Thanks in advance,


(Last edited by robrob on 15 Nov 2011, 15:33)

I am also having this problem, and have yet to find any information on it. We need it back under "make menuconfig". Thanks

./scripts/feeds update packages
./scripts/feeds install -d m minidlna
make menuconfig

That alone is not going to show Multimedia --> minidlna package. One needs to first enable Libraries -> libffmpeg-custom -> Configuration --> Include support for minidlna before Multimedia --> minidlna will show up.

(Last edited by mazilo on 13 Nov 2011, 22:02)

written_direcon's code worked for me, minidlna is back in Multimedia. Thanks wd.

I used written_direcon's code on another machine and minidlna doesn't show up in the Multimedia menu. Weird.

Edit: Solved: see my next post below.

(Last edited by robrob on 15 Nov 2011, 15:33)

mazilo, I somehow missed your post. My problem on the second machine was indeed related to Libraries -> libffmpeg, but libffmpeg-custom isn't a menu item in my "make menuconfig" but when I selected libffmpeg-full minidlna did show up in the Multimedia menu.

To summarize the fix for no minidlna selection:

written_direcon wrote:
./scripts/feeds update packages
./scripts/feeds install -d m minidlna


In "make menuconfig" select: Libraries -> libffmpeg-full
Then select: Multimedia -> minidlna

And/or you can select minidlna support in the LuCI -> Applications section of "make menuconfig"

(Last edited by robrob on 17 Jun 2012, 15:06)

You don't need libffmpeg-full, libffmpeg-mini is enough to show, select and compile minidlna successfully.

The discussion might have continued from here.