OpenWrt Forum Archive

Topic: TP-Link's Range of Portable Wireless Routers (TL-WR)

The content of this topic has been archived between 22 May 2015 and 26 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Just trying to make sense of the range...

TL-MR11U (TL-MR3040) - USB port for WWAN dongles; Internal battery; Micro-USB-powered; OpenWrt support
TL-MR3020 - USB port for WWAN dongles; Dedicated switch for different operation modes; Mini-USB-powered; OpenWrt support
TL-WR800N - 2x2 interface (300Mbps operation); AC-powered
TL-WR720N - 2 WAN/LAN ports; USB port for WWAN dongles or charging devices; Dedicated switch for different operation modes; Micro-USB/AC-powered; OpenWrt support?
TL-WR710N - 2 WAN/LAN ports; USB port for charging devices; AC-powered
TL-WR703N - USB port for WWAN dongles; Micro-USB-powered; OpenWrt support
TL-WR702N (US) - Mini-USB-powered
TL-WR700N (US) - AC-powered

All of them have at least one WAN/LAN port

Some of the models have only 2MB flash. OpenWrt in general requires 4MB flash.

702N and 703N have smaller chassis than the rest of the models. (See the the relative size of the LAN port and the chassis.)


TL-MR11U / TL-MR3040








Corrections are welcome!

(Last edited by loyukfai on 11 Nov 2012, 17:04)

One small correction: The TL-WR710N has the same chipset, flash and RAM as the 703N, and should be supportable by OpenWrt. I haven't got one yet, but intend to get one if/when they are released with an EU plug integrated.

I know the 700N and 702N are definitely 2MB flash as you mentioned. I'm not familiar with the 800N.



Thanks for the correction, I'll update the OP after it's confirmed.

BTW, do they make EU-plug models of these? Cause I'm not sure if it's physically feasible to maintain the box shape with an EU-plug.


No, they don't yet. Hopefully they might - a two Ethernet port version of the 703N would be quite useful I think.



Excellent summary, thanks for the information. Can you confirm that the TL-MR11U and TL-MR3020 have only 2MB flash?

Ah! Actually no, but I forgot to update that part of the post...

Thanks for the heads-up!

I have just received a sample WR710N device and I am wondering how best to proceed towards getting OpenWRT on to it (with least chance of bricking!)
I was hopeful that the device might be the same internally as the WR703N and accept the same firmware image.

Is there any way to probe the device to get it to indicate any information about its structure?

You mentioned that the device has the same internals as the WR703N. Do you have a link to that or any other information on the device please?  I have explored the TP Link web site with the assistance of Google translate, but the info I found was marketing rather than technical.

I have connected to the device and brought up the Chinese language web page. I found the firmware upgrade page but it is different to that for the WR703N device. Instead of uploading the new .bin file through the web interface, it appears to want to use TFTP.

This is the translation of the SoftwareUgradeRpm.htm page:
By upgrading the router software, you will get new features.
File name:                               wr710nv1-cn-up.bin
TFTP Server IP:                        (This is my laptop static address)
Current software version:           4.18.22 Build 110928 Rel.62011n
The current hardware version:    WR710N 1.0 00000000

Note: Please use the wired LAN port for software upgrades. Please select the upgrade consistent with the current hardware version of the software. Upgrade process can not turn off the router power, will cause damage and can not use the router. Upgrade process about 40 seconds, when the upgrade is complete, the router will automatically restart.

There are two buttons on the screen but I can't work out how to translate them.

Any suggestions on how to proceed are welcome.

@tlg - I recommend opening the case and connecting a serial console cable.
We'll be able to help you more if you post the serial boot log.
Sorry but you're a pioneer on this device so you need to make these modifications if you want to have Openwrt running or a chance to recover your device.

Thanks for the response.
I have the case apart.
Let me know if you would like some photos and / or screenshots.

The chipset is Atheros AR9331 and Zentel A3S28040FTP-G5, so pretty similar to WR703N device.

I haven't located the serial port points as yet - they are not as obvious as on the WR703N device.
I am waiting to receive a USB serial adapter for the ttl serial port on a 703 device, so if I can locate the points on the 710 I will try to grab the boot output. It looks like it will require removing the board from the case and then operating from a separate power supply in lieu of the built in mains power supply.

I got bold and tried to tftp the 703 .bin file to the device but no joy.

I set up a static IP and ran tftp on my laptop, pointed to the IP of the TP device and tried to 'put' the file in the normal manner, while clicking  the Go button on the web page but it comes straight back with an error message.

I have not seen this method of upgrading on other devices so I am not sure what the expected process is.
the page has two fields - one for the file name, and the other for the tftp host IP address.

The built in help page translation for the firmware upgrade is as follows:

Follow these steps to upgrade the software:
1 Log in to the company's Web site (, download the latest version of the software.
2 Open the TFTP server, use the Browse button to select the downloaded file.
3 In the "File" column, the downloaded file name.
4 in the "TFTP server IP" column, the local host's IP address.
5 Click "upgrade" for software upgrades.
6 After the upgrade is complete, the router will automatically restart.

But clearly I am missing something in the process.

tlg wrote:

The chipset is Atheros AR9331 and Zentel A3S28040FTP-G5, so pretty similar to WR703N device.

No. Looks like it has only 16MB RAM and 2MB flash. Why don't you upload a hi-res photo of the board?

Is there another Zentel A3S28D40FTP-G5 under board?
Look for the smaller flash chip code like: Spansion FL016PIF

tlg wrote:

and the device has a USB port that supports a memory stick

No. The USB port of the TL-WR710N functions as a 5VDC/1A charger.

loyukfai wrote:

TL-WR710N - 2 WAN/LAN ports; USB port for charging another device; AC-powered

Why don't you upload the photos to Flicker or ImageShake?

Images of the TP-Link WR710N board are here:

The serial port test points are easily visible.

There is a chip on the back of the board labeled something like:
   cFeon F16-100HP
The nearest data sheet I can find is this one for a 2MB flash chip from cFeon / eonssi:

Does this mean that the total flash is 2Mb only, or is this additional flash?

Has anyone got a link to the data sheet on the Zentel A3S28040FTP-G5 device please?

The USB port seems to have no data connections, only power as @fyi said it's just for a power charger.

The board runs happily off a 5V supply.

(Last edited by tlg on 3 Dec 2011, 02:18)

cFeon F16-100HP 

is 2mb flash spi serial flash founf in many other tplink unit's like the wr542 found in mine

tlg wrote:

Has anyone got a link to the data sheet on the Zentel A3S28040FTP-G5 device please?

Already on #15

(Last edited by Nilfred on 29 Nov 2011, 17:16)

It's worth remembering that TP-Link have started shipping different hardware to China and international markets. For example, the latest Chinese version of the TL-WR841ND has 2MB flash / 16MB RAM, whereas the international version will retain 4MB flash and 32MB RAM. I suspect the same thing may be happening on the TL-WR700N and others too.



Serial port boot output text files for the TP-Link WR710N are here:

Full boot output plus command set:

Stop auto-boot plus command set:

It's different to the WR703N There is no U-Boot
This is the bit at the first part of the output:

CPU: AR9330: AP121 Board                                                       
CPU freq: 400 MHZ                                                               
SDRAM size: 8 MB                                                               

Any thoughts on whether it is a candidate for an OpenWrt image?


I can't follow all of this too well. Does this mean that the 710 can take this firmware or not? I just got it and the Chinese firmware is kinda hard to use.

I found it also here for 48$: … ite-101760

Looks very interesting, especially with some external solar panel that would keep it running during the day, it would be even better if battery would last atleast 12-15 hours...

Any news on what chipset does mr11u has inside? Is it same as 703 model?