OpenWrt Forum Archive

Topic: How to do a factory reset on the NetGear WNDR3800.

The content of this topic has been archived on 13 Mar 2017. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

I've been trying to figure out how to reset the WNDR3800 running OpenWrt trunk version.  I've tried holding the reset for 30 seconds on startup, for 60 seconds on startup, the 30-30-30 method, the NetGear method (after booted up, hold for 2 seconds).  Nothing seems to reset the password for the root user back to blank so telnet works again.  Am I just doing something wrong (likely :-), or is this a defect I should report? 

I need to get back to telnet, as I had the router user/password set to root/root, but after reloading the firmware with sysupgrade, and not putting anything in the /etc/sysupgrade.conf (I didn't feel I needed to save any settings), the root password no longer works to get in with an SSH connection.  It responds with "Access denied".

Thanks for your suggestions!

hnyman wrote:

Use the TFTP mode to flash a new firmware to it. It is rather simple with WNDR3700/3800. … lsafe.mode

And include a reset button functionality in the next firmware build. … set.button

Sounds good, but getting into TFTP mode requires the reset button to work, and it doesn't.  (Catch 22 :-)  Tried it a couple more times with the option of continuous ping and letting up on the reset when the pinging started again - still no joy.  Thanks for the tip just the same!  Any others?

I wonder if I just have a bad reset button.  Might crack the case and put a meter on it to check.

(Last edited by R.Smitty on 16 Nov 2011, 22:50)

When pressed on poweron, the *bootloader* will catch the event and launch a tftp server
When pressed during boot, the *OpenWrt* will intercept it and drop into failsafe
When OpenWrt is fully booted, the reset button does nothing anymore.

30-30-30 is DD-Wrt snake-oil, it has no effect on anything w.r.t. OpenWrt. As for holding it for 30-60 seconds, start holding it down ca. 2 seconds after poweron, then keep it holding until after all ethernet port leds flashed once simultaneously - at this point the switch got initialized by the bootloader.

R.Smitty wrote:
hnyman wrote:

Use the TFTP mode to flash a new firmware to it. It is rather simple with WNDR3700/3800.

Sounds good, but getting into TFTP mode requires the reset button to work, and it doesn't.  (Catch 22 :-)

Like Jow already explained, it is not catch-22. Reset button works early in the boot process to launch you into TFTP mode, independently of the functionality you optionally build for it for the later up-and-running OpenWrt phase. I have used TFTP mode several times after bricking my WNDR3700.

Including a runtime reset button functionality makes it easier to reset router later, but that is completely separate from the bootloader phase.

(Last edited by hnyman on 17 Nov 2011, 00:29)

The WNDR3800 must work differently than the WNDR3700.  After playing with it a while, I figured out how to get it into FailSafe mode. Power on the WNDR3800 and wait for the power LED to turn from a steady amber color to a slowly flashing green color.  Press any one of the three buttons (the recessed factory reset, the WPS button, or the wireless on/off button) prior to the green power LED flashing for the 8th time.  Then the green power LED will flash rapidly, indicating you are in FailSafe mode.  Then you can telnet in and run mount_root and passwd to reset the password of the root user. 

Alternatively, you can power on, wait 2 seconds, and press and hold in the button until the green power LED starts flashing, but apparently you don't need to hold it in for this model.  It just needs to see the button press after the green LED starts to flash.

Not sure why loading new firmware would hose up the root user's password, but at least I know how to get out of it now.


By the way, after working on this some more, I was able to get the WNDR3800 into bootloader mode.  As previously suggested, just turn it on with the reset switch held in and wait for about 30 seconds until the power light gets past amber and starts slowly flashing green (once per second), then let up on the reset button.  Alternatively, you can start pressing the reset button any time before the LAN lights flash on, but you still have to hold it in until the power light starts flashing green.

If the power light is flashing green fast (5 times per second or so), then you are in failsafe mode vs. bootloader mode - likely because the reset button lost contact part way through the above process.  See my last post if you purposly want in failsafe mode.

After in bootloader mode, I was able to set my PC on the same subnet (, put a factory firmware image in a folder, rename it with a short file name (not sure if that is needed or not, but it does make it easier), and load it with a TFTP client:
tftp -i put fw.img

I did get a "Received bad opcode. Opcode = 18025" on a custom firmware image, but I think it was just a bad image as the one on the OpenWrt web site downloaded jsut fine.

Hope this is of help to someone!  Thanks for all the tips!

(Last edited by R.Smitty on 12 Dec 2011, 18:25)

WOW, you guys are awesome. And Smitty, don't know if you'll get this but "You dah man!" After a week of screwing around with your exact same problem, scouring the net, and proceeding to fubar the works up even further in multiple ways I carefully followed your advice and was able to get my router up and running again. My sincere gratitude to you.

The discussion might have continued from here.