OpenWrt Forum Archive

Topic: WBMR-HP-G300H ... willing to help

The content of this topic has been archived between 2 Oct 2014 and 16 Apr 2018. Unfortunately there are posts – most likely complete pages – missing.

bassman wrote:
peps1iko wrote:

Is it just me or lately the trunk version is broken for this router?

Just you.  You probably need to make a new .config - old ones won't  build after major changes.

Thanks for the reply.

Strange. I usually build every weekend and I make a new config everytime.
Could you share with me your latest config?

wink

@peps1iko
You only really have to make menuconfig, choose target (Buffalo), exit menuconfig (saving). Then make defconfig, so the config gets updated to sane defaults, and make menuconfig again choosing packages and options. Making defconfig again after that can't harm, either.

However, here's my present configuration with packages etc. For brevity, I edited it by removing all lines about inactive packages, so you HAVE to make defconfig on this one before using it. I checked that the resulting .config file is identical to the unedited version.

If it still doesn't work, you might be out of sync with the distribution for some reason. In this case, try to do the following before using the new configuration file:

make distclean
make download
svn update
./scripts/feeds update -a
./scripts/feeds install -a

Be forewarned, it will take a while since you will be rebuilding the whole toolchain etc. from scratch.

#
# OpenWrt Configuration
# Edited for brevity
# run 'make defconfig' to turn it into a working configuration file
#
CONFIG_MODULES=y
CONFIG_HAVE_DOT_CONFIG=y
CONFIG_TARGET_lantiq=y
CONFIG_TARGET_lantiq_xway=y
CONFIG_TARGET_lantiq_xway_WBMRA=y
CONFIG_HAS_SUBTARGETS=y
CONFIG_TARGET_BOARD="lantiq"
CONFIG_TARGET_ARCH_PACKAGES="lantiq"
CONFIG_DEFAULT_TARGET_OPTIMIZATION="-Os -pipe -mno-branch-likely -mips32r2 -mtune=34kc -mdsp"
CONFIG_CPU_TYPE="34kc+dsp"
CONFIG_LINUX_3_10=y
CONFIG_DEFAULT_6relayd=y
CONFIG_DEFAULT_base-files=y
CONFIG_DEFAULT_busybox=y
CONFIG_DEFAULT_dnsmasq=y
CONFIG_DEFAULT_dropbear=y
CONFIG_DEFAULT_firewall=y
CONFIG_DEFAULT_hostapd-utils=y
CONFIG_DEFAULT_ip6tables=y
CONFIG_DEFAULT_iptables=y
CONFIG_DEFAULT_kmod-ath9k=y
CONFIG_DEFAULT_kmod-gpio-button-hotplug=y
CONFIG_DEFAULT_kmod-ipt-nathelper=y
CONFIG_DEFAULT_kmod-leds-gpio=y
CONFIG_DEFAULT_kmod-ledtrig-usbdev=y
CONFIG_DEFAULT_kmod-ltq-adsl-ar9=y
CONFIG_DEFAULT_kmod-ltq-adsl-ar9-fw-a=y
CONFIG_DEFAULT_kmod-ltq-adsl-ar9-mei=y
CONFIG_DEFAULT_kmod-ltq-atm-ar9=y
CONFIG_DEFAULT_kmod-ltq-hcd-ar9=y
CONFIG_DEFAULT_libc=y
CONFIG_DEFAULT_libgcc=y
CONFIG_DEFAULT_ltq-adsl-app=y
CONFIG_DEFAULT_mtd=y
CONFIG_DEFAULT_netifd=y
CONFIG_DEFAULT_odhcp6c=y
CONFIG_DEFAULT_opkg=y
CONFIG_DEFAULT_ppp=y
CONFIG_DEFAULT_ppp-mod-pppoa=y
CONFIG_DEFAULT_ppp-mod-pppoe=y
CONFIG_DEFAULT_swconfig=y
CONFIG_DEFAULT_uci=y
CONFIG_DEFAULT_wpad=y
CONFIG_AUDIO_SUPPORT=y
CONFIG_GPIO_SUPPORT=y
CONFIG_PCI_SUPPORT=y
CONFIG_USB_SUPPORT=y
CONFIG_BIG_ENDIAN=y
CONFIG_USES_SQUASHFS=y
CONFIG_HAS_MIPS16=y
CONFIG_mips=y
CONFIG_ARCH="mips"

#
# Target Images
#
CONFIG_EXTERNAL_CPIO=""

#
# Root filesystem images
#
CONFIG_TARGET_ROOTFS_SQUASHFS=y

#
# General build options
#
CONFIG_BUILD_PATENTED=y
CONFIG_SHADOW_PASSWORDS=y

#
# Kernel build options
#
CONFIG_KERNEL_DEBUG_FS=y
CONFIG_KERNEL_KALLSYMS=y
CONFIG_KERNEL_DEBUG_KERNEL=y
CONFIG_KERNEL_DEBUG_INFO=y
CONFIG_KERNEL_MAGIC_SYSRQ=y
CONFIG_KERNEL_COREDUMP=y
CONFIG_KERNEL_ELF_CORE=y
CONFIG_KERNEL_PRINTK_TIME=y
CONFIG_KERNEL_RELAY=y

#
# Package build options
#
CONFIG_IPV6=y
CONFIG_PKG_BUILD_PARALLEL=y
CONFIG_PKG_BUILD_USE_JOBSERVER=y

#
# Stripping options
#
CONFIG_USE_SSTRIP=y
CONFIG_USE_UCLIBCXX=y
CONFIG_DOWNLOAD_FOLDER=""
CONFIG_LOCALMIRROR=""
CONFIG_AUTOREBUILD=y
CONFIG_BUILD_SUFFIX=""
CONFIG_TARGET_ROOTFS_DIR=""
CONFIG_EXTERNAL_KERNEL_TREE=""
CONFIG_KERNEL_GIT_CLONE_URI=""
CONFIG_KERNEL_GIT_LOCAL_REPOSITORY=""
CONFIG_EXTRA_OPTIMIZATION="-fno-caller-saves"
CONFIG_TARGET_OPTIMIZATION="-Os -pipe -mno-branch-likely -mips32r2 -mtune=34kc -mdsp"
CONFIG_SOFT_FLOAT=y
CONFIG_EXTRA_BINUTILS_CONFIG_OPTIONS=""
CONFIG_BINUTILS_VERSION="2.22"
CONFIG_EXTRA_GCC_CONFIG_OPTIONS=""
CONFIG_GDB=y
CONFIG_USE_UCLIBC=y
CONFIG_GCC_VERSION_4_6_LINARO=y
CONFIG_GCC_VERSION="4.6-linaro"
CONFIG_GCC_VERSION_4_6=y
CONFIG_UCLIBC_VERSION="0.9.33.2"
CONFIG_UCLIBC_VERSION_0_9_33=y
CONFIG_LIBC="uClibc"
CONFIG_LIBC_VERSION="0.9.33.2"
CONFIG_TARGET_SUFFIX="uclibc"
CONFIG_IMAGEOPT=y
CONFIG_TARGET_PREINIT_SUPPRESS_STDERR=y
CONFIG_TARGET_PREINIT_TIMEOUT=2
CONFIG_TARGET_PREINIT_IFNAME=""
CONFIG_TARGET_PREINIT_IP="192.168.1.1"
CONFIG_TARGET_PREINIT_NETMASK="255.255.255.0"
CONFIG_TARGET_PREINIT_BROADCAST="192.168.1.255"
CONFIG_TARGET_INIT_PATH="/bin:/sbin:/usr/bin:/usr/sbin"
CONFIG_TARGET_INIT_ENV=""
CONFIG_TARGET_INIT_CMD="/sbin/init"
CONFIG_TARGET_INIT_SUPPRESS_STDERR=y
CONFIG_VERSIONOPT=y
CONFIG_VERSION_DIST="OpenWrt"
CONFIG_VERSION_NICK="Bassman Buffalo"
CONFIG_VERSION_NUMBER=""
CONFIG_VERSION_REPO="http://downloads.openwrt.org/snapshots/trunk/%T/packages"

#
# Package features
#
CONFIG_FEATURE_drawing-backend_DirectFB=y

#
# Base system
#
CONFIG_PACKAGE_base-files=y
CONFIG_PACKAGE_block-mount=y
CONFIG_PACKAGE_busybox=y
CONFIG_BUSYBOX_CONFIG_HAVE_DOT_CONFIG=y

#
# General Configuration
#
CONFIG_BUSYBOX_CONFIG_INCLUDE_SUSv2=y
CONFIG_BUSYBOX_CONFIG_PLATFORM_LINUX=y
CONFIG_BUSYBOX_CONFIG_FEATURE_BUFFERS_GO_ON_STACK=y
CONFIG_BUSYBOX_CONFIG_SHOW_USAGE=y
CONFIG_BUSYBOX_CONFIG_FEATURE_VERBOSE_USAGE=y
CONFIG_BUSYBOX_CONFIG_FEATURE_COMPRESS_USAGE=y
CONFIG_BUSYBOX_CONFIG_LONG_OPTS=y
CONFIG_BUSYBOX_CONFIG_FEATURE_DEVPTS=y
CONFIG_BUSYBOX_CONFIG_FEATURE_PIDFILE=y
CONFIG_BUSYBOX_CONFIG_FEATURE_SUID=y
CONFIG_BUSYBOX_CONFIG_FEATURE_PREFER_APPLETS=y
CONFIG_BUSYBOX_CONFIG_BUSYBOX_EXEC_PATH="/proc/self/exe"
CONFIG_BUSYBOX_CONFIG_FEATURE_SYSLOG=y

#
# Build Options
#
CONFIG_BUSYBOX_CONFIG_LFS=y
CONFIG_BUSYBOX_CONFIG_CROSS_COMPILER_PREFIX=""
CONFIG_BUSYBOX_CONFIG_EXTRA_CFLAGS=""

#
# Debugging Options
#
CONFIG_BUSYBOX_CONFIG_NO_DEBUG_LIB=y

#
# Installation Options ("make install" behavior)
#
CONFIG_BUSYBOX_CONFIG_INSTALL_APPLET_SYMLINKS=y
CONFIG_BUSYBOX_CONFIG_PREFIX="./_install"

#
# Busybox Library Tuning
#
CONFIG_BUSYBOX_CONFIG_PASSWORD_MINLEN=6
CONFIG_BUSYBOX_CONFIG_MD5_SIZE_VS_SPEED=2
CONFIG_BUSYBOX_CONFIG_FEATURE_FAST_TOP=y
CONFIG_BUSYBOX_CONFIG_FEATURE_EDITING=y
CONFIG_BUSYBOX_CONFIG_FEATURE_EDITING_MAX_LEN=512
CONFIG_BUSYBOX_CONFIG_FEATURE_EDITING_HISTORY=256
CONFIG_BUSYBOX_CONFIG_FEATURE_TAB_COMPLETION=y
CONFIG_BUSYBOX_CONFIG_FEATURE_EDITING_FANCY_PROMPT=y
CONFIG_BUSYBOX_CONFIG_FEATURE_NON_POSIX_CP=y
CONFIG_BUSYBOX_CONFIG_FEATURE_COPYBUF_KB=4
CONFIG_BUSYBOX_CONFIG_IOCTL_HEX2STR_ERROR=y

#
# Archival Utilities
#
CONFIG_BUSYBOX_CONFIG_FEATURE_SEAMLESS_GZ=y
CONFIG_BUSYBOX_CONFIG_BUNZIP2=y
CONFIG_BUSYBOX_CONFIG_GUNZIP=y
CONFIG_BUSYBOX_CONFIG_GZIP=y
CONFIG_BUSYBOX_CONFIG_TAR=y
CONFIG_BUSYBOX_CONFIG_FEATURE_TAR_CREATE=y
CONFIG_BUSYBOX_CONFIG_FEATURE_TAR_FROM=y
CONFIG_BUSYBOX_CONFIG_FEATURE_TAR_GNU_EXTENSIONS=y

#
# Coreutils
#
CONFIG_BUSYBOX_CONFIG_BASENAME=y
CONFIG_BUSYBOX_CONFIG_CAT=y
CONFIG_BUSYBOX_CONFIG_DATE=y
CONFIG_BUSYBOX_CONFIG_FEATURE_DATE_ISOFMT=y
CONFIG_BUSYBOX_CONFIG_ID=y
CONFIG_BUSYBOX_CONFIG_TEST=y
CONFIG_BUSYBOX_CONFIG_FEATURE_TEST_64=y
CONFIG_BUSYBOX_CONFIG_TOUCH=y
CONFIG_BUSYBOX_CONFIG_TR=y
CONFIG_BUSYBOX_CONFIG_CHGRP=y
CONFIG_BUSYBOX_CONFIG_CHMOD=y
CONFIG_BUSYBOX_CONFIG_CHOWN=y
CONFIG_BUSYBOX_CONFIG_CHROOT=y
CONFIG_BUSYBOX_CONFIG_CP=y
CONFIG_BUSYBOX_CONFIG_CUT=y
CONFIG_BUSYBOX_CONFIG_DD=y
CONFIG_BUSYBOX_CONFIG_FEATURE_DD_SIGNAL_HANDLING=y
CONFIG_BUSYBOX_CONFIG_FEATURE_DD_IBS_OBS=y
CONFIG_BUSYBOX_CONFIG_DF=y
CONFIG_BUSYBOX_CONFIG_DIRNAME=y
CONFIG_BUSYBOX_CONFIG_DU=y
CONFIG_BUSYBOX_CONFIG_FEATURE_DU_DEFAULT_BLOCKSIZE_1K=y
CONFIG_BUSYBOX_CONFIG_ECHO=y
CONFIG_BUSYBOX_CONFIG_FEATURE_FANCY_ECHO=y
CONFIG_BUSYBOX_CONFIG_ENV=y
CONFIG_BUSYBOX_CONFIG_EXPR=y
CONFIG_BUSYBOX_CONFIG_EXPR_MATH_SUPPORT_64=y
CONFIG_BUSYBOX_CONFIG_FALSE=y
CONFIG_BUSYBOX_CONFIG_FSYNC=y
CONFIG_BUSYBOX_CONFIG_HEAD=y
CONFIG_BUSYBOX_CONFIG_FEATURE_FANCY_HEAD=y
CONFIG_BUSYBOX_CONFIG_HOSTID=y
CONFIG_BUSYBOX_CONFIG_LN=y
CONFIG_BUSYBOX_CONFIG_LS=y
CONFIG_BUSYBOX_CONFIG_FEATURE_LS_FILETYPES=y
CONFIG_BUSYBOX_CONFIG_FEATURE_LS_FOLLOWLINKS=y
CONFIG_BUSYBOX_CONFIG_FEATURE_LS_RECURSIVE=y
CONFIG_BUSYBOX_CONFIG_FEATURE_LS_SORTFILES=y
CONFIG_BUSYBOX_CONFIG_FEATURE_LS_TIMESTAMPS=y
CONFIG_BUSYBOX_CONFIG_FEATURE_LS_USERNAME=y
CONFIG_BUSYBOX_CONFIG_FEATURE_LS_COLOR=y
CONFIG_BUSYBOX_CONFIG_FEATURE_LS_COLOR_IS_DEFAULT=y
CONFIG_BUSYBOX_CONFIG_MD5SUM=y
CONFIG_BUSYBOX_CONFIG_MKDIR=y
CONFIG_BUSYBOX_CONFIG_MKFIFO=y
CONFIG_BUSYBOX_CONFIG_MKNOD=y
CONFIG_BUSYBOX_CONFIG_MV=y
CONFIG_BUSYBOX_CONFIG_NICE=y
CONFIG_BUSYBOX_CONFIG_PRINTF=y
CONFIG_BUSYBOX_CONFIG_PWD=y
CONFIG_BUSYBOX_CONFIG_READLINK=y
CONFIG_BUSYBOX_CONFIG_FEATURE_READLINK_FOLLOW=y
CONFIG_BUSYBOX_CONFIG_RM=y
CONFIG_BUSYBOX_CONFIG_RMDIR=y
CONFIG_BUSYBOX_CONFIG_SEQ=y
CONFIG_BUSYBOX_CONFIG_SLEEP=y
CONFIG_BUSYBOX_CONFIG_FEATURE_FANCY_SLEEP=y
CONFIG_BUSYBOX_CONFIG_SORT=y
CONFIG_BUSYBOX_CONFIG_SYNC=y
CONFIG_BUSYBOX_CONFIG_TAIL=y
CONFIG_BUSYBOX_CONFIG_FEATURE_FANCY_TAIL=y
CONFIG_BUSYBOX_CONFIG_TEE=y
CONFIG_BUSYBOX_CONFIG_FEATURE_TEE_USE_BLOCK_IO=y
CONFIG_BUSYBOX_CONFIG_TRUE=y
CONFIG_BUSYBOX_CONFIG_UNAME=y
CONFIG_BUSYBOX_CONFIG_UNIQ=y
CONFIG_BUSYBOX_CONFIG_WC=y
CONFIG_BUSYBOX_CONFIG_YES=y

#
# Common options for cp and mv
#
CONFIG_BUSYBOX_CONFIG_FEATURE_PRESERVE_HARDLINKS=y

#
# Common options for ls, more and telnet
#
CONFIG_BUSYBOX_CONFIG_FEATURE_AUTOWIDTH=y

#
# Common options for df, du, ls
#
CONFIG_BUSYBOX_CONFIG_FEATURE_HUMAN_READABLE=y

#
# Common options for md5sum, sha1sum, sha256sum, sha512sum
#
CONFIG_BUSYBOX_CONFIG_FEATURE_MD5_SHA1_SUM_CHECK=y

#
# Console Utilities
#
CONFIG_BUSYBOX_CONFIG_CLEAR=y
CONFIG_BUSYBOX_CONFIG_RESET=y

#
# Debian Utilities
#
CONFIG_BUSYBOX_CONFIG_MKTEMP=y
CONFIG_BUSYBOX_CONFIG_START_STOP_DAEMON=y
CONFIG_BUSYBOX_CONFIG_WHICH=y

#
# Editors
#
CONFIG_BUSYBOX_CONFIG_VI=y
CONFIG_BUSYBOX_CONFIG_FEATURE_VI_MAX_LEN=1024
CONFIG_BUSYBOX_CONFIG_FEATURE_VI_COLON=y
CONFIG_BUSYBOX_CONFIG_FEATURE_VI_YANKMARK=y
CONFIG_BUSYBOX_CONFIG_FEATURE_VI_SEARCH=y
CONFIG_BUSYBOX_CONFIG_FEATURE_VI_USE_SIGNALS=y
CONFIG_BUSYBOX_CONFIG_FEATURE_VI_DOT_CMD=y
CONFIG_BUSYBOX_CONFIG_FEATURE_VI_READONLY=y
CONFIG_BUSYBOX_CONFIG_FEATURE_VI_SETOPTS=y
CONFIG_BUSYBOX_CONFIG_FEATURE_VI_SET=y
CONFIG_BUSYBOX_CONFIG_FEATURE_VI_WIN_RESIZE=y
CONFIG_BUSYBOX_CONFIG_FEATURE_VI_ASK_TERMINAL=y
CONFIG_BUSYBOX_CONFIG_FEATURE_VI_OPTIMIZE_CURSOR=y
CONFIG_BUSYBOX_CONFIG_AWK=y
CONFIG_BUSYBOX_CONFIG_FEATURE_AWK_LIBM=y
CONFIG_BUSYBOX_CONFIG_CMP=y
CONFIG_BUSYBOX_CONFIG_SED=y
CONFIG_BUSYBOX_CONFIG_FEATURE_ALLOW_EXEC=y

#
# Finding Utilities
#
CONFIG_BUSYBOX_CONFIG_FIND=y
CONFIG_BUSYBOX_CONFIG_FEATURE_FIND_PRINT0=y
CONFIG_BUSYBOX_CONFIG_FEATURE_FIND_PERM=y
CONFIG_BUSYBOX_CONFIG_FEATURE_FIND_TYPE=y
CONFIG_BUSYBOX_CONFIG_FEATURE_FIND_XDEV=y
CONFIG_BUSYBOX_CONFIG_FEATURE_FIND_MAXDEPTH=y
CONFIG_BUSYBOX_CONFIG_FEATURE_FIND_EXEC=y
CONFIG_BUSYBOX_CONFIG_FEATURE_FIND_USER=y
CONFIG_BUSYBOX_CONFIG_FEATURE_FIND_GROUP=y
CONFIG_BUSYBOX_CONFIG_FEATURE_FIND_NOT=y
CONFIG_BUSYBOX_CONFIG_FEATURE_FIND_DEPTH=y
CONFIG_BUSYBOX_CONFIG_FEATURE_FIND_PAREN=y
CONFIG_BUSYBOX_CONFIG_FEATURE_FIND_SIZE=y
CONFIG_BUSYBOX_CONFIG_FEATURE_FIND_PRUNE=y
CONFIG_BUSYBOX_CONFIG_FEATURE_FIND_PATH=y
CONFIG_BUSYBOX_CONFIG_FEATURE_FIND_REGEX=y
CONFIG_BUSYBOX_CONFIG_GREP=y
CONFIG_BUSYBOX_CONFIG_FEATURE_GREP_EGREP_ALIAS=y
CONFIG_BUSYBOX_CONFIG_FEATURE_GREP_FGREP_ALIAS=y
CONFIG_BUSYBOX_CONFIG_FEATURE_GREP_CONTEXT=y
CONFIG_BUSYBOX_CONFIG_XARGS=y
CONFIG_BUSYBOX_CONFIG_FEATURE_XARGS_SUPPORT_CONFIRMATION=y
CONFIG_BUSYBOX_CONFIG_FEATURE_XARGS_SUPPORT_QUOTES=y
CONFIG_BUSYBOX_CONFIG_FEATURE_XARGS_SUPPORT_TERMOPT=y
CONFIG_BUSYBOX_CONFIG_FEATURE_XARGS_SUPPORT_ZERO_TERM=y

#
# Init Utilities
#
CONFIG_BUSYBOX_CONFIG_HALT=y

#
# Login/Password Management Utilities
#
CONFIG_BUSYBOX_CONFIG_FEATURE_SHADOWPASSWDS=y
CONFIG_BUSYBOX_CONFIG_PASSWD=y
CONFIG_BUSYBOX_CONFIG_FEATURE_PASSWD_WEAK_CHECK=y

#
# Linux Module Utilities
#
CONFIG_BUSYBOX_CONFIG_INSMOD=y
CONFIG_BUSYBOX_CONFIG_RMMOD=y
CONFIG_BUSYBOX_CONFIG_LSMOD=y
CONFIG_BUSYBOX_CONFIG_FEATURE_LSMOD_PRETTY_2_6_OUTPUT=y

#
# Options common to multiple modutils
#
CONFIG_BUSYBOX_CONFIG_FEATURE_CHECK_TAINTED_MODULE=y
CONFIG_BUSYBOX_CONFIG_DEFAULT_MODULES_DIR="/lib/modules"

#
# Linux System Utilities
#
CONFIG_BUSYBOX_CONFIG_DMESG=y
CONFIG_BUSYBOX_CONFIG_FEATURE_DMESG_PRETTY=y
CONFIG_BUSYBOX_CONFIG_HEXDUMP=y
CONFIG_BUSYBOX_CONFIG_HWCLOCK=y
CONFIG_BUSYBOX_CONFIG_MKSWAP=y
CONFIG_BUSYBOX_CONFIG_MOUNT=y
CONFIG_BUSYBOX_CONFIG_FEATURE_MOUNT_HELPERS=y
CONFIG_BUSYBOX_CONFIG_FEATURE_MOUNT_CIFS=y
CONFIG_BUSYBOX_CONFIG_FEATURE_MOUNT_FLAGS=y
CONFIG_BUSYBOX_CONFIG_FEATURE_MOUNT_FSTAB=y
CONFIG_BUSYBOX_CONFIG_PIVOT_ROOT=y
CONFIG_BUSYBOX_CONFIG_SWAPONOFF=y
CONFIG_BUSYBOX_CONFIG_SWITCH_ROOT=y
CONFIG_BUSYBOX_CONFIG_UMOUNT=y
CONFIG_BUSYBOX_CONFIG_FEATURE_UMOUNT_ALL=y

#
# Common options for mount/umount
#
CONFIG_BUSYBOX_CONFIG_FEATURE_MOUNT_LOOP=y

#
# Miscellaneous Utilities
#
CONFIG_BUSYBOX_CONFIG_LESS=y
CONFIG_BUSYBOX_CONFIG_FEATURE_LESS_MAXLINES=9999999
CONFIG_BUSYBOX_CONFIG_CROND=y
CONFIG_BUSYBOX_CONFIG_FEATURE_CROND_DIR="/var/spool/cron"
CONFIG_BUSYBOX_CONFIG_CRONTAB=y
CONFIG_BUSYBOX_CONFIG_LOCK=y
CONFIG_BUSYBOX_CONFIG_STRINGS=y
CONFIG_BUSYBOX_CONFIG_TIME=y
CONFIG_BUSYBOX_CONFIG_WATCHDOG=y

#
# Networking Utilities
#
CONFIG_BUSYBOX_CONFIG_NC=y
CONFIG_BUSYBOX_CONFIG_PING=y
CONFIG_BUSYBOX_CONFIG_PING6=y
CONFIG_BUSYBOX_CONFIG_FEATURE_FANCY_PING=y
CONFIG_BUSYBOX_CONFIG_FEATURE_IPV6=y
CONFIG_BUSYBOX_CONFIG_FEATURE_PREFER_IPV4_ADDRESS=y
CONFIG_BUSYBOX_CONFIG_VERBOSE_RESOLUTION_ERRORS=y
CONFIG_BUSYBOX_CONFIG_ARPING=y
CONFIG_BUSYBOX_CONFIG_BRCTL=y
CONFIG_BUSYBOX_CONFIG_FEATURE_BRCTL_FANCY=y
CONFIG_BUSYBOX_CONFIG_FEATURE_BRCTL_SHOW=y
CONFIG_BUSYBOX_CONFIG_IFCONFIG=y
CONFIG_BUSYBOX_CONFIG_FEATURE_IFCONFIG_STATUS=y
CONFIG_BUSYBOX_CONFIG_FEATURE_IFCONFIG_HW=y
CONFIG_BUSYBOX_CONFIG_FEATURE_IFCONFIG_BROADCAST_PLUS=y
CONFIG_BUSYBOX_CONFIG_NETMSG=y
CONFIG_BUSYBOX_CONFIG_NETSTAT=y
CONFIG_BUSYBOX_CONFIG_FEATURE_NETSTAT_WIDE=y
CONFIG_BUSYBOX_CONFIG_FEATURE_NETSTAT_PRG=y
CONFIG_BUSYBOX_CONFIG_NSLOOKUP=y
CONFIG_BUSYBOX_CONFIG_NTPD=y
CONFIG_BUSYBOX_CONFIG_FEATURE_NTPD_SERVER=y
CONFIG_BUSYBOX_CONFIG_ROUTE=y
CONFIG_BUSYBOX_CONFIG_TELNET=y
CONFIG_BUSYBOX_CONFIG_FEATURE_TELNET_TTYPE=y
CONFIG_BUSYBOX_CONFIG_TELNETD=y
CONFIG_BUSYBOX_CONFIG_FEATURE_TELNETD_STANDALONE=y
CONFIG_BUSYBOX_CONFIG_TRACEROUTE=y
CONFIG_BUSYBOX_CONFIG_FEATURE_TRACEROUTE_VERBOSE=y
CONFIG_BUSYBOX_CONFIG_UDHCPC=y
CONFIG_BUSYBOX_CONFIG_UDHCP_DEBUG=0
CONFIG_BUSYBOX_CONFIG_FEATURE_UDHCP_RFC3397=y
CONFIG_BUSYBOX_CONFIG_UDHCPC_DEFAULT_SCRIPT="/usr/share/udhcpc/default.script"
CONFIG_BUSYBOX_CONFIG_UDHCPC_SLACK_FOR_BUGGY_SERVERS=80
CONFIG_BUSYBOX_CONFIG_VCONFIG=y
CONFIG_BUSYBOX_CONFIG_WGET=y
CONFIG_BUSYBOX_CONFIG_FEATURE_WGET_STATUSBAR=y
CONFIG_BUSYBOX_CONFIG_FEATURE_WGET_AUTHENTICATION=y
CONFIG_BUSYBOX_CONFIG_FEATURE_WGET_LONG_OPTIONS=y

#
# Process Utilities
#
CONFIG_BUSYBOX_CONFIG_UPTIME=y
CONFIG_BUSYBOX_CONFIG_FREE=y
CONFIG_BUSYBOX_CONFIG_KILL=y
CONFIG_BUSYBOX_CONFIG_KILLALL=y
CONFIG_BUSYBOX_CONFIG_PGREP=y
CONFIG_BUSYBOX_CONFIG_PIDOF=y
CONFIG_BUSYBOX_CONFIG_PS=y
CONFIG_BUSYBOX_CONFIG_FEATURE_PS_WIDE=y
CONFIG_BUSYBOX_CONFIG_BB_SYSCTL=y
CONFIG_BUSYBOX_CONFIG_TOP=y
CONFIG_BUSYBOX_CONFIG_FEATURE_TOP_CPU_USAGE_PERCENTAGE=y
CONFIG_BUSYBOX_CONFIG_FEATURE_TOP_CPU_GLOBAL_PERCENTS=y

#
# Shells
#
CONFIG_BUSYBOX_CONFIG_ASH=y
CONFIG_BUSYBOX_CONFIG_ASH_BASH_COMPAT=y
CONFIG_BUSYBOX_CONFIG_ASH_JOB_CONTROL=y
CONFIG_BUSYBOX_CONFIG_ASH_ALIAS=y
CONFIG_BUSYBOX_CONFIG_ASH_GETOPTS=y
CONFIG_BUSYBOX_CONFIG_ASH_BUILTIN_ECHO=y
CONFIG_BUSYBOX_CONFIG_ASH_BUILTIN_PRINTF=y
CONFIG_BUSYBOX_CONFIG_ASH_BUILTIN_TEST=y
CONFIG_BUSYBOX_CONFIG_ASH_CMDCMD=y
CONFIG_BUSYBOX_CONFIG_ASH_EXPAND_PRMT=y
CONFIG_BUSYBOX_CONFIG_FEATURE_SH_IS_ASH=y
CONFIG_BUSYBOX_CONFIG_FEATURE_BASH_IS_NONE=y
CONFIG_BUSYBOX_CONFIG_SH_MATH_SUPPORT=y
CONFIG_BUSYBOX_CONFIG_SH_MATH_SUPPORT_64=y

#
# System Logging Utilities
#
CONFIG_BUSYBOX_CONFIG_SYSLOGD=y
CONFIG_BUSYBOX_CONFIG_FEATURE_ROTATE_LOGFILE=y
CONFIG_BUSYBOX_CONFIG_FEATURE_REMOTE_LOG=y
CONFIG_BUSYBOX_CONFIG_FEATURE_SYSLOGD_READ_BUFFER_SIZE=256
CONFIG_BUSYBOX_CONFIG_FEATURE_IPC_SYSLOG=y
CONFIG_BUSYBOX_CONFIG_FEATURE_IPC_SYSLOG_BUFFER_SIZE=16
CONFIG_BUSYBOX_CONFIG_KLOGD=y
CONFIG_BUSYBOX_CONFIG_FEATURE_KLOGD_KLOGCTL=y
CONFIG_BUSYBOX_CONFIG_LOGGER=y
CONFIG_PACKAGE_dnsmasq=y
CONFIG_PACKAGE_dropbear=y
CONFIG_PACKAGE_firewall=y
CONFIG_PACKAGE_libc=y
CONFIG_PACKAGE_libgcc=y
CONFIG_PACKAGE_libpthread=y
CONFIG_PACKAGE_mtd=y
CONFIG_PACKAGE_netifd=y
CONFIG_PACKAGE_opkg=y
CONFIG_PACKAGE_procd=y
CONFIG_PACKAGE_qos-scripts=y
CONFIG_PACKAGE_swconfig=y
CONFIG_PACKAGE_ubox=y
CONFIG_PACKAGE_ubus=y
CONFIG_PACKAGE_ubusd=y
CONFIG_PACKAGE_uci=y

#
# Block Devices
#
CONFIG_PACKAGE_kmod-scsi-core=y
CONFIG_PACKAGE_kmod-scsi-generic=y

#
# Cryptographic API modules
#
CONFIG_PACKAGE_kmod-crypto-aes=y
CONFIG_PACKAGE_kmod-crypto-arc4=y
CONFIG_PACKAGE_kmod-crypto-core=y
CONFIG_PACKAGE_kmod-crypto-hash=y
CONFIG_PACKAGE_kmod-crypto-manager=y
CONFIG_PACKAGE_kmod-crypto-pcompress=y

#
# Filesystems
#
CONFIG_PACKAGE_kmod-fs-ext4=y
CONFIG_PACKAGE_kmod-fuse=y

#
# LED modules
#
CONFIG_PACKAGE_kmod-leds-gpio=y
CONFIG_PACKAGE_kmod-ledtrig-usbdev=y

#
# Libraries
#
CONFIG_PACKAGE_kmod-lib-crc-ccitt=y
CONFIG_PACKAGE_kmod-lib-crc16=y
CONFIG_PACKAGE_kmod-lib-textsearch=y

#
# Native Language Support
#
CONFIG_PACKAGE_kmod-nls-base=y

#
# Netfilter Extensions
#
CONFIG_PACKAGE_kmod-ip6tables=y
CONFIG_PACKAGE_kmod-ipt-conntrack=y
CONFIG_PACKAGE_kmod-ipt-conntrack-extra=y
CONFIG_PACKAGE_kmod-ipt-core=y
CONFIG_PACKAGE_kmod-ipt-filter=y
CONFIG_PACKAGE_kmod-ipt-ipopt=y
CONFIG_PACKAGE_kmod-ipt-nat=y
CONFIG_PACKAGE_kmod-ipt-nathelper=y

#
# Network Devices
#
CONFIG_PACKAGE_kmod-ifb=y
CONFIG_PACKAGE_kmod-ltq-adsl-ar9=y
CONFIG_PACKAGE_kmod-ltq-adsl-ar9-fw-a=y
CONFIG_PACKAGE_kmod-ltq-adsl-ar9-mei=y
CONFIG_PACKAGE_kmod-ltq-atm-ar9=y

#
# Network Support
#
CONFIG_PACKAGE_kmod-atm=y
CONFIG_PACKAGE_kmod-ipv6=y
CONFIG_PACKAGE_kmod-ppp=y
CONFIG_PACKAGE_kmod-pppoa=y
CONFIG_PACKAGE_kmod-pppoe=y
CONFIG_PACKAGE_kmod-pppox=y
CONFIG_PACKAGE_kmod-sched-connmark=y
CONFIG_PACKAGE_kmod-sched-core=y
CONFIG_PACKAGE_kmod-slhc=y
CONFIG_PACKAGE_kmod-tun=y

#
# Other modules
#
CONFIG_PACKAGE_kmod-gpio-button-hotplug=y

#
# USB Support
#
CONFIG_PACKAGE_kmod-ltq-hcd-ar9=y
CONFIG_PACKAGE_kmod-usb-core=y
CONFIG_PACKAGE_kmod-usb-storage=y
CONFIG_PACKAGE_kmod-usb-storage-extras=y
CONFIG_PACKAGE_kmod-usb2=y

#
# Wireless Drivers
#
CONFIG_PACKAGE_kmod-ath=y
CONFIG_PACKAGE_kmod-ath9k=y
CONFIG_PACKAGE_kmod-ath9k-common=y
CONFIG_PACKAGE_kmod-cfg80211=y
CONFIG_PACKAGE_kmod-mac80211=y
CONFIG_PACKAGE_MAC80211_DEBUGFS=y
CONFIG_PACKAGE_MAC80211_MESH=y

#
# Lua
#
CONFIG_PACKAGE_libiwinfo-lua=y
CONFIG_PACKAGE_lua=y

#
# Firewall
#
CONFIG_PACKAGE_libip4tc=y
CONFIG_PACKAGE_libip6tc=y
CONFIG_PACKAGE_libxtables=y

#
# SSL
#
CONFIG_PACKAGE_libcyassl=y
CONFIG_PACKAGE_libopenssl=y

#
# Configuration
#
CONFIG_OPENSSL_WITH_EC=y

#
# database
#
CONFIG_PACKAGE_libblkid=y
CONFIG_PACKAGE_libblobmsg-json=y
CONFIG_PACKAGE_libiwinfo=y
CONFIG_PACKAGE_libjson=y
CONFIG_PACKAGE_libjson-c=y
CONFIG_PACKAGE_libltdl=y
CONFIG_PACKAGE_liblua=y
CONFIG_PACKAGE_liblzo=y
CONFIG_PACKAGE_libnet1=y
CONFIG_PACKAGE_libnfnetlink=y
CONFIG_PACKAGE_libnl-tiny=y
CONFIG_PACKAGE_libpcap=y

#
# Configuration
#
CONFIG_PACKAGE_librrd1=y
CONFIG_PACKAGE_libubox=y
CONFIG_PACKAGE_libubus=y
CONFIG_PACKAGE_libubus-lua=y
CONFIG_PACKAGE_libuci=y
CONFIG_PACKAGE_libuci-lua=y
CONFIG_PACKAGE_libustream-cyassl=y
CONFIG_PACKAGE_libuuid=y
CONFIG_PACKAGE_linux-atm=y
CONFIG_PACKAGE_zlib=y

#
# LuCI
#

#
# 1. Collections
#
CONFIG_PACKAGE_luci=y
CONFIG_PACKAGE_luci-ssl=y

#
# 2. Modules
#
CONFIG_PACKAGE_luci-mod-admin-core=y
CONFIG_PACKAGE_luci-mod-admin-full=y

#
# 3. Applications
#
CONFIG_PACKAGE_luci-app-commands=y
CONFIG_PACKAGE_luci-app-ddns=y
CONFIG_PACKAGE_luci-app-diag-core=y
CONFIG_PACKAGE_luci-app-diag-devinfo=y
CONFIG_PACKAGE_luci-app-firewall=y
CONFIG_PACKAGE_luci-app-hd-idle=y
CONFIG_PACKAGE_luci-app-qos=y
CONFIG_PACKAGE_luci-app-samba=y
CONFIG_PACKAGE_luci-app-statistics=y
CONFIG_PACKAGE_luci-app-upnp=y
CONFIG_PACKAGE_luci-app-wol=y

#
# 4. Themes
#
CONFIG_PACKAGE_luci-theme-base=y
CONFIG_PACKAGE_luci-theme-bootstrap=y

#
# 5. Translations
#
CONFIG_PACKAGE_luci-i18n-english=y

#
# 6. Protocols
#
CONFIG_PACKAGE_luci-proto-core=y
CONFIG_PACKAGE_luci-proto-ipv6=y
CONFIG_PACKAGE_luci-proto-ppp=y

#
# 7. Server Interfaces
#
CONFIG_PACKAGE_luci-sgi-cgi=y

#
# 8. Libraries
#
CONFIG_PACKAGE_luci-lib-core=y
CONFIG_PACKAGE_luci-lib-core_source=y
CONFIG_PACKAGE_luci-lib-ipkg=y
CONFIG_PACKAGE_luci-lib-nixio=y
CONFIG_PACKAGE_luci-lib-nixio_notls=y
CONFIG_PACKAGE_luci-lib-sys=y
CONFIG_PACKAGE_luci-lib-web=y

#
# Firewall
#
CONFIG_PACKAGE_ip6tables=y
CONFIG_PACKAGE_iptables=y
CONFIG_PACKAGE_iptables-mod-conntrack-extra=y
CONFIG_PACKAGE_iptables-mod-filter=y
CONFIG_PACKAGE_iptables-mod-ipopt=y
CONFIG_PACKAGE_miniupnpd=y

#
# IP Addresses and Names
#
CONFIG_PACKAGE_ddns-scripts=y

#
# Linux ATM tools
#
CONFIG_PACKAGE_br2684ctl=y

#
# Telephony
#
CONFIG_PACKAGE_smap=y
CONFIG_PACKAGE_smap-to-devinfo=y

#
# VPN
#
CONFIG_PACKAGE_openvpn-easy-rsa=y
CONFIG_PACKAGE_openvpn-openssl=y
CONFIG_OPENVPN_openssl_ENABLE_LZO=y
CONFIG_OPENVPN_openssl_ENABLE_SERVER=y
CONFIG_OPENVPN_openssl_ENABLE_HTTP=y
CONFIG_OPENVPN_openssl_ENABLE_SOCKS=y
CONFIG_OPENVPN_openssl_ENABLE_FRAGMENT=y
CONFIG_OPENVPN_openssl_ENABLE_MULTIHOME=y
CONFIG_OPENVPN_openssl_ENABLE_PORT_SHARE=y
CONFIG_OPENVPN_openssl_ENABLE_DEF_AUTH=y
CONFIG_OPENVPN_openssl_ENABLE_PF=y

#
# Web Servers/Proxies
#
CONFIG_PACKAGE_uhttpd=y
CONFIG_PACKAGE_uhttpd-mod-ubus=y

#
# wireless
#
CONFIG_PACKAGE_6relayd=y
CONFIG_PACKAGE_etherwake=y
CONFIG_PACKAGE_hostapd-utils=y
CONFIG_PACKAGE_httping=y
CONFIG_PACKAGE_iputils-traceroute6=y
CONFIG_PACKAGE_iw=y
CONFIG_PACKAGE_ltq-adsl-app=y
CONFIG_PACKAGE_mac-to-devinfo=y
CONFIG_PACKAGE_netdiscover=y
CONFIG_PACKAGE_netdiscover-to-devinfo=y
CONFIG_PACKAGE_odhcp6c=y
CONFIG_PACKAGE_ppp=y
CONFIG_PACKAGE_ppp-mod-pppoa=y
CONFIG_PACKAGE_ppp-mod-pppoe=y
CONFIG_PACKAGE_samba36-server=y
CONFIG_PACKAGE_SAMBA_MAX_DEBUG_LEVEL=-1
CONFIG_PACKAGE_tc=y
CONFIG_WPA_SUPPLICANT_INTERNAL=y
CONFIG_WPA_MSG_MIN_PRIORITY=3
CONFIG_DRIVER_11N_SUPPORT=y
CONFIG_PACKAGE_wpad=y

#
# Filesystem
#
CONFIG_PACKAGE_ntfs-3g=y

#
# disc
#
CONFIG_PACKAGE_blkid=y
CONFIG_PACKAGE_hd-idle=y
CONFIG_PACKAGE_swap-utils=y

#
# zoneinfo
#
CONFIG_PACKAGE_collectd=y
CONFIG_PACKAGE_collectd-mod-interface=y
CONFIG_PACKAGE_collectd-mod-iwinfo=y
CONFIG_PACKAGE_collectd-mod-load=y
CONFIG_PACKAGE_collectd-mod-rrdtool=y
CONFIG_PACKAGE_jshn=y
CONFIG_PACKAGE_libjson-script=y
CONFIG_PACKAGE_openssl-util=y
CONFIG_PACKAGE_px5g=y
CONFIG_PACKAGE_rrdtool1=y

Thanks for the config.

Yeah, as I thought you use the default gcc and binutils version and I just tested, it compiles without errors.
Tried with gcc 4.8 and binutils 2.32.2 and it fails (until a few weeks ago it always compiled).

I will stick to gcc 4.6 for now until they fix it.

OpenWrt Barrier Breaker r39304 works out of the box with a single VLAN enabled on my WBMR-HP-G300H.

I spent a day configuring the device and did not crash it. I consciously avoided tagged and untagged VLANs on the same port, no crashes.

The real trouble was with the VLAN IDs over 128 or so. I am using 500 for the outbound connection and 1000 for management. The enable_vlan4k setting that opens the wider range of numbers for some rtl switches does nothing for this one. That revealed a flaw in my thinking: The vlan option for switch_vlans is an internal number for the switch. The actual VLAN id is the vid parameter.

This device is just a DSL bridge for me and the actual routing is done by another device. So I terminate my ATM connection here and handle routing, firewalling et al on the other device.

Here is my config for those who may be interested:

config interface 'ap'
        option type 'bridge'
        option proto 'none'
        option ifname 'eth0.1'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 2t 3 4'

config switch_vlan
        option device 'switch0'
        option vlan '15'
        option ports '0t 2t'

config switch_vlan
        option device 'switch0'
        option vlan '5'
        option vid '555'
        option ports '0t 2t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '1000'
        option ports '0t 2t 5'

config switch_port
        option port '2'
        option pvid '5'

config switch_port
        option port '5'
        option pvid '2'

config atm-bridge 'atm'
        option vpi '0'
        option vci '100'
        option encaps 'llc'
        option payload 'bridged'
        option unit '0'

config interface 'wan'
        option type 'bridge'
        option ifname 'eth0.500 nas0'
        option proto 'none'

config interface 'mgt'
        option type 'bridge'
        option proto 'static'
        option ipaddr '10.255.255.2'
        option netmask '255.255.255.0'
        option ifname 'eth0.1000'

config interface 'alt'
        option proto 'none'
        option ifname 'eth0.15'
        option type 'bridge'

The other two other VLANs (ap and alt) are duplicates of my WLAN at the other end of the apartment.

ferrix wrote:

OpenWrt Barrier Breaker r39304 works out of the box with a single VLAN enabled on my WBMR-HP-G300H.

Uhh what? I'm using "attitude adjustment", do I have to get a newer firmware?

I bought this box today, and was following the wiki. I got to the point of "Configure switch" and ended up here. Needless to say the Wiki is a bit obscure about this part. First of all I don't understand what is the purpose of this part? I can login and I get intranet IP. If I were to connect another device in this the intranet would not work between the two? I haven't gotten that far yet to try.

Also I want to be able to map multiple DHCP IP's using kmod-macvlan but tutorial I followed bricked my device, fortunately debricking was simple. If someone can help to get multiple DHCP IP's working I would appreciate. I followed the macvlan tutorial in here. With replacing "eth0.1" with "nas0" which is the ADSL2+ WAN in this Buffalo box.

Thanks.

hello all,

I'm using the excellent build from Giuseppe here http://nayaka.de/

But I'm struggling to get the adsl to connect. I'm not sure it's properly set up. I seem to have the packages required so I guess it must be in the configuration.

My ISP requires:
RFC 1483 routed
mode : VCMUX
VPI: 8
VCI: 36

(Free ADSL in France)

Here's my network config so far (I added the ADSL part that I saw a few posts above):

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

#config globals 'globals'
#    option ula_prefix 'fd78:6e4a:7477::/48'

config interface 'lan'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.0.178'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option ifname 'eth0.1'
    option gateway '192.168.0.178'
    option dns '192.168.0.178'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0t 2 3 4 5'

config atm-bridge 'atm'
    option encaps 'vc'
    option vci '36'
    option vpi '8'
    option payload 'routed'

config interface 'wan'
    option _orig_ifname 'nas0'
    option _orig_bridge 'false'
    option ifname 'nas0'
    option proto 'dhcp'

config adsl-device 'adsl'
    option fwannex 'a'
        option annex 'a2p'

Thanks!

(Last edited by Etique on 4 Mar 2014, 00:06)

And why don't you use the WBMR as a modem router and not only as a router?
The main purpose of buying a WBMR is NOT to have two (or more) devices instead of one...

Mishunja wrote:
bcosta wrote:

I am looking to buy this device, and it seems the only version I have easily available to me is: WBMR-HP-G300H-AP (Note extra -AP).

Does anyone know if this is the same device? or if the build will work on this?

Hi!
AP stands for Asia/Pacific. I bought WBMR-HP-G300H-RU. It had Russian GUI and this is the same device. Unfortunatelly I coudn't flash dd-wrt firmware on it. I suspect that new devices check the firmware before flashing.

Mishunja,

Ho did you finally get flashed your WBMR-HP-G300H-RU? I am getting same "Wrong Image" error with the same model.

Thanks

OK, since we have Barrier Breaker RC2 and going towards the Final Release, a little feedback for the devs and anyone else who's interested.

- My ISP uses IPv6, and without touching anything in the default configuration, my ADSL connection works like a charm. And solid rock!

http://i.imgur.com/eFNffFf.png?1

- My two Huawei USB modems (E173 & E3131) need two things to work. First, a file /etc/modules.d/60-usb-serial with the modem's vendor and product code, for example:

usbserial vendor=0x12d1 product=0x1506

And second, usbmode must be enabled:

/etc/init.d/usbmode enable

- The led configuration is slightly different than AA 12.09
Here is mine:

config led 'led_power'
        option name 'power'
        option sysfs 'power'
        option default '0'
        option trigger 'default-on'

config led 'led_security'
        option name 'security'
        option sysfs 'security'
        option default '0'
        option trigger 'phy0tpt'

config led 'led_wifi'
        option name 'wifi'
        option sysfs 'wifi'
        option default '0'
        option trigger 'phy0tpt'

config led 'led_dsl'
        option name 'dsl'
        option sysfs 'dsl'
        option default '0'
        option trigger 'netdev'
        option mode 'link tx rx'
        option dev 'nas0'

config led 'led_online'
        option name 'online'
        option sysfs 'online'
        option default '0'
        option trigger 'none'

config led 'led_online2'
        option name 'online2'
        option sysfs 'online2'
        option default '0'
        option trigger 'netdev'
        option mode 'tx rx'
        option dev 'nas0'

config led 'led_usb'
        option name 'usb'
        option sysfs 'usb'
        option default '0'
        option trigger 'default-on'

config led 'led_movie'
        option name 'movie'
        option sysfs 'movie'
        option default '0'
        option trigger 'timer'
        option delayon '1000'
        option delayoff '1000'

- The WAN configuration is also a little different.
Here is an example for a PPPoE ADSL connection (with IPv6 enabled):

config atm-bridge 'atm'
        option encaps 'llc'
        option payload 'bridged'
        option vci '35'
        option vpi '8'

config adsl 'dsl'
        option annex 'a'
        option firmware '/lib/firmware/adsl.bin'

config interface 'wan'
        option ifname 'nas0'
        option proto 'pppoe'
        option username 'user@isp.net'
        option password 'XXXXXXXXX'
        option ipv6 '1'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

- The BB RC2 image includes Annex B firmware, so If you use Annex A, remove B and install A.

opkg remove kmod-ltq-adsl-ar9-fw-b
opkg install kmod-ltq-adsl-ar9-fw-a

- br2684ctl is enabled by default

- Default theme is bootstrap, if you want the nice old openwrt theme...

opkg install luci-theme-openwrt

- I also have two TP-Link TL-WN722N (Atheros AR9271) WLAN USB dongles, which they do NOT work with ath9k-htc module.
(There are a couple of tickets open for this issue).
Here is the log:

Sun Aug 3 20:33:30 2014 kern.info kernel: [ 2579.420000] usb 1-1: new high-speed USB device number 2 using ifxusb_hcd
Sun Aug 3 20:33:30 2014 kern.info kernel: [ 2579.644000] usb 1-1: ath9k_htc: Firmware htc_9271.fw requested
Sun Aug 3 20:33:33 2014 kern.info kernel: [ 2582.352000] usb 1-1: ath9k_htc: Transferred FW: htc_9271.fw, size: 51272
Sun Aug 3 20:33:34 2014 kern.err kernel: [ 2583.360000] ath9k_htc 1-1:1.0: ath9k_htc: Target is unresponsive
Sun Aug 3 20:33:34 2014 kern.err kernel: [ 2583.364000] ath9k_htc: Failed to initialize the device


----------------------------------------------------------------------------
If I remember anything else which might be important, I will add it.
----------------------------------------------------------------------------

(Last edited by angelos on 7 Mar 2017, 11:06)

I have been running WBMR-HP-G300H box with Chaos Calmer OpenWRT for about one week now.  I have also updated the firmware file in OpenWRT image with newer "alternative fw" file as listed in http://wiki.openwrt.org/toh/buffalo/wbmr-hp-g300h page. The ADSL here is Annex-A, RFC1483, LLC connection (Sonera ADSL in Finland). Works great.

ADSL line seems to be rock solid and finally the box manages to handshake ADSL line after powering on the box. The stock Buffalo firmware failed 2/3 times to handshake ADSL line after powering on (threw an dhcpc exception into logfile).

LAN wired connection works just fine.  WLAN wireless connection works OK.  IPV6 stuff works. LEDs work.
USB disk shared folder is yet-to-be-tested.

However, haven't done any before-after benchmark tests, but Internet Speedtests show normal download/upload speeds for my 8Mbit ADSL line.

I used Chaos Calmer GIT sources (2015-08-10) and compiled the image from scratch to include LUCI Gui, Dropbear ssh, Nano editor, usb support and other usual stuff for this box.

CC-OpenWRT image was at first a bit difficult to configure (mainly ADSL RFC1483 WAN settings) but until realizing how WAN DHCP interface type and ATM options worked together, things started to work just fine.

(Last edited by Goble on 15 Aug 2015, 00:33)

Hi.

Is anyone using this device facing the Wifi isse?

I've been struggling with it since I installed OpenWrt on it.

After a couple of hours, the Wireless becomes unusuable, the logs are flooded with:

[ 8643.360000] ath: phy0: Unable to reset channel, reset status -22
[ 8643.496000] ath: phy0: DMA failed to stop in 10 ms AR_CR=0xffffffff AR_DIAG_SW=0xffffffff DMADBG_7=0xffffffff
[ 8643.612000] ath: phy0: Chip reset failed
[ 8643.616000] ath: phy0: Unable to reset channel, reset status -22
[ 8643.716000] ath: phy0: DMA failed to stop in 10 ms AR_CR=0xffffffff AR_DIAG_SW=0xffffffff DMADBG_7=0xffffffff
[ 8643.832000] ath: phy0: Chip reset failed
[ 8643.836000] ath: phy0: Unable to reset channel, reset status -22
[ 8644.260000] ath: phy0: DMA failed to stop in 10 ms AR_CR=0xffffffff AR_DIAG_SW=0xffffffff DMADBG_7=0xffffffff
[ 8644.376000] ath: phy0: Chip reset failed

I trying setting Wireless in different ways, like disabling N network (keeping it legacy), fixing it to a specific channel, reducing the power, etc. No luck so far.

Here's my setup details:

DISTRIB_ID='OpenWrt'
DISTRIB_RELEASE='15.05'
DISTRIB_REVISION='r46767'
DISTRIB_CODENAME='chaos_calmer'
DISTRIB_TARGET='lantiq/xway'
DISTRIB_DESCRIPTION='OpenWrt Chaos Calmer 15.05'
DISTRIB_TAINTS=''
system type        : AR9 rev 1.2
machine            : WBMR - Buffalo WBMR-HP-G300H
processor        : 0
cpu model        : MIPS 34Kc V4.12
BogoMIPS        : 221.18
wait instruction    : yes
microsecond timers    : yes
tlb_entries        : 16
extra interrupt vector    : yes
hardware watchpoint    : yes, count: 4, address/irw mask: [0x0ffc, 0x0ffc, 0x0ffb, 0x0ffb]
isa            : mips1 mips2 mips32r1 mips32r2
ASEs implemented    : mips16 dsp mt
shadow register sets    : 1
kscratch registers    : 0
package            : 0
core            : 0
VCED exceptions        : not available
VCEI exceptions        : not available
config wifi-device 'radio0'
    option type 'mac80211'
    option hwmode '11g'
    option path 'pci0000:00/0000:00:0e.0'
    option txpower '20'
    option country 'BR'
    option log_level '3'
    option channel '6'
    option htmode 'HT20'

config wifi-iface
    option device 'radio0'
    option mode 'ap'
    option wps_device_name 'Buffalo WBMR-HP-G300H'
    option ssid 'ABC'
    option key '1234567890'
    option network 'lan'
    option wps_pushbutton '0'
    option encryption 'psk-mixed+ccmp'

config wifi-iface
    option device 'radio0'
    option mode 'ap'
    option ssid 'DEF'
    option key '1234567890'
    option wps_pushbutton '0'
    option network 'lanb'
    option encryption 'psk-mixed+ccmp'

I don't think it is related but I must mention I was able to solve the constant ADSL disconnect following the details on this post:
https://dev.openwrt.org/ticket/18105#comment:15

Is anyone facing similar Wireless problem with this device? Any solution?

Thank you.

Maybe the fact that you have two wifi-iface's, causes problems.
Remove one of them and watch the router's behaviour for some hours to see if the problem still exist.

Nyx__ wrote:

Is anyone using this device facing the Wifi isse?

I have been running WBMR-HP-G300h with OpenWRT/ChaosCalmer for about 6 months and it works great. I didn't use any existing OpenWRT images, instead I re-compiled the image from OpenWRT/CC sources released about 6 months ago. I know there are newer CC  source codes already available but because the one I re-compiled works without problems I haven't bothered to update it.

I have several WLAN and few LAN devices connected to the box. The only problem I had was with one of the Win10 laptops. It sometimes lost WLAN connection but the problem was in that laptop because other devices worked just fine (laptops, PS3, television and several Android mobiles and one Windows Phone mobile). Eventually tweaking Win10 laptop settings that problem was also solved so definetly a client problem and not OpenWRT device issue.

OpenWRT/ChaosCalmer: Bleeding Edge (r46584)

cat /etc/config/wireless:

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:0e.0'
        option country 'FI'
        option htmode 'HT20'
        option txpower '17'
        option channel '1'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option wps_pushbutton '0'
        option wps_device_name 'OpenWrt - Buffalo WBMR-HP-G300H'
        option ssid 'MyWLAN'
        option encryption 'psk2'
        option key 'sensoredPwdKey'
        option wpa_group_rekey '7200'

(Last edited by Goble on 14 Jan 2016, 17:27)

Goble wrote:

I have been running WBMR-HP-G300h with OpenWRT/ChaosCalmer for about 6 months and it works great. I didn't use any existing OpenWRT images, instead I re-compiled the image from OpenWRT/CC sources released about 6 months ago. I know there are newer CC  source codes already available but because the one I re-compiled works without problems I haven't bothered to update it.

I have several WLAN and few LAN devices connected to the box. The only problem I had was with one of the Win10 laptops. It sometimes lost WLAN connection but the problem was in that laptop because other devices worked just fine (laptops, PS3, television and several Android mobiles and one Windows Phone mobile). Eventually tweaking Win10 laptop settings that problem was also solved so definetly a client problem and not OpenWRT device issue.

OpenWRT/ChaosCalmer: Bleeding Edge (r46584)


Hi. I tried using a compiled from sources version (CC - r48430). The problem still occurs.

To compile it, I followed the guide available here: https://wiki.openwrt.org/doc/howto/build

Can you tell me how to compile that specific version (r46584) you used? How to change to that specific release using GIT?

I'll then compile that specific version and test on my device.

Thank you very much.

Nyx__ wrote:

I tried using a compiled from sources version (CC - r48430). The problem still occurs.
Can you tell me how to compile that specific version (r46584) you used? How to change to that specific release using GIT?

You can use git checkout command to checkout certain revision. Or you can use http://git.openwrt.org/?p=openwrt.git;a=shortlog website to download a snapshot tar.gz package of certain commit (just go back to certain date in a log history). My revision is something like 6-7 months old.

Are you sure this is not a client related problem (or certain client triggers this hidden bug)? If WLAN dropouts occurs always wihin 2-3 hours of lifetime then how about trying to run in one by one with different clients to see is there certain WLAN client causing this bug.

One thing I didn't remember to mention is that I'm using Annex-A "alternative firmware". The one coming with OpenWRT source package is (presumably) quite old. See https://dev.openwrt.org/ticket/18105# discussion. I updated the OpenWRT image to use dsl_ar9_firmware_adsl_a-04.05.04.09.01.01.bin firmware version.

This firmware is supposed to fix some ADSL line problems, so probably has nothing to do with WLAN but if you have Annex-A ADSL line then give it a chance.

EDIT: Aaah. I see you are already using the "alternative fw" (just read again one of your old posts).

(Last edited by Goble on 29 Jan 2016, 22:06)

Anyone here had any luck upgrading this router to LEDE? It's not on the support matrix, but it would seem that both Annex-A and Annex-B images continue to be built for this router

I am planning to do the migration from 15.05.1 to 17.01.0 in the next couple of days.
So... just be a little patient and I will post any info I think it's crucial (like important differences etc).
Cheers! smile

Migration from 15.05.1 to 17.01.0... DONE! smile

https://s24.postimg.org/rhrzvsz6t/wbmr000.png

Notes:

  • LuCI respond is slower in comparison to 15.05.1

  • By default, wpad-mini is installed. If you want WPA2-EAP support, you must install the wpad package.

  • DSL improvements and options added...
    https://s23.postimg.org/ucd5vtr17/wbmr001.png
    https://s9.postimg.org/6ggv75fqn/wbmr002.png
    https://s18.postimg.org/kpixd23gp/wbmr003.png

If I notice anything else that is worth mentioning, I will add it.

(Last edited by angelos on 7 Mar 2017, 16:45)

Thanks for that - before checking this thread - as I forgot to tick the 'subscribe to topic option' I went off and did my own upgrade of the Buffalo last night.

Things I noticed so far:

- LuCI is slower which you mention above, especially the initial status screen, though the overall memory profile of the entire system is better (lower running memory use).
- Cake is available as a built in QoS Scheduler, which does seem to have better CPU usage under network saturation.
- The Annex-A firmware file adsl.bin is still the older openwrt one, rather than the one identified in the ticket 18105 (can't post the url).
- Some of the collectd modules are logging extra information that is differentiated by type_instance only - I send everything to a local influx/grafana combo, and it screwed up the graphs until i fixed this.
- By default, even if you specify the DNS servers separately in the DNSMASQ file the ones against the connection are also appended on - perhaps there was a setting that made this happen, but I couldn't find it.

Thank you for the feedback, it's always useful.

-----

3 years ago, I opened a ticket...
#16755 / ath9k_htc: Failed to initialize the device

Although this was not a WBMR-HP-G300H issue and affected many OpenWrt versions, it seems that it's fixed in LEDE 17.01.0!

I don't know if the problem was the kernel, the firmware, a combination of both or something else, but I'm very happy to see that my TP-LINK TL-WN722N (Atheros AR9271 chipset) is finally working!

Thu Mar  9 15:29:28 2017 kern.info kernel: [  132.707331] usb 1-1: new high-speed USB device number 2 using dwc2
Thu Mar  9 15:29:28 2017 kern.info kernel: [  132.932747] usb 1-1: ath9k_htc: Firmware ath9k_htc/htc_9271-1.4.0.fw requested
Thu Mar  9 15:29:29 2017 kern.info kernel: [  133.783406] usb 1-1: ath9k_htc: Transferred FW: ath9k_htc/htc_9271-1.4.0.fw, size: 51008
Thu Mar  9 15:29:29 2017 kern.info kernel: [  134.024293] ath9k_htc 1-1:1.0: ath9k_htc: HTC initialized with 33 credits
Thu Mar  9 15:29:29 2017 kern.info kernel: [  134.466531] ath9k_htc 1-1:1.0: ath9k_htc: FW Version: 1.4
Thu Mar  9 15:29:29 2017 kern.info kernel: [  134.470660] ath9k_htc 1-1:1.0: FW RMW support: On
Thu Mar  9 15:29:29 2017 kern.debug kernel: [  134.475237] ath: EEPROM regdomain: 0x809c
Thu Mar  9 15:29:29 2017 kern.debug kernel: [  134.479131] ath: EEPROM indicates we should expect a country code
Thu Mar  9 15:29:29 2017 kern.debug kernel: [  134.485235] ath: doing EEPROM country->regdmn map search
Thu Mar  9 15:29:29 2017 kern.debug kernel: [  134.490511] ath: country maps to regdmn code: 0x52
Thu Mar  9 15:29:29 2017 kern.debug kernel: [  134.495282] ath: Country alpha2 being used: CN
Tue Mar  7 15:29:29 2017 kern.debug kernel: [  134.499656] ath: Regpair used: 0x52
Thu Mar  9 15:29:29 2017 kern.info kernel: [  134.549066] ieee80211 phy1: Atheros AR9271 Rev:1

(Last edited by angelos on 9 Mar 2017, 21:33)

I need to add a WAN port to my WBMR-HP-G300H, because I'm switching to VDSL and the Buffalo can't handle that. The ISP now forces a crappy modem/router on its subscribers, and if you want your landline to work you have to use THAT, at least for the modem part: VoIP credentials are encrypted in the crappy modem's firmware.

So I will use it as modem only, and keep the Buffalo as my main router. As it is now (before switching), the Buffalo's wan is a pppoe connection to the nas (ATM) adapter. However, the Buffalo has no actual ethernet WAN port. I need to make one so it can connect to the crappy modem. How do I fake a WAN port with VLANS without touching anything else? I'd like to just move the original pppoe connection from the nas adapter to the new virtual WAN ethernet port.

@angelos
In your post dated 2017-03-07 16:41:21, you show some nice pages (DSL, ATM bridges). I also run LEDE now, but I don't have those pages in LuCi. Is there a specific package I must include when building? Where are those pages located in LuCi's menus? This isn't important, as I'm switching to VDSL anyway. Just my curiosity...

(Last edited by bassman on 31 May 2017, 02:32)

I have openwrt 14.
sysupgrade from openwrt to lede is working for this router?

etness wrote:

I have openwrt 14.
sysupgrade from openwrt to lede is working for this router?

Yes, it works flawlessly in my experience. Switched to Lede painlessly a long time ago already.

Just ensure that if you are using Annex A, that you replace the firmware with the more stable firmware linked from the wiki.

bassman wrote:

Yes, it works flawlessly in my experience.

Fantastic! I updated today without issue. Thank you for your feedback.

The discussion might have continued from here.