OpenWrt Forum Archive

Topic: Digital Photo Frame as OpenWrt display howto

The content of this topic has been archived between 30 Mar 2018 and 26 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

irimi wrote:
derrij wrote:

please, someone, share compiled lcd4linux-dpf ipk file.

An old version is still available at DropBox

thank you.
here is  lcd4linux-dpf_r1184-2_ar71xx.ipk may be someone needs

I tried to compile the lcd4linux-dpf for OpenWrt Backfire 10.03.1 on a NSLU2.

I miss several plugins in the binary:

/ # lcd4linux -l
LCD4Linux 0.11.0-SVN-1158
Copyright (C) 2005, 2006, 2007, 2008, 2009 The LCD4Linux Team <lcd4linux-devel@u
sers.sourceforge.net>

available display drivers:
   DPF                 : generic hacked photo frame

available plugins:
  cfg, math, string, test, time, cpuinfo, loadavg, meminfo, proc_stat, uptime

As far as i know these are only the default plugins.

How can i compile a version with plugins like file, netdev, statfs, etc. ?

@irimi
@derrij

I found your two lcd4linux-dpf ipk file, both worked but:

irimi: your ipk file is based on r1142, so there is not bigger text allowd
derriJ: your ipk file is based on r1184 (so there is bigger text), but a lot of plugins are missing.

is there a chance that one of you can compiled it again based on r1184 with all plugins for ar71xx? would be great!

thanks jan

I got the ipk now and it works. But here is another question, probably someone of you can help me:
I use my Tl-MR3020 with usb-hub and usb sound card as a audioplayer. my audio amp get the power via usb-hub. now I can hear some noises for wifi activity and even more of lcd4linux activity. first I thought the noise is transmitted through audio cable, but it's not, because if I disconnect the audio cable I still have the noises and the sound through the connected headphones are fine. so, probably it has to be something with the 5v power. what do you think? and what can be done against these noises?
thanks for any tips

Did you tried to mute the sound mic input with alsamixer?. Also use always volume control by hardware not software. How cheap is your sound card?

I think, yes a faulty power supply can introduce noises.
How to avoid noises, well, just shield your sound card. I'm not an expert but it could be a solution.

Thanks for your response. I made some tests and it's definitely not the sound card or the audio cable. Because:
-if I mute the sound output (by software, hardware is not working) the noises are still heard
-if I stop lcd4linux and mpd (so CPU load are more or less 0) the noises are gone
So this means CPU generates a noise through USB-hub somehow (but not through sound card). So any ideas of getting rid of this?

Hello dddesign,

If you have an ar71xx ipk based off 1184 or later with more plugins compiled in, can you share this please?

Thanks,
/vv

Hi I reworked the package with dpf support for the latest lcd4linux revision (1196)

https://files.myopera.com/danitool/live … _r1196.zip

Tested against Backfire. It seems there exist a bug reading the configuration. After the firs boot execute the command:

chmod 600 /etc/lcd4linux.conf

For compiling just drop the lcd4linux-dpf directory under the package directory, then select it in make menuconfig, and build the firmware.

I think so:For me it makes no difference to flash the landscape zipfile firmware at windows or by python script at linux (linux way is only faster).
The only problem I had, if you are using latest firmware and latest dpflib the display output is mirrored / 180° rotated. The workaround is to use the latest firmware but dpflib of 01alpha version hack.
are interested can go to my blog to have a look.

(Last edited by RichardHeap32 on 27 Mar 2013, 11:00)

i am new here. i'd like to ask a question.
i download the dpf-ax_0.41_20130520.tgz from http://sourceforge.net/projects/dpf-ax/files/source/ and upload to my NAS box.

installed the packages need by the " build-dpf-lcd4linux.sh", except one package "aclocal",

then i run the build-dpf-lcd4linux.sh and get the following output.

bootstrap:$LINENO> aclocal
./bootstrap: line 13: aclocal: not found
checking for a BSD-compatible install... ./install-sh -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... ./install-sh -c -d
checking for gawk... no
checking for mawk... no
checking for nawk... no
checking for awk... awk
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking how to run the C preprocessor... gcc -E
checking whether ln -s works... yes
checking whether make sets $(MAKE)... (cached) yes
checking for pkg-config... /opt/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking if malloc debugging is wanted... no
checking for log in -lm... yes
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
configure: checking location of ncurses.h file...
checking for ncurses version... 5.5
checking for X... no
checking gd/gd.h usability... no
checking gd/gd.h presence... no
checking for gd/gd.h... no
checking gd.h usability... no
checking gd.h presence... no
checking for gd.h... no
checking jpeglib.h usability... no
checking jpeglib.h presence... no
checking for jpeglib.h... no
checking sys/io.h usability... yes
checking sys/io.h presence... yes
checking for sys/io.h... yes
checking usb.h usability... no
checking usb.h presence... no
checking for usb.h... no
checking libusb-1.0/libusb.h usability... no
checking libusb-1.0/libusb.h presence... no
checking for libusb-1.0/libusb.h... no
checking luise.h usability... no
checking luise.h presence... no
checking for luise.h... no
checking serdisplib/serdisp.h usability... no
checking serdisplib/serdisp.h presence... no
checking for serdisplib/serdisp.h... no
checking st2205.h usability... no
checking st2205.h presence... no
checking for st2205.h... no
checking libdpf/libdpf.h usability... no
checking libdpf/libdpf.h presence... no
checking for libdpf/libdpf.h... no
checking rfb/rfb.h usability... no
checking rfb/rfb.h presence... no
checking for rfb/rfb.h... no
checking linux/lcd-linux.h usability... no
checking linux/lcd-linux.h presence... no
checking for linux/lcd-linux.h... no
checking ftdi.h usability... no
checking ftdi.h presence... no
checking for ftdi.h... no
checking if python support is wanted... no
checking if raw port I/O is wanted... no
checking asm/io.h usability... yes
checking asm/io.h presence... yes
checking for asm/io.h... yes
checking linux/parport.h usability... yes
checking linux/parport.h presence... yes
checking for linux/parport.h... yes
checking linux/ppdev.h usability... yes
checking linux/ppdev.h presence... yes
checking for linux/ppdev.h... yes
checking which drivers to compile... done
configure: WARNING: libdpf.h not found: DPF driver disabled
configure: error: You should activate at least one driver...
make: *** No targets specified and no makefile found.  Stop.

Seems i need to install the DPF driver,  what's the next ?

thanks.

Can somebody please Compile the LCD4Linux Version with DPF for AR71xx with latest musl Toolchain?

Hi,

since a few days I am trying to update my dokstar together with the pearl digital photo frame to BarrierBreaker 14.07. But I do nit have success to get lcd4linux-dpf compiled. I always get the same error message:

checking libdpf/libdpf.h usability... no
checking libdpf/libdpf.h presence... yes
configure: WARNING: libdpf/libdpf.h: present but cannot be compiled
configure: WARNING: libdpf/libdpf.h:     check for missing prerequisite headers?
configure: WARNING: libdpf/libdpf.h: see the Autoconf documentation
configure: WARNING: libdpf/libdpf.h:     section "Present But Cannot Be Compiled"
configure: WARNING: libdpf/libdpf.h: proceeding with the compiler's result
configure: WARNING:     ## ---------------------------------------------------- ##
configure: WARNING:     ## Report this to lcd4linux-users@lists.sourceforge.net ##
configure: WARNING:     ## ---------------------------------------------------- ##

and a few lines below:

checking which drivers to compile... done
configure: WARNING: libdpf.h not found: DPF driver disabled
configure: error: You should activate at least one driver...

I followed the instructions as mentioned in the first post.

Does anybody has a solution for that problem?

Thanks
Elektrischlumpf

Yes, i get the same error with latest musl Toolchain in Buildroot.

Hi,

i was able to fix the Build for dpf.

./lcd4linux -l
LCD4Linux 0.11.0-SVN-1202
Copyright (C) 2005, 2006, 2007, 2008, 2009 The LCD4Linux Team <lcd4linux-devel@users.sourceforge.net>

available display drivers:
   DPF                 : Hacked dpf-ax digital photo frame
   Image               : PNG

available plugins:
  cfg, math, string, test, time, apm, asterisk, button_exec, cpuinfo, diskstats, dvb, exec, event, fifo, file, hddtemp, huawei, i2c_sensors, iconv, imon, isdn, kvv, loadavg, meminfo, mpd, netdev, netinfo, pop3, proc_stat, seti, statfs, uname, uptime, w1retap, xmms

Hi DarkStarXxX,

thats great. Congratulation :-) How did you do it. Could you please write a short how to.

Thanks
Elektrischlumpf

Hello,

I have a Pearl 2,4" DPF display wiht AX206 chip.

On my Debian wheezy server it runs perfect.

I buyed a new router (TP-Link Archer C7 "AC1750") and i installed OpenWRT Chaos Calmer RC3 Trunk. It runs very perfect.

I have the idea to connect a DPF display to this router. It it pre hacked.

also i installed lcd4linux:

opkg install /root/lcd4linux-custom_r1187-1_ar71xx.ipk

it was installed without error.

but then i will start lcd4linux:

lcd4linux -l

i get the error:

lcd4linux: can't load library 'libgd.so.2'

But libgd - 2.1.1.1 is installed. i can not found the lib on the openwrt system.

Can anybody help me? Or have anybody any idea for this problem.

Okey,

i installed now:

lcd4linux-dpf_1184-2.ipk
libusb-1.0
libusb-compat (Because libusb-0.1.so.4 was not found)

with lsusb:

Bus 002 Device 003: ID 1908:0102 GEMBIRD

Ok the DPF was found in the USB devices:

But with:

lcd4linux -F i get the following errors:

root@OpenWrt:~# lcd4linux -F
Found AX206 DPF
Error: No matching USB device found!
dpf: cannot open dpf device usb
Error initializing driver DPF: Exit!

EDIT:

i must set the 'usb0' variable.

Now i get the next error:

root@OpenWrt:~# lcd4linux -F
Found AX206 DPF
Got LCD dimensions: 320x240
Huh? Not even a single timer to process? Dazed and confused...

Very stranged, because on my debian server i have no of these errors.

(Last edited by danieljo on 22 Jul 2015, 23:54)

I have some problems to build the last trunk version of lcd4linux for openwrt. it compiles without errors but also WITHOUT dpf display driver (of course I selected dpf in make menuconfig before compiling). The same happens with SamsungSPF display driver. by the way: my target is raspberry pi (brcm2708)

As I understand nothing else than actual trunk source of lcd4linux (1203) is needed.
Or do I need more/other sources or scripts?
Any ideas what's wrong or how I can debug this?

@DarkStarXxX: I compiled trunk1202. any tips from you?
@Elektrischlumpf: did you have success to do it for your own?

thanks

The discussion might have continued from here.