OpenWrt Forum Archive

Topic: Successful TP-MR3220 with MF190

The content of this topic has been archived on 5 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hi, I have successfully installed the openwrt 9-Jan-2012 r29697 (from ), additional packages to use 3g and everything is working properly. ZTE MF190 is incompatible with the mode that original firmware using to connect, but they resolved in terms of connecting directly to the port ttyUSB4.

However I have some doubts. The first one with "sysupgrade", the router loses access SSH, so to get it back I had to use the serial port, so it seems that is not the best method to update the firmware.

The second is about making a small howto in Spanish to make installation easier or maybe make a squashfs with all the packages required to have 3G service enabled (if you only have the mobile connectivity package installation is more complicated, since we have to download and use a tftp from local network).

The third is about how to link to the Android USB connection, but I suppose this topic duty to search or comment elsewhere smile.

Best regards.

p.d.: On LuCI show "OpenWrt Firmware Attitude Adjustment (r29763) / LuCI Trunk (trunk+svn8187)" and kernel, but base-files are r29697

(Last edited by almursi on 23 Jan 2012, 16:09)

Hi, first draft of Spanish howto 3g.mr3220 on
I've probably forgotten a lot of details, but I think the basics are as simple as that...
Best regards.

Hi, in this moment I'm testing a self-compiled OpenWrt (r29871) and seem that everything work fine. For now I can comment that the sysupgrade (with my own compilation) with LuCi has worked well but avoid copying the configuration files (for the problems they are discussing in other threads). The fact is that the modules needed to activate the modem are much less than I have in my manual, so I'll have to make a separation between those who are related to the modem, USB disks and text editor.
Edited: for some reason sysupgrade (by console) does not work, but through LuCI everything works fine (also I test with recover configurations without problems). And draft of little howto is finish (it is simply the notes that I use every time I install, these days often while trying to do some experiment smile ).

(Last edited by almursi on 26 Jan 2012, 07:33)

Hi. definitively or have "LuCI" or support for USB drives, but not both at once. Anyway, through a HUB want to reuse an old stick of 4GB (now no longer in use), and the goal is to have both smile (although probably take me a week to make time for it). The only thing that makes me doubt is when turned off (how to safely shut down???).

Edited: with a single hub (no power) seems not possible to connect the modem and the USB drive at the same time (sometimes reattaching fix any of them, but that prevents us make the rootfs). If it's a kernel problem, perhaps it ends up with solution, but I fear that is due to energy consumption... Anyway I will continue trying to get a working rootfs. (Re-edited: or maybe a compatibility problem between modules installed, I compiled again removing some modules and looks much better...
Success and problem with dns is solved with dhcp.dnsmasq.resolvfile=/tmp/resolv.conf.ppp
Re-Edited: On r29967 /tmp/ is working again.   )


(Last edited by almursi on 1 Feb 2012, 03:43)

Hi. Which hardware version do you have?
I come from the wiki where you add a new row, but a non sense r29697.
The version column is for "version supported from to latest"
I suggest add your success history to the previous row.

Hi, thanks, the truth is that I did not know where to put it, but it seemed interesting to leave the link smile. I fix it now... Regards.

Hi, some people without linux skill ask me help whit mr3220, and finally I do a non-official image (with LuCI and 3G support) and share links on
If that goes against the policy on the wiki, correct me smile. Regards.

How often will you update your FORK? There is a snapshot every 3 days.

You can sync with current trunk, so no need to provide your own packages. Sync process detailed here.

And before update, please do a packages backup. Someone may ask for later:

cd /
tar --remove-files -ncf packages$r.tar packages

Fast uncompressed tar, because *.ipk are already compressed and decompress may take a long time also, unnecessary.

I add some lines to ease the package installation to your wiki document, later I will add a tar | wget | untar pipe to ease that many wget.

About fork policy: "You shouldn't fork".
You should ask nicely "[Request] [Argument]" like:
"Please add 3G profile to routers already marketing as 3G router: 3020, 3220, 3420, etc."
And obviously, include such profiles in the ticket.

Hi, thanks Nilfred. It really has been a haphazard one. Someone asked me the image, and after placing it into the public server, I thought maybe I could include it also in the wiki in case it was useful. Public server is not at home (and have a shared fork is not in my plans), I think that best idea is request a fork. Meanwhile, the image will be available for one month (at least), but like I say not in my plans to maintain a fork  (my personal builds are once a month). Just one of the reasons for not collaborate on more projects is the difficulty to have updated the svn public servers.

Edited: Here is the ticket smile

Edited2: I update to r30950 with resolveip and no more dns problems. Links on wiki ending over 10-april. And Nilfred, yes: sip more easy, but I don't found how to change ISP number with sed (no working \* \" same impossible)... but finally I'd remember how to use vi big_smile.

Best regards.

(Last edited by almursi on 15 Mar 2012, 17:35)

Hi, some custom task that I'm thinking to do:
1. Use of qss button for call poweroff (in case of ext-root it's good idea) before power down -and change system LED status to show it-.
2. Change 3g LED status to 3g-wan status (now is a confuse USB stick present).
3. Looking for a reconnecting script for 3g-wan (that I see here some days ago, but I don't remember where is smile ).
if anyone want to join it (or explain how to it's done), perfect. I do not think I'm the first to think of something like smile. Regards.

almursi wrote:

Nilfred, yes: sip more easy, but I don't found how to change ISP number with sed (no working \* \" same impossible)... but finally I'd remember how to use vi big_smile.

# Avoid * (preferred, reusable)
sed -e 's/\("ATD\).*"/\1*99#"/' /etc/chatscripts/
# escape * (usable once)
sed -e 's/\*99\*\*\*1#/*99#/' /etc/chatscripts/
# remove * (minimal, once anyway)
sed -e 's/\*\*\*1//' /etc/chatscripts/

Test them all. Insert -i parameter to edit really.

Hi Nilfred, thanks for sed tips (problem was "-i" parameter, that give me a confuse ed output -that I don't have use-). About fork I comment that I see that my internet access is very poor in this moment for maintain it.

On the other hand, finally I found a way to connect android phones (at least a model, I suppose that it will be hardware dependent...):

Need: kmod-usb-net, kmod-usb-net-cdc-ether and kmod-usb-net-rndis
New interface "usbnet", dhcp client, phisical settings link to usb after enable usb on phone, assign firewall together wan.

config interface 'usbnet'
    option proto 'dhcp'
    option ifname 'usb0'
    option auto '0'

config zone
    option name 'wan'
    option network 'wan wwan usbnet'


(Last edited by almursi on 28 Mar 2012, 21:19)

Thanks a lot. I am from Turkey. My 3g router  is 25$ Chinese - TP  Link WR703N and 3G dongle is ZTE MF190. Firmware is OpenWrt Firmware Attitude Adjustment (r31219) / LuCI Trunk (trunk+svn8531). After "sed -e 's/\*99\*\*\*1#/*99#/' /etc/chatscripts/ -i" command 3g router started to work fine.

@madanadam, can you please post or email me the the firmware that you used to get the zte mf190 to work on the wr703n.
i sent you a pm about it with my email.
very much appreciated.

Can anyone share succesfully working /etc/chatscripts/ and /etc/config/network files? I couldn't get it work.

@fobo: Maybe you need another ttyUSB port, latest versions of MF190 are using ttyUSB3 (and this can always change with each new version).

i tried every 5ttyUSB (yes 5, i dont know why that much smile
I fixed the dialing number in chatscript
Tried many combination in network configuration and no success
another huawei e177 won' even bring ttyusb options
now i am started to compile last trunk. i'm afraid i will start to hacking kernel soon -p

Hi, strange... disables the PIN first of all (putting the sim in another phone for example). You need install packets (as explained in ). On console, you can try "comgt info" and paste here similar output to:

Model: MF190
Revision: MF190V1.0.0B07

and "band settings" (that show what happen with Regards.

The discussion might have continued from here.