OpenWrt Forum Archive

Topic: Ubiquity AirRouer

The content of this topic has been archived on 2 Feb 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Please bear with me, I'm new to OpenWRT....

I have a lovely UBNT AirRouter that i would like to put OpenWRT onto.  I looked in the Wiki and Table of Hardware but it was unlisted (not a single reference to it). 

However, I was poking around and I found what looks like a build for Ubiquiti AirRouter here. 

http://downloads.openwrt.org/snapshots/trunk/ar71xx/

Does this meen there is a valid build for AirRouter?

If so, would it be an Alpha/Beta or stable release (for the AirRouter hardware)?

It appears there aren't any open bugs for it.  http://patchwork.openwrt.org/project/op … chive=both 


If it is a good build, Are their any special install instructions or is it the TFTP install for other UBNT devices?

Thanks,

Adam

Hi,

Don't know if you tried it, but just flash on my AirRouter and so far have no problem to report. I used the squashfs version.

If you have any question, don't hesitate to ask.

Thanks,
Jonathan

First I installed DD-WRT easely, didn't like activation (20 euros), put OpenWRT on. A bit scary, it doesn't respond at first, but you reset it once more and it is done. I have a feeling that AirRouter will be my favorite router. It couldn't NAT thru full 100Mbps with AirOS or DD-WRT, but it did 91Mbps. Now need to rest, will continue trolling later smile
If I am not mistaking, I used http://downloads.openwrt.org/snapshots/ … actory.bin

P.S. Serial port is working, tried with old Siemens mobile phone cable.

Has anyone ells installed on an airRouter recently and does anyone ells have a comment on the functionality of either version here?

Thanks

Zeffern

I've just installed  the latest trunk over AirOS on the AirRouter and it works perfect.
While the ath9k driver from OpenWRT doesn't expose the radio scanning capabilities (afaik) that the AirOS closed source driver does, and might not have some of the options... OpenWRT is way better.

Note that AirOS's driver doesn't even work properly with some of the options anyway, and Ubiquity doesn't seems concerned (been very long , no patch, no comments).

So yeah, OpenWRT is superior in every other way.

Installation is dead easy, just go to the  AirOS upgrade page and select the OpenWRT firmware - done.
That's the one I use: http://downloads.openwrt.org/snapshots/ … actory.bin

Once it rebooted, wired network will be up (incl. WAN DHCP) and you can telnet to it (192.168.1.1) then set a root password (passwd), and reconnect via ssh.
See the OpenWRT documentation to set it up (mainly, edit /etc/config/wireless and comment out the "disabled 1" line to enable wifi.. then again check doc to get WPA2 AP, default is no encryption, channel 11, SSID OpenWrt).

You can use the sysupgrade image and again, OpenWRT doc to upgrade.

Important note: while I use trunk (the dev version) you might want a stable version. I haven't tested the stable release - but it probably works too.

Anyhow, that's that smile

(Last edited by kang on 1 Apr 2012, 10:58)

The discussion might have continued from here.