Hello everyone

Today i bought the router and installed OpenWRT

While I was trying to set up the router as a repeater i performed the following steps:

------- /etc/config/network -------------------
config switch    "eth0"
    option vlan0 "1 2 3 4 5*"
    option vlan1 "0 5"

config interface wan
        option type     bridge
        option proto    dhcp

config interface lan
        option type     bridge
        option ifname   "eth0.0"
        option proto    static
        option ipaddr   192.168.1.1
        option netmask  255.255.255.0

config interface loopback
        option ifname   "lo"
        option proto    static
        option ipaddr   127.0.0.1
        option netmask  255.0.0.0


------- /etc/config/wireless -------------------
config wifi-device      wl0
        option type     broadcom
        option channel  5

config wifi-iface
        option device   wl0
        option mode     ap
        option ssid     myNet
        option hidden   0
        option encryption wep
        option key   XXXXXXXXXXXXXXX
        option network   lan

config wifi-iface
        option device   wl0
        option mode     sta
        option ssid     wireless
        option hidden   0
        option encryption none
        option network   wan

After rebooting the device I have no longer access on it!
There is no wifi AP and I can't connect through LAN cable. I suppose that the DHCP is not working.

I tried setting a static IP in my PC and connect the router but with no luck.

That's why i tried to login through telnet during the failsafe mode but with no luck either.

I am did all the steps but the router doesn't respond in Telnet, neither in pings!


That's the tcpdumb while entering in failsafe mode:

    06:09:06.898439 IP 192.168.1.4.mdns > 224.0.0.251.mdns: 0*- [0q] 7/0/0 (Cache flush) PTR linux.local., (Cache flush) SRV linux.local.:22 0 0, (Cache flush) A 192.168.1.4, (Cache flush) TXT "", (Cache flush) SRV linux.local.:22 0 0, (Cache flush) TXT "", (Cache flush) AAAA fe80::222:15ff:fe3b:6787 (253)
    06:09:06.898950 IP 192.168.1.4.mdns > 224.0.0.251.mdns: 0*- [0q] 4/0/0 (Cache flush) TXT "", (Cache flush) PTR linux.local., (Cache flush) HINFO, (Cache flush) SRV linux.local.:9 0 0 (161)
    06:09:07.816164 IP 192.168.1.4 > 224.0.0.22: igmp v3 report, 1 group record(s)
    06:09:12.779014 IP truncated-ip - 4 bytes missing! 192.168.1.1.54209 > 192.168.1.255.4919: UDP, length 1001

Please advice.
Thank you very much!

(Last edited by cmpahar on 21 Mar 2012, 15:57)