OpenWrt Forum Archive

Topic: Just bought a wrt54GL with OpenWRT - Can't reset it

The content of this topic has been archived on 28 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hello,

I came here seeking for help because i'm facing a situation.

I just bought a wrt54gl linksys router from some guy on ebay, and it appears that it has openwrt on it. When I link it to my computer, it gives me an adress with DHCP but I can't access the Web UI. The guy gave me the root password, so I can successfully ssh into it, and i saw it is running White Russian 0.9 version. If I try to browse to http://192.168.10.1 (which is the router adress) I can see openWrt logo for a second, and then it redirects me to "http://192.168.10.1/cgi-bin/webif.sh" which gives me a 404 error. The Web UI never asked me for authentication. I suppose the guy must have put some scripts in it.

I just want to reset it to default settings, or flash it back to the factory firmware. So I browsed OpenWrt wiki, documentation and some blogs, and here is what I can tell :
- It seems the guy disabled the failsage mode (is that possible ?) When I tried to failsafe boot it, it looks successful (power and DMZ led blinking) but I can't telnet or acess adress 192.168.10.1 or 192.168.1.1 (I of course tried manual IP on my computer for the both networks).
- I tried to contact the router with tftp, but I believe it is disabled to. When I try "tftp 192.168.10.1" in my command prompt I just end up with a "tftp>" prompt and commands don't seem to work when I enter them.

I'm desperate, and can't think of any other solution. Could you please provide some help to reset this router, of flash it with linksys firmware. As I said, I have the root password and can successfully ssh into it. I can provide you with the results of any commands you can tell me to try.

Thank you in advance.
Regards

(Last edited by YassT on 27 Mar 2012, 21:32)

YassT,

You can reflash this router easily using the mtd command and the right TRX file.  Consider maybe this one for a wrt54GL:
http://downloads.openwrt.org/whiterussi … uashfs.trx

According to this page (http://wiki.openwrt.org/doc/techref/mtd) you can run mtd to drop the new firmware into place.  First you'll want to scp it up, though:

1. ssh in, use df to check for space
2. wget the TRX URL
3. scp the TRX file to 192.168.10.1:/tmp or so
4. (ssh back in and) look in the router's /tmp for the filename.trx
5. do a  mtd -r write /tmp/filename.trx linux    using the name of the file you uploaded
6. wait for the reboot
7. rejoice, post update to the forum

I do this frequently, and it's never killed a unit.  My command line history is littered with statements like:
  scp newbuild.trx root@10.1.1.1:/tmp/openwrt.trx
  ssh root@10.1.1.1 "mtd -e linux -r write /tmp/openwrt.trx linux"

Having said that, though, I don't know how safe it is -- that's my disclaimer.  So don't do it if you aren't exactly sure of what you're doing.

(Last edited by bishopolis on 11 Apr 2012, 16:54)

The discussion might have continued from here.