OpenWrt Forum Archive

Topic: Inside 3G150B

The content of this topic has been archived between 20 Apr 2018 and 30 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

I uploaded my own compilation of OpenWRT but it doesn't work as expected and I have to upload a new one.
Now the only way to upload new firmware is serial port and tftp.
I tried above instructions but with no luck.
When I connect serial (CA-42) to J2 and turn on the router then nothing happens. It looks like rooter is waiting for something.
When I disconnect rooter from serial and then turn it on and then reconnect serial then I can see in putty boot sequence but when I try to press any key I always get "You chosed 3".

What I'm doing wrong?

Problem solved. I was not quick enough pressing keys in putty.

Because log mentioned in one of above posts is currently not available I'd like to share some information.
IP address for tftp server should be:
Bootloader asks for name of the file with firmware.
Then infinite loop begins and router waits for tftp server.
If you make any typo in filename you have a lot of time to correct it. Just rename the file with firmware on the local computer to match value entered in bootloader. It tries to upload file every few seconds if the file is not found (like another infinite loop).

The discussion might have continued from here.