OpenWrt Forum Archive

Topic: Possible bug in switch driver Atheros AR8316 please help

The content of this topic has been archived on 30 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hello, i have a Buffalo WBMR-HP-G300H with actual trunk.

It isn´t possible to make traffic between lan Ports.

https://dev.openwrt.org/ticket/11143

If i configure the switch in /etc/config/network

config switch
  option name 'switch0'
  option reset '1'
  option enable_vlan '1'

config switch_vlan
  option device 'switch0'
  option vlan '1'
  option ports '0 1 2 3 4 5'

after reboot, the switch is unusable.
I mean it isn´t possible to connect my pc to the switch. No DCHP, no Internet..... the switch is death.


Would someone please look at the driver code so that I can use the switch?

Hi,

Are you able to post dmesg output? It might be useful. I wonder if this is adding a port which shouldn't be.

I would suggest changing:

option ports '0 1 2 3 4 5'

to:

option ports '0 1 2 3 5'

or:

option ports '0 1 2 3 4'

and retrying. If that doesn't work, try removing others singly and then doubly etc and see which ones can talk to each other, if any. Don't know if it will help, but it's worth a try....

Ash

Hi, thanks for your help but I sent the router back.
Not only that I could not use the switch, the router has established connection to the Internet is no longer connected.
DSL sync was ok, there was no connect.

(Last edited by darkwin on 8 May 2012, 18:49)

ash87 I have the same router, soon enough I'll put openwrt in it (have ddwrt running at the moment) and try what you said

nass, if you have dd-wrt running still, maybe you could find some of vlan settings there and see how they differ from the above? I've never used dd-wrt, so I don't know if there is a similar config option somewhere?

(Last edited by ash87 on 9 May 2012, 23:12)

ok will do, probably will find some time over the weekend

Awesome. It might be wise to make sure you set up wireless access as darkwin's posts suggest that getting the vlan wrong disables wired access somehow. Do you have a serial connection to it or anything, just in case? big_smile

no unfortunately not yet, but I have ordered a usb -to- UART adaptor, should arrive in a few days

Hi, despite the switch config it was always possible to connect the router via wireless.

yes that is very help full indeed:)

Hi,
I'm planning to buy this modem and use it whith openwrt, but only if I can make traffic between lan ports.
what is the state of this request and https://dev.openwrt.org/ticket/11143 ?

hello everyone, sorry it tool me so long to reply
I was not familiar with dd-wrt so i spent sometime trying to understand it.

here is the relevant post it ddwrt forum..

to sum up, trying to configure theswitch does not brick the wired access to the router, but it doesn't do what i want either.
it appears the switch configuration is never 'downloaded' to the switch itself to change it. bummer.

I also have problems connecting to the internet (PPPoE, annex A) but thats another problem... in the meantime, i do have a serial connection so if you guys have any clever thought, we can work it out probably.
also for the time being, i'll avoid switching to openwrt since i don't have a way to go back to ddwrt, should things not work...
of course if its as easy as copying the firmware using mtd or smth, i'm more than willing to try it...:)

Hi, you can bring your router back to ddwrt with mtd.
but you will not want to, because openwrt is simply great

Sorry to re-answear but: is the traffic between lan ports works now on openwrt ?

sachaz wrote:

Hi,
I'm planning to buy this modem and use it whith openwrt, but only if I can make traffic between lan ports.
what is the state of this request and https://dev.openwrt.org/ticket/11143 ?

I have yet heard of anyone who says that it works

Build r32336

and it doesn't work. Today I flashed from ddwrt 18024 (lan worked) to this build.

What could it be?

The discussion might have continued from here.