OpenWrt Forum Archive

Topic: TP-Link TL-WDR4310 v1.0 First Steps

The content of this topic has been archived between 1 Oct 2014 and 4 May 2018. Unfortunately there are posts – most likely complete pages – missing.

Thank you for your answer slh. I guess I'll put it on then.

slh wrote:
rviktor wrote:

2. Is the trunk version somewhat okay for everyday usage with this model? (meaning is it somewhat stable and is the switch working correctly?)

Talking about the TL-WDR4300 v1.1, yes perfectly. Ethernet, switch and wlan are fully functional - EEPROM regdomain is US.

maurer wrote:

! noob warning ! - no web gui and wifi off by default !

The same as with all prebuilt trunk images, you can download/install LuCI (or build an image including it), install kmod-ath9k and configure your wlan.

Hi slh,

I have built my own image, did you just install it from the firmware upload page on the original firmware?

thanks

Yes, you can flash openwrt-ar71xx-generic-tl-wdr4300-v1-squashfs-factory.bin directly from the upgrade page of the original firmware.

Any improvements in range/performance over stock?

slh wrote:

Yes, you can flash openwrt-ar71xx-generic-tl-wdr4300-v1-squashfs-factory.bin directly from the upgrade page of the original firmware.

Hi slh,

How many average upload and download speeds of route's USB Hard Drives?

Thanks

Hello!
Damaged U-boot on 4310.
Big request, ??nm at whom - that is possibility to remove dump fullflash with S25FL064KIF?
I will look for restoration options through Jtag or directly to alter flash))))

How to you flash the router, is it through the TP-Link Factory config page or via serial tftp?
Edit - Sorry didn't read will try it now.

(Last edited by alphasparc on 27 Jun 2012, 11:13)

Could someone please tell me if trunk works for WDR4300 (or just WDR4310) and how much gbit lan throughput is on this router as it seems quite cpu heavy? (with iperf or smb or ftp)

I mean from PC to Router or Router to PC, not just routed PC to PC. (to use as a NAS with a USB HDD)

I did the openssl benchmark and updated the wiki pages.
Trunk works fine.

(Last edited by alphasparc on 27 Jun 2012, 15:13)

Hi all,
Because i accidentally erased TP-Link TL-WDR4310 whole flash, so i need whole flash file, please somebody can share it? , and i also want TP-Link TL-WDR4300 whole flash.
thanks

(Last edited by astralstorm on 27 Jun 2012, 20:33)

Hi, anyone know how to put this router into Simultaneous Dual Band Mode?
I can put it into 2.4GHZ Mode and 5GHZ Mode but not Simultaneous Dual Band Mode
Also during testing the NATing Performance took a real beating.
Original firmware was able to almost hit gigabit routing speeds but OpenWRT only managed 30% of Gigabit speeds.
I am quite sure it is due to the missing hardware NATing in OpenWRT, anyway to fix it?

My personal builds and other files for the WDR4310 V1.0 are available (for a limited time) on my pathetically weak and slow Seagate GoFlex Net server.
E-Mail or PM for the link.

(Last edited by ldpinney on 5 Jul 2012, 09:34)

My primary concern with my own build is if I screwed something up is it easy enough to restore a working build, whether it be stock or openwrt?

When I configure one wlan with 2,4ghz and another with 5ghz... is openwrt able to choose the right atheros chips for each wlan? Maybe it doesn´t recognize both of them correctly...

alphasparc/ vanhaakonnen, you configure radio0 and radio1 individually - you can use the same SSID/ passphrase or use individual ones for each band. LuCI is smart enough to only offer you the frequencies actually supported by the wlan cards.

alphasparc wrote:

Anyone able to bring HWAccel into OpenWRT?

hwaccel......Is in the TP-Link Source Code... how it gets into OpenWrt....dunno

With the newest trunk-version I have a problem installing a module:

root@OpenWrt:~# opkg  install kmod-usb-serial-ftdi
Installing kmod-usb-serial-ftdi (3.3.8-1) to root...
Downloading http://downloads.openwrt.org/snapshots/ … ar71xx.ipk.
Collected errors:
* satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-serial-ftdi:
*     kernel (= 3.3.8-1-4ddea9f0072cefba7ba289ba2b5fa12f) *     kernel (= 3.3.8-1-4ddea9f0072cefba7ba289ba2b5fa12f) *
* opkg_install_cmd: Cannot install package kmod-usb-serial-ftdi.

Has anyone a idea how to fix this?

(Last edited by vanhaakonnen on 30 Jun 2012, 13:59)

vanhaakonnen wrote:

Has anyone a idea how to fix this?

yes, reinstall latest trunk and then install any kmod package you want.
or just force install it with "--force-depends"

Reinstallation worked fine for me - thanks! smile

Does anybody know how vlan tagging with the 4310 is working?
I tried to let all four lan ports in the default configuration without vlan tagging. Then I wanted to use the default WAN Interface with an IP in VLAN10 with vlan tagging. I tried to configure it but it doesn´t work.... How must I set the configuration?

http://home.haake24.net/public/openwrt.jpg

(Last edited by vanhaakonnen on 3 Jul 2012, 22:49)

If you didn't overwrite the bootloader, try method 2 of this: http://wiki.openwrt.org/doc/howto/generic.flashing .
If you succeed in getting back openwrt, DON'T try to flash the 4300 firmware to the 4310, the fw's have differences.

If you overwrote the bootloader you most likely have to burn the flash by desoldering and using a burner that works with the Spansion FL064KIF.

OR you might use your warranty, if you have. (just don't mention what you did)

(Last edited by rviktor on 11 Jul 2012, 23:18)

The TL-WDR4310 v1.0 should be supported since today's trunk/ r32683. The autobuilders will probably start generating the according openwrt-ar71xx-generic-tl-wdr4310-v1-squashfs-factory.bin images within the next few days, which can be flashed directly from the vendor's firmware upgrade pages.

Thanks for the patch slh and Thanks for the Wiki update too....

(Last edited by ldpinney on 12 Jul 2012, 22:33)