OpenWrt Forum Archive

Topic: Config for Telekom Entertain IP (Tripleplay) with TP-Link 1043ND?

The content of this topic has been archived on 18 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hello guys,

I'm very down because all my trys to get the 1043ND router working with my VDSL connection failed. I'm searched through this forums and other tutorials (http://www.computerhilfen.de/hilfen-22-389919-0.html and http://www.projectiwear.org/~plasmahh/t_home.html and http://eko.one.pl/forum/viewtopic.php?id=3400).

I want to get my VoIP and IPTV working. Normal internet is working fine (VLAN ID 7). So I'm asking if someone can post his config for the Telekom Entertain Comfort IP connection, that I have a working base that I can modify.

It's annoying, because I'm running out of ideas what I can try next.

Thank you!

Here same problem with Buffalo WZR-HP-AG300H

I've found this page: http://rpc.one.pl/index.php/lista-artyk … od-openwrt
It's in Polish, but it's very good understandable. There are some examples how to configure the VLANs. So I will try this next and can report or probably post a working config next weekend.

EDIT: Example 4 could be interesting. It's the same configuration just with a third vlan @ wan. So if this works it should be no problem to get a working base.

(Last edited by DerUltrazauberer on 16 May 2012, 16:07)

Ok, I've got it! Here's a minimalistic config of the German Telekom Entertain IPTV. Internet and IPTV is running fine. I've just followed the Polish tutorial with example 4!

First the working /etc/config/network

config 'interface' 'loopback'
 option 'ifname'   'lo'
 option 'proto'    'static'
 option 'ipaddr'   '127.0.0.1'
 option 'netmask'  '255.0.0.0'

config 'interface' 'lan'
 option 'ifname'   'eth0.2'
 option 'type'     'bridge'
 option 'proto'    'static'
 option 'ipaddr'   '192.168.1.1'
 option 'netmask'  '255.255.255.0'

config 'interface' 'wan'
 option 'ifname' 'eth0.7'
 option proto 'pppoe'
 option username 'xxxxxxxxxxxxxxxxxxxxxxxx#001@t-online.de'
 option password 'mypassword'

config 'interface' 'vlan8'
 option 'ifname' 'eth0.8'
 option 'proto' 'dhcp'
 option 'metric' '10'

config 'switch'
 option 'name' 'rtl8366rb'
 option 'reset' '1'
 option 'enable_vlan' '1'

config 'switch_vlan'
 option 'device' 'rtl8366rb'
 option 'vlan' '8'
 option 'ports' '0t 4 5t'

config 'switch_vlan'
 option 'device' 'rtl8366rb'
 option 'vlan' '7'
 option 'ports' '0t 5t'

config 'switch_vlan'
 option 'device' 'rtl8366rb'
 option 'vlan' '2'
 option 'ports' '1 2 3 5t'

Second the working /etc/config/dhcp

config dnsmasq
        option domainneeded     1
        option boguspriv        1
        option filterwin2k      0  # enable for dial on demand
        option localise_queries 1
        option rebind_protection 1  # disable if upstream must serve RFC1918 addresses
        option rebind_localhost 1  # enable for RBL checking and similar services
        #list rebind_domain example.lan  # whitelist RFC1918 responses for domains
        option local    '/lan/'
        option domain   'lan'
        option expandhosts      1
        option nonegcache       0
        option authoritative    1
        option readethers       1
        option leasefile        '/tmp/dhcp.leases'
        option resolvfile       '/tmp/resolv.conf.auto'
        #list server            '/mycompany.local/1.2.3.4'
        #option nonwildcard     1
        #list interface         br-lan
        #list notinterface      lo
        #list bogusnxdomain     '64.94.110.11'

config dhcp lan
        option interface        lan
        option start    100
        option limit    150
        option leasetime        12h

config dhcp wan
        option interface        wan
        option ignore   1

config dhcp vlan8
        option interface        vlan8
        option ignore   1

That are the only files I modified. Nothing else and it's running fine! :-) No static routes, no firewall configurations. Please report back, if it is working for you (especially Lubomir)!

EDIT: I forgot to write, that I've seperated the IPTV receiver to port 4 on the switch.

(Last edited by DerUltrazauberer on 19 May 2012, 15:16)

Ok, one additional information:
I've changed my router to the new 1043ND and don't switched off the media receiver (MR). So it seems that the MR still had some configurations from the old router.
Because today some channels won't working and I did a hard reset of the MR. And now the MR doesn't start: hanging on the waiting screen...

If I plug the MR in a different port (1-3) the MR will start and get a proper time. Plugging it back to port 4 will not work (I think it has something to do with the IP release of the MR). In port 4 the MR will get an IP directly of the DHCP server from the ISP (217.250.xx.xx/18). So I still testing and hope to get the MR work!

Okay, another hint for all:

First I have connect the MR to another switchport (1-3). After that booting the MR and let it load the program guide and the correct time. After that you shut down the MR, then connect it to switchport 4 again and reboot the router.

After all switch on the MR (from standby - correct time should be displayed)... after this procedure I'm able to watch all tv-programs.

Now is the question, how to get the normal internet-traffic to switchport 4 and and the iptv traffic from vlan8.

Any ideas how to do that?

Okay, I've got it. Just follow the tutorial at http://www.computerhilfen.de/hilfen-22-389919-0.html. Then be careful at the igmpproxy.conf and firewall!

I had to comment out the network (altnet section) in the igmpproxy.conf which contains the mediareceiver. And second in the firewall config I had to add forwarding rules that the traffic from wan and vlan8 are reachable from the mediareceiver-network. That's all! If someone needs the complete config, I can post it here. Now my mediareceiver is seperated at port 4 and all is working fine. ;-)

Please post the completete config! 

Best regards,
lnn100

Okay, here are the important files:

/etc/config/dhcp

config dnsmasq
    option domainneeded '1'
    option boguspriv '1'
    option localise_queries '1'
    option rebind_protection '1'
    option rebind_localhost '1'
    option local '/lan/'
    option domain 'lan'
    option expandhosts '1'
    option authoritative '1'
    option readethers '1'
    option leasefile '/tmp/dhcp.leases'
    option resolvfile '/tmp/resolv.conf.auto'

config dhcp 'lan'
    option interface 'lan'
    option start '100'
    option limit '150'
    option leasetime '12h'

config dhcp 'iptv'
    option interface 'iptv'
    option start '10'
    option limit '20'
    option leasetime '12h'

config dhcp 'wan'
    option interface 'wan'
    option ignore '1'

config dhcp 'vlan8'
    option interface 'vlan8'
    option ignore '1'

/etc/config/firewall

config defaults
    option syn_flood '1'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'REJECT'

config zone
    option name 'lan'
    option network 'lan'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'REJECT'

config zone
    option name 'wan'
    option network 'wan'
    option input 'REJECT'
    option output 'ACCEPT'
    option forward 'REJECT'
    option masq '1'
    option mtu_fix '1'

config forwarding
    option src 'lan'
    option dest 'wan'

config rule
    option name 'Allow-DHCP-Renew'
    option src 'wan'
    option proto 'udp'
    option dest_port '68'
    option target 'ACCEPT'
    option family 'ipv4'

config rule
    option name 'Allow-Ping'
    option src 'wan'
    option proto 'icmp'
    option icmp_type 'echo-request'
    option family 'ipv4'
    option target 'ACCEPT'

config rule
    option name 'Allow-DHCPv6'
    option src 'wan'
    option proto 'udp'
    option src_ip 'fe80::/10'
    option src_port '547'
    option dest_ip 'fe80::/10'
    option dest_port '546'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-ICMPv6-Input'
    option src 'wan'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    list icmp_type 'router-solicitation'
    list icmp_type 'neighbour-solicitation'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-ICMPv6-Forward'
    option src 'wan'
    option dest '*'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

config include
    option path '/etc/firewall.user'

config zone
    option name 'vlan8'
    option network 'vlan8'
    option input 'REJECT'
    option output 'ACCEPT'
    option forward 'REJECT'
    option masq '1'
    option log '1'

config rule
    option name 'Allow-DHCP-Renew-vlan8'
    option src 'vlan8'
    option proto 'udp'
    option dest_port '68'
    option target 'ACCEPT'
    option family 'ipv4'

config rule
    option name 'Allow-Ping-vlan8'
    option src 'vlan8'
    option proto 'icmp'
    option icmp_type 'echo-request'
    option family 'ipv4'
    option target 'ACCEPT'

config rule
    option name 'Allow-DHCPv6-vlan8'
    option src 'vlan8'
    option proto 'udp'
    option src_ip 'fe80::/10'
    option src_port '547'
    option dest_ip 'fe80::/10'
    option dest_port '546'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option src 'vlan8'
    option proto 'igmp'
    option target 'ACCEPT'

config rule
    option src 'vlan8'
    option proto 'udp'
    option dest 'iptv'
    option dest_ip '224.0.0.0/4'
    option target 'ACCEPT'

config zone
    option name 'iptv'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'REJECT'

config forwarding
    option src 'iptv'
    option dest 'wan'

config forwarding
    option src 'iptv'
    option dest 'vlan8'

/etc/config/network

config 'interface' 'loopback'
 option 'ifname'   'lo'
 option 'proto'    'static'
 option 'ipaddr'   '127.0.0.1'
 option 'netmask'  '255.0.0.0'

config 'interface' 'lan'
 option 'ifname'   'eth0.2'
 option 'type'     'bridge'
 option 'proto'    'static'
 option 'ipaddr'   '192.168.1.1'
 option 'netmask'  '255.255.255.0'

config 'interface' 'iptv'
 option 'ifname'   'eth0.1'
 option 'type'     'bridge'
 option 'proto'    'static'
 option 'ipaddr'   '192.168.0.1'
 option 'netmask'  '255.255.255.0'

config 'interface' 'wan'
 option 'ifname' 'eth0.7'
 option proto 'pppoe'
 option username 'login@t-online.de'
 option password 'password'

config 'interface' 'vlan8'
 option 'ifname' 'eth0.8'
 option 'proto' 'dhcp'
 option 'metric' '10'

config 'switch'
 option 'name' 'rtl8366rb'
 option 'reset' '1'
 option 'enable_vlan' '1'

config 'switch_vlan'
 option 'device' 'rtl8366rb'
 option 'vlan' '8'
 option 'ports' '0t 5t'

config 'switch_vlan'
 option 'device' 'rtl8366rb'
 option 'vlan' '7'
 option 'ports' '0t 5t'

config 'switch_vlan'
 option 'device' 'rtl8366rb'
 option 'vlan' '2'
 option 'ports' '1 2 3 5t'

config 'switch_vlan'
 option 'device' 'rtl8366rb'
 option 'vlan' '1'
 option 'ports' '4 5t'

/etc/igmpproxy.conf

quickleave

############################################
### Telekom Entertain Multicast networks ###
############################################

phyint eth0.8 upstream ratelimit 0 threshold 1
    altnet 217.0.119.0/24
    altnet 193.158.35.0/24

################################
### Wohin soll der Multicast ###
################################

phyint eth0.1 downstream ratelimit 0 threshold 1

phyint br-lan disabled
phyint pppoe-wan disabled
phyint lo disabled

I hope this will help you... Let me know, if you got it!

Hi,

got my T-Home Entertain IPTV finally running with the config-files from Post #9.
Even "LIGAtotal!" and "TV-Archiv" are working.

Konfiguration:
1043nd with OpenWrt behind a normal ppoe modem with a 16k DSL connection.

I tried the "computerhilfen" tutorial before, but it didn't work for me.

Thank you very much DerUltrazauberer.

For all of you guys out there who get here from searching on the web like me.
It is working. Don't give up!

MfG,
n-p-k

The discussion might have continued from here.