OpenWrt Forum Archive

Topic: Can't flash TP-Link WR2543ND with the latest official firmware

The content of this topic has been archived on 19 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hi
My TL-WR2543ND has 3.13.17 (120509) firmware
When I try upgrade with openwrt it says: "Error code: 18005 Upgrade unsuccessfully because the version of the upgraded file was incorrect. Please check the file name."
I already tried download latest trunk and rename it to "wr2543nv1_en_3_13_17_up(120509).bin", but it didnt help.

Same problem here I rename the file as suggested in other threads but I can't upgrade any help will be appreciated

i'm afraid they changed something in the "file check", because there is this strange note:

TL-WR2543ND_v1_120509

Note:    With this version installed, firmware earlier than 3.13.12 won't be accepted any longer.

does not seems to me like a "simple" file name check!

Same problem here. I am really stupid because I just updated the original firmware out of boredom to see how it would look like. Now it kind of bricked my router  for openWRT -.-

It seems there is no fix , hope it will be fixed

My problem did not fix yet.
In my situation, when a specific computer connect to the router, the router will disconnect another one computer from network and cannot connect again. the two computers seems are mutually exclusive if use this router.
is anyone get this problem?

(Last edited by mason1234 on 18 May 2012, 07:09)

I just called the TP-Link support line and filed the bug. The guy on the phone told me that he would contact the development team as soon as possible to get out a new firmware. He promised to mail me next Thursday about their progress.
That seems like a better fix than soldering on some serial pins.

Maybe there are real reasons, that older firmwares are incompatible? Like different sizes of flash memory parts, changes in uboot or whatever.
Now would be interesting to know if current openwrt firmware image can be safely flashed over recent factory firmware.

I'm guessing they added some type of validation of the firmware upgrade image so until we know what that does we won't be able to install OpenWRT using the web interface and it would also explain why previous versions of the firmware cannot be flashed either.

I can see version number in factory firmware as 6 bytes at offset 99h. Maybe this is used for validation of firmware.

I found solution!
Flash Chinese firmware (warning, menu will be in Chinese language ) and then flash openwrt.

(Last edited by SPX on 19 May 2012, 19:28)

SPX wrote:

I found solution!
Flash Chinese firmware (warning, menu will be in Chinese language ) and then flash openwrt.

Thanks a lot it works as charm

Dear SPX
After trying openwrt vs original firmare the tp-link is better far than openwrt the menus are straight forward the Usb sharing is more advance.
the original tp-link firmare  is more stable for me so I revert it back waiting for a good firmware for TP-Link WR2543ND
Regards

I'm using openvrt r30919 on my 2543, plus additions like luci, ftp server, http server, wol and some other programs installed on USB pendrive. Uptime is showing 43 days, so I assume it can be called stable wink

it seems no one got the same problem as mine...is my router hardware problem@@?

mason1234 wrote:

it seems no one got the same problem as mine...is my router hardware problem@@?

Would need more details to find a fix.
Do you mean on wireless or over Ethernet?

Hi Guys.... i run into a problem

i have downloaded openwrt firmware from here:
http://wiki.openwrt.org/toh/tp-link/tl-wr2543nd
and uploaded this:
http://downloads.openwrt.org/snapshots/ … actory.bin

after reboot i was suprised there was no web gui avaliable b/c i wanted also to upload sys upgrade version:
http://downloads.openwrt.org/snapshots/ … pgrade.bin

from i have read i need to do this in 2 steps...

but without a gui i was unable to do anything...

so i downloaded latest firmware from tp link and followied 1st instruction from here:
http://wiki.openwrt.org/doc/howto/generic.uninstall

since i was unable to access web ( i got 2 routers, and after installing openwrt tplink did not switch to other subnet automatically, and my secound router don't have this option)
i installed xamp (apache server) and placed original firmware on it
and did this:

cd /tmp
wget http://192.168.1.154/original.bin
mtd -r write /tmp/original.bin firmware

so it was writing, then rebooting and now it's seems its dead....
any ideas?

i used static ip on my pc to try ssh on both 192.168.0.1 and 192.168.1.1 but it does not work

any ideas?

What you need to do to get OpenWrt working on the TP-Link WR2543ND:

1) download the two .bin files from http://wiki.openwrt.org/toh/tp-link/tl-wr2543nd
2) firmware upgrade using the TP-Link interface to the factory.bin
3) telnet 192.168.1.1 to set a password (using the 'passwd' command)
4) opkg update; opkg install luci; /etc/init.d/uhttpd enable; /etc/init.d/uhttpd start
5) browse to 192.168.1.1 and login with your freshly set password
6) goto firmware upgrade and select the sysupgrade.bin file
7) repeat steps 3 - 5, and now you're done!
8) i suggest installing the bootstrap theme for luci

I took me a few hours but this is how to get OpenWrt running nice and well. Without the sysupgrade.bin I was unable to install a lot of extra packages with opkg, but now most things work. I still can't access the nvram, but most things are working now. Hope this helps!

(Last edited by hylkepylke on 23 Aug 2012, 09:50)

hi there, i just got a set of TP-Link TL-WR2543ND, and i have set up everything... but my laptop and some others cannot exces the net through wifi..
the problem that will surface at the wifi system is : Validating Identitiy?

I can't find the certification for these laptops to recognize this Wifi router....?

How do i solve this problem..?

Please help...

Hi,
Does anybody know how can I boot my WR2543ND in failsafe mode? Which button should I press and when?
Thanks in advance

(Last edited by gesa07 on 24 Sep 2012, 06:38)

The discussion might have continued from here.