OpenWrt Forum Archive

Topic: MR3020 bricked?

The content of this topic has been archived on 17 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hi all,

after having problems with my OpenWrt installation i decided to reflash the .bin on my TP-Link TL-MR3020. Unfortunately the device does not boot up anymore. So I tried to enter fail safe mode described in the wiki, but it looks like there is no chance to get the device telnetable or even pingable...

So I tried to connect to the device using a serial connection - in HTerm i can see this output:

U-Boot 1.1.4 (Nov 28 2011 - 09:34:00)

AP121 (ar9330) U-boot

DRAM:  32 MB
led turning on for 1s...
id read 0x100000ff
flash size 4194304, sector count = 64
Flash:  4 MB
Using default environment

In:    serial
Out:   serial
Err:   serial
Net:   ag7240_enet_initialize...
No valid address in Flash. Using fixed address
No valid address in Flash. Using fixed address
: cfg1 0x5 cfg2 0x7114
eth0: 00:03:7f:09:0b:ad
eth0 up
: cfg1 0xf cfg2 0x7214
eth1: 00:03:7f:09:0b:ad
ATHRS26: resetting s26
ATHRS26: s26 reset done
eth1 up
eth0, eth1
Autobooting in 1 seconds
## Booting image at 9f020000 ...
   Uncompressing Kernel Image ... Too big uncompressed streamLZMA ERROR 1 - must RESET

After this output the device resets and sends the same messages again. So I tried to access the bootloader using "tpl" command - works. I get the "hornet>" command line. As described in the wiki I tried to reinstall the image using tftpboot, but it does not work... looks like the wan port is not active. Since I was able to connect and load a file through tftp unsing my android phone, I assume the server is up successfully.

Output of printenv (after booting and entereing tpl): 

bootargs=console=ttyS0,115200 root=31:02 rootfstype=squashfs init=/sbin/init mtdparts=ar7240-nor0:256k(u-boot),64k(u-boot-env),2752k(rootfs),896k(uImage),64k(NVRAM),64k(ART)
bootcmd=bootm 0x9f020000

Environment size: 362/65532 bytes

Is there any hope to recover this device? Probably it's possible to write to the flash directly by HTerm?


I have the same situation after restore an original firmware. After power on, device blinks wifi-led(?) one time and nothing more. Any ideas?


I recovered my device! Obviously a firewall blocked access on my notebooks lan port... after deactivating and reactivating lan interface in control panel a firewall message poped up.

For this process I used following software:
OpenTFTPServer (you don't need the service, just execute RunStandAloneMT.bat and copy the firmware .bin into the same directory. The batch file shows what interfaces are listened on and what devices try to access the tftp server)
HTerm (Serial Terminal)

@loco2k: Can you access the serial port? Try to watch the boot process on HTerm, it will answer a lot of questions smile


The discussion might have continued from here.