OpenWrt Forum Archive

Topic: Luci incorrectly showing "Wireless is disabled or not associated"

The content of this topic has been archived on 28 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hello,

I'm running Attitude Adjustment r32573 on a WNDR3700v1. I've noticed that in more recent builds (say, within the last month or so), something doesn't seem to work in Luci on the overview and edit pages for wireless. The status that normally shows under the bitrate always says "Wireless is disabled or not associated" even if everything is working fine. If I go to edit the settings, in Device configuration it says the same thing there in status, yet the button correctly says "disable", not "enable". On the other hand, if I click on the Wireless tab, and look at the overview, it both says the wireless is disabled, and the button incorrectly says "enable". Right next to the disabled message on the overview pages, I see the signal strength graphics and numbers working fine/live.

So basically, much of the user interface is incorrectly showing that the wireless radios are disabled, when in reality they are enabled and functioning properly. Is it obvious to anyone if this is something in my configuration vs. a bug in Luci/OpenWRT somewhere?

My wireless config is:

config wifi-device 'radio0'
    option type 'mac80211'
    option macaddr '[redacted]'
    list ht_capab 'SHORT-GI-40'
    list ht_capab 'TX-STBC'
    list ht_capab 'RX-STBC1'
    list ht_capab 'DSSS_CCK-40'
    option txpower '20'
    option country 'US'
    option hwmode '11ng'
    option channel 'auto'
    option htmode 'HT20'

config wifi-device 'radio1'
    option type 'mac80211'
    option macaddr '[redacted]'
    list ht_capab 'SHORT-GI-40'
    list ht_capab 'TX-STBC'
    list ht_capab 'RX-STBC1'
    list ht_capab 'DSSS_CCK-40'
    option txpower '17'
    option country 'US'
    option hwmode '11na'
    option channel 'auto'
    option htmode 'HT40+'

config wifi-iface
    option device 'radio0'
    option mode 'ap'
    option ssid '[redacted]'
    option network 'guest'
    option key '[redacted]'
    option encryption 'psk2+ccmp'

config wifi-iface
    option device 'radio1'
    option mode 'ap'
    option ssid '[redacted]'
    option network 'guest'
    option encryption 'psk2+ccmp'
    option key '[redacted]'


Thanks,

B

opkg update; opkg install iwinfo

iwinfo wlan0 info

wlan0     ESSID: "[redacted]"
          Access Point: [redacted]
          Mode: Master  Channel: unknown (unknown)
          Tx-Power: 20 dBm  Link Quality: 56/70
          Signal: -54 dBm  Noise: -95 dBm
          Bit Rate: 65.0 MBit/s
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11bgn
          Hardware: 168C:0029 168C:A095 [Atheros AR9223]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes

wlan1     ESSID: "[redacted]"
          Access Point: [redacted]
          Mode: Master  Channel: unknown (unknown)
          Tx-Power: 17 dBm  Link Quality: 40/70
          Signal: -70 dBm  Noise: -95 dBm
          Bit Rate: 120.0 MBit/s
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11an
          Hardware: 168C:0029 168C:A094 [Atheros AR9220]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes

Hi,

I have the same problem with OpenWrt Attitude Adjustment r32587.

The problem occurs when Channel is set to "Auto" in Lucy. If you set channel to a value (1, 2, ...) it works fine. I installed OpenWRT on my TL-WR842ND yesterday (WOW, my first time with OpenWRT and I'm really happy with it). Then I changed the channel to Auto...

In both cases, iwinfo wlan0 info gives:

wlan0     ESSID: "[redacted]"
          Access Point: [redacted]
          Mode: Master  Channel: unknown (unknown)
          Tx-Power: 20 dBm  Link Quality: 0/70
          Signal: unknown  Noise: -95 dBm
          Bit Rate: unknown
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11bgn
          Hardware: 168C:002E 168C:A199 [Generic MAC80211]
          TX power offset: unknown
          Frequency offset: unknown
          Supports VAPs: yes

When associated, with channel value set:

wlan0     ESSID: "[redacted]"
          Access Point: [redacted]
          Mode: Master  Channel: unknown (unknown)
          Tx-Power: 20 dBm  Link Quality: 39/70
          Signal: -71 dBm  Noise: -95 dBm
          Bit Rate: 1.0 MBit/s
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11bgn
          Hardware: 168C:002E 168C:A199 [Generic MAC80211]
          TX power offset: unknown
          Frequency offset: unknown
          Supports VAPs: yes

Don't worry about the bad link quality as it's an old house with thick walls.

Hope that can help,
Thanks you for your great job,
Regards

Hello again,

Setting the channels explicitly corrects most of the problem. I set mine to 1/36 for the two radios. The channel still comes back as "Channel: unknown (unknown)" with the iwinfo wlan0 and wlan1 info. I'm guessing that's why Luci also shows: Channel: 1 (0.000 GHz) and Channel: 36 (0.000 GHz)?

B

If I remember correctly, this also happens if you set it to channel 2.  Other channels seem to show the correct frequency out beside channel.  I will check when I can and see for sure if this is true...

Hmm, I was wrong.  It is all channels.

It is just a UI thing.   If it says unassociated if ya change channel and re-apply.  It should associate again.

(Last edited by slippyC on 6 Jul 2012, 01:02)

Is there any way to tell which trunk version is in a particular snapshot on the downloads site w/o downloading and installing? Like buildbot logs somewhere?

Look at the base-files package filename in the packages/ subfolder.

Basker wrote:

Is there any way to tell which trunk version is in a particular snapshot on the downloads site w/o downloading and installing? Like buildbot logs somewhere?

Excerpt from wiki:

baseurl=http://downloads.openwrt.org/snapshots/trunk/
platform=ar71xx
wget -S $baseurl$platform/packages/Packages.gz
r=$(zgrep base-files_ Packages.gz | sed -e 's/^.*-r\(.*\)_ar71xx.ipk/\1/')
echo $r

One thing missing from that command was specifying an output file:

baseurl=http://downloads.openwrt.org/snapshots/trunk/
platform=ar71xx
wget -S $baseurl$platform/packages/Packages.gz -O Packages.gz
r=$(zgrep base-files_ Packages.gz | sed -e 's/^.*-r\(.*\)_ar71xx.ipk/\1/')
echo $r

For some reason w/o the -O Packages.gz, it didn't update the file when I ran it more than once.

Also, FYI to anyone who might find it useful. I use this to get and build using the latest 32 or 64 bit image builder:

#!/bin/sh

echo "Clean up existing ImageBuilder files."
rm -rf ./Open*

IBPKG32="OpenWrt-ImageBuilder-ar71xx_generic-for-Linux-i686"
IBPKG64="OpenWrt-ImageBuilder-ar71xx_generic-for-Linux-x86_64"

echo "Retrieving latest OpenWRT image builder."
wget http://downloads.openwrt.org/snapshots/trunk/ar71xx/$IBPKG32.tar.bz2 && IBPKG=$IBPKG32
wget http://downloads.openwrt.org/snapshots/trunk/ar71xx/$IBPKG64.tar.bz2 && IBPKG=$IBPKG64

echo "BUnZip2 ImageBuilder files."
bunzip2 $IBPKG.tar.bz2

echo "DeTar ImageBuilder files."
tar -xvf $IBPKG.tar

echo "Place build script."
cp build.sh $IBPKG

# echo "Build AR71xx images."
cd $IBPKG && ./build.sh

On Ubuntu 12.04 with ia32 libs, everything builds fine. Also, I put my customization in build.sh and just copy in each time.

As of the the latest build, I can confirm that the issue with Luci / wireless info in general is fixed, and everything looks good.

B

Basker wrote:

One thing missing from that command was specifying an output file:

baseurl=http://downloads.openwrt.org/snapshots/trunk/
platform=ar71xx
wget -S $baseurl$platform/packages/Packages.gz -O Packages.gz
r=$(zgrep base-files_ Packages.gz | sed -e 's/^.*-r\(.*\)_ar71xx.ipk/\1/')
echo $r

For some reason w/o the -O Packages.gz, it didn't update the file when I ran it more than once.

Instead of download it unconditionally you may mean use timestamping:

baseurl=http://downloads.openwrt.org/snapshots/trunk/
platform=ar71xx
wget -N $baseurl$platform/packages/Packages.gz
r=$(zgrep base-files_ Packages.gz | sed -e 's/^.*-r\(.*\)_ar71xx.ipk/\1/')
echo $r

So you may ran it more than once, but download only once, and download again only when file date changes.

FYI I just installed current AA snapshot (CR1) and it is working fine with setting channel to auto. It shows up on channel 1 ATM. I don't know if it is going to ever change but at least wireless connections are working.

This topic is already old but I realized to have this problem on my WNDR3700v2 with AA 12.09 installing today. The overview page doesn't give me connected stations, switching to Network -> WiFi i get all stations connected.

avalon - does it still work on your device with 12.09?

Any idea how to fix this or will it be fixed?

Hi,
I use OpenWrt Barrier Breaker r38990 and I have the same problem.
My network work well, no problem. I just have this message "Wireless is disabled or not associated" on Luci web interface.
I just want to know if is a solution for that.
Thanks!

marighiz wrote:

Hi,
I use OpenWrt Barrier Breaker r38990 and I have the same problem.
My network work well, no problem. I just have this message "Wireless is disabled or not associated" on Luci web interface.
I just want to know if is a solution for that.
Thanks!

Luci fixes done on Dec 3 (one day after your build) may have already fixed that.
https://dev.openwrt.org/ticket/14562#comment:6
Check with the current build...

(Last edited by hnyman on 9 Dec 2013, 23:54)

Hi, the problem still exists.
Im using OpenWrt Barrier Breaker r39945 on ASUS RT-N10+ C1

iwinfo radio0 info:

radio0    ESSID: unknown
          Access Point: 00:00:00:00:00:00
          Mode: Unknown  Channel: unknown (unknown)
          Tx-Power: unknown  Link Quality: unknown/70
          Signal: unknown  Noise: unknown
          Bit Rate: unknown
          Encryption: unknown
          Type: nl80211  HW Mode(s): 802.11bgn
          Hardware: unknown [Generic MAC80211]
          TX power offset: unknown
          Frequency offset: unknown
          Supports VAPs: yes  PHY name: phy0

WiFi is not working. Luci says "Wireless is disabled or not associated"

How do I fix that?

Thanks

ramips doesn't compile since long time ago, so nobody know for sure if currently bugged or not.
From your input, r39945 looks bugged, but this bug appears last week in others platforms and then corrected in latest trunk.
There are no "latest trunk" for us, because of bug https://dev.openwrt.org/ticket/15382
We must wait longer.

Ok, there are a new trunk to test.
Please test with "latest trunk" wink

The discussion might have continued from here.