OpenWrt Forum Archive

Topic: WA901ND how to configure it as 'Repeater' mode using Luci?

The content of this topic has been archived on 7 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

I managed to flash openwrt and set it up as access point following dumbap guide and tips in topic https://forum.openwrt.org/viewtopic.php?id=36021

Now I can access Luci web UI.

It is being setup with default SSID 'OpenWrt' which my devices are able to connect to it to surf the internet. However I'm a little lost on what to do next to set it up as a wireless repeater instead (so that I don't need to plug the LAN cable to it)

I'm looking at Luci's Network -> Interface overview and my LAN settings are here
under Luci's Network -> Wifi overview the OpenWrt SSID with mode: master can be seen

How do I make it so it can connect to my wifi router wirelessly and still allow other devices to connect to it using SSID 'OpenWrt' and surf the internet?

Thanks in advance!

(Last edited by iori57 on 21 Aug 2012, 17:35)

Under Network -> Wifi
I click Scan ('Find and join network') and click 'Join network' to add my existing wifi connection and created a new interface called 'wwan'

After that under Network -> Wifi again
I click Add ('Provide new network') and under Interface Configuration there I choose the network the same as the above, which is 'wwan'

But this doesn't seem to work.. it's so hard to make sense of all these.

Help!

I also tried that following 5+ pages of the OpenWRT Wiki but never succeeded - it is somehow confusing and misleading.
However, I was lucky enough to find this straight forward guide: http://vogelzucht-ostenland.de/?page_id=41
It's in German, but you can probably understand it with Google translate and it contains the full configuration-files.
You have to use the br-2.4 release (which is gone in the current trunk).
I have no clue if repeater mode is also possible with the current open drivers nor did I find any documentation on that, but since br24 works for me I'm fine.
HTH
Chris

Thanks johan, I did read through some of them, but they are too technical for non network average day user like me.. after reading all of them I'm still not sure which is the one suitable for my case.

Thanks inte, I'll have a look at your link smile

I followed the guide here https://forum.openwrt.org/viewtopic.php … 09#p151609
Restarted my WA901ND and it seems bricked now.
The wifi led is now off, I tried connecting the LAN cable to it, but I couldn't telnet/ssh to 192.168.3.1 nor 192.168.0.1
Anyway to save this? O_O

managed to reset using openwrt failsafe method..

After that, I follow the same guide again, this time carefully change some of the settings to match with my current network settings: (192.168.2.1 is my internet router's IP address, and I access my WA901ND via 192.168.2.254 (luci too))

network

config interface 'lan'
        option ifname 'eth0 eth1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.2.254'
        option netmask '255.255.255.0'
        option gateway '192.168.2.1'
        option dns '8.8.8.8'

config interface 'wwan'
        option proto 'dhcp'

config interface 'stabridge'
        option proto 'relay'
        option network 'lan wwan'

wireless

config wifi-iface
        option device   radio0
        option network  lan
        option mode     ap
        option ssid     OpenWrt
        option encryption psk2
        option key      secretkey

config wifi-iface
        option device   radio0
        option network  wwan
        option mode     sta
        option ssid     MyRouterSSID
        option encryption psk2
        option key      secretkey

dhcp

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option ignore '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

firewall off

I think I'm getting close... I unplugged the network cable, after that my PC is able to connect to OpenWrt and telnet to the device (however cannot access Luci which I don't know why), I'm able to surf the internet for a while (my ip address is 192.168.2.102), until the connection got lost again after 1 minute or so (the ip address changes to some weird number 169.254.35.131) and can't surf the net anymore, then I have to reconnect to make it work.

Need a final push from someone!! Thanks in advance!

(Last edited by iori57 on 23 Aug 2012, 19:42)

Help please..

Check my configs: (they are not the full configs, just the parts you must add or modify)


network:

config interface 'lan'
    option ifname 'eth0'
    option type 'bridge'
    option proto 'static'
    option netmask '255.255.255.0'
    option ipaddr '192.168.11.1'    # to access from LAN if you lose dhcp from main router, force your ip to 192.168.11.x

config interface 'wan'
    option ifname 'eth1'
    option proto 'none'

config interface 'stabridge'
    option proto 'relay'
    option network 'lan wlanAP wlanSTA'                            
    option ipaddr '192.168.2.254'    # MATCH THIS IP WITH wlanSTA !!

config interface 'wlanSTA'
    option proto 'static'
                                    # by default is for a main router using 192.168.2.1. for your main router
                                    # It is set to 254 to be the last one and make all the IP range available for clients.
    option ipaddr '192.168.2.254'    # change to 192.168.0.254 , 192.168.1.254 ,  etc
    option netmask '255.255.255.0'    # to match the your main router's subnet
                            
    option gateway '192.168.2.1'    # set your main router's IP both in gateway and dns
    option dns  '192.168.2.1'
    
config interface 'wlanAP'
    option proto 'static'
    option ipaddr '192.168.10.1'    # to access from WLAN if you lose dhcp from main router, force your ip to 192.168.10.x
    option netmask '255.255.255.0'

wireless

config 'wifi-device' 'radio0'
    option 'type' 'mac80211'
    option 'macaddr' '40:50:xx:xx:xx:xx'
    option 'hwmode' '11ng'
    list 'ht_capab' 'SHORT-GI-20'
    list 'ht_capab' 'SHORT-GI-40'
    list 'ht_capab' 'RX-STBC1'
    list 'ht_capab' 'DSSS_CCK-40'
    option 'txpower' '30'
    option 'disabled' '0'
    option 'channel' '1'                           #<--ONLY CHANGE THIS OPTION ON YOUR WIFI-DEVICE! SET THE WIFI CHANNEL WHERE YOUR MAIN ROUTER IS ON.
    option 'country' 'US'
    option 'htmode' 'HT20'

config 'wifi-iface'
    option 'device' 'radio0'            # PUT THE SAME DEVICE NAME THAT IS SET BY DEFAULT ON YOUR OPENWRT !!
    option 'mode' 'sta'                # CLIENT MODE
    option 'network' 'wlanSTA'            #
    option 'ssid' 'MainRouterSSID'        # SET THE WIRELESS NAME OF YOUR MAIN WIRELESS NETWORK

    option 'encryption' 'psk2'            # UNCOMMENT THE SECURITY YOU WANT TO USE. 
    #option 'encryption' 'psk'            # ONLY ON CAN BE UNCOMMENTED!! (UNCOMMENT = REMOVE #)
    #option 'encryption' 'wep'
    option 'key' 'MainRouterPassword'    # SET THE WIRELESS PASSWORD

config 'wifi-iface'
    option 'device' 'radio0'            # PUT THE SAME DEVICE NAME THAT IS SET BY DEFAULT ON YOUR OPENWRT !!
    option 'mode' 'sta'                # ACCESS POINT MODE
    option 'network' 'wlanAP'            #
    option 'ssid' 'MyRepeater'            # SET THE WIRELESS NAME YOU WANT

    option 'encryption' 'psk2'            # UNCOMMENT THE SECURITY YOU WANT TO USE. 
    #option 'encryption' 'psk'            # ONLY ON CAN BE UNCOMMENTED!! (UNCOMMENT = REMOVE #)
    #option 'encryption' 'wep'
    option 'key' 'MyRepeaterPassword'    # SET THE WIRELESS PASSWORD YOU WANT, CAN BE DIFFERENT FROM THE wlanSTA KEY

firewall

config defaults
    option syn_flood '1'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'ACCEPT'
    option drop_invalid '1'

config zone
    option name 'lan'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'ACCEPT'
    option network 'lan wlanAP wlanSTA'

config zone
    option name 'wan'
    option input 'REJECT'
    option output 'ACCEPT'
    option masq '1'
    option mtu_fix '1'
    option forward 'REJECT'
    option network 'wan'

config forwarding
    option src 'lan'
    option dest 'wan'

config rule
    option 'src' 'wan'
    option 'proto' 'udp'
    option 'dest_port' '68'
    option 'target' 'ACCEPT'
    option 'family' 'ipv4'
                    
config include
    option path '/etc/firewall.user'

dhcp

config dnsmasq
    option domainneeded '1'
    option boguspriv '1'
    option filterwin2k '0'
    option localise_queries '1'
    option rebind_protection '1'
    option rebind_localhost '1'
    option local '/lan/'
    option domain 'lan'
    option expandhosts '1'
    option nonegcache '0'
    option authoritative '1'
    option readethers '1'
    option leasefile '/tmp/dhcp.leases'
    option resolvfile '/tmp/resolv.conf.auto'

config dhcp 'lan'
    option interface 'lan'
    option ignore '1'

config dhcp 'wan'
    option interface 'wan'
    option ignore '1'

config dhcp 'wlanAP'
    option interface 'wlanAP'
    option ignore '1'

By putting this configs on the router and rebooting, the only thing you will need to install is "relayd". All Luci etc is optional.

The easiest is to start over again.
Always connect with Ethernet until its finished.
Erase the router config by doing "mtd -r erase rootfs_data". It will erase all settings and reboot.
Set yor IP manually to 192.168.1.11 for example.
Connect by telnet to it,(192.168.1.1) and modify the configs as shown, but adapting it to the main router's IP and wireless security settings, of both networks, and its channel.
Check this https://forum.openwrt.org/viewtopic.php?id=35953 to see how to modify them with vi editor.
You can also edit manually the config files in windows, matching your router wireless device .
And then upload them to the router directly by running a http server. It is explained there too.

When finished, re-check the config twice. If correct, set the router where it can connect to the wireless network. Reboot it.
Change your ip to the new lan range, ex. 192.168.11.11.
Telnet again the router, this time 192.168.11.1.
Check that the router has connected to the wireless network and has internet, by doing "ping google.es" on the telnet shell.
If you got response, break it doing control+c and continue. If not, something is wrong, break it, and check all the configs, wireless settings....
At this point, only the router will have internet, as the DHCP still doesn't work. You need "relayd" to send the DHCP requests from the repeater clients to the main router.
Do "opkg update" and then "opkg install relayd".
Do "/etc/initd.d/relayd enable"
"/etc/initd.d/relayd start"

(optional, just for the nice HTTP WebGUI )
If you want LuCi, do this:
"opkg install luci luci-proto-relay"
"/etc/initd.d/uhttpd enable"
"/etc/initd.d/uhttpd start"

FINISHED!!

Reboot. Set your LAN IP to auto or DHCP, disconnect and reconnect the LAN cable to make sure it renews.
Now you should get and IP address from the main router by either wireless or lan, also should have internet and be able to access both the main router and openwrt's.
To access the openwrt's router by HTTP go to 192.168.x.254. You should have previously configured it on your "network" config.
By telnet is the same address.
If the repeater looses connectivity with the main router, you will loose all conectivity with both routers as the DHCP depends on the main router.
In this case, to access openwrt's router, manually assign IP addresss of 192.168.10.xx if connected with LAN or 192.168.11.xx with wifi.

I have been using this config for months. Very stable and fast, running for months without rebooting on a cheap TP-Link WR740n v4.
It was just 14euro, about 18$ USD. A great value for the money.

I also was new at  OpenWRT 6 months ago...completely lost. I understand how you might be feeling. OMG I thought it was going to be easier!
It is!! But there are so much options and looots of info that is very easy lo get lost.

Good luck, let me know if you achieve it!

(Last edited by dabyd64 on 28 Aug 2012, 20:26)

Hi thanks for the reply!

I followed your guide exactly up till the point to 'ping google.es' I'm able to access the internet, download relayd package and reboot.

But after rebooted and set my LAN to auto obtain IP, I get a weird IP 169.254.142.142 when i do ipconfig. Can't access the internet, and all of my devices with wifi cannot see the repeater's ssid at all although the WLAN led is lit (blinks once in a while and sometimes solid color).

What am I missing? Let me post all my configs below:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.11.1'
        option netmask '255.255.255.0'

config interface 'wan'
        option ifname 'eth1'
        option proto 'none'

config interface 'stabridge'
        option proto 'relay'
        option network 'lan wlanAP wlanSTA'
        option ipaddr '192.168.2.254'

config interface 'wlanSTA'
        option proto 'static'
        option ipaddr '192.168.2.254'
        option netmask '255.255.255.0'
        option gateway '192.168.2.1'
        option dns '192.168.2.1'

config interface 'wlanAP'
        option proto 'static'
        option ipaddr '192.168.10.1'
        option netmask '255.255.255.0'

config wifi-device  radio0
        option type     mac80211
        option channel  11
        option macaddr  64:70:02:7f:29:9a
        option hwmode   11ng
        option htmode   HT20
        list ht_capab   SHORT-GI-40
        list ht_capab   DSSS_CCK-40

config wifi-iface
        option device   radio0
        option mode     sta
        option network  wlanSTA
        option ssid     myrouterssid
        option encryption psk2
        option key      mypassword

config wifi-iface
        option device   radio0
        option mode     ap
        option network  wlanAP
        option ssid     OpenWrt
        option encryption psk2
        option key      mypassword

config defaults
        option syn_flood        1
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT
        option drop_invalid     1
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        option network          'lan wlanAP wlanSTA'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             wan
        option network          'wan'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
        option name             Allow-DHCP-Renew
        option src              wan
        option proto            udp
        option dest_port        68
        option target           ACCEPT
        option family           ipv4

config dnsmasq
        option domainneeded     1
        option boguspriv        1
        option filterwin2k      0  # enable for dial on demand
        option localise_queries 1
        option rebind_protection 1  # disable if upstream must serve RFC1918 addresses
        option rebind_localhost 1  # enable for RBL checking and similar services
        #list rebind_domain example.lan  # whitelist RFC1918 responses for domains
        option local    '/lan/'
        option domain   'lan'
        option expandhosts      1
        option nonegcache       0
        option authoritative    1
        option readethers       1
        option leasefile        '/tmp/dhcp.leases'
        option resolvfile       '/tmp/resolv.conf.auto'
        #list server            '/mycompany.local/1.2.3.4'
        #option nonwildcard     1
        #list interface         br-lan
        #list notinterface      lo
        #list bogusnxdomain     '64.94.110.11'

config dhcp lan
        option interface        lan
        option ignore   1

config dhcp wan
        option interface        wan
        option ignore   1

config dhcp wlanAP
        option interface        wlanAP
        option ignore   1

wireless

config wifi-iface
        option device   radio0
        option mode     sta
        option network  wlanSTA
        option ssid     myrouterssid
        option encryption psk2
        option key      mypassword

config wifi-iface
        option device   radio0
        option mode     ap
        option network  wlanAP
        option ssid     OpenWrt
        option encryption psk2
        option key      mypassword

Did you put the real ssid, password and encryption type on your own config, but changed it just to show here, right? I hope so...

If the router can ping google, then the connection to the main router is OK. But it seems the router is not running relayd.
Force your ip to enter luci (192.168.11.x) and check under "services" tab that Relayd is running.
If its not running, you may have forgotten to do this on telnet:

/etc/initd.d/relayd enable
/etc/initd.d/relayd start

Anyway, test again the ping to ensure its having internet after installing relayd, also do "iwconfig" and paste the result here, it may help.
If the ping works, ping 192.168.2.1 to check also that openwrt can access the main router.
Are you running the latest snapshot from the trunk?

And also try forcing your IP config as:

IP: 192.168.2.200
Subnet 255.255.255.255
Gateway: 192.168.2.1
DNS: 192.168.2.1


and check if you have internet, and if you can ping your repeater and the main router.

Also, some routers just won't give DHCP trough a repeater. This happened to me with Hitron routers, my repeater works with any router, encryption ... but never, with Hitron stuff, unless I give static IP manually on each computer, like I've just told you 3 lines ago.

Your WA901 can work as repeater with the original firmware, have you tested it before going to openwrt?
Maybe the problem is not in openwrt.
Regards

(Last edited by dabyd64 on 28 Aug 2012, 20:34)

iwconfig

root@OpenWrt:~# iwconfig
lo        no wireless extensions.

wlan0-1   IEEE 802.11bgn  ESSID:"cymok-new"
          Mode:Managed  Frequency:2.457 GHz  Access Point: F8:D1:11:44:77:C2
          Bit Rate=121.5 Mb/s   Tx-Power=23 dBm
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=61/70  Signal level=-49 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:1  Invalid misc:30   Missed beacon:0

wlan0     IEEE 802.11bgn  Mode:Master  Tx-Power=23 dBm
          RTS thr:off   Fragment thr:off
          Power Management:on

eth0      no wireless extensions.

br-lan    no wireless extensions.

relayd is running fine, ping to 192.168.2.1 works.

I tried setting 192.168.2.200 as my PC ip and connect to it via LAN cable, and it can surf the internet and can ping your repeater and the main router!

However with this ip set, I then try to connect to it via wifi ssid OpenWrt but it failed. This is the last step before I can use it as repeater!

Thanks everyone!

I finally finally finally finally got it to function as a repeater by following the config in post 17 here: https://forum.openwrt.org/viewtopic.php … 69#p173069

surprisingly, that config doesn't even need 'relayd'!! I'm not sure whether it's one of the points below that are important to make my device's dhcp to work:
EITHER option _orig_ifname 'eth0 wlan0'
OR config interface 'wwan' WITH option proto 'dhcp'
OR IS IT config dhcp 'lan' WITH option force '1'

Here I will post the exact config that I used to enable my WA901ND to function as a wireless repeater, hope it will help someone someday!!

/etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.99.1'
        option netmask '255.255.255.0'
        option gateway '192.168.99.1'
        option dns '192.168.99.1'
        option _orig_ifname 'eth0 wlan0'
        option _orig_bridge 'true'

config interface 'wwan'
        option proto 'dhcp'

/etc/config/wireless

config wifi-device  radio0
        option type     mac80211
        option channel  10
        option macaddr  64:70:02:7f:29:9a
        option hwmode   11ng
        option htmode   HT20
        list ht_capab   SHORT-GI-40
        list ht_capab   DSSS_CCK-40

config wifi-iface
        option device   radio0
        option mode     sta
        option network  wwan
        option ssid     mainrouterSSID
        option encryption psk2
        option key      secretpassword

config wifi-iface
        option device   radio0
        option mode     ap
        option network  lan
        option ssid     OpenWrt
        option encryption psk2
        option key      secretpassword

/etc/config/firewall

config defaults
        option syn_flood        1
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT
        option drop_invalid     1
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        option network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT

config zone
        option name             wan
        option network          'wan wwan'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan

/etc/config/dhcp

config dhcp lan
        option interface        lan
        option force    1

config dhcp wan
        option interface        wan
        option ignore   1

HOPE THIS WILL HELP SOMEONE SOMEDAY!

iori57 wrote:

Thanks everyone!

I finally finally finally finally got it to function as a repeater by following the config in post 17 here: https://forum.openwrt.org/viewtopic.php … 69#p173069

surprisingly, that config doesn't even need 'relayd'!!

yes but that's routed client + ap, not bridged (or pseudobridge) client + ap, right??? final question is, clients behind repeater are in the same network of those connected to the MAIN router or not??

nebbia88 wrote:
iori57 wrote:

Thanks everyone!

I finally finally finally finally got it to function as a repeater by following the config in post 17 here: https://forum.openwrt.org/viewtopic.php … 69#p173069

surprisingly, that config doesn't even need 'relayd'!!

yes but that's routed client + ap, not bridged (or pseudobridge) client + ap, right??? final question is, clients behind repeater are in the same network of those connected to the MAIN router or not??

You are right, they are on different network. But for me I just need to be able to go online smile

Anyway I'm left with no choice, I can't get relayd to work and I'm not sure what did I do wrong.

(Last edited by iori57 on 31 Aug 2012, 20:31)

Yes, I relayd will bridge both networks, and without relay its just a different network.
But, internet will work fine in both ways.
Nice you suceed ! smile

Hi,

I was just wondering, I've spent last few days configuring my wa901nd v.2 as repeater. I finally managed to do so, can access the net from the repeater and such, but dhcp doesnt work and broadcast on 192.168.1.0 network doesnt work either. I revert back to original firmware and use the universal repeater mode and works like a charm.

My question is anyone knows how tp-link implement their repeater mode? Their steps only takes few clicks and off you go whilst in it is abit challenging to do it in openwrt. Do they have like proprietary driver or something else?

br//

Hello I don't know how it works, but it works, even little better as repeater.

This way of install:

uci set wireless.@wifi-device[0].disabled=0; uci commit wireless; wifi     

Then I connect through WiFi

cat > /etc/resolv.conf <<EOF
nameserver 192.168.1.5
EOF
route add default gw 192.168.1.5                 >>>> Router IP, must connect to Router now with Lan cord

opkg update
opkg install luci

/etc/init.d/uhttpd enable
/etc/init.d/uhttpd start

/etc/init.d/network reload 


Just erase all settings if need:
mount_root                                                   
killall dropbear uhttpd; sleep 1; mtd -r erase rootfs_data       


In Luci I just create additional interface that will connect to the router with password, no specify settings. That's all.
It looks like that:
http://s17.postimage.org/aeqxcltqz/1111.jpg

Now I have choice where can connect through wifi - to the old weak signal router or to the new from repeater.

Actually it's hard to understand such complicated thing for me, maybe it can be solved easier way. But hopeful I help  someone)
Sorry for English.

(Last edited by nixospu1 on 5 Dec 2012, 19:57)

I was able to get the TL-WDR3500 to function as a repeater using your config. Thanks!

iori57 wrote:

Thanks everyone!

I finally finally finally finally got it to function as a repeater by following the config in post 17 here: https://forum.openwrt.org/viewtopic.php … 69#p173069

surprisingly, that config doesn't even need 'relayd'!! I'm not sure whether it's one of the points below that are important to make my device's dhcp to work:
EITHER option _orig_ifname 'eth0 wlan0'
OR config interface 'wwan' WITH option proto 'dhcp'
OR IS IT config dhcp 'lan' WITH option force '1'

Here I will post the exact config that I used to enable my WA901ND to function as a wireless repeater, hope it will help someone someday!!

/etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.99.1'
        option netmask '255.255.255.0'
        option gateway '192.168.99.1'
        option dns '192.168.99.1'
        option _orig_ifname 'eth0 wlan0'
        option _orig_bridge 'true'

config interface 'wwan'
        option proto 'dhcp'

/etc/config/wireless

config wifi-device  radio0
        option type     mac80211
        option channel  10
        option macaddr  64:70:02:7f:29:9a
        option hwmode   11ng
        option htmode   HT20
        list ht_capab   SHORT-GI-40
        list ht_capab   DSSS_CCK-40

config wifi-iface
        option device   radio0
        option mode     sta
        option network  wwan
        option ssid     mainrouterSSID
        option encryption psk2
        option key      secretpassword

config wifi-iface
        option device   radio0
        option mode     ap
        option network  lan
        option ssid     OpenWrt
        option encryption psk2
        option key      secretpassword

/etc/config/firewall

config defaults
        option syn_flood        1
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT
        option drop_invalid     1
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        option network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT

config zone
        option name             wan
        option network          'wan wwan'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan

/etc/config/dhcp

config dhcp lan
        option interface        lan
        option force    1

config dhcp wan
        option interface        wan
        option ignore   1

HOPE THIS WILL HELP SOMEONE SOMEDAY!

(Last edited by manthinking on 20 May 2014, 21:20)

iori57 wrote:

managed to reset using openwrt failsafe method..

After that, I follow the same guide again, this time carefully change some of the settings to match with my current network settings: (192.168.2.1 is my internet router's IP address, and I access my WA901ND via 192.168.2.254 (luci too))

network

config interface 'lan'
        option ifname 'eth0 eth1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.2.254'
        option netmask '255.255.255.0'
        option gateway '192.168.2.1'
        option dns '8.8.8.8'

config interface 'wwan'
        option proto 'dhcp'

config interface 'stabridge'
        option proto 'relay'
        option network 'lan wwan'

wireless

config wifi-iface
        option device   radio0
        option network  lan
        option mode     ap
        option ssid     OpenWrt
        option encryption psk2
        option key      secretkey

config wifi-iface
        option device   radio0
        option network  wwan
        option mode     sta
        option ssid     MyRouterSSID
        option encryption psk2
        option key      secretkey

dhcp

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option ignore '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

firewall off

I think I'm getting close... I unplugged the network cable, after that my PC is able to connect to OpenWrt and telnet to the device (however cannot access Luci which I don't know why), I'm able to surf the internet for a while (my ip address is 192.168.2.102), until the connection got lost again after 1 minute or so (the ip address changes to some weird number 169.254.35.131) and can't surf the net anymore, then I have to reconnect to make it work.

Need a final push from someone!! Thanks in advance!


SAME Trouble here. Same device, and I tried to use vi editor, But I am more inexperienced then you. My device bricked and I am tired of getting into Failsafe mode... I use macOSX Mavericks. Can't we just config it using Luci web interface?

(Last edited by pauloavilaneto on 20 Aug 2014, 20:44)

pauloavilaneto wrote:

SAME Trouble here. Same device, and I tried to use vi editor, But I am more inexperienced then you. My device bricked and I am tired of getting into Failsafe mode... I use macOSX Mavericks. Can't we just config it using Luci web interface?

Now we can do it using Luci interface. Realy easy! Already tried with success.

https://www.youtube.com/watch?v=3rbsh2zxPnk

The discussion might have continued from here.