OpenWrt Forum Archive

Topic: RAM Upgrad on Siemens SE-505 v2 possible?

The content of this topic has been archived on 9 Apr 2018. Unfortunately there are posts – most likely complete pages – missing.

hmmm... nvram:erase did not help...

now its getting hard...

is the nvram i backed up by:
dd if=/dev/mtdblock/3 > wrt-nvram.bin

compatible with the Dredrick-option restore:nvram?

can i flash the backup i made using dd now with the debrick utility?

THNX

axc27

as i did nvram erase before... simply tried...

still no go...

fuck... i schould have built the JTAG-cable before trying arround...

can someone please supply me with a working CFE.BIN and NVRAM.BIN for trhe se505v2, so i can bring my router back to life?

axc27

ok... CFE and NVRAM are ok... still no boot...

JTAG works, so CPU and Flash are alive.
perhaps the 16MB sdram died... will have to solder the old one back again...


axc27

nice talking to myself... ;-)

se505 is back up alive... :-D

seems to have been a bad solderpoint. unsoldered the ram, kontrolled everything, and resoldered it... boots up again... at least now i have played arround with a JTAG now... :-D

back to the old problem: have 16MB in, but con only access 8 MB. nvram setting sdram_init is ignored...

where could the RAM-Setting be encoded? could it be set by a kind of jumperblock?

CFE only sees 8 MB too...

Restarting system.
Please stand by while rebooting the system...
Decompressing..........done
Here we try to capture the default reset button: None.
Warning! invalid default profile, please update it first.


CFE version 1.0.37 for BCM947XX (32bit,SP,LE)
Build Date: Fri May 14 09:44:24 CST 2004 (denny@dnylinux)
Copyright (C) 2000,2001,2002,2003 Broadcom Corporation.

Initializing Arena.
Initializing Devices.
et0: Broadcom BCM47xx 10/100 Mbps Ethernet Controller 3.60.9.0
CPU type 0x29007: 200MHz
Total memory: 0x800000 bytes (8MB)

Total memory used by CFE:  0x80300000 - 0x80434F90 (1265552)
Initialized Data:          0x8032F0A0 - 0x803313D0 (9008)
BSS Area:                  0x803313D0 - 0x80332F90 (7104)
Local Heap:                0x80332F90 - 0x80432F90 (1048576)
Stack Area:                0x80432F90 - 0x80434F90 (8192)
Text (code) segment:       0x80300000 - 0x8032F0A0 (192672)
Boot area (physical):      0x00435000 - 0x00475000
Relocation Factor:         I:00000000 - D:00000000

help apreciated...

THNX

Hi there!

Can't say that I have anything to contribute, but are you sure that all address lines are connected to the processor? I am thinking of doing a similar mod to my wl500gd and on these all lines are routed but you need to install 0 ohm jumpers for the last address line. 

also, the folks at http://www.nslu2-linux.org/ replace the bootloader to gain access to the extra memory; http://www.nslu2-linux.org/wiki/HowTo/FattenYourSlug

good luck!

hmmm

according to http://wl500g.dyndns.org/sdram.html
4x16 chips and 8x16 chips only use adress pins A0-A11... so going from 8 to 16 MB schould be no problem...

you want to change your WL500 from 16 to 32 MB. this requires an additional adresspin A12...

i think the ram-setting is hidden in the CFE... but how to get it out there... ? The method shown in the Wiki for WRTs does not work for my se505. if i do a 'cat cfe.bin | strings' i do not get something umanreadable...

axc27

(Last edited by axc27 on 30 Aug 2006, 16:25)

I have a 500g deluxe with 32MB memory(2*8x16) so by replacing with 2 16x16 I hope to get 64MB.

Broadcom has the source for CFE online: http://www.broadcom.com/products/commun … ds.php#cfe

It is newer than the one in our routers, did not(yet) have a look in the gpl source codes provided by asus to see if they included the source of the version they used.

yeah baby yeah!!

running at 16MB now!!!

since the CFE of the se505v2 seems to be set to 4x16 and doesn't detect my 8x16 fully i thought: why not use the second RAM-place on the board.

so i soldered the original 4x16 on the second RAM spot, inserted a few 0Ohm bridges to connect the Adress-lines (there should be 33Ohm resistors according to the first RAM-spot. but they are REALY small. not the SMD-resistors with the resistance printed on it. even smaller. tried to solder somme 33Ohm from an old graphics card... but they were way too big. so i simply shortened them to connect the adress-pins).

and here i am, my Router has 16MB ram now and is finaly usable (8MB isn't much...)!!

ok, it was not as straightforward as it sounds... i soldered and unsoldered each of the RAM-chips at least twice, so i am realy used to soldering these small bastards now... but finaly it works!
if anyone wants to do this to his se505v2 too: don't solder a capacitor on C319, leave it open. i soldered one and it didn't boot anymore... unsoldered it, and it worked.

TODO to get from 8MB to 16MB on the se505v2:
shorten:
  R314
  R315
  R316
  R317
  R318
and solder a 4Mx16 sdram on the second RAM-spot.
afte booting the router you should have 16MB ! :-)
now do:
---
nvram set sdram_ncdl=0
nvram commit
reboot
---
to let the cfe reconfigure this value.
this is all you have to do! no change in sdram_init, it is ignored by the CFE on this router.

HAVE FUN!


TODO:
build a cfe that supports 8Mx16rams, so i can go to 32MB RAM with two 16MB 8Mx16 would be nice...
anyone used to this and willing to help me?

axc27

(Last edited by axc27 on 2 Sep 2006, 13:19)

Now I'm a proud owner of a beefed-up SE505 - V2, too!

To be honest, I have access to professional SMD soldering tools, which made soldering the second 4x16 SDRAM a lot easier. It worked on the spot!

One hint:
  nvram set sdram_ncdl=0
has turned out to be unnecessary. The additional RAM has been recognized right away.

What I've got now is a nice piece of hardware with sufficient RAM and USB 1.1 (USB storage, a USB 1.1 hub, and a Prolific USB-RS232 converter worked like charm).

One more thing: I did some research on the power supply: MP1410ES DC/DC Step-Down converters are being used. The specified input voltage range is 4,75 to 15V. The box boots up from 4V on. Battery power supply (even car battery) should be no problem.

/T

yes, it works without changing sdram_nctl. but resetting it cannot be bad.

from http://wl500g.dyndns.org/sdram.html:

sdram_ncdl:
  contains various memory controller timing information, this could be 
    either 0, which indicates to perform auto-tuning during memory
      initialzation (it will be updated to real  value once 
      initialization completed by CFE) 
    or predefined value.

as you add a second SDRAM-chip wich with doesn't have the same timing it can't be bad to let the CFE recalculate the optimal timing...

axc27

(Last edited by axc27 on 10 Oct 2006, 23:05)

Hi axc27,

I followed your advice - at least it didn't do any harm ^^

BTW: thanks for letting us know about your experiences with the mod - I'm not sure if I'd have done it if I hadn't known that it has been done before.

Cheers
/T

Just for information, I did successfully upgrade the memory in my wl500gd to 64MB. No changes to bootloader or sdram_init needed, just two jumpers to connect A12(R68&R69).

adding two 32M16 chips to get 128MB would be fun too:)

Hello Countzero,

Did you have any Photos from the RAM upgrade for the wl500gd ?
What (exact) Type of ram chips did you use ?

Maybe the Debianport runs much much better with 64MB Ram. Look @ http://wpkg.org/index.php/Running_Debia … 00G_deluxe

I don't want to hijack the tread(or crosspost too much for that matter) so please see this thread for details: http://wl500g.info/showthread.php?t=4609

Pictures will come when I get my digital camera back..

The discussion might have continued from here.