OpenWrt Forum Archive

Topic: Serial unbrick 1043ND - Can't enter console

The content of this topic has been archived on 26 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hi there,

i finally bricked my router so that i need to unbrick it via serial connection.

i have the problem, that it seems, that i cant send the tpl command to get to the command line when trying to serial unbrick my TP Link 1043ND. i resoldered the wires several times to make sure, everything is set up correctly. the output looks fine i can see the reboot loop output but i cant write anything to the console. i type the "tpl" right when the "Autobooting in 1 seconds" message appears. and yes i think im typing pretty fast. i also tried to spam the three "tpl" letters without success. i dont know what i am doin wrong here. I already tried to connect the rx and the tx of the converter to check in putty that sending and reading is working and it fact it does, so the converter should be fine. i only connected the rx, tx and gnd pins to the converter. can someone help me out and tell me what i am doing wrong? maybe there is another way to get it unbricked?

thx in advance

mexyn

http://img821.imageshack.us/img821/1337/fotozgz.jpg

did you turn off flow control ?

blogic wrote:

did you turn of flow control ?

is that an option in putty? if yes, then i didnt change anything else then the COM port and the baud speed. i left everything else by default. im at work right now and cant check the settings. do i need to turn it off then?

edit: ok im at home right now and turned off flow control. now it works perfectly!!! thx a lot blogic!!

note to myself --> RTFM

(Last edited by mexyn on 27 Aug 2012, 19:24)

Ok think now i finally killed it completely....

I tried to setup my 1043 as AP. It worked great until i recognized that the wifi performance was terribly bad!!! (down/upstream 3kb/s).

Ok so once again i searched this forum about that issue ending up with the following thread --> https://forum.openwrt.org/viewtopic.php?id=38020

Ok so lets try it with a current trunk i thought and downloaded this trunk image --> http://downloads.openwrt.org/snapshots/ … pgrade.bin

Flashed it via luci and now my 1043ND is dead. The flashing procedure ended up with just the power led on. all the other leds are off. cant establish any connection. if i power cycle the router the power led is on, the lan1-4 leds are flashing ONCE after 1 second and nothing else happens (no reboot cycle, power led is still on, rest off). No blinking sys led or something else (so no failsafe and no serial console). tried to access via serial console again, but this time there is no output at all.

Dunno what happend so i guess it was a big mistake to take this trunk image. As far as i could read, the next step would be to unsolder the memory, and reflash it.....but to be honest, this step is too much for my nerves...i just wanted to set up a simple wifi access point to extend my existing network sad

So i finally want to ask the advanced users here: Is there a way to unbrick my router without unsoldering the memory or can i give up and dump it buying a new one (dunno if it will be a 1043ND again sad )

greetings

mexyn

You could attach the spi cables and try in-system-programming.
Although I don't see, how you could kill your bootloader using luci.

Well i wasn't aware, that i could kill the bootloader with luci / trunk image. Thought the worst thing that could happen is that i have to debrick it again via serial console. I tried many firmwares (also DD WRT) but always ended up in something not working as it should (mostly Wifi performance). In these tries i bricked the router several times but i was always able to debrick it with the console.

Debricking via spi (even in-system-programming) is no option for me, as i dont have the needed hardware and it seems very time consuming. Never did that before though. The other thing is, that i wonder why the 1043ND model is that favored by many ppl. The experiences *I* made is that the wifi of this device sucks badly no matter what firmware is used. don't know if it was only my specific device, but as i read in this forum, there are many wifi problems with this model. now im thinking of buying a new router, but no matter where i look its always the 1043ND which has the best ratings if you have the requirements that i have (gigabit eth, wifi b/g/n 300, at least 4 switch ports). But as this is not a buying advisory service thread i leave it as it is and try to find a solution for my needs hmm

Thx for help

You are not alone on this, look here

mexyn, I know that you post it long time ago, but maybe my answer will help others.
You make mistake with pin connectors on your photo. You have RXD in place TXD and TXD in place RXD smile


Please see this link: http://halfface.se/wiki/index.php/File: … serial.jpg

PunBB bbcode test

Best regards,

Null modem.....

Need help sugestion with similar problem , iI connect TTL serial rs232 to rooter tl-wr1043nd (ver 1.8) , I started putty with settings 115200 8N1 , after press "Open" ,plug in Power cord to router after this I have in consle putty this:
U-Boot 1.1.4 (Mar 31 2012 - 10:40:21)

AP83 (ar9100) U-boot 0.0.11
DRAM:
sri
32 MB
id read 0x100000ff
flash size 8MB, sector count = 128
Flash:  8 MB
Using default environment

In:    serial
Out:   serial
Err:   serial
Net:   ag7100_enet_initialize...
No valid address in Flash. Using fixed address
: cfg1 0xf cfg2 0x7114
eth0: 00:03:7f:09:0b:ad
eth0 up
eth0
Autobooting in 1 seconds## Booting image at bf020000 ...
   Uncompressing Kernel Image ... OK

Starting kernel ...



OpenWrt kernel loader for AR7XXX/AR9XXX
Copyright (C) 2011 Gabor Juhos <juhosg@openwrt.org>
Decompressing kernel...
done!
Starting kernel...

[    0.000000] Linux version 3.5.7-rc1-svn20118 (root@dd-wrt) (gcc version 4.7.2 20120910 (prerelease) (Linaro GCC 4.7-2012.09) ) #1680 Fri Oct 12 09:52:41 CEST 2012
[    0.000000] flash_size passed from bootloader = 1649
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU revision is: 00019374 (MIPS 24Kc)
[    0.000000] arch_mem_init
[    0.000000] booting platform Atheros AR9132 rev 2 (0xb9)
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 02000000 @ 00000000 (usable)
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x00000000-0x01ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x00000000-0x01ffffff]
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 8128
[    0.000000] Kernel command line: console=ttyS0,115200 root=1f02 rootfstype=squashfs noinitrd init=/sbin/init
[    0.000000] PID hash table entries: 128 (order: -3, 512 bytes)
[    0.000000] Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
[    0.000000] __ex_table already sorted, skipping sort
[    0.000000] Writing ErrCtl register=00000000
[    0.000000] Readback ErrCtl register=00000000
[    0.000000] Memory: 29424k/32768k available (2168k kernel code, 3344k reserved, 411k data, 160k init, 0k highmem)
[    0.000000] NR_IRQS:80
[    0.000000] irq init done
[    0.000000] plat_time_init: plat time init done
[    0.000000] Calibrating delay loop... 265.42 BogoMIPS (lpj=1327104)
[    0.080000] pid_max: default: 32768 minimum: 301
[    0.080000] Mount-cache hash table entries: 512
[    0.090000] NET: Registered protocol family 16
[    0.110000] bio: create slab <bio-0> at 0
[    0.120000] Switching to clocksource MIPS
[    0.130000] NET: Registered protocol family 2
[    0.130000] IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.130000] TCP established hash table entries: 1024 (order: 1, 8192 bytes)
[    0.140000] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[    0.140000] TCP: Hash tables configured (established 1024 bind 1024)
[    0.150000] TCP: reno registered
[    0.150000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.160000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.170000] NET: Registered protocol family 1
[    0.170000] gpio_proc: module loaded and /proc/gpio/ created
[    0.180000] Register LED Device
[    0.180000] wl0gpio_proc: module loaded and /proc/wl0gpio/ created
[    0.190000] AR7100 GPIOC major 0
[    0.190000] squashfs: version 3.0 (2006/03/15) Phillip Lougher
[    0.200000] msgmni has been set to 57
[    0.200000] io scheduler noop registered
[    0.210000] io scheduler deadline registered (default)
[    0.210000] Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
[    0.240000] serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 19) is a 16550A
[    0.240000] console [ttyS0] enabled, bootconsole disabled
[    0.240000] console [ttyS0] enabled, bootconsole disabled
[    0.260000] guessed flashsize = 8M
[    0.260000] scanning for root partition
[    0.260000] tplink uboot detected
[    0.270000] bootloader size = 20000
[    0.270000]
[    0.270000] found squashfs at 110000
[    0.280000] Creating 8 MTD partitions on "ar7100-nor0":
[    0.290000] 0x000000000000-0x000000020000 : "RedBoot"
[    0.290000] 0x000000020000-0x0000007e0000 : "linux"
[    0.300000] 0x000000110000-0x000000730000 : "rootfs"
[    0.300000] mtd: partition "rootfs" set to be root filesystem
[    0.310000] 0x000000730000-0x0000007e0000 : "ddwrt"
[    0.320000] 0x0000007e0000-0x0000007f0000 : "nvram"
[    0.320000] 0x0000007f0000-0x000000800000 : "FIS directory"
[    0.330000] 0x0000007f0000-0x000000800000 : "board_config"
[    0.340000] 0x000000000000-0x000000800000 : "fullflash"
[    0.340000] ->Oops: flash id 0x10216 .
[    0.350000] tun: Universal TUN/TAP device driver, 1.6
[    0.350000] tun: (C) 1999-2004 Max Krasnyansky <maxk@qualcomm.com>
[    0.360000] Found an RTL8366RB switch
[    0.360000] Realtek RTL8366RB ethernet switch driver version 0.2.3
[    0.370000] rtl8366rb rtl8366rb: using GPIO pins 18 (SDA) and 19 (SCK)
[    0.380000] rtl8366rb rtl8366rb: RTL5937 ver. 3 chip found
[    0.430000] rtl8366rb: probed
[    0.640000] PPP generic driver version 2.4.2
[    0.640000] PPP BSD Compression module registered
[    0.640000] PPP Deflate Compression module registered
[    0.650000] PPP MPPE Compression module registered
[    0.660000] NET: Registered protocol family 24
[    0.670000] u32 classifier
[    0.670000]     Performance counters on
[    0.680000]     input device check on
[    0.680000]     Actions configured
[    0.680000] Netfilter messages via NETLINK v0.30.
[    0.690000] nf_conntrack version 0.5.0 (459 buckets, 1836 max)
[    0.690000] nf_conntrack_rtsp v0.6.21 loading
[    0.700000] nf_nat_rtsp v0.6.21 loading
[    0.700000] ip_tables: (C) 2000-2006 Netfilter Core Team
[    0.710000] IPP2P v0.8.2 loading
[    0.710000] TCP: westwood registered
[    0.720000] TCP: hybla registered
[    0.720000] TCP: vegas registered
[    0.720000] NET: Registered protocol family 17
[    0.730000] Bridge firewalling registered
[    0.730000] 8021q: 802.1Q VLAN Support v1.8
[    0.740000] searching for nvram
[    0.740000] nvram size = 0
[    0.770000] Broken NVRAM found, recovering it (Magic 19852003)
[    0.780000] Atheros AR71xx hardware watchdog driver version 0.1.0
[    0.780000] ar71xx-wdt: timeout=15 secs (max=21) ref freq=200000000
[    0.800000] SQUASHFS error: lzma returned unexpected result 0x2
[    0.810000] SQUASHFS error: Unable to read cache block [613b72:f21]
[    0.810000] SQUASHFS error: Unable to read inode [613b72:f21]
[    0.820000] List of all partitions:
[    0.820000] 1f00             128 mtdblock0  (driver?)
[    0.830000] 1f01            7936 mtdblock1  (driver?)
[    0.830000] 1f02            6272 mtdblock2  (driver?)
[    0.840000] 1f03             704 mtdblock3  (driver?)
[    0.840000] 1f04              64 mtdblock4  (driver?)
[    0.850000] 1f05              64 mtdblock5  (driver?)
[    0.850000] 1f06              64 mtdblock6  (driver?)
[    0.860000] 1f07            8192 mtdblock7  (driver?)
[    0.860000] No filesystem could mount root, tried:  squashfs
[    0.870000] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(31,2)
[    0.880000] Rebooting in 1 seconds..˙

U-Boot 1.1.4 (Mar 31 2012 - 10:40:21)

AP83 (ar9100) U-boot 0.0.11
DRAM:
sri
32 MB


Then try press "f" or "tpl" an putty console no heapen nothing and this process continuue to infinite.
Any ideea that is wrong ..?
Verry thanx in advance

* bad timing typing "tpl" - it sometimes takes me about 5 trys until I succeed
* bad connection - like mentioned on of the mentioned links
* bad cable type - some people reported that a different serial cable solved a connection issue

Some times TX pin is not properly connected to router CPU , so anything you type in your console will not be send to CPU. It's was typical problem on 1043ND serial port.

(Last edited by xopal on 3 Nov 2012, 17:35)

I resolved with "tpl" command ,but processor or flash is inofensife- no heapen anything .Toomorow be sent to dealer for service. Thanx for all reponse

johnny29 wrote:

I resolved with "tpl" command

So, how did you solve that problem?

Nice post...

(Last edited by nahian on 6 Nov 2012, 08:57)

You're welcome...............

BTW, what problems did you have in flashing from uboot?

I got only "boong" sound when hit open button sad

The discussion might have continued from here.