OpenWrt Forum Archive

Topic: [HOWTO] Unbrick TP-Link WR842ND WITHOUT serial

The content of this topic has been archived on 25 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

First of all, hi everybody! This is my first post on this forum, however I've been lurking around quite a bit: I hope this post will partially repay the community for all the help I got here.

Second, Many thanks to the developers of this wonderful firmware. I needed a universal repeater and bought the Wr842ND only once It got Openwrt support...

Third, sorry for my awful English... hope this post will make some sense...


Background:
A couple of days ago, I flashed a new OpenWRT build using 'sysupgrade -v' on a SSH shell USING A WIRELESS CONNECTION!
Never do that!!!
Long story short, the wireless connection went down in the middle of the upgrade and all I got was a rounded-edges, white brick.

I disconnected the power supply and reconnected after a bit: nothing happened, all the leds were off.

I had two choices: opening a warranty claim (I know it's unfair, it was my fault after all) or soldering a serial port (voiding the warranty) and restore from there. Moral issues apart, a claim would have costed me money and time while my soldering skills are less than optimal.

Never give up hope:
Today I tried this: remove power, press and keep pressed the reset button (on the back of the device) and connect the power again (reset button still pressed). About 10 seconds after giving power, I released the reset button. This time the USB led lit up. There was still life...
Next, I connected the router to my PC using an ethernet cable and the led of the connected eth port lit up too. Good. There was something passing over that eth port. A bit of wireshark sniffing and voilĂ ! I was able to reinstall the original tp-link firmware on the device.
Only for some minutes! Now I have opewrt again, of course smile

This is what I did, maybe It'll work with your little brick too:

- Power off the bricked device (disconnect the power plug)
- Press and keep pressed the reset button on the back
- Connect the power back (while keeping pressed the reset button)
- After 10 seconds, release the reset button
- USB led should be ON.
- Connect the WAN port of the router to your PC (Maybe you can use another LAN port, maybe not. Just use the WAN port and don't ask!)
- The WAN led should light up.

- Start Wireshark and sniff your PC's ethernet port. Try to locate packets coming from Atheros/xx:xx:xx, broadcasted, with protocol ARP.
   In my case, maybe it is the same for you (in this case you don't need wireshark at all), I saw messages like this:
   "Who has 192.168.1.66? Tell 192.168.1.86"
This means that my WR842ND had somehow got the IP 192.168.1.86 (don't ask me why) and was looking for a PC with address 192.168.1.66 (don't ask me why).

- So you have found one "Who has XXX.XXX.XXX.XXX?" message in your Wireshark log? Good. Keep note of the XXX.XXX.XXX.XXX address. Maybe it will be the same 192.168.1.66 as in my case, maybe not. Just write it down.

- In network control panel, assign to your PC the fixed IP: XXX.XXX.XXX.XXX  It's quite simple: the router's looking for XXX. Let's our PC be that XXX and check what the router wants to ask.

- If you are curious, check wireshark again: you'll see messages from the router (192.168.1.86 in my case) asking for the file "wr842ndv1_tp_recovery.bin". Protocol: TFTP. Perfect!!! The router's asking for a firmware!!!

- Install and set-up a TFTP server on your PC.

- Download the latest firmware for wr842nd from TP-Link.com. Extract the zip and RENAME the .BIN file inside to "wr842ndv1_tp_recovery.bin". Put the bin file in the folder served by your TFTP server.

- Disconnect the Ethernet cable from the PC (just to be sure). Start the TFTP server. Reconnect again the ethernet cable.  Your TFTP server, on your PC, should show the incoming connection (from the router) and the download (from PC to the router).

- Wait 10 minutes for the firmware to be processed/installed inside the router. After a while you should see it rebooting and all the leds come into life again.

- Remove the eth cable from the WAN port.

- Give your PC a dynamic address again (DHCP assigned)

- Connect the PC to one of the LAN ports. Go to: 192.168.0.1. Login with admin/admin

- Enjoy.


Nothing difficult. Only I wonder why the router got the address 192.168.1.86 and was looking for .66!!! I had never used the 192.168.1.0/24 class!

In my case, all went flawlessly. I think my bootloader was not gone for good, after all. I hope this will apply to you too in the unlucky event you brick your little box (which I hope not)!

Ask me if you need any more details.

Bye,
Isidoro

Do u have a hint how did router automatic downloaded .bin file ? tnx

hi risidoro, my problem is similar,

a openwrt installation on a tp link wr842nd, but via ethernet and with succesful message, but only first led working and no ssid and cp interface.

if i check my ip address is recognized like 192.168.1.105 with 192.168.1.1 like router.

i tried your method: removed power, press and keep pressed reset button and connected the power again, USB led lit up.

previously i search and downloaded last router fw (and renamed like written), wireshark and differents tftp server, 'cause i never use it one before...

all steps shows as you described:  "Who has 192.168.1.66? Tell 192.168.1.86"

so I determined my fixed ip address 192.168.1.66 and after put the fw file (renamed) in the root folder i follow you steps:
disconnect the ethernet cable from the PC. start the TFTP server. reconnect again the ethernet cable.

but no way to go on,

i tried server address (where send the bin file) 192.168.1.68 or 192.168.1.1
no response from the server....

if i use other destination like or localhost, tftp client only create a copy of the bin file in my own pc...

router still waiting with usb and wan leds on...

where is my mistake? suggestions?

really thanks...

Hi Onoff and Vido,
I hope the answer will suit both.

When you start the router keeping the reset button pressed, it (the router) starts a tftp CLIENT and automatically tries to download the file "wr842ndv1_tp_recovery.bin" from a tftp SERVER located at 192.168.1.66  (the router doesn't know if the server is there, it just asks indefinitely for the file.

What we do to make the router happy (and ourselves) is:

1 - Set the PC address to static IP 192.168.1.66 Subnet 255.255.255.0 (gateway and DNS can remain empty, we don't need them)

2 - Install a TFTP SERVER in the PC (for Windows you can use Tftpd32 or Tftpd64 ,32bit or 64bit, for Mac OSX use TFTPServer, both are free)

3 - Configure the server: basically you only need to create a folder i.e. "c:\firmware" (in windows) or "\Users\[yourname]\firmware" (in Mac OSX) and to tell the server program to use that folder (in the server settings). That is the folder where the server will send/receive (in our case, just send) the files requested by clients (in our case, the router)

3.a - Optional: If the server program asks for an interface to listen/work on, choose your Ethernet (LAN) interface (not WIFI or others).

4 - Copy the firmware file "wr842ndv1_tp_recovery.bin" in the folder you created in the previous step. (of course, because when the router will ask for the file, the server installed in your PC will look in that folder).

5 - Disable the firewall of the computer (i.e. Windows Firewall)

6 - With the router OFF, connect the ethernet cable to the PC and to the WAN port on the router.

7 - Keep pressed the Reset button on the router and connect the power plug. Continue keeping pressed the button for 15/20 seconds

8 - Wait... after 1/2 minutes you should see all the lights on the router going OFF and then back ON after some seconds. it means the router completed the installation and self-rebooted.

9 - With the router still on, disconnect the ethernet cable from the WAN port of the router and connect it to one of the 4 LAN ports.

10 - In your PC, set "Use automatically assigned IP adress" for your Ethernet card. (in the same place where we put the static address in step 1).

11 - After a short while, your PC should get an IP address assigned (in the range 192.168.0.[100-254]). If this happens then perfect. The router gave the PC an address. The router is alive.

12 - Open a browser and connect to 192.168.0.1. User: admin Pass: admin     ENJOY.

So, in short, this is what happens:
You start the router keeping the reset button pressed. The router starts asking 192.168.1.66 for a file named wr842ndv1_tp_recovery.bin

You set your Personal Computer with the address 192.168.1.66 (so it will answer to the router). You install a TFTP Server on the PC, configure the server to use a folder (i.e. c:\firmware) and put the file wr842ndv1_tp_recovery.bin in that folder.

So, when the router will ask 192.168.1.66 for the file, the TFTP server on your PC will answer and automatically send the file to the router. The router will then automatically download and install the firmware and reboot.
After the reboot the router is back as it was when you bought it.

Hope this time is clearer.

PS: I did the whole procedure 10 minutes ago to better remember the single steps.

Bye

thanks risidoro!

all ok after i use a pc with xp!!

...win 7 for me don't work...

which .bin do you suggest for Wr842ND?
i used THIS (https://forum.openwrt.org/viewtopic.php?id=37083)
but i'd like to know if there is a newest one...or which one you used...

really thanks again! smile

Hi,
I'm very happy it worked for you too smile

The newest firmware (precompiled, that is if you don't want to compile your own) can always be found here:
http://downloads.openwrt.org/snapshots/trunk/ar71xx/

The file to use are:
1) openwrt-ar71xx-generic-tl-wr842n-v1-squashfs-sysupgrade.bin (if you're upgrading from an older openwrt version)
OR
2) openwrt-ar71xx-generic-tl-wr842n-v1-squashfs-factory.bin (if you're installing openwrt for the first time on a device with the original tp-link firmware)

If you visit that link from time to time you'll find new versions (filename is always the same but date and time of upload change).
To update (with the file at (1) ) I usually use the luci web interface. If you want, you can do via ssh (without luci) with sysupgrade but PLEASE, do it over a cable connection. Wifi will fail!!! (read the first post in this thread).

I tend to stick with one version (i've never really found any particular difference between different versions) for a month or two. Then, I upgrade to the latest one to see if there are improvements (and to stay up to date).

I hope you will enjoy your router. It may not be Cisco quality but it ain't bad at all!

Bye

i got a weird one...
I'm trying this with tp-link 1043nd, the USB light doesn't come on, connected to lan4 - wan doesn't work
and it's asking: who has 169.254.26.250, tell 0.0.0.0 (???)
How exactly do i check the file name its asking for? First time Wireshark user...
I have tftpd64 installed and set up (IP and file), but the router isn't flinching.

(Last edited by clovk on 25 Sep 2012, 22:22)

risidoro,

It works!!! Many thanks.

Just a note. I tried to recover TL-WR842ND V1. Latest firmware (wr842ndv1_en_3_12_24_up_boot(130110).bin) does not work. After flashing and restarting my router blinked with all leds infinitely.

After that I tried wr842ndv1_en_3_12_22_up(120424).bin and after reboot my router has started!!! After restart I've updated it to wr842ndv1_en_3_12_24_up_boot(130110).bin. And now it works.

I guess "up_boot" in the firmware name is the reason.

Thanks
Dima

(Last edited by floppy on 3 Feb 2013, 14:21)

Hello guys!

I've just registered to say Thanks comrads risidoro and floppy.
I've unbrikked my friend's TL-WR842 in 10 minutes without disassembly and soldering a serial. BTW I was using Win 7 at PC, everything needed is to adjust it's firewall to enable TFTP.

Hello risidoro !

Just want to say a big thanks for this "tutorial". It helped me recover my bricked 842ND.
Many many MANY THANKS !

Hi Andrew82, Alinuts, Floppy,
Glad it worked!
It's a pleasure knowing you were able to fix your routers!

Tnks Floppy for your contribution!

Bye

Hey
I reflash my router by risidoro method, but in step 8 in yours instruction using tftpd64 i must wait almost 2 hours smile. At the end i had that same blinking all led as floopy. When I push reset button and power on router, usb led is on. Now I cant reflash again because router don't send signal in wireshark "asking for the file "wr842ndv1_tp_recovery.bin".

prodek wrote:

Hey
I reflash my router by risidoro method, but in step 8 in yours instruction using tftpd64 i must wait almost 2 hours smile. At the end i had that same blinking all led as floopy. When I push reset button and power on router, usb led is on. Now I cant reflash again because router don't send signal in wireshark "asking for the file "wr842ndv1_tp_recovery.bin".

Hi,
The problem you describe it's strange. Did you use an older original firmware as Floppy suggested?

Anyway, now that the problem is here, try restarting the device while keeping pressed the reset button as per instructions. I'm not sure, but this should trigger the ask-for-firmware boot mode...

Sorry for not being able to help you more, maybe someone else will do.

Good luck and let us know...
Bye

works until seccond reboot led blinking again ?

i did guide , (with older firmware thx floppy smile ) work well i upgrade with openWRT again everything is fine , telnet / passwd / ssh / 
did some setings ( just for wifi nothing big) and router reboots after the reboot again brick !?

i dont have time next few days but i think its luci , next debricking will be without luci ! (i dont know why i did install luci i prefer terminal)

ps. my project openwrt clientbriged mode + raspberrypi with openvpn  + mail server

risidoro,

thanks a lot! you made my day.

I bricked the router yesterday (I think it was due to a bad image as reported in another post) and was able to recover it with your guide.

For me the tricky, part was to find the original firmware from tl-Link (it has to be the non boot version) since in their web there are only boot versions but the rest without a problem and I had to do the process several times due to my insistence to install latest openwrt trunk image smile

Hi all,
First of all, thanks for the help. This tutorial is great and very user friendly. I feel like talking to friends.
I tried to make the procedures. While Using the Wireshark I manage to see the 'Who has..." message. However, oddly, the "tell..." part is coming from 0.0.0.0. Is there a way to correct this or the device is definitively dead?
Thank you in advance for any replies

Thanks, this helped a lot, I feared I had to start soldering.

In my case it the ip was 192.168.0.86 however that was not all I also had to remove the port from the tftp server as it was on port 69 instead of port 24.

dandenardi wrote:

Hi all,
First of all, thanks for the help. This tutorial is great and very user friendly. I feel like talking to friends.
I tried to make the procedures. While Using the Wireshark I manage to see the 'Who has..." message. However, oddly, the "tell..." part is coming from 0.0.0.0. Is there a way to correct this or the device is definitively dead?
Thank you in advance for any replies

I've got same problem then have you found any fixing?

(Last edited by enrico95 on 12 Apr 2014, 12:14)

Hi, in the tutorial (very well done ) the atheros named is the internal network adapter of the tplink, is it right? If yes my problem should be that my request it's from pc and not from router. Can anyone help me?

P.S. The device is a WR841N and the led are all functionants also without reset at power on( I also try doing it anywhere) but the ping is not responsive. It has been installed openwrt from the tplink firmware update and not from tftp server; the cause of the problem maybe this or a wrong version of openwrt.

Thanks in advance

This saved my bacon, I was able to make this work on my C7 Archer V1 after flashing a factory firmware with the word boot on it.
I know this is thread necroing but..

@enrico95, at first the messages always come from my pc (asus motherboard) but after switching it from LAN to Wan I managed to get the 192.168.1.66 - 192.168.186 combo. after a while i got that TFT message

Hi; I have a Archer C7 with the same problem. In my case, 192.168.1.86 is also asking for 192.168.1.66 for a TFTP Packet. But I never have set up a tftp server on my PC (runs Linux, Debian). Could you help me? Thank you

Hi, many thanks for risidoro. I've recover my TP-Link WR740N with the same way. But with my router, I set my PC IP "192.168.0.66", and of course use wr740v4_tp_recovery.bin instead. Now it's work perfectly.

I faced the same problem with my TL-WR842ND v2.
I tried to use this tutorial (also you can find it in wiki https://wiki.openwrt.org/toh/tp-link/tl-wr842nd) without any luck.
Router asks for 192.168.0.66, get answer, but DO NOT ask for firmware. I even already ordered serial cable on Ali (but  fortunately canceled it and saved my $1.18).
So, if you have the same issue just don't give up. All you have to do is to find proper moment to press/release RESET button. Before I used to start it with pressed reset and then released it plenty of time, but it didn't work for me. Finally I pressed reset button AFTER start and you can imagine how I was surprised when it asked for firmware after hundreds of unsuccessful attempts.
I didn't have proper firmware this time in the folder, so I had to find it first. Second time I did about 9 unsuccessful attempts until it asked about firmware again.
So always keep your Wireshark/nc open to trace the process.
Good luck!

(Last edited by ademin on 7 Jun 2016, 00:18)

The discussion might have continued from here.