OpenWrt Forum Archive

Topic: Block Wifi -> LAN

The content of this topic has been archived on 29 Mar 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

I thought this one was gonna be pretty straightforward but I can't make it work. I've already tried this tutorial: (guest-wlan http://wiki.openwrt.org/doc/recipes/guest-wlan) but I can't get it working.

So, this is the situation. I have WAN and two zones- one is "lan" (ethernet ports, on 192.168.5.x) and "Public" (wifi, on 192.168.3.x). Everything works but I'd like to block WLAN users from accessing LAN part.

I thought rejecting wlan --> lan would work but it doesn't :-/
Any ideas what rule could I try to just block "public" --> "lan"? :-/

Here's my config:

NETWORK:

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option ifname 'eth1'
    option type 'bridge'
    option proto 'static'
    option netmask '255.255.255.0'
    option ipaddr '192.168.5.1'

config interface 'wan'
    option ifname 'eth0'
    option proto 'dhcp'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0 1 2 3 4'

config interface 'Public'
    option _orig_ifname 'wlan0'
#    option _orig_bridge 'false'
    option proto 'static'
    option ipaddr '192.168.3.1'
    option netmask '255.255.255.0'



AND FIREWALL:

onfig defaults
    option syn_flood '1'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'REJECT'

config zone
    option name 'lan'
    option output 'ACCEPT'
    option forward 'REJECT'
    option input 'ACCEPT'
    option network 'lan'

config zone
    option name 'wan'
    option network 'wan'
    option output 'ACCEPT'
    option forward 'REJECT'
    option input 'ACCEPT'
    option masq '1'
    option mtu_fix '1'

config forwarding
    option src 'lan'
    option dest 'wan'

config rule
    option name 'Allow-DHCP-Renew'
    option src 'wan'
    option proto 'udp'
    option dest_port '68'
    option target 'ACCEPT'
    option family 'ipv4'

config rule
    option name 'Allow-Ping'
    option src 'wan'
    option proto 'icmp'
    option icmp_type 'echo-request'
    option family 'ipv4'
    option target 'ACCEPT'

config rule
    option name 'Allow-DHCPv6'
    option src 'wan'
    option proto 'udp'
    option src_ip 'fe80::/10'
    option src_port '547'
    option dest_ip 'fe80::/10'
    option dest_port '546'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-ICMPv6-Input'
    option src 'wan'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    list icmp_type 'router-solicitation'
    list icmp_type 'neighbour-solicitation'
    list icmp_type 'router-advertisement'
    list icmp_type 'neighbour-advertisement'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-ICMPv6-Forward'
    option src 'wan'
    option dest '*'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

config include
    option path '/etc/firewall.user'

config zone
    option name 'PUBLIC'
    option input 'ACCEPT'
    option forward 'REJECT'
    option output 'ACCEPT'
    option network 'Public'

config forwarding
    option dest 'wan'
    option src 'PUBLIC'

hi

did u try to disable STP (spanning tree protocol) ?

...without that clients cant see each other

The discussion might have continued from here.