OpenWrt Forum Archive

Topic: Installation on ZyXel nbg4615

The content of this topic has been archived on 24 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hello.
Is it possible to install the OpenWRT on this router? I didn't find it among the supported routers on the [link url=http://wiki.openwrt.org/toh/start#zyxel]wiki[/link], is that list updated?

According to this this site, it should be based on Ralink RT3052 platform (as is a supported router from the same manufacturer), it has 32 megabytes of ram (again, other routers with less ram are supported). here and here are the FCC specs. (I cannot download it, dunno why).

To sum up: Is the router somehow supported? Will I be able to build and run OpenWRT on it? Or will I (being a noob) brick it likely?

(Last edited by menganito on 19 Nov 2012, 21:23)

This is quite an old chipset and most likely openwrt should work on that.

If you are afraid of bricking it then try with ramfs. Atleast, you will know for sure before flashing it.


//ali

I tried and I messed up.
I tried to install OpenWRT through the router's original upgrade utility, selecting a file fom the hard drive, this one: http://downloads.openwrt.org/attitude_a … grade.bin. After the install, the router rebooted, but I didn't get a connection back. Now it doesn't respond to ping, telnet, I cannot connect to it. HW seems alive, Power LED blinks and lights up as expected, wlan blinks as expected, LAN lights up and blinks when I try to connect. Is there an easy way out of this or should I contact my vendor?

Thats sad but thats the fun part!

Question:

0) What IP you are trying to ping\telnet and actually how do you know IP of that very device.

//ali

192.168.1.1, isn't that the default? I'll go try nmap to verify.
However, as I said, I cannot connect (Using Ethernet, PC is running Debian and wicd network manager) to the internet at all, which I guess I should be able to.

Yes, fixing broken things is often a LOT of fun, but this router is somewhat critical to my home network

Yes, 192.168.1.1 is default. Whether you can connect to this IP or not depends how the router is connected itself.

192.168.1.1 should be accessible if you connect your computer directly to the router's LAN port. Do not connect anything else for this first attempt. This will ensure that openwrt firmware is working fine. If you can connect via browser or telenet the router then you have to look into network configurations for internet part.

//ali

No luck. I connected only the LAN1 to the PC and POWER to the electric outlet smile

The discussion might have continued from here.