OpenWrt Forum Archive

Topic: No WAN ip with AA sp1 on g300nh

The content of this topic has been archived on 26 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hi,
Been a gargoyle user, last version 1.5.8 with beta 2 of AA.
No problems, but the recent upgrade 1.5.9 which uses AA rc1 gives me a problem.  The WAN interface, eth1 does not get an IP!  This is a fresh sysupgrade, not keeping old settings.

I tried AA rc1 alone, same issue.  If I do udhcpc -i eth1, it gets an IP, but dns is not working even when I try restarting dnsmasq.

So, I have no idea, I went back to 1.5.8 which uses AA beta2 and got an IP, then restored my backup config.

I'm stumped as to what is happening, the MAC didn't change, I even rebooted the "modem"  Fios ONT!

I also noted that with AA rc1, my wan interface would no longer get an IP address. Manually running udhcpc did work.

It seems that in AA rc1, the dhcp client is configured not to send the MAC address as client identifier (udhcpc is started with the "-C" option), unless you specify a "clientid" in the configuration (see /lib/netifd/proto/dhcp.sh). My ISP (VZ), requires that the client ID is included, and thus I changed my config (/etc/config/network):

config 'interface' 'wan'
        option 'ifname' 'eth0'
        option 'proto' 'dhcp'
        option 'clientid' '01:mm:aa:cc:aa:dd:rr'

Note, the client ID needs to start with 01, followed by the MAC address of the interface.

Thanks!  I am on vz fios so that explains it.

I suppose the next build will have this.  Or do we have to report it elsewhere?

I have a TL-WDR3600 on Verizon FiOS & am getting an IP just fine.

| Gargoyle version 1.5.X    | OpenWrt Attitude Adjustment branch |
| Gargoyle revision a786afa | OpenWrt revision r34879            |
| Built January 16, 2013    | Target  ar71xx/usb_large           |
------------------------------------------------------------------

cat /lib/netifd/proto/dhcp.sh:

    [ -n "$clientid" ] && clientid="-x 0x3d:${clientid//:/}" || clientid="-C"

    proto_export "INTERFACE=$config"
    proto_run_command "$config" udhcpc \
        -p /var/run/udhcpc-$iface.pid \
        -s /lib/netifd/dhcp.script \
        -f -t 0 -i "$iface" \
        ${ipaddr:+-r $ipaddr} \
        ${hostname:+-H $hostname} \
        ${vendorid:+-V $vendorid} \
        $clientid $broadcast $dhcpopts

ps:
udhcpc -p /var/run/udhcpc-eth0.2.pid -s /lib/netifd/dhcp.script -f -t 0 -i eth0.2 -C

ifconfig:
config interface 'wan'
    option ifname 'eth0.2'
    option proto 'dhcp'

(Last edited by BashfulBladder on 19 Jan 2013, 19:49)

Verizon might be running different types of equipment at different areas.

My dhcp.sh shows the same thing.... the client ID is what my fios seems to need.
"-C,--clientid-none Don't send MAC as client identifier"

(Last edited by robnitro on 20 Jan 2013, 04:27)

The discussion might have continued from here.