OpenWrt Forum Archive

Topic: WDS Link with two TL-WR740N routers.

The content of this topic has been archived on 7 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hey, I have a small problem and i can`t figure it out myself.
I have two routers TL-WR740N with  OpenWrt Attitude Adjustment 12.09-beta firmware.

The main router is connected to internet and the second one is going to be a wireless repeater. The main problem is, i cant see my computers behind the repeater and main router is not giving ip addreses to second router devices.

Here is config for main router:

config wifi-device 'radio0'
    option type 'mac80211'
    option macaddr '64:70:02:54:b9:b8'
    option hwmode '11ng'
    option htmode 'HT20'
    list ht_capab 'SHORT-GI-20'
    list ht_capab 'SHORT-GI-40'
    list ht_capab 'RX-STBC1'
    list ht_capab 'DSSS_CCK-40'
    option channel '6'
    option txpower '27'
    option country 'US'
    option distance '23'

config wifi-iface
    option device 'radio0'
    option mode 'ap'
    option wds '1'
    option ssid 'M3'
    option network 'lan'
    option encryption 'psk2'
    option key '1213141516'

---

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option ifname 'eth0'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'

config interface 'wan'
    option ifname 'eth1'
    option proto 'dhcp'

config switch
    option name 'eth0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'eth0'
    option vlan '1'
    option ports '0 1 2 3 4'

and here is config for second router:

config wifi-device 'radio0'
    option type 'mac80211'
    option macaddr '64:70:02:56:1b:92'
    option hwmode '11ng'
    option htmode 'HT20'
    list ht_capab 'SHORT-GI-20'
    list ht_capab 'SHORT-GI-40'
    list ht_capab 'RX-STBC1'
    list ht_capab 'DSSS_CCK-40'
    option disabled '0'
    option channel '6'
    option txpower '27'
    option country 'US'
    option distance '23'

config wifi-iface
    option network 'wwan'
    option ssid 'M3'
    option encryption 'psk2'
    option device 'radio0'
    option mode 'sta'
    option bssid '64:70:02:54:B9:B8'
    option wds '1'
    option key '1213141516'

---


config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option ifname 'eth0'
    option type 'bridge'
    option proto 'static'
    option netmask '255.255.255.0'
    option ipaddr '192.168.2.1'
    option gateway '192.168.1.1'

config interface 'wan'
    option ifname 'eth1'
    option proto 'dhcp'

config switch
    option name 'eth0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'eth0'
    option vlan '1'
    option ports '0 1 2 3 4'

config interface 'wwan'
    option proto 'dhcp'

On the second router wifi iface must be part of the lan netwok, not wwan!

The discussion might have continued from here.