OpenWrt Forum Archive

Topic: Help a n00b get started with a DG834G v3, please

The content of this topic has been archived on 21 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.


I've decided to take the plunge and have a play with OpenWRT as I've been frustrated with the limited features of off-the-shelf routers and I've had a fair few headaches running Smoothwall on a dedicated Atom box, plus I'd like to use a lower power device.

I've bought myself a DG834G v3 from ebay after having a look at the options available and thinking it was a good price / feature / support balance, and all looked straightforward. It's arrived and I'm having some trouble getting going, can someone give me a push in the right direction, please, as I think I'm very close to success.

Following the advice here I've downgraded the Netgear firmware to get wget. Despite the Wiki reccomending using a pre-buit image, I found it very hard to track down which one is the correct / best one for this router - Am I missing something obvious? Eventually this post pointed me in the direction of … uashfs.bin which has gone up and booted. However telnet connections time out and pings failed. I've now soldered on the required serial connector and the device seems to be functioning correctly - I've confirmed that the IP address is appropriate, however I can't ping my laptop from the router either. The LEDs flash appropriately when I initiate a ping from either end, and the trasmitted packet count increases, however the other end does not seem to respond, and the recieved packets from either end do not incriment.

I notice that the documentation in the OldWiki suggests that the Ethernet was broken when it was written, but I've not found out how old the oldwiki is. Is this still a current bug? One that I need a newer version than the 10.03.1 release for?

Any pointers as to how to get round this would be much appreciated, please! My research seems to be going round in circles by now...

Thanks in advance.

--Toby W.

I've been through the documentation again, but I'm still stuck. Any pointers would be much appreciated, as at the moment I don't seem to have many options for progressing. The router is listed as supported in the hardware list, so I presume I'm not the only one with this device - it even has it's own section of the forum, though that seems to be obsolete.

The only way I can see to progress is to try the Netgear firmware recovery tool, then try with a different image - perhaps 10.03 rather than the 10.03.1, as it's the earlier one that is mentioned in the hardware support list (though I would be surprised if it became un-supported in a later branch). I'm also tempted by the RC release of the current version, as that's what the Beginners Guide seems to sway towards.

I'm still not confident that I've got the right image for the device. Despite recommending that I us a pre-built image, the documentation seems to give no advice on how to select the correct one for my device and all I've got to go on is a passing forum post. Please can anyone give me a definiete pointer of what to go for?

OK, thanks, I'll give that a go!

Thanks for the pointers, I now have the router up and running, and while it's going it seems to work well - I'm getting 7Mb/s from a speed test, which is pretty much as fast as I've seen my line go smile. However the router seems unstable - about 50% of the time the web interface fails to serve a page, I've seen it lose communication with the modem, and despite finding discussions about the wireless card for the device, I'm making little headway into getting it to recognize its wireless adapter. After some more searching, I've come across this page: … revision.3

Which doesn't seem to be linked to from any of the Wiki pages I've found before. I realize that the RC1 release you have linked me to is newer than the beta they have mentioned, but the device is definitely listed as not working when the page was last updated.

Before I abandon my afternoon's work and revert to the 10.03 release that that page lists as working, do you know if the 12.09-RC1 release should be working on this device?

I too am trying to get openwrt on a DG834G.

How did you get the ethernet working on 10.03.1 ?

Did you try 10.03 or 12.09-RC1 ? Did they work?

Did you get the wireless working?

Many thanks.

Hi SmartRat,

No, I never got the networking going on 10.03.1, I'm afraid.

I tried 10.03, but that seemed even less functional. Despite the status light giving the "heartbeat" flash, I couldn't get anything out the network, and the serial console seemed to switch during the boot to outputting garbage, possibly it changed baud rate, but I couldn't find any settings that got any sense out of it.

12.09-RC1 came up and ran I was able to configure the modem and get it to connect. However the web-interface only responded intermittently and then the ADSL modem lights went out and appeared not to be visible when trying to diagnose over SSH.

Despite having bought the device from ebay to try out openWRT, I tried it with the stock firmware and it ran quite reliably, so I don't think that there's anything too wrong with the hardware. I never made any progress with the Wireless, I'm afraid.

What version of the DG834G are you using? I believe the wireless card from the v2 is better supported than the one on the v3, but the processor is slower. Given that when the web interface was responding, pages would take 10s of seconds to come up, I wouldn't want to run it on anything slower...

Do let me know if you get anywhere with it, I like the sound of OpenWRT, but having had so much trouble when I'd carefully chosen something listed as supported, I'm afraid I've put it back to stock and put it in the cupboard as an emergency spare modem.



Thank you tobestool for posting your progress.

I am an unlucky one as well to have a v3. I never tried with Attitude Ajustement (12.09-RC1) because the documentation says it does not work with it. Maybe this documentation need updating!

I'll have a go with 12.09-RC1 once I have connected my serial port to it.

No problem, I hope you get further than I did.

I don't think the serial port was actually vital for any of the work I did - I just used the Netgear rescue tool to restore it to stock then started again from scratch each time. The serial port was good for confidence and extra debugging info, but I can't recall it being vital for any of the steps.



Hey Tobestool,

I'm about to try out 12.09-rc1. If I'm not happy with that, I'll look at trying the bleeding edge. If you're still interested, there should be a report in under a week.

That sounds good, conn-fused. I'd be interested to know how you get on!

Hi again,

So after a day of work on the DG834Gv3 using 12.09-rc1, I'm pretty happy with the results. Here's a summary:

-Flashing, following the link provided above by tobestool, was straightforward. No problems there.

-The LuCI web interface is painfully slow. Initially I thought it would be totally useless, and that I would want to build an image that did not include it. In the end, however, it was usable as long as you turn "AutoRefresh" to "off" at every opportunity (I haven't yet figured out how to make this the default behaviour). It's still slow and prone to errors (no wonder, given that one minute load can get above 5.00 when calling a page), but if you're very, very patient you could do all configuration with the web interface. Using SSH where possible, however, will save you a lot of time.

-The default firewall rules included a few I wanted to modify or replace. Modifying firewall rules is very strenuous for LuCI, so I strongly recommend SSH here (vi /etc/config/firewall). There are good examples on the wiki.

-Internet Access: I created a "wan" interface in LuCI and fed it the required details. On a reboot of the modem, I had a solid connection. There have been no problems on that front (yet), but I'll do some stress testing over the next few days. External port scans look very good.

-LEDs: The only issue (and it's trivial) with the internet connection is that there is no LED showing that the connection is active. The third LED is probably supposed to do this. I can probably figure out how to fix that over the next few days.

-Wireless: I haven't done anything with the wireless yet. According to the wiki, it is disabled by default. I want it to be disabled, so I haven't put any effort into it yet. That said, I'd be happier if I could get it to work and then explicitly disable it, so I'll probably try to do that and add results here later.

-Serial Port: I didn't even consider playing with this. Tobestool is correct: it isn't necessary for any of the key steps.

Overall, I'm pretty pleased with what OpenWrt can do on this device, given its hardware specs. If anyone has any questions about getting this far, please feel free to ask in this thread. I'll help if I can.

(Last edited by conn-fused on 16 Mar 2013, 05:10)

I have installed it on a Sphairon Turbolink JDR454WB (DG834Gv1 Clone). But it's more or less useless for me. LuCI is too buggy and crashes too often. I don't think the CPU is too slow. It's just not working properly. I have installed a DGTeam's custom firmware now (Netgear stock modified firmware).

At leat I got attitude adjustment to work on a dg834gb v3.

I used information from this thread, but the above links did not work (anymore?). May be the new name is: … r/dg834gv3

What I did as a summary:


downgrade to a netgear firmware containing wget, i took 4.01.04, found it here:
just do it via the web interface

supply the openwrt image on your own local webserver, I user lighttp on a ubuntu machine:
apt-get install lighttp
cd /var/www
wget … uashfs.bin

activate telnet on your router: browse to
telnet router-ip-adress

via telnet on your router:
cd /proc/sys/dev/adam2
echo "mtd5 0x90020000,0x903e0000" > environment
wait some seconds

reactivate telnet as above

via telnet on your router:
cd /tmp
wget http://local-web-server/openwrt-ar7-squashfs.bin
dd if= openwrt-ar7-squashfs.bin of=/dev/mtdblock/5
wait some seconds
disconnect power
wait some seconds
connect power

After that I had a freshly installed attitude adjustment. Doing some configuration everything looks fine now, including stable ADSL2+ through the internal modem. Though fascinating, that it is working, I am not sure if I like this solution.

- very small memory, very slow cpu
- webinterface fails often, most times followed by reboot, so I deactivated uhttpd
- shell commands fail often too, also reboots
- cannot install packets due to lack of memory
- for me: useless preinstalled kmod-sangam-atm-annex-a, need kmod-sangam-atm-annex-b
- did not try wireless

Workaround for Installing Software

general description:
"opkg update" loads … ackages.gz
saved as
This is a gzip-ped text file. It seems to be too big to work with, so "opkg install package" fails.
My quick and dirty solution is to download the package list to my PC, create new version containing simply one package and supply on the router. Then install. Worked for me.

On PC:
cd /tmp
wget … ackages.gz
gunzip Packages
delete all execept the desired package.
gzip Packages
mv Packages.gz /var/www/attitude_adjustment

on router:
cd /var/opkg-lists
wget http://local-web-server/attitude_adjustment
opkg install <package>

Hi all,
I know this is an old thread, however I would like to use openWRT with DG834G v3. In particular, I followed your suggestions and as meinereiner said the openWRT 12.09 is very slow and it is very difficult to configure from GUI.
What about the newer versions 14.07 and 15.05? Did you try them?
Thank you

I don't think that newer versions are any resource friendlier. But yes, i would flash it immediately as well if it runs somewhat properly. I guess all that CGI and Python stuff is way too much for that little device.
I cannot test it atm as i handed it over to a friend.

(Last edited by HectoPascal on 18 Sep 2015, 23:01)

Hi HectoPascal,
it is impossible to upload a newer firmware 15.05 from GUI due to speed and because it is no allowed by GUI. Via SSH I'm not able to copy the binary file to the router since the scp command becomes stalled. I asked for any suggestions here otherwise I have to buy a new router.

P.S. I tried also via wget as described before by meinereiner, I get a stalled transfer.

P.S.2 I tried to downgrade to 10.03 and I successfully copied it to the RAM of router via scp, but I get the message "Firmware upgrade is not implemented for this platform." when I use sysupgrade -v openwrt-10.03-ar7-generic-squashfs.bin

(Last edited by erotavlas on 23 Sep 2015, 15:50)

Did you try by recovery (minimal/emergency system) or bootloader yet? You could also try to stop unnecessary services/processes first. Writing to partitions directly might lead to better results but you have to make sure you can recover the device if the image doesn't work.

(Last edited by HectoPascal on 23 Sep 2015, 16:05)

Yes, I stopped all the services and removed the packages as describe here
rm -r /tmp/opkg-lists/
echo 3 > /proc/sys/vm/drop_caches
rm /etc/modules.d/*80211*
In this way I was able to copy openwrt-10.03-ar7-generic-squashfs.bin in the /tmp folder of the router. However, I could not write it to partition with sysupgrade since I get the message "Firmware upgrade is not implemented for this platform.".
My system is running with openWRT 12.09, why should I try to recovery or bootloader? In order to reinstall netgear firmware?
Thank you

(Last edited by erotavlas on 23 Sep 2015, 17:55)

Recovery system might give you more resources and bootloader might give you direct/alternative access to the nand/mtd (if it has u-boot or something). Bootloader might be kinda complicated though if you never did that before.
I would try to dd the partitions directly into mtdblocks or by bootloader if possible. The actual flashing process works always but if it runs is a different question.

(Last edited by HectoPascal on 23 Sep 2015, 16:53)

Ok, I read about the bootloader and You are right, it does not seem immediate. In which partition should I write the image?
dd if=openwrt-10.03-ar7-generic-squashfs.bin  of=?
/dev/mtdblock4 does not have enough free space

df -h
Filesystem                Size      Used Available Use% Mounted on
rootfs                  896.0K    212.0K    684.0K  24% /
/dev/root                 2.0M      2.0M         0 100% /rom
tmpfs                     6.4M     60.0K      6.4M   1% /tmp
tmpfs                   512.0K         0    512.0K   0% /dev
/dev/mtdblock4          896.0K    212.0K    684.0K  24% /overlay
overlayfs:/overlay      896.0K    212.0K    684.0K  24% /

What do you recommend to do?

(Last edited by erotavlas on 23 Sep 2015, 17:54)

Look up the device page in the wiki. I would dump the original partitions first and roughly examine/compare them (by hexeditor) with the data you want to flash. Maybe you have to split/cut images first or something.

(Last edited by HectoPascal on 23 Sep 2015, 18:22)

Ok. I successfully flashed my device by following the procedure here In particular, I booted the device in idle mode by pressing the reset button and powered it up. After, I flashed the firmware provided in the website of DGTEAM. It worked.
Finally, I would like to try openWRT 15.05 and I installed it by following the procedure of meinereiner in this therad, but it did not work since there is not enough space on the device. The device was bricked again.
Now I would like to flash the device with the same operations, but I cannot boot on idle mode even if I hold on the reset button for two minutes.
All the leds blink in strange way (power led, adsl connection led and lan leds) instead of alternating green-red blinking of power and adsl connection leds.

(Last edited by erotavlas on 24 Sep 2015, 06:59)

Not sure. Maybe hangs at bootloader now.

Hence, now could not I recover it?

The discussion might have continued from here.