Before trying this verify your hardware configuration including correct port labels and order.

This guide is for Netgear n600 routers (WNDR3700 and WNDR37AV)

The port layout is as follows

Lan 1 = 0
Lan 2 = 1
Lan 3 = 2
Lan 4 = 3
CPU = 5

Go here to find yours: http://wiki.openwrt.org/toh/start

*******Configure your Network settings (/etc/config/network) following these steps:******

### Step 1 add your interfaces ###

config interface vlan2
        option ifname   eth0.2
        option type     bridge
        option proto    static
        option ipaddr   192.168.2.1
        option netmask  255.255.255.0

config interface vlan3
        option ifname   eth0.3
        option type     bridge
        option proto    static
        option ipaddr   192.168.3.1
        option netmask  255.255.255.0

config interface vlan4
        option ifname   eth0.4
        option type     bridge
        option proto    static
        option ipaddr   192.168.4.1
        option netmask  255.255.255.0 
                                 
                                                                       
### Step 2 add your default vlan0 config always using the cpu port ####
     
config switch_vlan                                                     
        option device rtl8366s                                         
        option vlan     0                                             
        option ports "*5"                                             
                                                                       
### Step 3 define and configure your vlans in this configuration ###     
### I'm using all 4 ports one per vlan ###
                               
config switch_vlan                                                     
        option device   rtl8366s                                       
        option vlan     1                                             
        option ports    "0 5t" ### Notice the CPU port has to be tagged on all vlans ###
                                                                                   
config switch_vlan                                                                 
        option device   rtl8366s                                                   
        option vlan     2                                                           
        option ports    "1 5t"                                                     
                                                                                   
config switch_vlan                                                                 
        option device   rtl8366s                                                   
        option vlan     3                                                           
        option ports    "2 5t"                                                     
                                                                                   
config switch_vlan                                                                 
        option device   rtl8366s                                                   
        option vlan     4                                                           
        option ports    "3 5t"       

****Leave the remaining settings as is (unless you need specific configuration for WAN, etc)****


****Then Configure your DHCP servers (/etc/config/dhcp) for each new Vlan****
                                             
config dhcp lan                               
        option interface        lan           
        option start    100                   
        option limit    150       
        option leasetime        12h
                                   
config dhcp vlan2                 
        option interface       vlan2
        option start    100         
        option limit    150         
        option leasetime        12h
                                   
config dhcp vlan3                 
        option interface       vlan3
        option start    100         
        option limit    150         
        option leasetime        12h
                                   
config dhcp vlan4                 
        option interface       vlan4
        option start    100         
        option limit    150         
        option leasetime        12h
                                   
****Leave the remaining settings as is (unless you need specific configuration for WAN)***** 


*****Finally configure your firewall (/etc/config/firewall) to allow Internet access for your newly created Vlans*****

config zone
        option name             lan
        option network          "lan vlan2 vlan3 vlan4"
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT

*****And you are done*****

Enjoy!