OpenWrt Forum Archive

Topic: [Solved] I've briked my MR3420 V1.2 ( cfeon flash Winboun SDRam)

The content of this topic has been archived between 19 Apr 2018 and 4 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

I know thers is a subjetct with the same tp-link but there is a difference
ok i hava a tp-link mr3420 V1.2

i have flashed backfire 10.03.1 and my routeur is briked only the pwr led is green
I tried many thing to have a serial connection to debrike it
pl2303 with one 10K pull up resistor in TX with tow puul up in TX and RX one In RX but i have a perturbed signal
then i tried with max 232 and a normal com port in another pc and extern alimentation for Max232 and a 470 ohm resistor and zener diod 3.3 V in the 9 pin on Max232 to limit the output
the loop back test in the circuit in doing well 0% of error
but when i connect my MR3420 i have the same perturbed signal with PL2303
Normally i have a winbond flash  But at my surprise i have a Cfeon Flash q32B-104 and a sdram winbound i'd i'm sure tha in the back of my MR3420 it's wirtten V1.2
ah i'm not very good in soldring for that i have burned le normal serial connection and i have connect directly the wire in the Cfeon flash ( this time done by an expert in soldring   )

Plz any one have an idea how i can make the connection
Sorry for my english and i hope that the solution is with max232 the only componet that i find in my country tunisia and we con't buy by internet

(Last edited by Shinoace on 14 Feb 2013, 13:50)

The serial goes to the processor, not the flash!
Did you set the baudrate at 115200? 8 bits data, 1 bit stop, 1 bit start?
If you burned the serial pads, then you probably are out of luck.
Post some photos to let us see what are you doing smile
Also check:

(Last edited by dabyd64 on 10 Feb 2013, 03:12)

i m pretty sure that serial connecyion is make in dlash memory i for tha that they add u boot ti make flashing with serial withawout external programmer
ok i'll do the photo tomorrow but i'm sure i messed up the regular serial connection and i tried with the same conf u mentionned above
thx for your reply

(Last edited by Shinoace on 10 Feb 2013, 04:25)

Serial is for sending commands to uboot, thats executed by cpu as any piece of software.. Connecting to flash directly is only for using an external programmer..

than's for the information i'm not specialiste about electronics thing. this is the pic of my MR3420 V1.2 and the pic of where i connecte thi wire

My mr3420


The model reference

global view of the motherboard

My messe up in the serial connection

Where i connecte the wire in the flash

Pin 2 DO(data out or Tx)
Pin 4 GND
Pin 5 DI (data in or Rx)
Pin 8 Vcc

when i use putty i see a garbedge like whene i solder the thing in serial connection before i burn them

have any one an idea am i doing right or i messed up every thing.
when i test voltage between Tx and GND i found 1.26 V the same voltage in the origilal serial connection

As dabyd and nebbia pointed out already, you don't connect serial (rs232) to the flash, but to the serial header. That header is most likely on SJ1 (about 4-5 cm to the left and 1-2 cm up from the flash chip, according to your pictures).

FYI: the flash chip talks SPI, which requires at least to hook up DI, DO, CLK, GND and Vcc (normally even CS). Just in case you really want to hook up a SPI programmer ;-)

(Last edited by MBS on 10 Feb 2013, 23:35)

yeah i know that but the thing that i burned up the connection with my amazing skill of soldrig i searche for alternatif solution( juste for the challange i can buy another one it s not a probleme if i brick it more)
ok so what is SPI programmer ??
a PIC programmer or eeprome programmer is good or ther is specific one ??
i can find a pic or eeprome programmer i think

Post a closeup photo of the burned serial conmections.
Those small resistors near the serial are connected to the serial lines, so with a lot of care, you still can recover it.
where are you from? if shipping cost to/from spain are reasonable, I may try to fix it. Or maybe you could be interestesd at selling it?
Precisely, I was searching for a bricked or cheap router to experiment with, trying to upgrade flash/ram,etc.

i m from tunisia this is the probleme but i want to experiment also on it ..
ok the resistor near the serial connection can i know what is the connection for every one ???
i ll try to find an api with macro i have juste a phone for the moment for the pic

And please, be extremely careful! That is your last way to recover, if you break that too, you will have to buy a SPI programmer, or build yourself.
oops, the image seems to be from other version of the router, is different from yours!
Ignore it!

(Last edited by dabyd64 on 11 Feb 2013, 01:03)

ok i'll gnore it and i wiil tacke it to some one how can solder it i hope.
for the SPI programmer if the compont aren't unusuel to find in tunisia  can make one i think in last ressort
tommorow i'll make a good image for the serial connection

clean the serial port with alcohol or acetone, to remove any rest of flux. Then look at the board races of that resistors.
You should clearly see what goes to Tx and what to Rx.
Can you post a photo of the serial port, but the upper side? Closest as you can.

theres is the pic but clearly i have done more damage than i thoght

juste one alternative the spi programmer i have juste make a littel resarche but i found the it possible with parallel port not serial port and the probleme that i have juste serial port

an eeprom programmer can work with this ship???? may be a freind have an eeprom programmer

(Last edited by Shinoace on 11 Feb 2013, 01:51)

Here you can see Rx and Tx on the resistors smile. Follow the damaged line, solder to the resistor pad. Use a thin wire!
For gnd, scratch and solder any of those holes that are surrounding the serial header.
For vcc, check the capacitor. the small light-brown component. the upper side is vcc.
I dont know if your eeprom programmer works with the spi flash. Check its software or manual.

(Last edited by dabyd64 on 11 Feb 2013, 02:23)
free image hosting

Remove C-496 and short the traces , check with ohm meter between Tx to one of CPU pins must have direct connection do the same for Rx pin but without removing R-613.

Go get USB-TTL cable , you only need TX RX and GND pins to make it work, do not use CA-42 cable its too complicated for new beginner.

Ok il ll use max232 with Standart RS232 but where is the TX in the CPU?

A capacitor in series in Tx line? Strange, is the first time I see that

Ok who can tell me where I find that and rx in cpu to test connection

Thx xopal i'll test it this afternoon and practice some soldring skill in another mother bored of a broken cellular and i'll search the rx pin in cpu

ok i have done the continuty test for tx and rx and i have the continuty between spot in the image.
First i hope tha my test is goode
Second can i bybass le capacitor C496 without remouving it
Third i have continuty in R613 and not R612

You can bypass C496 without removing it, just drop tiny lead on top of it while you keep it on place by holding the capacitor with pinset.

The correct one is  R612, sorry I miss it.

ok i baypass the capacitor in tx but not the resistor in rx that's right??
normally it will work with max232 i hope

Thx every one my MR3420 back to life by bayssing the capacitor in TX but not R612 in RX.
The problem was the kernel in backfire.  Now I just flashed AA distribution and it work still go to my freinds home to install package from the Internet

(Last edited by Shinoace on 14 Feb 2013, 13:42)