OpenWrt Forum Archive

Topic: Tp-Link td-w8970

The content of this topic has been archived between 26 Mar 2018 and 7 May 2018. Unfortunately there are posts – most likely complete pages – missing.

Hi All,

Is it possible to connect using Annex M instead of Annex A? I've got w8970 running the stock firmware and Annex M is indeed supported.


Many thanks!

Snakus wrote:

edit config file /etc/config/network

config adsl 'dsl'
    option annex 'm2p'
    option firmware '/lib/firmware/adsl.bin'

Nice, thanks! Can I reach you somehow at IRC/Jabber/Mail?


Mozhna Ukrajinskoju abo na Russkom :)

hope this will help you to select correct settings for option annex

# ITU-T G.997.1 (06/2012) - Section 7.3.1.1.1 (xTU transmission system enabling (XTSE))
# ITU-T G.997.1 Amendment 2 (04/2013) - Section 2.1 - (Vectoring mode enable (VECTORMODE_ENABLE))
#
# G.992.1 Annex A
# G.992.2 Annex A
# G.992.3 Annex A / L-US1 / L_US-2 / M
# G.992.5 Annex A / M
# G.993.2 Annex A/B/C
# G.993.5 Annex A/B/C
xtse_xdsl_a="05_01_04_00_4C_01_04_07"

# G.992.1 Annex B
# G.992.3 Annex B
# G.992.5 Annex B
# G.993.2 Annex A/B/C
# G.993.5 Annex A/B/C
xtse_xdsl_b="10_00_10_00_00_04_00_07"

# G.992.1 Annex B
# G.992.3 Annex B
# G.992.3 Annex J
# G.992.5 Annex B
# G.992.5 Annex J
# G.993.2 Annex A/B/C
# G.993.5 Annex A/B/C
xtse_xdsl_j="10_00_10_40_00_04_01_07"

# G.992.1 Annex B
xtse_xdsl_bdmt="10_00_00_00_00_00_00_00"

# G.992.3 Annex B
xtse_xdsl_b2="00_00_10_00_00_00_00_00"

# G.992.5 Annex B
xtse_xdsl_b2p="00_00_00_00_00_04_00_00"

# ANSI T1.413
xtse_xdsl_at1="01_00_00_00_00_00_00_00"

# G.992.2 Annex A
xtse_xdsl_alite="00_01_00_00_00_00_00_00"

# G.992.1 Annex A
xtse_xdsl_admt="04_00_00_00_00_00_00_00"

# G.992.3 Annex A
xtse_xdsl_a2="00_00_04_00_00_00_00_00"

# G.992.5 Annex A
xtse_xdsl_a2p="00_00_00_00_00_01_00_00"

# G.992.3 Annex L
xtse_xdsl_l="00_00_00_00_0C_00_00_00"

# G.992.3 Annex M
# G.992.5 Annex M
xtse_xdsl_m="00_00_00_00_40_00_04_00"

# G.992.3 Annex M
xtse_xdsl_m2="00_00_00_00_40_00_00_00"

# G.992.5 Annex M
xtse_xdsl_m2p="00_00_00_00_00_00_04_00"

#
# ITU-T G.994.1 (06/2012) - Table 2 (Mandatory carrier sets)
#

# A43
tone_adsl_a="0x142" # A43C + J43 + A43
tone_vdsl_a="0x142" # A43C + J43 + A43

# A43 + V43
tone_adsl_av="0x142" # A43C + J43 + A43
tone_vdsl_av="0x146" # A43C + J43 + A43 + V43

# B43
tone_adsl_b="0x81" # B43 + B43c
tone_vdsl_b="0x1" # B43

# B43 + V43
tone_adsl_bv="0x81" # B43 + B43c
tone_vdsl_bv="0x5" # B43 + V43

I do not know why auto mode is missing 05_00_04_00_4c_01_04_00

Toutatis and Sophoclean  can you post your ifconfig output from telnet or ssh ?

also I'm waiting for USB to serial adapter to try LEDE on it.
Sophoclean -> ICQ 282115

(Last edited by Snakus on 15 Nov 2016, 12:01)

Sorry Snakus, what you wrote is above my knowledge. I don't know what to do with it.

My network config was working well for few weeks, so should I add something in?
ifconfig no WAN connected

ifconfig
br-lan    Link encap:Ethernet  HWaddr C4:6E:1F:74:11:11  
          inet addr:192.168.0.120  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::c66e:1fff:fe74:3926/64 Scope:Link
          inet6 addr: fd70:9f01:7ac4::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:135 errors:0 dropped:0 overruns:0 frame:0
          TX packets:53 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:10225 (9.9 KiB)  TX bytes:7696 (7.5 KiB)

eth0      Link encap:Ethernet  HWaddr C4:6E:1F:74:11:11  
          inet6 addr: fe80::c66e:1fff:fe74:3926/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:167 errors:0 dropped:0 overruns:0 frame:0
          TX packets:58 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:17314 (16.9 KiB)  TX bytes:9563 (9.3 KiB)

eth0.1    Link encap:Ethernet  HWaddr C4:6E:1F:74:11:11  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:149 errors:0 dropped:0 overruns:0 frame:0
          TX packets:50 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:12216 (11.9 KiB)  TX bytes:7282 (7.1 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:240 errors:0 dropped:0 overruns:0 frame:0
          TX packets:240 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:16320 (15.9 KiB)  TX bytes:16320 (15.9 KiB)

ptm0      Link encap:Ethernet  HWaddr 00:20:DA:86:11:11  
          inet6 addr: fe80::220:daff:fe86:2375/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:111 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

ptm0.10   Link encap:Ethernet  HWaddr C4:6E:1F:74:11:11  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:72 (72.0 B)

wlan0     Link encap:Ethernet  HWaddr C4:6E:1F:74:11:11  
          inet6 addr: fe80::c66e:1fff:fe74:3926/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:89 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:6668 (6.5 KiB)
cat /etc/config/network  ###Extract

config switch
    option name 'switch0'
    option reset '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0 2 4 5 6t'
    option vid '1'

config interface 'wan'
    option ifname 'ptm0.10'
    option proto 'pppoe'
    option username '?????@vodafone.ie'
    option password '??????'
    option ipv6 '0'
    option macaddr 'c4:6e:1f:74:11:11'

config interface 'wan6'
    option ifname '@wan'
    option proto 'dhcpv6'

config vdsl 'dsl'
    option annex 'a'
    option firmware '/lib/firmware/vdsl.bin'
    option tone 'av'
    option xfer_mode 'ptm'

Do you know LEDE? What are the difference with OpenWrt? Is there a GUI inside?

Do you know LEDE?

OpenWRT stopped developing and transferred to LEDE
LEDE is only snapshots at the moment without LUCI .

I have compiled LEDE with LUCI
You can give a try if you want, but  I did not check it yet on my router.
without any warranty - https://cloud.mail.ru/public/CbK7/tTtCDAVvB

as to ifconfig - too small uptime in your results.

and just change at the moment

config vdsl 'dsl'
    option annex 'a'
    option firmware '/lib/firmware/vdsl.bin'
    option tone 'av' 
    option xfer_mode 'ptm'

to

config vdsl 'dsl'
    option annex 'a'
    option firmware '/lib/firmware/vdsl.bin'
    option tone 'm' 
    option xfer_mode 'ptm'

also I need to know full setting as per provider manual (except pass).

(Last edited by Snakus on 15 Nov 2016, 11:59)

I still can't connect WAN with option tone 'm'

For your info, for few weeks it was working well but I could not install samba, not enough memory. So I reinstalled it but now I can't connect even with my previous (working) setup.

Snakus wrote:

also I need to know full setting as per provider manual (except pass).

The only I can provide is here https://forum.openwrt.org/viewtopic.php … 25#p336225
and you can read the 3 following posts where I got it working for the first time after OpenWrt new install..

Snakus wrote:

I have compiled LEDE with LUCI
You can give a try if you want, but  I did not check it yet on my router.
without any warranty

I'll wait until you try it. Let me know, I am interested especially if the footprint is smaller than OpenWrt.
BTW, I'll need to connect USB drive and use samba, is it possible to add the drivers in the image?

Sure
May be a few weeks until I get serial converter
Did you try reset settings and setup again?
Even samba maybe included

(Last edited by Snakus on 17 Nov 2016, 16:14)

I didn't try reset. How to do it, by software or hardware button?
I did 2 installs from GUI then restore settings, still no WAN. This is why I'd be glad to try your image.
If you are sure I can install your image and if it's not working there is no difficulty to reinstall the official, I can do it.
I mean I don't want to brick the W8970.

Let me know

is DSL is up ?
Already tested. At least router starts

(Last edited by Snakus on 17 Nov 2016, 16:15)

ADSL     Status: DOWN
Line State: idle request [0xff]
Line Speed: 0 b/s / 0 b/s
Line Attenuation: 0 dB / 0 dB
Noise Margin: 0 dB / 0 dB
....
Sun Sep 11 23:45:23 2016 daemon.warn pppd[3302]: Timeout waiting for PADO packets
Sun Sep 11 23:45:23 2016 daemon.err pppd[3302]: Unable to complete PPPoE Discovery
Sun Sep 11 23:45:23 2016 daemon.info pppd[3302]: Exit.
Sun Sep 11 23:45:23 2016 daemon.notice netifd: Interface 'wan' is now down
Sun Sep 11 23:45:23 2016 kern.info kernel: [  806.516000] device ptm0 left promiscuous mode
Sun Sep 11 23:45:23 2016 kern.info kernel: [  806.520000] IPv6: ADDRCONF(NETDEV_UP): ptm0.10: link is not ready
Sun Sep 11 23:45:23 2016 daemon.notice netifd: Interface 'wan' is disabled
Sun Sep 11 23:45:23 2016 kern.err kernel: [  806.540000] /home/buildbot/slave-local/lantiq_xrx200/build/build_dir/target-mips_34kc+dsp_uClibc-0.9.33.2/linux-lantiq_xrx200/ltq-ptm-vr9/ifxmips_ptm_vdsl.c:281:ptm_hard_start_xmit: not in showtime
Sun Sep 11 23:45:23 2016 kern.info kernel: [  806.556000] device ptm0 entered promiscuous mode
Sun Sep 11 23:45:23 2016 daemon.notice netifd: Interface 'wan' is enabled
Sun Sep 11 23:45:23 2016 daemon.notice netifd: Interface 'wan' is setting up now
Sun Sep 11 23:45:23 2016 daemon.info pppd[3590]: Plugin rp-pppoe.so loaded.
Sun Sep 11 23:45:23 2016 daemon.info pppd[3590]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Sun Sep 11 23:45:23 2016 daemon.notice pppd[3590]: pppd 2.4.7 started by root, uid 0
Sun Sep 11 23:45:24 2016 kern.err kernel: [  806.792000] /home/buildbot/slave-local/lantiq_xrx200/build/build_dir/target-mips_34kc+dsp_uClibc-0.9.33.2/linux-lantiq_xrx200/ltq-ptm-vr9/ifxmips_ptm_vdsl.c:281:ptm_hard_start_xmit: not in showtime
Sun Sep 11 23:45:24 2016 kern.err kernel: [  807.272000] /home/buildbot/slave-local/lantiq_xrx200/build/build_dir/target-mips_34kc+dsp_uClibc-0.9.33.2/linux-lantiq_xrx200/ltq-ptm-vr9/ifxmips_ptm_vdsl.c:281:ptm_hard_start_xmit: not in showtime
Sun Sep 11 23:45:24 2016 kern.err kernel: [  807.332000] /home/buildbot/slave-local/lantiq_xrx200/build/build_dir/target-mips_34kc+dsp_uClibc-0.9.33.2/linux-lantiq_xrx200/ltq-ptm-vr9/ifxmips_ptm_vdsl.c:281:ptm_hard_start_xmit: not in showtime
Sun Sep 11 23:45:25 2016 kern.err kernel: [  808.332000] /home/buildbot/slave-local/lantiq_xrx200/build/build_dir/target-mips_34kc+dsp_uClibc-0.9.33.2/linux-lantiq_xrx200/ltq-ptm-vr9/ifxmips_ptm_vdsl.c:281:ptm_hard_start_xmit: not in showtime
Sun Sep 11 23:45:25 2016 kern.err kernel: [  808.348000] /home/buildbot/slave-local/lantiq_xrx200/build/build_dir/target-mips_34kc+dsp_uClibc-0.9.33.2/linux-lantiq_xrx200/ltq-ptm-vr9/ifxmips_ptm_vdsl.c:281:ptm_hard_start_xmit: not in showtime
Sun Sep 11 23:45:26 2016 kern.err kernel: [  809.264000] /home/buildbot/slave-local/lantiq_xrx200/build/build_dir/target-mips_34kc+dsp_uClibc-0.9.33.2/linux-lantiq_xrx200/ltq-ptm-vr9/ifxmips_ptm_vdsl.c:281:ptm_hard_start_xmit: not in showtime
Sun Sep 11 23:45:26 2016 kern.err kernel: [  809.332000] /home/buildbot/slave-local/lantiq_xrx200/build/build_dir/target-mips_34kc+dsp_uClibc-0.9.33.2/linux-lantiq_xrx200/ltq-ptm-vr9/ifxmips_ptm_vdsl.c:281:ptm_hard_start_xmit: not in showtime
Sun Sep 11 23:45:29 2016 kern.err kernel: [  811.812000] /home/buildbot/slave-local/lantiq_xrx200/build/build_dir/target-mips_34kc+dsp_uClibc-0.9.33.2/linux-lantiq_xrx200/ltq-ptm-vr9/ifxmips_ptm_vdsl.c:281:ptm_hard_start_xmit: not in showtime
Sun Sep 11 23:45:34 2016 kern.err kernel: [  816.832000] /home/buildbot/slave-local/lantiq_xrx200/build/build_dir/target-mips_34kc+dsp_uClibc-0.9.33.2/linux-lantiq_xrx200/ltq-ptm-vr9/ifxmips_ptm_vdsl.c:281:ptm_hard_start_xmit: not in showtime
Sun Sep 11 23:45:39 2016 daemon.warn pppd[3590]: Timeout waiting for PADO packets
Sun Sep 11 23:45:39 2016 daemon.err pppd[3590]: Unable to complete PPPoE Discovery
Sun Sep 11 23:45:39 2016 daemon.info pppd[3590]: Exit.
Sun Sep 11 23:45:39 2016 daemon.notice netifd: Interface 'wan' is now down
....

Do you want more info, what?
Can I try your image securely (even if not fully working?)?

I flashed my lede compilation on the router.
It was a problem ADSL connection is up but no internet.

solution:
1. change encapsulation mode from PTM to ATM
2. change in Interfaces -> WAN -Edit -> Physical Settings  ptm0.10 to nas0

Toutatis
Try another modem | router
or try with original firmware
and also check your line.
Your router do not get DSL connection up

- He! how do you think I can post here, I use another modem ;-) the one I got from the provider, Vodafone Huawei HG658c.
- The original firmware is TP-Link, I don't know how to do, Is it the same as OpenWrt or LEDE, through GUI?

I flashed your image and try now to set it up manually. I have now to install vdsl.bin
I'll let you know soon

You do not need VDSL.bin it's already there

DONE!!! It's working!
Could you check if all is right?
Vodafone says modem should use vectorisation, is it good here?


Is it good:
In the GUI : Annex: B
In the network file : config dsl 'dsl'     option annex 'a'

Status: UP
Line State: showtime_tc_sync [0x801]
Line Mode: G.993.2 (VDSL2)
Annex: B
Profile: 8b
Data Rate: 17.061 Mb/s / 4.707 Mb/s
Max. Attainable Data Rate (ATTNDR): 34.779 Mb/s / 7.745 Mb/s
Latency: 0.14 ms / 0.0 ms
Line Attenuation (LATN): 25 dB / 28.8 dB
Signal Attenuation (SATN): 24 dB / 28.8 dB
Noise Margin (SNR): 17 dB / 11.2 dB
Aggregate Transmit Power(ACTATP): 7.3 dB / 13.9 dB
Forward Error Correction Seconds (FECS): 0 / 168
Errored seconds (ES): 0 / 31
Severely Errored Seconds (SES): 0 / 14
Loss of Signal Seconds (LOSS): 0 / 2
Unavailable Seconds (UAS): 77 / 77
Header Error Code Errors (HEC): 0 / 0
Non Pre-emtive CRC errors (CRC_P): 0 / 0
Pre-emtive CRC errors (CRCP_P): 0 / 0
Line Uptime: 1m 52s
ATU-C System Vendor ID: Broadcom 164.81
Power Management Mode: L0 - Synchronized
cat /etc/config/network

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fd9a:764d:06c6::/48'

config atm-bridge 'atm'
    option vpi '1'
    option vci '32'
    option encaps 'llc'
    option payload 'bridged'

config dsl 'dsl'
    option annex 'a'
    option tone 'av'
    option xfer_mode 'ptm'

config interface 'lan'
    option type 'bridge'
    option ifname 'eth0.1'
    option proto 'static'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option ipaddr '192.168.0.1'

config interface 'wan'
    option ifname 'ptm0.10'
    option proto 'pppoe'
    option ipv6 'auto'
    option username '?????@vodafone.ie'
    option password '????'

config device 'wan_dev'
    option name 'ptm0'
    option macaddr 'c4:6e:1f:74:38:27'

config interface 'wan6'
    option ifname 'pppoe-wan'
    option proto 'dhcpv6'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0 2 4 5 6t'

Can I remove?

config atm-bridge 'atm'
    option vpi '1'
    option vci '32'
    option encaps 'llc'
    option payload 'bridged'

Can I remove?

I don't think

As to correct settings you can check your Vodafone Huawei HG658c

Here is updated build from updated sources for ADSL Annex A
https://cloud.mail.ru/public/GB4N/ZEoHyhEis
also included LuCi, samba, vsftpd, usb storage (ntfs, fat, ext4), print support p910nd, usb over ip server.

(Last edited by Snakus on 20 Nov 2016, 18:04)

bassplayerchris wrote:

...
I then followed the instructions outlined by s7mx1 (including the block size check against the size of mtd1). Unfortunately after a reboot (by typing 'reboot' on the telnet shell), my router didn't come back up, appears bricked, and I'll need to dig out a serial interface to restore it, probably.

Today I have an adventure to follow s7mx1's guide and flash my TD-W8970. After flashing my Tp-link was near the brick state due corrupted squashfs partition. Thanks God this corruption was not fatal and device booted with network interface, sshd and dhcpd but all kernel modules are not readable with strange squashfs read errors in logs:

root@OpenWrt:/lib/modules/3.18.23# ls
aead.ko                    iptable_filter.ko          nf_reject_ipv4.ko
arc4.ko                    iptable_mangle.ko          nf_reject_ipv6.ko
ath.ko                     iptable_nat.ko             ppp_async.ko
ath9k.ko                   iptable_raw.ko             ppp_generic.ko
ath9k_common.ko            ipv6.ko                    pppoatm.ko
ath9k_hw.ko                ledtrig-usbdev.ko          pppoe.ko
atm.ko                     ltq_atm_vr9.ko             pppox.ko
br2684.ko                  ltq_deu_vr9.ko             slhc.ko
cfg80211.ko                ltq_ptm_vr9.ko             x_tables.ko
compat.ko                  lz4_compress.ko            xt_CT.ko
crc-ccitt.ko               lz4_decompress.ko          xt_LOG.ko
crypto_blkcipher.ko        mac80211.ko                xt_REDIRECT.ko
drv_dsl_cpe_api.ko         nf_conntrack.ko            xt_TCPMSS.ko
drv_ifxos.ko               nf_conntrack_ftp.ko        xt_comment.ko
drv_mei_cpe.ko             nf_conntrack_ipv4.ko       xt_conntrack.ko
dwc2.ko                    nf_conntrack_ipv6.ko       xt_id.ko
dwc2_platform.ko           nf_conntrack_rtcache.ko    xt_limit.ko
gpio-button-hotplug.ko     nf_defrag_ipv4.ko          xt_mac.ko
ip6_tables.ko              nf_defrag_ipv6.ko          xt_mark.ko
ip6t_REJECT.ko             nf_log_common.ko           xt_multiport.ko
ip6table_filter.ko         nf_log_ipv4.ko             xt_nat.ko
ip6table_mangle.ko         nf_log_ipv6.ko             xt_state.ko
ip6table_raw.ko            nf_nat.ko                  xt_tcpudp.ko
ip_tables.ko               nf_nat_ftp.ko              xt_time.ko
ipt_MASQUERADE.ko          nf_nat_ipv4.ko             zram.ko
ipt_REJECT.ko              nf_nat_masquerade_ipv4.ko  zsmalloc.ko
root@OpenWrt:/lib/modules/3.18.23# tar c * >/dev/null
tar: read error: Input/output error
root@OpenWrt:/lib/modules/3.18.23# logread
.....
Thu Nov 17 17:32:53 2016 kern.err kernel: [ 1352.888000] SQUASHFS error: xz decompression failed, data probably corrupt
Thu Nov 17 17:32:53 2016 kern.err kernel: [ 1352.896000] SQUASHFS error: squashfs_read_data failed to read block 0xc236e

Problem was resolved by flashing sysupgrade image in cli interface (sysupgrade).
Be careful, probably writing to mtdblock1 ended up with not-enough-space error leaves corrupted data on the flash.
IMO It will be better to flash exactly the same sized first part of image onto /dev/mtdblock1.
Prepare both parts:

dd if=openwrt-15.05.1-lantiq-xrx200-TDW8970-sysupgrade.image of=openwrt-15.05.1-lantiq-xrx200-TDW8970-sysupgrade-0.image bs=1310720 count=1 
dd if=openwrt-15.05.1-lantiq-xrx200-TDW8970-sysupgrade.image of=openwrt-15.05.1-lantiq-xrx200-TDW8970-sysupgrade-1.image bs=1310720 skip=1

copy both parts on USB stick and flash it onto mtd partitions accordingly:

cat /var/usbdisk/sda1/openwrt-15.05.1-lantiq-xrx200-TDW8970-sysupgrade-0.image > /dev/mtdblock1
cat /var/usbdisk/sda1/openwrt-15.05.1-lantiq-xrx200-TDW8970-sysupgrade-1.image > /dev/mtdblock2

Snakus

This is MY mistake.
I flashed your image from Yesterday 17:29:19 then tried to setup.
As I don't use virtual LAN, I removed VLAN in the GUI. Very bad, no LAN any more.
I started the box in failsave mode

ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
64 bytes from 192.168.1.1: icmp_seq=1 ttl=64 time=0.177 ms
64 bytes from 192.168.1.1: icmp_seq=2 ttl=64 time=0.180 ms
^C
--- 192.168.1.1 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1031ms
rtt min/avg/max/mdev = 0.177/0.178/0.180/0.013 ms

$ telnet 192.168.1.1
Trying 192.168.1.1...
telnet: connect to address 192.168.1.1: Connection refused

$ telnet 192.168.1.1 80
Trying 192.168.1.1...
telnet: connect to address 192.168.1.1: Connection refused

$ telnet
telnet> open 192.168.1.1 80
Trying 192.168.1.1...
telnet: connect to address 192.168.1.1: Connection refused
telnet> open 192.168.1.1
Trying 192.168.1.1...
telnet: connect to address 192.168.1.1: Connection refused

The box is in failsafe mode but I can't telnet it.
Any idea how to connect to it? It should accept telnet, I did it previously.

factory reset with reset button
press button and switch it on keeping reset button pressed around 10 sec

Snakus

Thank you very much, I appreciate all the help you gave me.
Now it' working well.
FYI network config, I deleted ATM conf as I use PPPoE
USB share is working
CRON is working
So I am happy with that thanks to you

cat /etc/config/network

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fd9a:764d:06c8::/48'

config dsl 'dsl'
    option xfer_mode 'ptm'
    option annex 'b'
    option line_mode 'vdsl'

config interface 'lan'
    option type 'bridge'
    option ifname 'eth0.1'
    option proto 'static'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option ipaddr '192.168.0.1'

config interface 'wan'
    option ifname 'ptm0.10'
    option proto 'pppoe'
    option ipv6 'auto'
    option username '???@vodafone.ie'
    option password '???'

config device 'wan_dev'
    option name 'ptm0'
    option macaddr 'c4:6e:1f:74:11:11'

config interface 'wan6'
    option ifname 'pppoe-wan'
    option proto 'dhcpv6'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0 2 4 5 6t'
xssa wrote:

Today I have an adventure to follow s7mx1's guide and flash my TD-W8970. After flashing my Tp-link was near the brick state due corrupted squashfs partition. Thanks God this corruption was not fatal and device booted with network interface, sshd and dhcpd but all kernel modules are not readable with strange squashfs read errors in logs:
Problem was resolved by flashing sysupgrade image in cli interface (sysupgrade).
Be careful, probably writing to mtdblock1 ended up with not-enough-space error leaves corrupted data on the flash.
IMO It will be better to flash exactly the same sized first part of image onto /dev/mtdblock1.

No, I don't think this will be the case. The boundary and extent of that device is being policed by the kernel, as long as the size you use for the second slice is adjusted appropriately then everything should be fine.  The not-enough-space error just means you've exceeded the bounds of mtdblock1 [if you think about it, if it was this easy to corrupt flash, then there'd be bugs all over the place just because someone seek'ed to the wrong part of the device]

I think what's more likely is that this method is highly sensitive to the contents of at least one of the other flash partitions - probably there is something left on the config partition (mtd3) that causes subsequent boots to fail.

Snakus

There is an issue with the config running LEDE
It's working fine however, there was a drop on the WAN line this night. I presume this is a provider outage.
This morning the modem was not connected and I did a reboot to get it back.
I'd guess the line status should be tested every x seconds to bring back DSL up. I tried to fine a faulty setting but everything looks good.
Is there something I miss or is there a bug?
Let me know if you need more info

cat /etc/config/network 

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fd9a:764d:06c8::/48'

config dsl 'dsl'
    option xfer_mode 'ptm'
    option annex 'b'
    option line_mode 'vdsl'

config interface 'lan'
    option type 'bridge'
    option ifname 'eth0.1'
    option proto 'static'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option ipaddr '192.168.0.1'

config interface 'wan'
    option ifname 'ptm0.10'
    option proto 'pppoe'
    option ipv6 'auto'
    option username '????@vodafone.ie'
    option password '????'

config device 'wan_dev'
    option name 'ptm0'
    option macaddr 'c4:6e:1f:74:11:11'

config interface 'wan6'
    option ifname 'pppoe-wan'
    option proto 'dhcpv6'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0 2 4 5 6t'
dmesg
...
Tue Nov 22 01:25:08 2016 daemon.info dnsmasq-dhcp[2005]: DHCPREQUEST(br-lan) 192.168.0.115 00:17:a4:...
Tue Nov 22 01:25:08 2016 daemon.info dnsmasq-dhcp[2005]: DHCPACK(br-lan) 192.168.0.115 00:17:a4:d2:b9...
Tue Nov 22 06:42:19 2016 daemon.info dnsmasq-dhcp[2005]: DHCPREQUEST(br-lan) 192.168.0.115 00:17:a...
Tue Nov 22 06:42:19 2016 daemon.info dnsmasq-dhcp[2005]: DHCPACK(br-lan) 192.168.0.115 00:17:a4:d...
Tue Nov 22 08:35:34 2016 kern.warn kernel: [82954.144191] leave showtime
Tue Nov 22 08:35:34 2016 daemon.notice netifd: Network device 'ptm0' link is down
Tue Nov 22 08:35:34 2016 daemon.notice netifd: VLAN 'ptm0.10' link is down
Tue Nov 22 08:35:34 2016 daemon.notice netifd: Interface 'wan' has link connectivity loss
Tue Nov 22 08:35:34 2016 daemon.notice netifd: Interface 'wan_6' is now down
Tue Nov 22 08:35:34 2016 daemon.notice netifd: Network alias '' link is down
Tue Nov 22 08:35:34 2016 daemon.notice netifd: Interface 'wan_6' has link connectivity loss
Tue Nov 22 08:35:34 2016 daemon.notice netifd: Interface 'wan_6' is disabled
Tue Nov 22 08:35:34 2016 daemon.warn dnsmasq[2005]: no servers found in /tmp/resolv.conf.auto, will retry
Tue Nov 22 08:35:34 2016 daemon.info pppd[1839]: Terminating on signal 15
Tue Nov 22 08:35:34 2016 daemon.info pppd[1839]: Connect time 1381.7 minutes.
Tue Nov 22 08:35:34 2016 daemon.info pppd[1839]: Sent 302041292 bytes, received 1697747989 bytes.
Tue Nov 22 08:35:34 2016 daemon.notice netifd: Network device 'pppoe-wan' link is down
Tue Nov 22 08:35:34 2016 daemon.notice netifd: Interface 'wan6' has link connectivity loss
Tue Nov 22 08:35:37 2016 daemon.info dnsmasq[2005]: exiting on receipt of SIGTERM
Tue Nov 22 08:35:37 2016 daemon.info dnsmasq[6383]: started, version 2.76 cachesize 150
Tue Nov 22 08:35:37 2016 daemon.info dnsmasq[6383]: compile time options: IPv6 GNU-getopt no-DBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack no-ipset no-auth no-DNSSEC no-ID loop-detect inotify
Tue Nov 22 08:35:37 2016 daemon.info dnsmasq[6383]: DNS service limited to local subnets
Tue Nov 22 08:35:37 2016 daemon.info dnsmasq-dhcp[6383]: DHCP, IP range 192.168.0.100 -- 192.168.0.229, lease time 12h
Tue Nov 22 08:35:37 2016 daemon.info dnsmasq[6383]: using nameserver 89.19.64.164#53
Tue Nov 22 08:35:37 2016 daemon.info dnsmasq[6383]: using nameserver 89.19.64.36#53
Tue Nov 22 08:35:37 2016 daemon.info dnsmasq[6383]: using local addresses only for domain lan
Tue Nov 22 08:35:37 2016 daemon.warn dnsmasq[6383]: no servers found in /tmp/resolv.conf.auto, will retry
Tue Nov 22 08:35:37 2016 daemon.info dnsmasq[6383]: read /etc/hosts - 4 addresses
Tue Nov 22 08:35:37 2016 daemon.info dnsmasq[6383]: read /tmp/hosts/dhcp.cfg02411c - 3 addresses
Tue Nov 22 08:35:37 2016 daemon.info dnsmasq-dhcp[6383]: read /etc/ethers - 0 addresses
Tue Nov 22 08:35:39 2016 daemon.notice netifd: Interface 'wan6' is disabled
Tue Nov 22 09:56:02 2016 kern.info kernel: [87782.504039] eth0: port 0 lost link
Tue Nov 22 09:56:04 2016 kern.info kernel: [87784.503998] eth0: port 0 got link
Tue Nov 22 09:56:06 2016 daemon.warn odhcpd[874]: DHCPV6 CONFIRM IA_NA from 0004776d948f5b5be5c0c0792aaf35fddcbf on br-lan: not on-link fd9a:764d:6a8::ab4/128 
Tue Nov 22 09:56:06 2016 daemon.info dnsmasq[6383]: read /etc/hosts - 4 addresses
Tue Nov 22 09:56:06 2016 daemon.info dnsmasq[6383]: read /tmp/hosts/dhcp.cfg02411c - 3 addresses
Tue Nov 22 09:56:06 2016 daemon.info dnsmasq-dhcp[6383]: read /etc/ethers - 0 addresses
Tue Nov 22 09:56:06 2016 daemon.warn odhcpd[874]: DHCPV6 SOLICIT IA_NA from 0004776d948f5b5be5c0c0792aaf35fddcbf on br-lan: ok fd9a:764d:6c8::ab4/128 
Tue Nov 22 09:56:07 2016 daemon.warn odhcpd[874]: DHCPV6 REQUEST IA_NA from 0004776d948f5b5be5c0c0792aaf35fddcbf on br-lan: ok fd9a:764d:6c8::ab4/128 
Tue Nov 22 09:56:07 2016 daemon.info dnsmasq[6383]: read /etc/hosts - 4 addresses
Tue Nov 22 09:56:07 2016 daemon.info dnsmasq[6383]: read /tmp/hosts/dhcp.cfg02411c - 3 addresses
Tue Nov 22 09:56:07 2016 daemon.info dnsmasq-dhcp[6383]: read /etc/ethers - 0 addresses
Tue Nov 22 09:56:11 2016 daemon.info dnsmasq-dhcp[6383]: DHCPDISCOVER(br-lan) 192.168.0.110 bc:5f:...
Tue Nov 22 09:56:11 2016 daemon.info dnsmasq-dhcp[6383]: DHCPOFFER(br-lan) 192.168.0.110 bc:5f...
Tue Nov 22 09:56:11 2016 daemon.info dnsmasq-dhcp[6383]: DHCPREQUEST(br-lan) 192.168.0.110 bc:5f:...
Tue Nov 22 09:56:11 2016 daemon.info dnsmasq-dhcp[6383]: DHCPACK(br-lan) 192.168.0.110 bc:5f:f4:3...
Tue Nov 22 09:57:25 2016 daemon.err uhttpd[1688]: sh: write error: Broken pipe
Tue Nov 22 09:57:25 2016 daemon.err uhttpd[1688]: sh: write error: Broken pipe
Tue Nov 22 09:57:25 2016 daemon.err uhttpd[1688]: sh: write error: Broken pipe
Tue Nov 22 09:57:25 2016 daemon.err uhttpd[1688]: sh: write error: Broken pipe
Tue Nov 22 09:57:25 2016 daemon.err uhttpd[1688]: sh: write error: Broken pipe
...