OpenWrt Forum Archive

Topic: Tp-Link td-w8970

The content of this topic has been archived between 26 Mar 2018 and 7 May 2018. Unfortunately there are posts – most likely complete pages – missing.

echza wrote:

... Can we flash this image directly from luci interface?

No download that image.
Copy to /tmp as "code.bin" (using WinSCP or SCP)
Then log to the router using putty and use command:
sysupgrade -n /tmp/code.bin

After about 2 minutes upgrade will be completed and router will reboot itself.

Warning: do not interrupt this process, using -n parameter is the safest way, but it erase all your settings.

Edit: Do not use Wifi connection, only LAN connection is safe for upgrading of any router smile

(Last edited by Scotch's on 28 Oct 2015, 00:59)

Hi all.

New to OpenWRT.

Got it on my router successfully smile v1.x

I would like to know if there is a way to get adsl line stats(max sync rates mostly). I know telnet is an option, but I cannot seem to get that working.

I would like to log a call with my ISP so I can show them my line can sync higher than its current rate.

Sorry if this has been covered in this topic.

Thanks in advance

O

Hi all,

I have install official openwrt release on TD9980 from
https://downloads.openwrt.org/chaos_cal … rade.image

WiFi seem to be unusable because ath9 doesn't recognize the right adapter.

CHAOS CALMER (15.05, r46767)

root@OpenWrt:/# lspci
00:00.0 PCI bridge: Device 1bef:0011 (rev 01)
01:00.0 Ethernet controller: Qualcomm Atheros AR5008 Wireless Network Adapter (rev 01)


With CHAOS CALMER (Bleeding Edge, r46384) image from this forum:

root@OpenWrt:/etc/config# lspci
00:00.0 PCI bridge: Device 1bef:0011 (rev 01)
01:00.0 Ethernet controller: Qualcomm Atheros AR9287 Wireless Network Adapter (PCI-Express) (rev 01)


https://dev.openwrt.org/changeset/46869 is not include in release ?

(Last edited by jcmichot on 30 Oct 2015, 10:03)

Thanks, i have compile my own OpenWrt with today (r47280 trunk), and WiFi is ok (but without 5Mhz).

BTW except binary with patches you can download (from this forum), only trunk support WiFi for TD 9980.

That's right support/patches for Wifi (models TD-W8980 and TD-W9980) as well as new xdsl driver support were added after CC official release.
Regarding the 5GHz WiFi support you must search for information in other threads (for TD-W8980 and TD-W9980) - as this is for TD-W8970 only.

@Orion8703

The easiest way to get more adsl/vdsl connection details is to compile DD trunk image by your own, or use one of ready images.
Because more information about line status was added https://dev.openwrt.org/changeset/46917 also in trunk support for new xdsl fimware and drivers was added:  https://dev.openwrt.org/changeset/46920
Below an example of my vdsl line information:

root@modem:~# /etc/init.d/dsl_control status
ATU-C Vendor ID:                          B5,00,42,44,43,4D,A3,AA
ATU-C System Vendor ID:                   B5,00,42,44,43,4D,00,00
Chipset:                                  Lantiq-VRX200 Unknown
Firmware Version:                         5.7.4.3.0.6
API Version:                              4.16.2.4
XTSE Capabilities:                        0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x2
Annex:                                    B
Line Mode:                                G.993.2 (VDSL2)
Line State:                               UP [0x801: showtime_tc_sync]
Forward Error Correction Seconds (FECS):  Near: 0 / Far: 0
Errored seconds (ES):                     Near: 0 / Far: 4225
Severely Errored Seconds (SES):           Near: 0 / Far: 5
Loss of Signal Seconds (LOSS):            Near: 0 / Far: 0
Unavailable Seconds (UAS):                Near: 108 / Far: 108
Header Error Code Errors (HEC):           Near: 0 / Far: 0
Non Pre-emtive CRC errors (CRC_P):        Near: 0 / Far: 0
Pre-emtive CRC errors (CRCP_P):           Near: 0 / Far: 0
Power Management Mode:                    L0 - Synchronized
Latency / Interleave Delay:               Down: Interleave (8.0 ms) / Up: Interleave (8.0 ms)
Data Rate:                                Down: 59.968 Mb/s / Up: 8.568 Mb/s
Line Attenuation (LATN):                  Down: 17.1dB / Up: 19.4dB
Signal Attenuation (SATN):                Down: 17.1dB / Up: 19.6dB
Noise Margin (SNR):                       Down: 10.8dB / Up: 10.0dB
Aggregate Transmit Power(ACTATP):         Down: -11.0dB / Up: 14.6dB
Max. Attainable Data Rate (ATTNDR):       Down: 82.498 Mb/s / Up: 10.366 Mb/s
Line Uptime Seconds:                      40
Line Uptime:                              40s
root@modem:~#

(Last edited by Scotch's on 31 Oct 2015, 12:23)

Scotch's wrote:

@Orion8703

The easiest way to get more adsl/vdsl connection details is to compile DD trunk image by your own, or use one of ready images.
Because more information about line status was added https://dev.openwrt.org/changeset/46917 also in trunk support for new xdsl fimware and drivers was added:  https://dev.openwrt.org/changeset/46920
Below an example of my vdsl line information:

root@modem:~# /etc/init.d/dsl_control status
ATU-C Vendor ID:                          B5,00,42,44,43,4D,A3,AA
ATU-C System Vendor ID:                   B5,00,42,44,43,4D,00,00
Chipset:                                  Lantiq-VRX200 Unknown
Firmware Version:                         5.7.4.3.0.6
API Version:                              4.16.2.4
XTSE Capabilities:                        0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x2
Annex:                                    B
Line Mode:                                G.993.2 (VDSL2)
Line State:                               UP [0x801: showtime_tc_sync]
Forward Error Correction Seconds (FECS):  Near: 0 / Far: 0
Errored seconds (ES):                     Near: 0 / Far: 4225
Severely Errored Seconds (SES):           Near: 0 / Far: 5
Loss of Signal Seconds (LOSS):            Near: 0 / Far: 0
Unavailable Seconds (UAS):                Near: 108 / Far: 108
Header Error Code Errors (HEC):           Near: 0 / Far: 0
Non Pre-emtive CRC errors (CRC_P):        Near: 0 / Far: 0
Pre-emtive CRC errors (CRCP_P):           Near: 0 / Far: 0
Power Management Mode:                    L0 - Synchronized
Latency / Interleave Delay:               Down: Interleave (8.0 ms) / Up: Interleave (8.0 ms)
Data Rate:                                Down: 59.968 Mb/s / Up: 8.568 Mb/s
Line Attenuation (LATN):                  Down: 17.1dB / Up: 19.4dB
Signal Attenuation (SATN):                Down: 17.1dB / Up: 19.6dB
Noise Margin (SNR):                       Down: 10.8dB / Up: 10.0dB
Aggregate Transmit Power(ACTATP):         Down: -11.0dB / Up: 14.6dB
Max. Attainable Data Rate (ATTNDR):       Down: 82.498 Mb/s / Up: 10.366 Mb/s
Line Uptime Seconds:                      40
Line Uptime:                              40s
root@modem:~#

Thank you sir, I will look into that smile

echza wrote:

I used this image (chaos calmer) :
http://dl.eko.one.pl/chaos_calmer/lanti … rade.image
when you boot the image the size of the binary size is shown below the line.  its hexadecimal number something like: 486755
so when writing to flash instead 680004 (i mean 0x680004) you should use like in our example (0x486755)

Does it mean that all other addresses stay intact? The only address that needs to be adjusted is the image size 0x680004 when you write to flash (step F)?

d. Download the image into RAM (*not* flash):
tftpboot 0x80800000 openwrt-lantiq-xrx200-TDW8970-sysupgrade.image
e. Erase the rootfs flash area:
sf erase 0x20000 0x7a0000
f. Write image to flash:
sf write 0x80800000 0x20000 0x680004

I m nub in Linux...

Yes, only this part must be change:

I followed instructions from here: http://tplink-forum.pl/porady-serwisowe … /#msg20225

Connect your router and computer with LAN cable and USB->TTL converter (GND->GND, RX->TX, TX->RX)
Set static IP for your computer's network card: 192.168.1.100
Run putty (serial settings: 115200 8n1) - of couse the same setting should have installed converter.
Run tftpd server ("tftpd32" for Winows or "atftpd" for Linux) and copy image file (openwrt-lantiq-xrx200-TDW8970-sysupgrade.image) to server's main folder

Turn on the router and hit "t" until you stop booting process:

ROM VER: 1.1.4
CFG 05

ROM VER: 1.1.4
CFG 05

DDR autotuning Rev 0.3ff
DDR size from 0xa0000000 - 0xa3ffffff
DDR check ok... start booting...



U-Boot 2010.06-LANTIQ-v-2.0.40-svn4469 (Aug 28 2013 - 09:28:56)

CLOCK CPU 500M RAM 250M
DRAM:  64 MiB
Using default environment

In:    serial
Out:   serial
Err:   serial
Net:   Internal phy(GE) firmware version: 0x8434
vr9 Switch8192 KiB W25Q64 at 0:3 is now current device


Type "run flash_nfs" to mount root filesystem over NFS

Hit any key to stop autoboot:  0
VR9 #

Paste in putty command:

tftpboot 0x80800000 openwrt-lantiq-xrx200-TDW8970-sysupgrade.image

You'll see someting like that:

VR9 # tftpboot 0x80800000 openwrt-lantiq-xrx200-TDW8970-sysupgrade.image
8192 KiB W25Q64 at 0:3 is now current device
Using vr9 Switch device
TFTP from server 192.168.1.100; our IP address is 192.168.1.1
Filename 'openwrt-lantiq-xrx200-TDW8970-sysupgrade.image'.
Load address: 0x80800000
Loading: #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         ################################################
done
Bytes transferred = 6422532 (620004 hex)

Now the image file is loaded to router's RAM
Next step is to erase official firmware, putty command:

sf erase 0x20000 0x7a0000

And you'll see:

VR9 # sf erase 0x20000 0x7a0000

...
Successfully erased 7995392 bytes @ 0x20000

Now it's time to write image from router's RAM:

sf write 0x80800000 0x20000 0x620004

Please note: you must change this part of command "0x620004" to the proper hex value (received while image was transfered to RAM).

You'll see something like that:

VR9 # sf write 0x80800000 0x20000 0x620004

..................................................................................................
Successfully programmed 6422532 bytes @ 0x20000
VR9 #

Now you have to type:

reset

That's all folks. Router should reboot and start openwrt.

(Last edited by Scotch's on 3 Nov 2015, 13:29)

Scotch's wrote:

Yes, only this part must be change:
I followed instructions from here: http://tplink-forum.pl/porady-serwisowe … /#msg20225
That's all folks. Router should reboot and start openwrt.

Thanks. It makes more sense now.
Official page needs to be updated...

Scotch's wrote:

@Orion8703

The easiest way to get more adsl/vdsl connection details is to compile DD trunk image by your own, or use one of ready images.
Because more information about line status was added https://dev.openwrt.org/changeset/46917 also in trunk support for new xdsl fimware and drivers was added:  https://dev.openwrt.org/changeset/46920
Below an example of my vdsl line information:

root@modem:~# /etc/init.d/dsl_control status
ATU-C Vendor ID:                          B5,00,42,44,43,4D,A3,AA
ATU-C System Vendor ID:                   B5,00,42,44,43,4D,00,00
Chipset:                                  Lantiq-VRX200 Unknown
Firmware Version:                         5.7.4.3.0.6
API Version:                              4.16.2.4
XTSE Capabilities:                        0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x2
Annex:                                    B
Line Mode:                                G.993.2 (VDSL2)
Line State:                               UP [0x801: showtime_tc_sync]
Forward Error Correction Seconds (FECS):  Near: 0 / Far: 0
Errored seconds (ES):                     Near: 0 / Far: 4225
Severely Errored Seconds (SES):           Near: 0 / Far: 5
Loss of Signal Seconds (LOSS):            Near: 0 / Far: 0
Unavailable Seconds (UAS):                Near: 108 / Far: 108
Header Error Code Errors (HEC):           Near: 0 / Far: 0
Non Pre-emtive CRC errors (CRC_P):        Near: 0 / Far: 0
Pre-emtive CRC errors (CRCP_P):           Near: 0 / Far: 0
Power Management Mode:                    L0 - Synchronized
Latency / Interleave Delay:               Down: Interleave (8.0 ms) / Up: Interleave (8.0 ms)
Data Rate:                                Down: 59.968 Mb/s / Up: 8.568 Mb/s
Line Attenuation (LATN):                  Down: 17.1dB / Up: 19.4dB
Signal Attenuation (SATN):                Down: 17.1dB / Up: 19.6dB
Noise Margin (SNR):                       Down: 10.8dB / Up: 10.0dB
Aggregate Transmit Power(ACTATP):         Down: -11.0dB / Up: 14.6dB
Max. Attainable Data Rate (ATTNDR):       Down: 82.498 Mb/s / Up: 10.366 Mb/s
Line Uptime Seconds:                      40
Line Uptime:                              40s
root@modem:~#

I looked into the link you posted and instead of building a new trunk image, I just used WinSCP and navigated to /lib/functions/ and replaced the lantiq_dsl.sh file with the one from the trunk link. It was one of the few files that was edited in the lantiq/base files directory in comparison with my routers own files.

Gave the desired information.

Thank you

root@OpenWrt:~# /etc/init.d/dsl_control status
ATU-C Vendor ID:                          B5,00,49,46,54,4E,70,F3
ATU-C System Vendor ID:                   00,00,30,30,30,30,00,00
Chipset:                                  Lantiq-VRx Unknown
Firmware Version:                         5.5.2.0.1.1
API Version:                              4.11.4
XTSE Capabilities:                        0x0, 0x0, 0x0, 0x0, 0x0, 0x1, 0x0, 0x0
Annex:                                    A
Line Mode:                                G.992.5 (ADSL2+)
Line State:                               UP [0x801: showtime_tc_sync]
Forward Error Correction Seconds (FECS):  Near: 0 / Far: 0
Errored seconds (ES):                     Near: 28 / Far: 0
Severely Errored Seconds (SES):           Near: 0 / Far: 0
Loss of Signal Seconds (LOSS):            Near: 0 / Far: 0
Unavailable Seconds (UAS):                Near: 66 / Far: 66
Header Error Code Errors (HEC):           Near: 25 / Far: 0
Non Pre-emtive CRC errors (CRC_P):        Near: 0 / Far: 0
Pre-emtive CRC errors (CRCP_P):           Near: 0 / Far: 0
Power Management Mode:                    L0 - Synchronized
Latency / Interleave Delay:               Down: Interleave (0.0 ms) / Up: Interl                    eave (0.0 ms)
Data Rate:                                Down: 4.092 Mb/s / Up: 508 Kb/s
Line Attenuation (LATN):                  Down: 11.9dB / Up: 6.2dB
Signal Attenuation (SATN):                Down: 11.6dB / Up: 6.2dB
Noise Margin (SNR):                       Down: 22.9dB / Up: 2.9dB
Aggregate Transmit Power(ACTATP):         Down: -9.-1dB / Up: 12.4dB
Max. Attainable Data Rate (ATTNDR):       Down: 13.124 Mb/s / Up: 1.280 Mb/s
Line Uptime Seconds:                      364283
Line Uptime:                              4d 5h 11m 23s

(Last edited by Orion8703 on 25 Nov 2015, 12:51)

Scotch's wrote:

@echza
For all users, who have problems with USB devices under Chaos Calmer I recommend to use compilation prepared by lpm11 - latest you can find here: http://www.speedyshare.com/NcfrB/W8970.image
It's still Barrier Breaker based - as there is a problem with memory leak caused by dwc2 driver under Chaos Calmer, which results disconnecting USB.
At the moment lpm11's compilations are the best solution for this router - you have 3,23 MB free space in flash (lpm11 removed unnecessary partition reserved for xdsl firmware).

I've installed this image today. Tested few main things and came across issue with DSL connection.
Can you confrim that the image has DSL driver inbuilt? I m just trying to figure out if configuration is wrong or driver is missing...

Yes this image contains adsl/vdsl driver firmware (vdsl.bin - for annex A).
If your line is annex B you need to replace vdsl.bin

Edit:

This may help you: https://wiki.openwrt.org/toh/zyxel/p2812hnu-fx

Regards

(Last edited by Scotch's on 1 Dec 2015, 20:03)

opeFisher wrote:
Scotch's wrote:

@echza
For all users, who have problems with USB devices under Chaos Calmer I recommend to use compilation prepared by lpm11 - latest you can find here: http://www.speedyshare.com/NcfrB/W8970.image
It's still Barrier Breaker based - as there is a problem with memory leak caused by dwc2 driver under Chaos Calmer, which results disconnecting USB.
At the moment lpm11's compilations are the best solution for this router - you have 3,23 MB free space in flash (lpm11 removed unnecessary partition reserved for xdsl firmware).

I've installed this image today. Tested few main things and came across issue with DSL connection.
Can you confrim that the image has DSL driver inbuilt? I m just trying to figure out if configuration is wrong or driver is missing...

Do you use ADSL or VDSL line? ADSL line is easy to install via luci interface. If you use VDSL you can use my configuration file:

/etc/config/network

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fde0:1189:8555::/48'

config interface 'lan'
    option force_link '1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option ifname 'eth0.1'
    option macaddr '00:00:00:00:00:00'

config interface 'wan'
    option ifname 'ptm0.35'
    option encaps 'vc'
    option delegate '0'
    option proto 'pppoe'
    option username 'ispusername'
    option password 'isppassword'
    option ipv6 '0'
    option macaddr '00:00:00:00:00:00'
    option peerdns '0'
    option dns '8.8.8.8 8.8.4.4'

config vdsl 'dsl'
    option annex 'a'
    option firmware '/lib/firmware/vdsl.bin'
    option tone 'av'
    option xfer_mode 'ptm'

config switch_vlan
    option device 'ptm0'
    option vlan '35'
    option vid '35'

(Last edited by echza on 1 Dec 2015, 16:54)

Thanks guys. It works now. The problem was (as I think) the last line at

config vdsl 'dsl'
    option annex 'a'
    option firmware '/lib/firmware/vdsl.bin'
    option tone 'av'
    option xfer_mode 'atm'

instead of 'atm' I had 'vtm'. Not sure what it means though sad Any way it works

Hi again.
The thing is working but does some strange behavior. First of all, it brakes adsl connection. Second, the speed is 2 times lower then before.
What might be wrong? Is it dodgy driver or wrong config?

root@OpenWrt:~# /etc/init.d/dsl_control status
Chipset:                Lantiq-VRx Unknown
Line State:             UP [0x801: showtime_tc_sync]
Data Rate:              664 Kb/s / 648 Kb/s
Line Attenuation:       58.2dB / 38.8dB
Noise Margin:           13.6dB / 12.0dB
Line Uptime:            59s

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fde5:f7e2:162a::/48'

config interface 'lan'
    option force_link '1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option ifname 'eth0.1'
    option macaddr '64:66:b3:b0:84:a0'

config switch
    option name 'switch0'
    option reset '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0t 1t 2t 3t 4t 5t 6t'
    option vid '1'

config atm-bridge 'atm'
    option vci '35'
    option encaps 'llc'
    option payload 'bridged'
    option vpi '8'

config interface 'wan'
    option ifname 'nas0'
    option proto 'pppoe'
    option macaddr '64:66:b3:b0:84:a1'
    option username '***'
    option password '***'
    option delegate '0'
    option mtu '1480'

config interface 'wan6'
    option ifname '@wan'
    option proto 'dhcpv6'

config vdsl 'dsl'
    option annex 'a'
    option firmware '/lib/firmware/vdsl.bin'
    option tone 'av'
    option xfer_mode 'atm'

(Last edited by opeFisher on 10 Dec 2015, 15:22)

Hi
I dont' know what's appening. My lantency in upload is really high, if i use the Vodafone station it's 15ms less! The upload sync speed is lower of about 5Mbits. If i do a speed test, the result in download is moore that the sync speed. What's app? Can i see somewhere what kind of vdsl profile i'm using?  Are there any patch i need to apply? I've only compiled the last trunk  and set the /ect/config/network file.

Chipset: Lantiq-VRX200 Unknown
Firmware Version: 5.7.4.3.0.6
API Version: 4.16.6.3
XTSE Capabilities: 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x2
Annex: B
Line Mode: G.993.2 (VDSL2)
Line State: UP [0x801: showtime_tc_sync]
Forward Error Correction Seconds (FECS): Near: / Far:
Errored seconds (ES): Near: 0 / Far: 10
Severely Errored Seconds (SES): Near: 0 / Far: 0
Loss of Signal Seconds (LOSS): Near: 0 / Far: 0
Unavailable Seconds (UAS): Near: 31 / Far: 31
Header Error Code Errors (HEC): Near: 0 / Far: 0
Non Pre-emtive CRC errors (CRC_P): Near: 0 / Far: 0
Pre-emtive CRC errors (CRCP_P): Near: 0 / Far: 0
Power Management Mode: L0 - Synchronized
Latency / Interleave Delay: Down: Interleave (0.16 ms) / Up: Interleave (16.0 ms)
Data Rate: Down: 54.537 Mb/s / Up: 16.212 Mb/s
Line Attenuation (LATN): Down: 17.0dB / Up: 28.5dB
Signal Attenuation (SATN): Down: 17.0dB / Up: 28.0dB
Noise Margin (SNR): Down: 6.1dB / Up: 5.8dB
Aggregate Transmit Power(ACTATP): Down: -1.-6dB / Up: 14.6dB
Max. Attainable Data Rate (ATTNDR): Down: 62.621 Mb/s / Up: 16.175 Mb/s
Line Uptime Seconds: 0
Line Uptime: down

Settings:

config vdsl 'dsl'
option annex 'a'
option firmware '/lib/firmware/vdsl.bin'
option tone 'av'
option xfer_mode 'ptm'

(Last edited by oressac on 10 Dec 2015, 16:18)

oressac wrote:

Hi
I dont' know what's appening. My lantency in upload is really high, if i use the Vodafone station it's 15ms less! The upload sync speed is lower of about 5Mbits. If i do a speed test, the result in download is moore that the sync speed. What's app? Can i see somewhere what kind of vdsl profile i'm using?  Are there any patch i need to apply? I've only compiled the last trunk  and set the /ect/config/network file.

Are you using Annex A or B?
I m reading this now https://wiki.openwrt.org/doc/howto/internet.connection

opeFisher wrote:
oressac wrote:

Hi
I dont' know what's appening. My lantency in upload is really high, if i use the Vodafone station it's 15ms less! The upload sync speed is lower of about 5Mbits. If i do a speed test, the result in download is moore that the sync speed. What's app? Can i see somewhere what kind of vdsl profile i'm using?  Are there any patch i need to apply? I've only compiled the last trunk  and set the /ect/config/network file.

Are you using Annex A or B?
I m reading this now https://wiki.openwrt.org/doc/howto/internet.connection

I've tried both of them. I don't know what else to do.

Hi, with OpenWRT is possible to change the SNR value on this modem?

TheGiolly wrote:

Hi, with OpenWRT is possible to change the SNR value on this modem?

Hard to say I tried several times with my vdsl line - with no luck.
But in this thread: http://www.hwupgrade.it/forum/showthrea … p;page=116 they say it works with new xdsl firmware and drivers.
An example how to change:

vdsl_cpe_control --console
locs 0 -30
acs 2
quit

More commands with descriptions:

vdsl_cpe_control --console
g997csg 0 1
# Check the current sync on the download
g997csg 0 0
# Check the current sync to upload,
locs 0 -20
# To change the target SNR of-2dBm (25 = 2.5 dbm 30 = 3 dBm, etc.)
acs 2
# To force a re-synchronization
g997csg 0 1
# Check the current sync on the download after changes
g997csg 0 0
# Check the current sync to upload, after changes
g997lsg 1 1
# Check snr download
g997lsg 0 1
# Check snr upload
quit
# To exit

Hi guys im new to this all,

Basically i have a w8970, and am stuck on vdsl... with no modem routers in sight or the ones that are available are $200+

Can someone please give me a simple to follow tutorial, i have tried to google some of the programs to use and download but to get weird file names and no executable, cant seem to wrap my head around this as i do not code at all.

I have the .Image file, i cant really source a usb to usb for my modem, but have it connected Ethernet and wifi. Any easy to use programs that can gain access? or if there is one with some lines of codes could i get a hand? My current modem has the best speeds and would be a shame to throw it out for a slower more expensive router due to all this confusion. Many thanks.

(Last edited by wazzuppi on 8 Jan 2016, 04:26)

wazzuppi wrote:

Hi guys im new to this all,

Basically i have a w8970, and am stuck on vdsl... with no modem routers in sight or the ones that are available are $200+

Can someone please give me a simple to follow tutorial, i have tried to google some of the programs to use and download but to get weird file names and no executable, cant seem to wrap my head around this as i do not code at all.

I have the .Image file, i cant really source a usb to usb for my modem, but have it connected Ethernet and wifi. Any easy to use programs that can gain access? or if there is one with some lines of codes could i get a hand? My current modem has the best speeds and would be a shame to throw it out for a slower more expensive router due to all this confusion. Many thanks.

Hi wazzuppi,

I found http://www.pierovdfn.it/2014/08/09/tp-l … 0-openwrt/ the simplest tutorial to follow using google translate

wazzuppi wrote:

Hi guys im new to this all,

Basically i have a w8970, and am stuck on vdsl... with no modem routers in sight or the ones that are available are $200+

Can someone please give me a simple to follow tutorial, i have tried to google some of the programs to use and download but to get weird file names and no executable, cant seem to wrap my head around this as i do not code at all.

I have the .Image file, i cant really source a usb to usb for my modem, but have it connected Ethernet and wifi. Any easy to use programs that can gain access? or if there is one with some lines of codes could i get a hand? My current modem has the best speeds and would be a shame to throw it out for a slower more expensive router due to all this confusion. Many thanks.

Hi. all possible topics were discussed here. Just read it from the beginning.