OpenWrt Forum Archive

Topic: 1043nd 12.09rc1 WIFI drops.

The content of this topic has been archived between 7 Oct 2014 and 27 Apr 2018. Unfortunately there are posts – most likely complete pages – missing.

Hope it helps smile

Version of your WR1043ND: 1.6
Type of the Connection: Ethernet (only used as Accesspoint)
Type of your Modem: I have no modem
Speed of the tests: iperf and normal Android play store downloading, normal browsing 
Type of the Tests: WiFi-to-LAN and reverse
Type of WiFi encryption: WPA2-PSK with AES Encryption (tested also TKIP, issues stays the same, but AES is the latest and should work)
WiFi Channel width/htmode: forced 40Mhz ( because i have to ) / also tested with 20/40 and 20, issues persist, no difference visible
wireless protocol/hwmode: n-mode (with n mode disabled, there are no issues, but a n mode ap, should do N without any flaws)
Type of the WiFi Mode: AP
Speed of the connection:  ~30 Mbps up/down (Samsung Galaxy S2 / S4)
Signal Strength: 80-90%
Which Firmware: openWRT (12.09 and newer), Stock crashes wifi, but with 10.03.1 it's a bit more stable, but sometimes i get failed to stop dma failues with one wifi client.
Firmware Version: with stock firmware every of them crashes, with openwrt 12.09 and newer ones are crap.
U-Boot Version: U-Boot 1.1.4 (Nov 17 2009 - 11:56:26)
What do you do against the problem: only reboot / or powercycle helps
How often does it appear: 2-3 times a week or more in one day, downloading big fils triggers it faster i think, then i got this more than once daily
When does it not appear: doing nothing with it.
changing channels helps: does not help
any other information: no 
any other details: no

Sorry, posts 127 to 125 are missing from our archive.

My problem is that WiFi randomly dissapears or you cant connect.

Version of your WR1043ND: 1.11
Type of the Connection: PPPOE
Type of your Modem: Ubee Modem
Speed of the tests: Speed is fine.
Type of the Tests: Wan-to-WiFi
Type of WiFi encryption: mixed WPA/WPA2 PSK (TKIP, CCMP)
WiFi Channel width/htmode: auto, 40MHz above (doesnt matter if I chose a channel)
wireless protocol/hwmode: n-mode
Type of the WiFi Mode: AP
Speed of the connection: Dont know. Fast enough when it works!
Signal Strength: 60-90%
Which Firmware: openWRT
Firmware Version: 12.09 latest
U-Boot Version: U-Boot 1.1.4 (Nov 17 2009 - 11:56:26)
What do you do against the problem: reboot or just press SCAN in the web module.
How often does it appear: 2-3 times a week or more in one day, mostly at night (not at high speeds).
When does it not appear: always appearsa.
changing channels helps: Doesn't help
any other information: no
any other details: no

(Last edited by mastertje on 7 Nov 2013, 16:05)

Hi,

I was about to buy one of these devices, so it's good to see all this discussion and have it in mind.

However one thing I've noticed and I wanted to point, despite if it's related or not with the issue, is that most of you are using HT40 with 2.4Ghz.
Did you guys check your neighborhood to find out what other people are using and how you are interfering with their signal ?
I see HT40 to be used more in places like a Warehouse, a Point to Point link, Farm area or even in a house where you don't have many neighbors using 2.4Ghz too.

I find it quiet selfish people who try to force the use HT40(disabling wifi scan) without doing a proper survey of what is around them and how they are interfering with others' signals.
Yes, everybody wants their routers to operate at full speed and get the most throughput out of their radios, but I think we are all technical enough to understand what the effects of using HT40 in a dense area are.
Be considerate with people around you and only use it when it is really possible, otherwise I suggest buying a 5Ghz capable router and you will find a much more free spectrum to get higher throughput.

(Last edited by FREDY on 14 Nov 2013, 12:17)

speaking for me, there is no interference from any neighbors. The nearest neighbor  wlan has a very very poor signal and is on channel 10, i am on channel 1, so this should not affect any, the no scan option was a suggestion some time ago, before, i did not have it enabled.

But your point is good, everybody should check this on his self, perhaps it helps 1 or 2 people.

Ronny

I don't know anymore.
I changed all my clients to atheros adapters.
And saturate the connection using Bittorrent as usual.
But no errors yet.
Edit: Got the errors again...

(Last edited by alphasparc on 14 Dec 2013, 14:39)

I have  v1.8 that's been ok since I bought it...2 years ago? But over the last week or so started having real problems with the wireless  dropping out at the edge of the range. Had been able to watch streamed video on my iPad2 for months and then suddenly and then suddenly not.

Played about with channels etc all to no avail. Then this evening I decided to try reverting the only thing that had physically changed – i'd bought a new modem and its power cable was shorter so I'd moved the router all of 4 inches to the right horizontally and put the modem where the router was – moved it back and boom! problems have gone away again. From 1 bar on the ipad back to 4 and streaming movies is working again.

I'm happy but somewhat dumbfounded. Moving router 4 inches closer to the windowsill we'd been sitting the iPad on = wireless dropouts and wireless dying just as other people in the thread describe. Move the router 4 inches further away from the windowsill that's on the far side of the house all of 10 metres away and its fine again.

Conclusion: Wireless is weird.

All can say is yes, the wr1043nd v1.8 running AA does have issues moving a lot of data when the signal gets weak and that does seem to cause the wireless to stop entirely for a few seconds. <cough> Try moving the router....

For me, putting this into /etc/rc.local seems to help in preventing the client connections from dropping:

watch_wlan() {
        while true; do
                iw dev wlan0 scan | grep SSID:
                sleep 5m
        done
}

watch_wlan &

See https://forum.openwrt.org/viewtopic.php?pid=223053, the symptoms I was seeing were:

So after 3 hours suddenly all stations timed out.
Even more interestingly when I do a wireless scan on the web UI, immediately all stations reconnect.

So the workaround now does a scripted wireless scan every 5 minutes and I haven't seen any further client timeout issues.

Hey all,

Whats the latest with this?? Im currently running an old version of the stock firmware, which for some weird reason, needs rebooting every day....

Any progress on this? Does the above workaround work for all?

Hi,

i've also same troubles with the WLAN connection, like it's described in this thread.

My Wireless Config is this one:

config wifi-device 'radio0'
        option type 'mac80211'
        option macaddr 'a0:f3:c1:3c:df:c2'
        option hwmode '11ng'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'DSSS_CCK-40'
        option txpower '20'
        option country 'US'
        option channel '9'
        option noscan '1'
        option bursting '1'
        option ff '1'
        option compression '1'
        option xr '1'
        option ar '1'
        option htmode 'HT40+'

I've just implemented moroboshi's workarroud - let's see if this helps.

As anyone updated his 1043nd from the rc1 to the final release version?
Is there the problem solved?

cu
Ronar

(Last edited by Ronar85 on 18 Feb 2014, 17:31)

Hi,

ok - just implemented the workarround... and now... WLAN drops again ... sad

System Log says the following:

Feb 18 17:53:48 Router kern.err kernel: [ 6184.520000] ath: phy0: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x42000020 DMADBG_7=0x000084c0
Feb 18 17:53:48 Router kern.err kernel: [ 6184.530000] ath: phy0: Could not stop RX, we could be confusing the DMA engine when we start RX up
Feb 18 17:53:48 Router kern.err kernel: [ 6185.010000] ath: phy0: Failed to stop TX DMA, queues=0x008!
Feb 18 17:53:49 Router kern.err kernel: [ 6185.260000] ath: phy0: Failed to stop TX DMA, queues=0x100!
Feb 18 17:53:49 Router kern.err kernel: [ 6185.730000] ath: phy0: Failed to stop TX DMA, queues=0x100!
Feb 18 17:53:50 Router kern.err kernel: [ 6186.670000] ath: phy0: Failed to stop TX DMA, queues=0x004!
Feb 18 17:53:50 Router kern.err kernel: [ 6187.140000] ath: phy0: Failed to stop TX DMA, queues=0x100!
Feb 18 17:53:52 Router kern.err kernel: [ 6188.310000] ath: phy0: Failed to stop TX DMA, queues=0x008!
Feb 18 17:53:52 Router kern.err kernel: [ 6188.570000] ath: phy0: Failed to stop TX DMA, queues=0x10c!
Feb 18 17:53:53 Router kern.err kernel: [ 6189.510000] ath: phy0: Failed to stop TX DMA, queues=0x108!
Feb 18 17:53:54 Router kern.err kernel: [ 6190.910000] ath: phy0: Failed to stop TX DMA, queues=0x008!
Feb 18 17:53:55 Router kern.err kernel: [ 6191.150000] ath: phy0: Failed to stop TX DMA, queues=0x008!
Feb 18 17:53:55 Router kern.err kernel: [ 6191.400000] ath: phy0: Failed to stop TX DMA, queues=0x100!
Feb 18 17:53:55 Router kern.err kernel: [ 6191.870000] ath: phy0: Failed to stop TX DMA, queues=0x100!
Feb 18 17:53:55 Router kern.err kernel: [ 6192.110000] ath: phy0: Failed to stop TX DMA, queues=0x008!
Feb 18 17:53:57 Router kern.err kernel: [ 6193.280000] ath: phy0: Failed to stop TX DMA, queues=0x100!
Feb 18 17:53:58 Router kern.err kernel: [ 6194.220000] ath: phy0: Failed to stop TX DMA, queues=0x008!
Feb 18 17:53:58 Router kern.err kernel: [ 6194.470000] ath: phy0: Failed to stop TX DMA, queues=0x008!
Feb 18 17:53:58 Router kern.err kernel: [ 6194.710000] ath: phy0: Failed to stop TX DMA, queues=0x100!
Feb 18 17:53:59 Router kern.err kernel: [ 6195.180000] ath: phy0: Failed to stop TX DMA, queues=0x100!
Feb 18 17:53:59 Router kern.err kernel: [ 6195.430000] ath: phy0: Failed to stop TX DMA, queues=0x008!
Feb 18 17:54:01 Router kern.err kernel: [ 6197.520000] ath: phy0: Failed to stop TX DMA, queues=0x100!
Feb 18 17:54:03 Router kern.err kernel: [ 6199.150000] ath: phy0: Failed to stop TX DMA, queues=0x004!
Feb 18 17:54:03 Router kern.err kernel: [ 6199.400000] ath: phy0: Failed to stop TX DMA, queues=0x104!
Feb 18 17:54:04 Router kern.err kernel: [ 6200.350000] ath: phy0: Failed to stop TX DMA, queues=0x10c!
Feb 18 17:54:04 Router kern.err kernel: [ 6200.830000] ath: phy0: Failed to stop TX DMA, queues=0x100!
Feb 18 17:54:04 Router kern.err kernel: [ 6201.070000] ath: phy0: Failed to stop TX DMA, queues=0x004!
Feb 18 17:54:05 Router kern.err kernel: [ 6201.320000] ath: phy0: Failed to stop TX DMA, queues=0x104!
Feb 18 17:54:06 Router kern.err kernel: [ 6202.260000] ath: phy0: Failed to stop TX DMA, queues=0x104!
Feb 18 17:54:06 Router kern.err kernel: [ 6202.740000] ath: phy0: Failed to stop TX DMA, queues=0x100!
Feb 18 17:54:07 Router kern.err kernel: [ 6203.210000] ath: phy0: Failed to stop TX DMA, queues=0x100!
Feb 18 17:54:07 Router kern.err kernel: [ 6203.690000] ath: phy0: Failed to stop TX DMA, queues=0x100!
Feb 18 17:54:08 Router kern.err kernel: [ 6204.620000] ath: phy0: Failed to stop TX DMA, queues=0x100!
Feb 18 17:54:09 Router kern.err kernel: [ 6205.560000] ath: phy0: Failed to stop TX DMA, queues=0x100!
Feb 18 17:54:10 Router kern.err kernel: [ 6206.500000] ath: phy0: Failed to stop TX DMA, queues=0x100!
Feb 18 17:54:10 Router kern.err kernel: [ 6206.970000] ath: phy0: Failed to stop TX DMA, queues=0x100!
Feb 18 17:54:11 Router kern.err kernel: [ 6207.450000] ath: phy0: Failed to stop TX DMA, queues=0x100!
Feb 18 17:54:12 Router kern.err kernel: [ 6208.390000] ath: phy0: Failed to stop TX DMA, queues=0x100!
Feb 18 17:54:13 Router kern.err kernel: [ 6209.320000] ath: phy0: Failed to stop TX DMA, queues=0x100!

any ideas?

cu

Using HT40 in a crowded environment will definitely make things worse. Try HT20.

hi,

ok - i'll try it with HT20 - i'll give it a chance ;-)

and - my Router is rev. 1.10... i've bought the router Nov. 2012... i believe there was no rev. 2.0 available... sad

Which revision are you using? Are you using the same or likely same configuration?

cu

(Last edited by Ronar85 on 18 Feb 2014, 21:17)

Good news for every people who still have waranty (on paper)!

I have reinstalled the original firmware on my router, sent back to the shop where i bought it, and now i'm using a new TP-LINK TL-WR-1043ND V2 (2.1) router. TP-LINK has just replaced the 1.8 model with a 2.1 model smile Now i have two of the 2.1 model and they have no problem at all. They are running 24 hours every day. Before you send back the router, you should reinstall a firmware with non boot word, and then do a hard reset on it. It is worth it, even without internet connection for a week...

Good Luck!

(Last edited by kisssandoradam on 22 Feb 2014, 15:24)

How's it been performing for you?

EDIT: Looks like this could be interesting: https://dev.openwrt.org/changeset/39767

(Last edited by raz123 on 4 Mar 2014, 20:32)

moroboshi wrote:

For me, putting this into /etc/rc.local seems to help in preventing the client connections from dropping:

watch_wlan() {
        while true; do
                iw dev wlan0 scan | grep SSID:
                sleep 5m
        done
}

watch_wlan &

So the workaround now does a scripted wireless scan every 5 minutes and I haven't seen any further client timeout issues.

For me, It doesn't prevent nor resolve the problem, but I sightly modified the script based on a previous discussed symptom: 

watch_wlan() {
        while true; do
if ! iw dev wlan0 station dump | grep -q Station; then
    iw dev wlan0 scan | grep "^BSS\|SSID\|signal\|DS \|WPS"
fi
                sleep 5m
        done
}

watch_wlan &

The modified script only perform the scan if there are nobody connected.

First I will resume what doesn't work so far:

/sbin/wifi down
/sbin/wifi up
iw dev wlan0 scan | grep "^BSS\|SSID\|signal\|DS \|WPS"

I found a way to restore functionality without rebooting:

/sbin/wifi down
/sbin/rmmod ath9k
/sbin/insmod ath9k
/sbin/lsmod | grep ath9k
/sbin/wifi up

But, the downside is that it generate a wlan1 instead of wlan0. Anyways it's just works for me.

Reading the reports of times vs. speed, looks like a traffic of around 8 GiB is what we are seeing.
I just installed vnstat to confirm. But could be as easy as add to the report the output of:

cat /proc/net/dev | awk '/wlan/ {print $1,$2,$3,$10,$11}' wrote:

wlan0: 20218801 187028 106390993 405873

(This sample output is not a bug one)

I'd say this workaround is doing well on my device, at least for the last month.

moroboshi wrote:

For me, putting this into /etc/rc.local seems to help in preventing the client connections from dropping:

watch_wlan() {
        while true; do
                iw dev wlan0 scan | grep SSID:
                sleep 5m
        done
}

watch_wlan &

See https://forum.openwrt.org/viewtopic.php?pid=223053, the symptoms I was seeing were:

So after 3 hours suddenly all stations timed out.
Even more interestingly when I do a wireless scan on the web UI, immediately all stations reconnect.

So the workaround now does a scripted wireless scan every 5 minutes and I haven't seen any further client timeout issues.

This workaround does the trick with the newest version of OpenWRT. I even don't need to reboot the device every day.

Just of curiosity, why do "grep SSID:"? We don't see the results, so why filter something?

by nbd
please try r41952

https://dev.openwrt.org/changeset/41952
Message: ath9k: disable periodic entropy gathering (keep initial) to fix some stability issues


Has anyone tested this release on WR1043ND v1.0 ? with success?

(Last edited by cave on 4 Aug 2014, 16:52)

bump

i am now trying  BARRIER BREAKER (14.07-rc3, r42056) on my WR1043ND v1.10
http://downloads.openwrt.org/barrier_br … pgrade.bin

configured as a dumb Access point to make a longer test, keeping my regular Wi-Fi as a Backup.

150KiB Tx and 150KiB Rx are transfered and i watch with bmon on both ends and run pings to the device.

no drop yet. but i want to run longer tests.

Ping seems to drop sometimes. but this is maybe unrelated.


https://dev.openwrt.org/changeset/42010 … er_breaker
r42010 BB contains Backport from r41952 trunk
https://dev.openwrt.org/changeset/41952


-------
update/warning , WR1043nd v1.10 with BBrc3  r42056 contains DMA Errors

[  969.550000] ath: phy0: Failed to stop TX DMA, queues=0x004!
[ 1067.340000] ath: phy0: Failed to stop TX DMA, queues=0x00c!
[ 1070.000000] ath: phy0: Failed to stop TX DMA, queues=0x004!
[ 1087.710000] ath: phy0: Failed to stop TX DMA, queues=0x004!
[ 1092.220000] ath: phy0: Failed to stop TX DMA, queues=0x00c!
[ 1101.950000] ath: phy0: Failed to stop TX DMA, queues=0x004!
[ 1110.040000] ath: phy0: Failed to stop TX DMA, queues=0x004!
[ 1127.040000] ath: phy0: Failed to stop TX DMA, queues=0x00c!

and

Wed Sep  3 00:22:14 2014 daemon.info hostapd: wlan0: STA 4c:eb:42:52:51:d9 IEEE 802.11: disconnected due to excessive missing ACKs
Wed Sep  3 00:22:15 2014 daemon.info hostapd: wlan0: STA 4c:eb:42:52:51:d9 IEEE 802.11: authenticated
Wed Sep  3 00:22:15 2014 daemon.info hostapd: wlan0: STA 4c:eb:42:52:51:d9 IEEE 802.11: associated (aid 1)
Wed Sep  3 00:22:15 2014 daemon.info hostapd: wlan0: STA 4c:eb:42:52:51:d9 WPA: pairwise key handshake completed (RSN)

Wed Sep  3 20:06:39 2014 kern.err kernel: [71901.600000] ath: phy0: Failed to stop TX DMA, queues=0x004!
Wed Sep  3 20:08:09 2014 daemon.info hostapd: wlan0: STA 4c:eb:42:52:51:d9 IEEE 802.11: disconnected due to excessive missing ACKs
Wed Sep  3 20:08:10 2014 daemon.info hostapd: wlan0: STA 4c:eb:42:52:51:d9 IEEE 802.11: authenticated
Wed Sep  3 20:08:10 2014 daemon.info hostapd: wlan0: STA 4c:eb:42:52:51:d9 IEEE 802.11: associated (aid 1)
Wed Sep  3 20:08:10 2014 daemon.info hostapd: wlan0: STA 4c:eb:42:52:51:d9 WPA: pairwise key handshake completed (RSN)
Wed Sep  3 20:08:40 2014 daemon.info hostapd: wlan0: STA 4c:eb:42:52:51:d9 WPA: group key handshake completed (RSN)
Wed Sep  3 20:12:01 2014 kern.err kernel: [72223.960000] ath: phy0: Failed to stop TX DMA, queues=0x004!
Wed Sep  3 20:12:33 2014 kern.err kernel: [72255.800000] ath: phy0: Failed to stop TX DMA, queues=0x004!
Wed Sep  3 20:17:46 2014 daemon.info dnsmasq[962]: read /etc/hosts - 1 addresses
Wed Sep  3 20:17:46 2014 daemon.info dnsmasq[962]: read /tmp/hosts/dhcp - 0 addresses
Wed Sep  3 20:17:46 2014 daemon.info dnsmasq[962]: read /tmp/hosts/odhcpd - 0 addresses
Wed Sep  3 20:17:48 2014 daemon.info dnsmasq[962]: read /etc/hosts - 1 addresses
Wed Sep  3 20:17:48 2014 daemon.info dnsmasq[962]: read /tmp/hosts/dhcp - 0 addresses
Wed Sep  3 20:17:48 2014 daemon.info dnsmasq[962]: read /tmp/hosts/odhcpd - 1 addresses

(Last edited by cave on 3 Sep 2014, 21:20)

So are there any stable versions of OpenWRT (or anything for that matter?) that work without issues?  I've even tried restoring the latest stock firmware and am experiencing the exact same problems (connection drops and extremely slow wireless speeds).

found out a solution;
modify 'Fragmentation Threshold' and 'RTS/CTS Threshold' to same value; default they have no value;
i tested with 400 and 1000; for the value of 400 the wifi speed was lower then expected; 1000 seems ok;
also added 30 to 'Distance Optimization'

on my setup i had frequent disconnects with distance; near router is ok but 2 rooms apart is bad; before finding this solution i had signal power to 100mW.. now only 39mW is all thats needed

ps: strange thing on router i get Signal: -65 to -69 dBm | Noise: -95 dBm (2 rooms apart) both with 100mW and 39mW; shouldn't signal increase with power?


my current setup tp-link 1043nd fw 1.8 / attitude adj 12.09-rc2 / Atheros AR5007EG adapter @ wifi-g

edit: still disconnects but less

(Last edited by makarel on 5 Mar 2015, 22:24)

hi all

i am now running on my TP-Link TL-WR1043N Version 1.10
Firmware Version    OpenWrt Chaos Calmer r44017 / LuCI (git-15.017.51462-30d45d0) Kernel Version    3.14.28

running modem on WAN, WIFI with WPA2

Pushing traffic through the wifi and pings keep around at 10ms without drops or problems for 2 hours. so no longtime test, but longest positive result.

KernelLog wrote:

[   19.820000] device eth0.1 entered promiscuous mode
[   19.820000] device eth0 entered promiscuous mode
[   19.850000] br-lan: port 1(eth0.1) entered forwarding state
[   19.850000] br-lan: port 1(eth0.1) entered forwarding state
[   21.190000] cfg80211: Calling CRDA for country: AT
[   21.190000] cfg80211: Regulatory domain changed to country: AT
[   21.200000] cfg80211:  DFS Master region: ETSI
[   21.200000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   21.210000] cfg80211:   (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   21.220000] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
[   21.230000] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[   21.240000] cfg80211:   (5490000 KHz - 5710000 KHz @ 160000 KHz), (N/A, 2700 mBm), (0 s)
[   21.250000] cfg80211:   (57000000 KHz - 66000000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)
[   21.850000] br-lan: port 1(eth0.1) entered forwarding state
[   22.940000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   22.960000] device wlan0 entered promiscuous mode
[   24.650000] br-lan: port 2(wlan0) entered forwarding state
[   24.660000] br-lan: port 2(wlan0) entered forwarding state
[   24.670000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   26.660000] br-lan: port 2(wlan0) entered forwarding state



SystemLog wrote:

Wed Jan 21 23:11:05 2015 daemon.info hostapd: wlan0: STA 18:e2:c2:97:33:fa WPA: group key handshake completed (RSN)
Wed Jan 21 23:11:05 2015 daemon.info hostapd: wlan0: STA 50:46:5d:7c:fc:cb WPA: group key handshake completed (RSN)
Wed Jan 21 23:11:06 2015 daemon.info hostapd: wlan0: STA 04:46:65:c9:a0:44 WPA: group key handshake completed (RSN)

hello again

found this post http://www.gargoyle-router.com/phpbb/vi … amp;t=4667

in /etc/rc.local, add the line: echo 1 >/sys/kernel/debug/ieee80211/phy0/ath9k/disable_ani
(check the path; you should have a disable_any with 0 inside)

in /etc/config/wireless, add the following option to your wifi-iface section:
(i added the 2 lines at the end of wireless file, didnt have wifi-iface section)

    config wifi-iface 'ap_g'
       option disassoc_low_ack 0

reboot
im watching for a weak now and no disconnects or wifi errors of any kind



edit1: 3 months later...

after some weaks of peaceful coexistence it got worse

before it just dropped the connection and reconnected right after but now it just drops the connection
i have installed wifitoggle and can disable/enable wifi from QSS button, this being the only way to restore wifi besides reboot after dropping
it seems wifi has a problem if its activated for too long

edit2: one month later..
ive put a script to restart wifi every day and have some observations to make
- wifi doesnt drop anymore except when (i guess) laptop wifi card goes to standby (laptop goes to screensaver..)
- router ram doesnt drop anymore: at the moment i have 7.5M free.. wo wifi restart i usually had ~1M free at times ~3M free but dropped during access(id say wifi driver memory leak)

(Last edited by makarel on 20 Jul 2015, 15:50)

hey everybody i have .v1.10 and v1.11 all work perfect  no problem with wifi after i put this build on all of them  work better than new.Before i was ready to throw all of them in the trash and bye something other than TP-LINK but now WOW, i was using DDWRT now im a openwrt man now.If you want to give it a try here it is.

http://s000.tinyupload.com/?file_id=804 … 1370373525

If you don't like the failsafe default  luci go to system/software remove luci-mod-failsafe the ead will work just fine.

This one is new no failsafe luci.

http://s000.tinyupload.com/?file_id=963 … 3677047846

(Last edited by ckm on 16 May 2015, 17:30)